Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-13 Thread kbuild test robot
Hi David, [auto build test ERROR on linus/master] [also build test ERROR on v4.10-rc3 next-20170113] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url:

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-13 Thread kbuild test robot
Hi David, [auto build test ERROR on linus/master] [also build test ERROR on v4.10-rc3 next-20170113] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url:

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-13 Thread David Howells
kbuild test robot wrote: >fs/afs/cmservice.c: In function 'afs_deliver_cb_init_call_back_state3': > >> fs/afs/cmservice.c:365:34: error: invalid application of 'sizeof' to > >> incomplete type 'struct uuid_v1' > call->request = kmalloc(sizeof(struct uuid_v1),

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-13 Thread David Howells
kbuild test robot wrote: >fs/afs/cmservice.c: In function 'afs_deliver_cb_init_call_back_state3': > >> fs/afs/cmservice.c:365:34: error: invalid application of 'sizeof' to > >> incomplete type 'struct uuid_v1' > call->request = kmalloc(sizeof(struct uuid_v1), GFP_KERNEL); >

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-13 Thread kbuild test robot
Hi David, [auto build test ERROR on linus/master] [also build test ERROR on v4.10-rc3 next-20170113] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url:

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-13 Thread kbuild test robot
Hi David, [auto build test ERROR on linus/master] [also build test ERROR on v4.10-rc3 next-20170113] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url:

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread David Howells
Arnd Bergmann wrote: > Yes, looks good to me. Can I put that down as a Reviewed-by? David

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread David Howells
Arnd Bergmann wrote: > Yes, looks good to me. Can I put that down as a Reviewed-by? David

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread Arnd Bergmann
On Thu, Jan 12, 2017 at 5:14 PM, David Howells wrote: >> > reply.ia.uuid[3] = htonl((s8) afs_uuid.clock_seq_hi_and_reserved); >> > reply.ia.uuid[4] = htonl((s8) afs_uuid.clock_seq_low); >> > for (loop = 0; loop < 6; loop++) >> >> Shouldn't this be

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread Arnd Bergmann
On Thu, Jan 12, 2017 at 5:14 PM, David Howells wrote: >> > reply.ia.uuid[3] = htonl((s8) afs_uuid.clock_seq_hi_and_reserved); >> > reply.ia.uuid[4] = htonl((s8) afs_uuid.clock_seq_low); >> > for (loop = 0; loop < 6; loop++) >> >> Shouldn't this be ntohs() instead of

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread David Howells
Arnd Bergmann wrote: > > - reply.ia.uuid[0] = htonl(afs_uuid.time_low); > > - reply.ia.uuid[1] = htonl(afs_uuid.time_mid); > > - reply.ia.uuid[2] = htonl(afs_uuid.time_hi_and_version); > > + reply.ia.uuid[0] = afs_uuid.time_low; > > + reply.ia.uuid[1]

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread David Howells
Arnd Bergmann wrote: > > - reply.ia.uuid[0] = htonl(afs_uuid.time_low); > > - reply.ia.uuid[1] = htonl(afs_uuid.time_mid); > > - reply.ia.uuid[2] = htonl(afs_uuid.time_hi_and_version); > > + reply.ia.uuid[0] = afs_uuid.time_low; > > + reply.ia.uuid[1] =

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread Arnd Bergmann
On Thursday, January 12, 2017 2:12:56 PM CET David Howells wrote: > Arnd Bergmann wrote: > > > Looks good to me, but I wonder if this part: > > > > r = call->request; > > - r->time_low = ntohl(b[0]); > > -

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread Arnd Bergmann
On Thursday, January 12, 2017 2:12:56 PM CET David Howells wrote: > Arnd Bergmann wrote: > > > Looks good to me, but I wonder if this part: > > > > r = call->request; > > - r->time_low = ntohl(b[0]); > > - r->time_mid

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread David Howells
Arnd Bergmann wrote: > Looks good to me, but I wonder if this part: > > r = call->request; > - r->time_low = ntohl(b[0]); > - r->time_mid = ntohl(b[1]); > - r->time_hi_and_version

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread David Howells
Arnd Bergmann wrote: > Looks good to me, but I wonder if this part: > > r = call->request; > - r->time_low = ntohl(b[0]); > - r->time_mid = ntohl(b[1]); > - r->time_hi_and_version =

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread Arnd Bergmann
On Thursday, January 12, 2017 11:56:34 AM CET David Howells wrote: > Move the afs_uuid struct to linux/uuid.h and rename it to uuid_v1. > > Signed-off-by: David Howells > Looks good to me, but I wonder if this part: r = call->request; -

Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h

2017-01-12 Thread Arnd Bergmann
On Thursday, January 12, 2017 11:56:34 AM CET David Howells wrote: > Move the afs_uuid struct to linux/uuid.h and rename it to uuid_v1. > > Signed-off-by: David Howells > Looks good to me, but I wonder if this part: r = call->request; - r->time_low