Re: [PATCH RFC v3 1/7] proc: add proc_fs_info struct to store proc information

2017-11-10 Thread Djalal Harouni
On Fri, Nov 10, 2017 at 11:26 AM, Alexey Dobriyan wrote: > On 11/9/17, Djalal Harouni wrote: > >> +struct proc_fs_info { >> + struct pid_namespace *pid_ns; >> +}; > >> +static inline struct proc_fs_info *proc_sb(struct super_block *sb) >> +{ >> +

Re: [PATCH RFC v3 1/7] proc: add proc_fs_info struct to store proc information

2017-11-10 Thread Djalal Harouni
On Fri, Nov 10, 2017 at 11:26 AM, Alexey Dobriyan wrote: > On 11/9/17, Djalal Harouni wrote: > >> +struct proc_fs_info { >> + struct pid_namespace *pid_ns; >> +}; > >> +static inline struct proc_fs_info *proc_sb(struct super_block *sb) >> +{ >> + return sb->s_fs_info; >> +} > > Can you

Re: [PATCH RFC v3 1/7] proc: add proc_fs_info struct to store proc information

2017-11-10 Thread Alexey Dobriyan
On 11/9/17, Djalal Harouni wrote: > +struct proc_fs_info { > + struct pid_namespace *pid_ns; > +}; > +static inline struct proc_fs_info *proc_sb(struct super_block *sb) > +{ > + return sb->s_fs_info; > +} Can you rename this to "struct proc_super_block *" then? That

Re: [PATCH RFC v3 1/7] proc: add proc_fs_info struct to store proc information

2017-11-10 Thread Alexey Dobriyan
On 11/9/17, Djalal Harouni wrote: > +struct proc_fs_info { > + struct pid_namespace *pid_ns; > +}; > +static inline struct proc_fs_info *proc_sb(struct super_block *sb) > +{ > + return sb->s_fs_info; > +} Can you rename this to "struct proc_super_block *" then? That "info" suffix all