Re: [PATCH v4 0/4] add mutex wait/wound/style style locks

2013-06-12 Thread Maarten Lankhorst
Op 28-05-13 16:48, Maarten Lankhorst schreef: Version 4 already? Small api changes since v3: - Remove ww_mutex_unlock_single and ww_mutex_lock_single. - Rename ww_mutex_trylock_single to ww_mutex_trylock. - Remove separate implementations of ww_mutex_lock_slow*, normal functions can be

Re: [PATCH] [media] usbtv: Add driver for Fushicai USBTV007 video frame grabber

2013-06-12 Thread Hans Verkuil
On Mon 10 June 2013 19:38:54 Lubomir Rintel wrote: On Mon, 2013-06-10 at 13:05 +0200, Hans Verkuil wrote: Also, I the hardware uses V4L2_FIELD_ALTERNATE interlacing, but I couldn't make it work, What didn't work exactly? Both mplayer and gstream v4l2src displayed only half of an

Re: [PATCH] [media] usbtv: Add driver for Fushicai USBTV007 video frame grabber

2013-06-12 Thread Hans Verkuil
On Mon 10 June 2013 19:43:31 Lubomir Rintel wrote: Reverse-engineered driver for cheapo video digitizer, made from observations of Windows XP driver. The protocol is not yet completely understood, so far we don't provide any controls, only support a single format out of three and don't

Re: [RFC] Add query/get/set matrix ioctls

2013-06-12 Thread Hans Verkuil
On Tue 11 June 2013 23:33:42 Sylwester Nawrocki wrote: Hi Hans, On 06/03/2013 02:14 PM, Hans Verkuil wrote: Hi all, When working on the Motion Detection API, I realized that my proposal for two new G/S_MD_BLOCKS ioctls was too specific for the motion detection use case. The

Re: Corrupt Raw webcam data

2013-06-12 Thread Paulo Assis
Hi, You must add the nodrop option to the uvc driver (nodrop=1), otherwise bayer frames (smaller than yuyv frames) will get droped, since the driver mistakens these with incomplete yuyv frames. If you are using guvcview make sure you use the latest version (1.7.0), then I would try different

Re: [RFC] Add query/get/set matrix ioctls

2013-06-12 Thread Sakari Ailus
Hi Hans, Thanks for the RFC! On Wed, Jun 12, 2013 at 10:35:07AM +0200, Hans Verkuil wrote: On Tue 11 June 2013 23:33:42 Sylwester Nawrocki wrote: Hi Hans, On 06/03/2013 02:14 PM, Hans Verkuil wrote: Hi all, When working on the Motion Detection API, I realized that my proposal

Re: [RFC] Add query/get/set matrix ioctls

2013-06-12 Thread Hans Verkuil
On Wed 12 June 2013 14:26:27 Sakari Ailus wrote: Hi Hans, Thanks for the RFC! On Wed, Jun 12, 2013 at 10:35:07AM +0200, Hans Verkuil wrote: On Tue 11 June 2013 23:33:42 Sylwester Nawrocki wrote: Hi Hans, On 06/03/2013 02:14 PM, Hans Verkuil wrote: Hi all, When

Re: [RFC] Add query/get/set matrix ioctls

2013-06-12 Thread Andrzej Hajda
Hi Hans and Sylwester, I would like to add my two cents. On 06/12/2013 10:35 AM, Hans Verkuil wrote: On Tue 11 June 2013 23:33:42 Sylwester Nawrocki wrote: Hi Hans, On 06/03/2013 02:14 PM, Hans Verkuil wrote: Hi all, When working on the Motion Detection API, I realized that my proposal

Re: [RFC] Add query/get/set matrix ioctls

2013-06-12 Thread Hans Verkuil
On Wed June 12 2013 16:07:48 Andrzej Hajda wrote: Hi Hans and Sylwester, I would like to add my two cents. On 06/12/2013 10:35 AM, Hans Verkuil wrote: On Tue 11 June 2013 23:33:42 Sylwester Nawrocki wrote: Hi Hans, On 06/03/2013 02:14 PM, Hans Verkuil wrote: Hi all, When

[REVIEWv2 PATCH 01/12] v4l2-device: check if already unregistered.

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com It was possible to unregister an already unregistered v4l2_device struct. Add a check whether that already happened and just return if that was the case. Also refure to register a v4l2_device if both the dev and name fields are empty. A warning was

[REVIEWv2 PATCH 03/12] cx23885-417: use v4l2_dev instead of the deprecated parent field.

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com Signed-off-by: Hans Verkuil hans.verk...@cisco.com --- drivers/media/pci/cx23885/cx23885-417.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/pci/cx23885/cx23885-417.c b/drivers/media/pci/cx23885/cx23885-417.c index

[REVIEWv2 PATCH 00/11] Use v4l2_dev instead of parent

2013-06-12 Thread Hans Verkuil
This patch series converts the last set of drivers still using the parent field of video_device to using v4l2_dev instead and at the end the parent field is renamed to dev_parent and used again in cx88. A proper pointer to v4l2_dev is necessary otherwise the advanced debugging ioctls will not

[REVIEWv2 PATCH 04/12] zoran: use v4l2_dev instead of the deprecated parent field.

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com Signed-off-by: Hans Verkuil hans.verk...@cisco.com --- drivers/media/pci/zoran/zoran_card.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/pci/zoran/zoran_card.c b/drivers/media/pci/zoran/zoran_card.c index

[REVIEWv2 PATCH 11/12] cx88: set dev_parent to the correct parent PCI bus.

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com The cx88 driver has one v4l2_device, but the video nodes are owned by two different PCI busses. So the dev_parent pointer should be set to the correct parent bus, otherwise sysfs won't show the correct device hierarchy. This broke starting in 3.6 after a

[REVIEWv2 PATCH 02/12] soc_camera: replace vdev-parent by vdev-v4l2_dev.

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com The parent field will eventually disappear to be replaced by v4l2_dev. soc_camera does provide a v4l2_device struct but did not point to it in struct video_device. This is now fixed. Now the video nodes can be found under the correct platform bus, and

[REVIEWv2 PATCH 06/12] saa7164: add v4l2_device and replace parent with v4l2_dev

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com This driver did not yet support struct v4l2_device, so add it. This make it possible to replace the deprecated parent field with the v4l2_dev field, allowing the eventual removal of the parent field. Signed-off-by: Hans Verkuil hans.verk...@cisco.com ---

[REVIEWv2 PATCH 09/12] omap24xxcam: add v4l2_device and replace parent with v4l2_dev

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com This driver did not yet support struct v4l2_device, so add it. This make it possible to replace the deprecated parent field with the v4l2_dev field, allowing the eventual removal of the parent field. Signed-off-by: Hans Verkuil hans.verk...@cisco.com

[REVIEWv2 PATCH 10/12] v4l2: always require v4l2_dev, rename parent to dev_parent

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com The last set of drivers still using the parent field of video_device instead of the v4l2_dev field have been converted, so v4l2_dev is now always set. A proper pointer to v4l2_dev is necessary these days otherwise the advanced debugging ioctls will not

[REVIEWv2 PATCH 05/12] sn9c102_core: add v4l2_device and replace parent with v4l2_dev

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com This driver did not yet support struct v4l2_device, so add it. This make it possible to replace the deprecated parent field with the v4l2_dev field, allowing the eventual removal of the parent field. Signed-off-by: Hans Verkuil hans.verk...@cisco.com ---

[REVIEWv2 PATCH 08/12] f_uvc: add v4l2_device and replace parent with v4l2_dev

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com This driver did not yet support struct v4l2_device, so add it. This make it possible to replace the deprecated parent field with the v4l2_dev field, allowing the eventual removal of the parent field. Signed-off-by: Hans Verkuil hans.verk...@cisco.com ---

[REVIEWv2 PATCH 12/12] v4l2-framework: update documentation

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com 'parent' was renamed to 'dev_parent'. Clarify how/when this should be used. Signed-off-by: Hans Verkuil hans.verk...@cisco.com --- Documentation/video4linux/v4l2-framework.txt | 17 +++-- 1 file changed, 11 insertions(+), 6 deletions(-)

[REVIEWv2 PATCH 07/12] pvrusb2: use v4l2_dev instead of the deprecated parent field.

2013-06-12 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com Signed-off-by: Hans Verkuil hans.verk...@cisco.com --- drivers/media/usb/pvrusb2/pvrusb2-hdw.c |4 drivers/media/usb/pvrusb2/pvrusb2-hdw.h |4 drivers/media/usb/pvrusb2/pvrusb2-v4l2.c |7 --- 3 files changed, 12 insertions(+),

Re: [REVIEWv2 PATCH 07/12] pvrusb2: use v4l2_dev instead of the deprecated parent field.

2013-06-12 Thread Mike Isely
Acked-By: Mike Isely is...@pobox.com -Mike On Wed, 12 Jun 2013, Hans Verkuil wrote: From: Hans Verkuil hans.verk...@cisco.com Signed-off-by: Hans Verkuil hans.verk...@cisco.com --- drivers/media/usb/pvrusb2/pvrusb2-hdw.c |4 drivers/media/usb/pvrusb2/pvrusb2-hdw.h |4

double-buffering with the omap3 parallel interface

2013-06-12 Thread Michael Jones
Hi Laurent co., I'd like to look at what the maximum possible frame rates are for a sensor connected to the OMAP3 ISP CCDC via the parallel interface, writing frames directly to memory. I understand that there is some minimum amount of time required between frames to pass on the finished

Re: [PATCH v10 15/21] V4L2: add a device pointer to struct v4l2_subdev

2013-06-12 Thread Prabhakar Lad
On Tue, Jun 11, 2013 at 1:53 PM, Guennadi Liakhovetski g.liakhovet...@gmx.de wrote: It is often useful to have simple means to get from a subdevice to the underlying physical device. This patch adds such a pointer to struct v4l2_subdev and sets it accordingly in the I2C and SPI cases.

Re: [PATCH v10 16/21] V4L2: support asynchronous subdevice registration

2013-06-12 Thread Prabhakar Lad
Hi Guennadi, Thanks for the patch. Hopefully we get this in for 3.11 On Tue, Jun 11, 2013 at 1:53 PM, Guennadi Liakhovetski g.liakhovet...@gmx.de wrote: Currently bridge device drivers register devices for all subdevices synchronously, tupically, during their probing. E.g. if an I2C CMOS

Re: [REVIEWv2 PATCH 01/12] v4l2-device: check if already unregistered.

2013-06-12 Thread Prabhakar Lad
Hi Hans, Thanks for the patch. The patch looks OK expect for the small typo below in the commit message. On Wed, Jun 12, 2013 at 8:30 PM, Hans Verkuil hverk...@xs4all.nl wrote: From: Hans Verkuil hans.verk...@cisco.com It was possible to unregister an already unregistered v4l2_device struct.

cron job: media_tree daily build: WARNINGS

2013-06-12 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Wed Jun 12 19:00:19 CEST 2013 git branch: test git hash: ab5060cdb8829c0503b7be2b239b52e9a25063b4 gcc

Confirmed Reciept.....

2013-06-12 Thread info
Uk National Lottery Ref: L/200-26937 Batch: 2007MJL-01 FINAL NOTIFICATION We are pleased to inform you today 6th June, 2013 of the result of the winners of the UK NATIONAL LOTTERY ONLINE PROMO PROGRAMME, held on the 30th of May, 2013. You have therefore been approved