[PATCH] Staging: media: davinci_vpfe: Fix spelling error on a comment

2016-03-07 Thread Manuel Rodriguez
Fix spelling error on a comment, change 'wether' to 'whether' Signed-off-by: Manuel Rodriguez --- drivers/staging/media/davinci_vpfe/vpfe_video.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/media/davinci_vpfe/vpfe_video.c

Re: How to see the content of my device's EEPROM?

2016-03-07 Thread Olli Salonen
Hi, Load the module with i2c_debug on: From: em28xx-i2c.c: 693 if (i2c_debug) { 694 /* Display eeprom content */ 695 print_hex_dump(KERN_INFO, "eeprom ", DUMP_PREFIX_OFFSET, 69616, 1, data, len, true); 697 698

Re: Kernel docs: muddying the waters a bit

2016-03-07 Thread Russel Winder
On Fri, 2016-03-04 at 09:46 +0200, Jani Nikula wrote: > […] > If we're talking about the same asciidoctor (http://asciidoctor.org/) > it's written in ruby but you can apparently run it in JVM using > JRuby. Calling it Java-based is misleading. Indeed, I was somewhat imprecise. Thanks to the work

cron job: media_tree daily build: OK

2016-03-07 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Tue Mar 8 04:00:26 CET 2016 git branch: test git hash: de08b5a8be0df1eb7c796b0fe6b30cf1d03d14a6 gcc

How to see the content of my device's EEPROM?

2016-03-07 Thread Alexandre-Xavier Labonté-Lamoureux
Hello everyone, On the kernel version 4.3.3, when I do dmesg to see the content of the EEPROM of the device that I just connected, I don't see it. I only see this: https://justpaste.it/qchd On older kernel versions like 3.10, I had what I wanted: https://justpaste.it/qchh i2c eeprom 00: 1a eb

[PATCH v2] media: rcar_vin: Use ARCH_RENESAS

2016-03-07 Thread Simon Horman
Make use of ARCH_RENESAS in place of ARCH_SHMOBILE. This is part of an ongoing process to migrate from ARCH_SHMOBILE to ARCH_RENESAS the motivation for which being that RENESAS seems to be a more appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs. Signed-off-by: Simon

[PATCH v2] media: sh_mobile_ceu_camera: Remove dependency on SUPERH

2016-03-07 Thread Simon Horman
A dependency on ARCH_SHMOBILE seems to be the best option for sh_mobile_ceu_camera: * For Super H based SoCs: sh_mobile_ceu is used on SH_AP325RXA, SH_ECOVEC, SH_KFR2R09, SH_MIGOR, and SH_7724_SOLUTION_ENGINE which depend on CPU_SUBTYPE_SH7722, CPU_SUBTYPE_SH7723, or CPU_SUBTYPE_SH7724 which

Re: [PATCH] media: sh_mobile_ceu_camera, rcar_vin: Use ARCH_RENESAS

2016-03-07 Thread Simon Horman
On Mon, Mar 07, 2016 at 08:53:56AM +0100, Geert Uytterhoeven wrote: > Hi Simon, > > Oops, seems I dropped all CCs in my earlier reply. Fixing up... > > On Mon, Mar 7, 2016 at 2:28 AM, Simon Horman wrote: > > On Thu, Mar 03, 2016 at 09:40:07AM +0100, Geert Uytterhoeven wrote:

Re: [PATCH v5 22/22] sound/usb: Use Media Controller API to share media resources

2016-03-07 Thread Shuah Khan
On 03/05/2016 03:00 AM, Mauro Carvalho Chehab wrote: > Em Wed, 2 Mar 2016 09:50:31 -0700 > Shuah Khan escreveu: > >> Change ALSA driver to use Media Controller API to >> share media resources with DVB and V4L2 drivers >> on a AU0828 media device. Media Controller

Re: [PATCH v5 22/22] sound/usb: Use Media Controller API to share media resources

2016-03-07 Thread Shuah Khan
On 03/05/2016 03:00 AM, Mauro Carvalho Chehab wrote: > Em Wed, 2 Mar 2016 09:50:31 -0700 > Shuah Khan escreveu: > >> Change ALSA driver to use Media Controller API to >> share media resources with DVB and V4L2 drivers >> on a AU0828 media device. Media Controller

Re: [PATCH v5 22/22] sound/usb: Use Media Controller API to share media resources

2016-03-07 Thread Shuah Khan
On 03/07/2016 07:16 AM, Shuah Khan wrote: > On 03/05/2016 03:00 AM, Mauro Carvalho Chehab wrote: >> Em Wed, 2 Mar 2016 09:50:31 -0700 >> Shuah Khan escreveu: >> >>> Change ALSA driver to use Media Controller API to >>> share media resources with DVB and V4L2 drivers >>>

Re: [PATCH 0/2] [media] gspca_kinect: enable both video and depth streams

2016-03-07 Thread Ulrik de Muelenaere
Hi Hans, On Mon, Mar 07, 2016 at 08:00:46PM +0100, Hans de Goede wrote: > Hi Ulrik, > > On 06-03-16 14:50, Ulrik de Muelenaere wrote: > >Hello, > > > >The Kinect produces both a video and depth stream, but the current > >implementation of the > >gspca_kinect subdriver requires a depth_mode

Re: [PATCH 0/2] [media] gspca_kinect: enable both video and depth streams

2016-03-07 Thread Hans de Goede
Hi Ulrik, On 06-03-16 14:50, Ulrik de Muelenaere wrote: Hello, The Kinect produces both a video and depth stream, but the current implementation of the gspca_kinect subdriver requires a depth_mode parameter at probe time to select one of the streams which will be exposed as a v4l device.

[PATCH] media: i2c/adp1653: fix check of devm_gpiod_get() error code

2016-03-07 Thread Vladimir Zapolskiy
The devm_gpiod_get() function returns either a valid pointer to struct gpio_desc or ERR_PTR() error value, check for NULL is bogus. Signed-off-by: Vladimir Zapolskiy --- drivers/media/i2c/adp1653.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

Re: videobuf2-dma-sg and multiple planes semantics

2016-03-07 Thread Robert Jarzmik
Robert Jarzmik writes: > Hi, > > I've been converting pxa_camera driver from videobuf to videobuf2, and I have > a > question about multiple plane semantics. > > I have a case where I have 3 planes for a yuv422 capture : > - 1 Y plane (total_size / 2 bytes) > - 1 U

videobuf2-dma-sg and multiple planes semantics

2016-03-07 Thread Robert Jarzmik
Hi, I've been converting pxa_camera driver from videobuf to videobuf2, and I have a question about multiple plane semantics. I have a case where I have 3 planes for a yuv422 capture : - 1 Y plane (total_size / 2 bytes) - 1 U plane (total_size / 4 bytes) - 1 V plane (total_size / 4 bytes) I

Re: i.mx6 camera interface (CSI) and mainline kernel

2016-03-07 Thread Tim Harvey
On Thu, Mar 3, 2016 at 9:45 AM, Steve Longerbeam wrote: > Hi Philippe, > > On 03/03/2016 12:36 AM, Philippe De Muyter wrote: >> >> Just to be sure : do you mean https://github.com/slongerbeam/mediatree.git >> or something else ? > > Sorry, yes I meant

Re: [TRIVIAL PATCH] treewide: Remove unnecessary 0x prefixes before %pa extension uses

2016-03-07 Thread Ross Zwisler
On Fri, Mar 04, 2016 at 11:46:32PM -0800, Joe Perches wrote: > Since commit 3cab1e711297 ("lib/vsprintf: refactor duplicate code > to special_hex_number()") %pa uses have been ouput with a 0x prefix. > > These 0x prefixes in the formats are unnecessary. > > Signed-off-by: Joe Perches

Re: [TRIVIAL PATCH] treewide: Remove unnecessary 0x prefixes before %pa extension uses

2016-03-07 Thread Vinod Koul
On Fri, Mar 04, 2016 at 11:46:32PM -0800, Joe Perches wrote: > Since commit 3cab1e711297 ("lib/vsprintf: refactor duplicate code > to special_hex_number()") %pa uses have been ouput with a 0x prefix. > > These 0x prefixes in the formats are unnecessary. > For this: >

Re: [PATCH 0/2] [media] exynos4-is: Trivial fixes for DT port/endpoint parse logic

2016-03-07 Thread Javier Martinez Canillas
Hello Sylwester, On 03/07/2016 06:24 AM, Sylwester Nawrocki wrote: > Hi Javier, Krzysztof, > > On 03/05/2016 05:35 AM, Krzysztof Kozlowski wrote: >> 2016-03-05 5:20 GMT+09:00 Javier Martinez Canillas : Hello, This series have two trivial fixes for issues

Re: [RFT 2/2] [media] exynos4-is: Add missing port parent of_node_put on error paths

2016-03-07 Thread Javier Martinez Canillas
Hello Krzysztof, On 01/25/2016 09:41 PM, Krzysztof Kozlowski wrote: > In fimc_md_parse_port_node() remote port parent node is get with > of_graph_get_remote_port_parent() but it is not put on error path. > > Fixes: fa91f1056f17 ("[media] exynos4-is: Add support for asynchronous > subdevices

Re: [PATCH v5 22/22] sound/usb: Use Media Controller API to share media resources

2016-03-07 Thread Shuah Khan
On 03/05/2016 03:00 AM, Mauro Carvalho Chehab wrote: > Em Wed, 2 Mar 2016 09:50:31 -0700 > Shuah Khan escreveu: > >> Change ALSA driver to use Media Controller API to >> share media resources with DVB and V4L2 drivers >> on a AU0828 media device. Media Controller

Re: [RFT 1/2] [media] exynos4-is: Add missing endpoint of_node_put on error paths

2016-03-07 Thread Javier Martinez Canillas
Hello Krzysztof, On 01/25/2016 09:41 PM, Krzysztof Kozlowski wrote: > In fimc_md_parse_port_node() endpoint node is get with of_get_next_child() > but it is not put on error path. > > Fixes: 56fa1a6a6a7d ("[media] s5p-fimc: Change the driver directory name to > exynos4-is") > Signed-off-by:

RE: [TRIVIAL PATCH] treewide: Remove unnecessary 0x prefixes before %pa extension uses

2016-03-07 Thread Bounine, Alexandre
> From: Joe Perches [mailto:j...@perches.com] > Sent: Saturday, March 05, 2016 2:47 AM . > Subject: [TRIVIAL PATCH] treewide: Remove unnecessary 0x prefixes > before %pa extension uses > > Since commit 3cab1e711297 ("lib/vsprintf: refactor duplicate code > to special_hex_number()") %pa uses

Re: Panic upon DViCO FusionHDTV DVB-T USB (TH7579) insertion

2016-03-07 Thread Tim Connors
Upgraded kernel to debian linux-image-4.4.0-1-amd64 (was a debian prerelease 4.4.0-trunk-amd64), compiled in new media_build.git with this patch: diff --git a/drivers/media/usb/dvb-usb/cxusb.c b/drivers/media/usb/dvb-usb/cxusb.c index 24a457d9d803..def6d21d1445 100644 ---

Re: Kernel docs: muddying the waters a bit

2016-03-07 Thread Mauro Carvalho Chehab
Em Mon, 7 Mar 2016 00:29:08 +0100 Johannes Stezenbach escreveu: > On Sat, Mar 05, 2016 at 11:29:37PM -0300, Mauro Carvalho Chehab wrote: > > > > I converted one of the big tables to CSV. At least now it recognized > > it as a table. Yet, the table was very badly formated: > >

Re: Kernel docs: muddying the waters a bit

2016-03-07 Thread Mauro Carvalho Chehab
Em Mon, 7 Mar 2016 09:48:26 +0100 Johannes Stezenbach escreveu: > On Mon, Mar 07, 2016 at 12:29:08AM +0100, Johannes Stezenbach wrote: > > On Sat, Mar 05, 2016 at 11:29:37PM -0300, Mauro Carvalho Chehab wrote: > > > > > > I converted one of the big tables to CSV. At least

[PATCH] [media] dw2102: fix unreleased firmware

2016-03-07 Thread Sudip Mukherjee
On the particular case when the product id is 0x2101 we have requested for a firmware but after processing it we missed releasing it. Signed-off-by: Sudip Mukherjee --- drivers/media/usb/dvb-usb/dw2102.c | 3 +++ 1 file changed, 3 insertions(+) diff --git

Re: [PATCH 4/8] media: Rename is_media_entity_v4l2_io to is_media_entity_v4l2_video_device

2016-03-07 Thread Lad, Prabhakar
Hi Laurent, Thanks for the patch. On Tue, Mar 1, 2016 at 2:57 PM, Laurent Pinchart wrote: > All users of is_media_entity_v4l2_io() (the exynos4-is, omap3isp, > davince_vpfe and omap4iss drivers) use the function to check whether > entities are

Re: [PATCH v3 0/8] i2c mux cleanup and locking update

2016-03-07 Thread Wolfram Sang
> My offer is going to be this, I'll look after any unforeseen future problems > caused by this rework, and I can be the i2c-mux maintainer. But if being Yay, thanks a lot! > the i2c-mux maintainer turns out to be a huge time-sink, there is no way I > can stay on in the long run. But I guess

[PATCH] [media] cx231xx: fix memory leak

2016-03-07 Thread Sudip Mukherjee
When we returned on error we missed freeing p_current_fw and p_buffer. Signed-off-by: Sudip Mukherjee --- drivers/media/usb/cx231xx/cx231xx-417.c | 9 + 1 file changed, 9 insertions(+) diff --git a/drivers/media/usb/cx231xx/cx231xx-417.c

Re: [TRIVIAL PATCH] treewide: Remove unnecessary 0x prefixes before %pa extension uses

2016-03-07 Thread Nicolas Ferre
Le 05/03/2016 08:46, Joe Perches a écrit : > Since commit 3cab1e711297 ("lib/vsprintf: refactor duplicate code > to special_hex_number()") %pa uses have been ouput with a 0x prefix. > > These 0x prefixes in the formats are unnecessary. > > Signed-off-by: Joe Perches > --- >

Re: [PATCH 0/2] [media] exynos4-is: Trivial fixes for DT port/endpoint parse logic

2016-03-07 Thread Sylwester Nawrocki
Hi Javier, Krzysztof, On 03/05/2016 05:35 AM, Krzysztof Kozlowski wrote: > 2016-03-05 5:20 GMT+09:00 Javier Martinez Canillas : >> > Hello, >> > >> > This series have two trivial fixes for issues that I noticed while >> > reading as a reference the driver's functions that

Re: Build regressions/improvements in v4.5-rc7

2016-03-07 Thread Geert Uytterhoeven
On Mon, Mar 7, 2016 at 9:55 AM, Geert Uytterhoeven wrote: > JFYI, when comparing v4.5-rc7[1] to v4.5-rc6[3], the summaries are: > - build errors: +8/-7 + error: debugfs.c: undefined reference to `clk_round_rate': => .text+0x11b9e0) arm-randconfig While looking for

Re: Kernel docs: muddying the waters a bit

2016-03-07 Thread Johannes Stezenbach
On Mon, Mar 07, 2016 at 12:29:08AM +0100, Johannes Stezenbach wrote: > On Sat, Mar 05, 2016 at 11:29:37PM -0300, Mauro Carvalho Chehab wrote: > > > > I converted one of the big tables to CSV. At least now it recognized > > it as a table. Yet, the table was very badly formated: > > > >

Re: [PATCH v3 0/8] i2c mux cleanup and locking update

2016-03-07 Thread Peter Rosin
On 2016-03-05 19:29, Wolfram Sang wrote: > >> Perhaps it's one to let sit into at least the next cycle (and get some >> testing >> on those media devices if we can) but, whilst it is fiddly the gains seen in >> individual drivers (like the example Peter put in response to the V4 series) >> make

Re: [PATCH 4/6] [media] st-rc: prevent a endless loop

2016-03-07 Thread Patrice Chotard
Hi Mauro On 03/06/2016 02:39 PM, Mauro Carvalho Chehab wrote: As warned by smatch: drivers/media/rc/st_rc.c:110 st_rc_rx_interrupt() warn: this loop depends on readl() succeeding as readl() might fail, with likely means some unrecovered error, let's loop only if it succeeds.