cron job: media_tree daily build: WARNINGS

2016-08-09 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Wed Aug 10 04:00:17 CEST 2016 git branch: test git hash: b6aa39228966e0d3f0bc3306be1892f87792903a gcc

Re: [PATCH 05/12] [media] dvb_frontend: merge duplicate dvb_tuner_ops.release implementations

2016-08-09 Thread kbuild test robot
Hi Max, [auto build test ERROR on linuxtv-media/master] [also build test ERROR on v4.8-rc1 next-20160809] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/Max-Kellermann/rc-main-clear-rc_map-name

Re: [PATCH 05/12] [media] dvb_frontend: merge duplicate dvb_tuner_ops.release implementations

2016-08-09 Thread kbuild test robot
Hi Max, [auto build test ERROR on linuxtv-media/master] [also build test ERROR on v4.8-rc1 next-20160809] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/Max-Kellermann/rc-main-clear-rc_map-name

[PATCH v3] cx23885: Add support for Hauppauge WinTV quadHD ATSC version

2016-08-09 Thread Stephen Backway
Add support for the Hauppauge WinTV quadHD ATSC version. IR support has not been provided, all 4 tuners, demodulators etc are working. Further documentation can be found on Linux TV wiki. Signed-Off-by: Stephen Backway --- v2: Updated to use doc-rst v3: Fixed patch, as gmail

[PATCH 09/12] [media] stb0899: move code to "detach" callback

2016-08-09 Thread Max Kellermann
Ensure that STB0899_POSTPROC_GPIO_POWER is set synchronously. Signed-off-by: Max Kellermann --- drivers/media/dvb-frontends/stb0899_drv.c | 11 +-- 1 file changed, 9 insertions(+), 2 deletions(-) diff --git a/drivers/media/dvb-frontends/stb0899_drv.c

[PATCH 01/12] [media] rc-main: clear rc_map.name in ir_free_table()

2016-08-09 Thread Max Kellermann
rc_unregister_device() will first call ir_free_table(), and later device_del(); however, the latter causes a call to rc_dev_uevent(), which prints rc_map.name, which at this point has already bee freed. This fixes a use-after-free bug found with KASAN. Signed-off-by: Max Kellermann

[PATCH 10/12] [media] dvb_frontend: move kref to struct dvb_frontend

2016-08-09 Thread Max Kellermann
This commit amends my old commit fe35637b0a9f ("[media] dvb_frontend: eliminate blocking wait in dvb_unregister_frontend()"), which added kref to struct dvb_frontend_private. It turned out that there are several use-after-free bugs left, which affect the struct dvb_frontend. Protecting it with

[PATCH 07/12] [media] dvb_frontend: merge the two dvb_frontend_detach() versions

2016-08-09 Thread Max Kellermann
This code duplication is confusing and error prone. Let's merge them by moving the release/dvb_detach call into one function with one #ifdef. Signed-off-by: Max Kellermann --- drivers/media/dvb-core/dvb_frontend.c | 42 + 1 file

[PATCH 06/12] [media] dvb_frontend: tuner_ops.release returns void

2016-08-09 Thread Max Kellermann
It is not clear what this return value means. All implemenations return 0, and the one caller ignores the value. Let's remove this useless return value completely. Signed-off-by: Max Kellermann --- drivers/media/dvb-core/dvb_frontend.c |3 +--

[PATCH 05/12] [media] dvb_frontend: merge duplicate dvb_tuner_ops.release implementations

2016-08-09 Thread Max Kellermann
Most release callback functions are identical: free the "tuner_priv" and clear it. Let's eliminate some bloat by providing this simple implementation in the dvb_frontend library. Signed-off-by: Max Kellermann --- drivers/media/dvb-core/dvb_frontend.c |9

[PATCH 03/12] [media] dvb-core/en50221: use dvb_remove_device()

2016-08-09 Thread Max Kellermann
Commit da677fe14364 ("[media] dvb-core/en50221: use kref to manage struct dvb_ca_private") moved the dvb_unregister_device() call to the kref callback, but that left lots of stale device state visible to userspace (e.g. in sysfs). By using dvb_remove_device() and dvb_free_device() instead of

[PATCH 02/12] [media] dvbdev: split dvb_unregister_device()

2016-08-09 Thread Max Kellermann
dvb_unregister_device() has a major problem: it combines unregistering with memory disposal. Sometimes, it is necessary to unregister a device, but no memory can be freed yet, because a process still has a (stale) file handle. Therefore, we need to split dvb_unregister_device(). This will allow

[PATCH 04/12] [media] dvb: make DVB frontend *_ops instances "const"

2016-08-09 Thread Max Kellermann
These are immutable. Making them "const" allows the compiler to move them to the "rodata" section. Note that cxd2841er_t_c_ops cannot be made "const", because cxd2841er_attach() modifies it. Ouch! Signed-off-by: Max Kellermann ---

[PATCH 08/12] [media] dvb_frontend: add "detach" callback

2016-08-09 Thread Max Kellermann
Prepare for making "release" asynchronous (via kref). Some operations may need to be run synchronously in dvb_frontend_detach(), and that's why we need a "detach" callback. Signed-off-by: Max Kellermann --- drivers/media/dvb-core/dvb_frontend.c |1 +

[PATCH 12/12] drivers/media/media-device: fix double free bug in _unregister()

2016-08-09 Thread Max Kellermann
While removing all interfaces in media_device_unregister(), all media_interface pointers are freed. This is illegal and results in double kfree() if any media_interface is still linked at this point; maybe because a userspace process still has a file handle. Once the process closes the file

[PATCH 11/12] [media] media-entity: clear media_gobj.mdev in _destroy()

2016-08-09 Thread Max Kellermann
media_gobj_destroy() may be called twice on one instance - once by media_device_unregister() and again by dvb_media_device_free(). The function media_remove_intf_links() establishes and documents the convention that mdev==NULL means that the object is not registered, but nobody ever NULLs this

Re: [PATCH 0/3] doc-rst: more generic way to build only sphinx sub-folders

2016-08-09 Thread Markus Heiser
Am 09.08.2016 um 20:02 schrieb Mauro Carvalho Chehab : > Em Tue, 9 Aug 2016 09:21:08 -0600 > Jonathan Corbet escreveu: > >> On Mon, 8 Aug 2016 15:14:57 +0200 >> Markus Heiser wrote: >> >>> this is my approach for a more

Re: [PATCH 0/3] doc-rst: more generic way to build only sphinx sub-folders

2016-08-09 Thread Mauro Carvalho Chehab
Em Tue, 9 Aug 2016 09:21:08 -0600 Jonathan Corbet escreveu: > On Mon, 8 Aug 2016 15:14:57 +0200 > Markus Heiser wrote: > > > this is my approach for a more generic way to build only sphinx > > sub-folders, we > > discussed in [1]. The last patch

[PATCH] [media] mtk-vcodec: constify venc_common_if structures

2016-08-09 Thread Julia Lawall
The venc_common_if structures are never modified, so declare them as const. Done with the help of Coccinelle. Signed-off-by: Julia Lawall --- drivers/media/platform/mtk-vcodec/mtk_vcodec_drv.h|2 +- drivers/media/platform/mtk-vcodec/venc/venc_h264_if.c |6

[PATCH] [media] rcar-fcp: Make sure rcar_fcp_enable() returns 0 on success

2016-08-09 Thread Geert Uytterhoeven
When resuming from suspend-to-RAM on r8a7795/salvator-x: dpm_run_callback(): pm_genpd_resume_noirq+0x0/0x90 returns 1 PM: Device fe94.fdp1 failed to resume noirq: error 1 dpm_run_callback(): pm_genpd_resume_noirq+0x0/0x90 returns 1 PM: Device fe944000.fdp1 failed to resume

Re: [PATCH 0/3] doc-rst: more generic way to build only sphinx sub-folders

2016-08-09 Thread Jonathan Corbet
On Mon, 8 Aug 2016 15:14:57 +0200 Markus Heiser wrote: > this is my approach for a more generic way to build only sphinx sub-folders, > we > discussed in [1]. The last patch adds a minimal conf.py to the gpu folder, if > you don't want to patch the gpu folder drop

Re: [PATCH 1/4] media: pci: netup_unidvb: don't print error when adding adapter fails

2016-08-09 Thread Wolfram Sang
> Sometimes it better to show more message - especially in error conditions :) Sure, if they contain additional information. > btw, do you make sanity check for "duplicate" log messages ? I checked all error messages if they contain additional information. >         ret =

hello linux

2016-08-09 Thread Patrick Cairns
Good afternoon linux http://tasheecapitalgateway.in/rojfoe/templates/date.php?engine=sg1t7r4s1g1rxy Patrick -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majord...@vger.kernel.org More majordomo info at

[PATCH v3 3/4] media: Add Mediatek MDP Driver

2016-08-09 Thread Minghsiu Tsai
Add MDP driver for MT8173 Signed-off-by: Minghsiu Tsai --- drivers/media/platform/Kconfig| 16 + drivers/media/platform/Makefile |2 + drivers/media/platform/mtk-mdp/Makefile |9 +

[PATCH v3 0/4] Add MT8173 MDP Driver

2016-08-09 Thread Minghsiu Tsai
Changes in v3: - Modify device ndoe as structured one. - Fix conflict in dts on Linux 4.8-rc1 Changes in v2: - Add section to describe blocks function in dts-bindings - Remove the assignment of device_caps in querycap() - Remove format's name assignment - Copy colorspace-related parameters from

[PATCH v3 1/4] VPU: mediatek: Add mdp support

2016-08-09 Thread Minghsiu Tsai
VPU driver add mdp support Signed-off-by: Minghsiu Tsai --- drivers/media/platform/mtk-vpu/mtk_vpu.h |5 + 1 file changed, 5 insertions(+) diff --git a/drivers/media/platform/mtk-vpu/mtk_vpu.h b/drivers/media/platform/mtk-vpu/mtk_vpu.h index

[PATCH v3 4/4] arm64: dts: mediatek: Add MDP for MT8173

2016-08-09 Thread Minghsiu Tsai
Add MDP node for MT8173 Signed-off-by: Minghsiu Tsai --- arch/arm64/boot/dts/mediatek/mt8173.dtsi | 84 ++ 1 file changed, 84 insertions(+) diff --git a/arch/arm64/boot/dts/mediatek/mt8173.dtsi

[PATCH v3 2/4] dt-bindings: Add a binding for Mediatek MDP

2016-08-09 Thread Minghsiu Tsai
Add a DT binding documentation of MDP for the MT8173 SoC from Mediatek Signed-off-by: Minghsiu Tsai --- .../devicetree/bindings/media/mediatek-mdp.txt | 109 1 file changed, 109 insertions(+) create mode 100644

[PATCH 0/4] media: don't print error when adding adapter fails

2016-08-09 Thread Wolfram Sang
Since v4.8-rc1, the I2C core will print detailed information when adding an I2C adapter fails. So, drivers can skip this now. Should go via subsystem tree, I'd think. Wolfram Sang (4): media: pci: netup_unidvb: don't print error when adding adapter fails media: pci: pt3: don't print error

[PATCH 2/4] media: pci: pt3: don't print error when adding adapter fails

2016-08-09 Thread Wolfram Sang
The core will do this for us now. Signed-off-by: Wolfram Sang --- drivers/media/pci/pt3/pt3.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/media/pci/pt3/pt3.c b/drivers/media/pci/pt3/pt3.c index eff5e9f51ace3d..7fb649e523f46e

[PATCH 4/4] media: usb: dvb-usb-v2: dvb_usb_core: don't print error when adding adapter fails

2016-08-09 Thread Wolfram Sang
The core will do this for us now. Signed-off-by: Wolfram Sang --- drivers/media/usb/dvb-usb-v2/dvb_usb_core.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/media/usb/dvb-usb-v2/dvb_usb_core.c b/drivers/media/usb/dvb-usb-v2/dvb_usb_core.c index

[PATCH 1/4] media: pci: netup_unidvb: don't print error when adding adapter fails

2016-08-09 Thread Wolfram Sang
The core will do this for us now. Signed-off-by: Wolfram Sang --- drivers/media/pci/netup_unidvb/netup_unidvb_i2c.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/drivers/media/pci/netup_unidvb/netup_unidvb_i2c.c

[PATCH 3/4] media: platform: exynos4-is: fimc-is-i2c: don't print error when adding adapter fails

2016-08-09 Thread Wolfram Sang
The core will do this for us now. Signed-off-by: Wolfram Sang --- drivers/media/platform/exynos4-is/fimc-is-i2c.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/drivers/media/platform/exynos4-is/fimc-is-i2c.c

Re: [PATCHv2] v4l2-common: add s_selection helper function

2016-08-09 Thread Tiffany Lin
Hi Hans, On Fri, 2016-08-05 at 15:57 +0200, Hans Verkuil wrote: > Hi Tiffany, > > We just had a long discussion about whether or not -ERANGE should be returned > if the constraint flags could not be satisfied, and the end result was that > the driver should not return an error in that case, but