Make use of the swap macro and remove unnecessary variable tmp_frame.
This makes the code easier to read and maintain.

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <garsi...@embeddedor.com>
---
 drivers/media/platform/sti/hva/hva-h264.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/media/platform/sti/hva/hva-h264.c 
b/drivers/media/platform/sti/hva/hva-h264.c
index e6f247a..a7e5eed 100644
--- a/drivers/media/platform/sti/hva/hva-h264.c
+++ b/drivers/media/platform/sti/hva/hva-h264.c
@@ -999,7 +999,6 @@ static int hva_h264_encode(struct hva_ctx *pctx, struct 
hva_frame *frame,
 {
        struct hva_h264_ctx *ctx = (struct hva_h264_ctx *)pctx->priv;
        struct hva_h264_task *task = (struct hva_h264_task *)ctx->task->vaddr;
-       struct hva_buffer *tmp_frame;
        u32 stuffing_bytes = 0;
        int ret = 0;
 
@@ -1023,9 +1022,7 @@ static int hva_h264_encode(struct hva_ctx *pctx, struct 
hva_frame *frame,
                                       &stream->bytesused);
 
        /* switch reference & reconstructed frame */
-       tmp_frame = ctx->ref_frame;
-       ctx->ref_frame = ctx->rec_frame;
-       ctx->rec_frame = tmp_frame;
+       swap(ctx->ref_frame, ctx->rec_frame);
 
        return 0;
 err:
-- 
2.7.4

Reply via email to