I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the 
corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng....@intel.com>
Signed-off-by: Baole Ni <baolex...@intel.com>
---
 drivers/media/pci/tw68/tw68-core.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/media/pci/tw68/tw68-core.c 
b/drivers/media/pci/tw68/tw68-core.c
index 4e77618..3f6af07 100644
--- a/drivers/media/pci/tw68/tw68-core.c
+++ b/drivers/media/pci/tw68/tw68-core.c
@@ -50,15 +50,15 @@ MODULE_AUTHOR("Hans Verkuil <hverk...@xs4all.nl>");
 MODULE_LICENSE("GPL");
 
 static unsigned int latency = UNSET;
-module_param(latency, int, 0444);
+module_param(latency, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(latency, "pci latency timer");
 
 static unsigned int video_nr[] = {[0 ... (TW68_MAXBOARDS - 1)] = UNSET };
-module_param_array(video_nr, int, NULL, 0444);
+module_param_array(video_nr, int, NULL, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(video_nr, "video device number");
 
 static unsigned int card[] = {[0 ... (TW68_MAXBOARDS - 1)] = UNSET };
-module_param_array(card, int, NULL, 0444);
+module_param_array(card, int, NULL, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(card, "card type");
 
 static atomic_t tw68_instance = ATOMIC_INIT(0);
-- 
2.9.2

--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to