[PATCH] libv4l1: move VIDIOCGTUNER and VIDIOCSTUNER to libv4l1

2010-06-04 Thread huzaifas
From: Huzaifa Sidhpurwala huzai...@redhat.com move VIDIOCGTUNER and VIDIOCSTUNER to libv4l1 Signed-of-by: Huzaifa Sidhpurwala huzai...@redhat.com --- lib/libv4l1/libv4l1.c | 58 + 1 files changed, 58 insertions(+), 0 deletions(-) diff --git

[PATCH] libv4l1: move VIDIOCGFREQ and VIDIOCSFREQ to libv4l1

2010-06-04 Thread huzaifas
From: Huzaifa Sidhpurwala huzai...@redhat.com move VIDIOCGFREQ and VIDIOCSFREQ to libv4l1 Signed-of-by: Huzaifa Sidhpurwala huzai...@redhat.com --- lib/libv4l1/libv4l1.c | 28 1 files changed, 28 insertions(+), 0 deletions(-) diff --git a/lib/libv4l1/libv4l1.c

[PATCH] libv4l1: move VIDIOCCAPTURE to libv4l1

2010-06-04 Thread huzaifas
From: Huzaifa Sidhpurwala huzai...@redhat.com move VIDIOCCAPTURE to libv4l1 Signed-of-by: Huzaifa Sidhpurwala huzai...@redhat.com --- lib/libv4l1/libv4l1.c | 16 1 files changed, 16 insertions(+), 0 deletions(-) diff --git a/lib/libv4l1/libv4l1.c b/lib/libv4l1/libv4l1.c

[PATCH v4 3/5] ASoC: WL1273 FM Radio Digital audio codec.

2010-06-04 Thread Matti J. Aaltonen
The codec handles digital audio input to and output from the WL1273 FM radio. Signed-off-by: Matti J. Aaltonen matti.j.aalto...@nokia.com --- sound/soc/codecs/Kconfig |6 + sound/soc/codecs/Makefile |2 + sound/soc/codecs/wl1273.c | 594 +

[PATCH v4 1/5] V4L2: Add seek spacing and FM RX class.

2010-06-04 Thread Matti J. Aaltonen
Add spacing field to v4l2_hw_freq_seek and also add FM RX class to control classes. Signed-off-by: Matti J. Aaltonen matti.j.aalto...@nokia.com --- include/linux/videodev2.h | 15 ++- 1 files changed, 14 insertions(+), 1 deletions(-) diff --git a/include/linux/videodev2.h

[PATCH v4 2/5] MFD: WL1273 FM Radio: MFD driver for the FM radio.

2010-06-04 Thread Matti J. Aaltonen
This is a parent driver for two child drivers: the V4L2 driver and the ALSA codec driver. The MFD part provides the I2C communication to the device and a couple of functions that are called from both children. Signed-off-by: Matti J. Aaltonen matti.j.aalto...@nokia.com --- drivers/mfd/Kconfig

[PATCH v4 4/5] V4L2: WL1273 FM Radio: Controls for the FM radio.

2010-06-04 Thread Matti J. Aaltonen
This file implements V4L2 controls for using the Texas Instruments WL1273 FM Radio. Signed-off-by: Matti J. Aaltonen matti.j.aalto...@nokia.com --- drivers/media/radio/Kconfig| 15 + drivers/media/radio/Makefile |1 + drivers/media/radio/radio-wl1273.c | 1907

[PATCH v4 5/5] Documentation: v4l: Add hw_seek spacing.

2010-06-04 Thread Matti J. Aaltonen
Add a couple of words about the spacing field in HW seek struct. Signed-off-by: Matti J. Aaltonen matti.j.aalto...@nokia.com --- .../DocBook/v4l/vidioc-s-hw-freq-seek.xml | 10 -- 1 files changed, 8 insertions(+), 2 deletions(-) diff --git

[PATCH v4 0/5] WL1273 FM Radio driver.

2010-06-04 Thread Matti J. Aaltonen
Hello again, and thank you for the comments. New in this version of the patch set: General headers: I removed the seek level stuff and added the FM RX class. And I've added the BAND IOCTL and I defined the three existing bands: I also added the OIRT band because I think it's nicer to have

[patch] media/radio: fix copy_to_user to user handling

2010-06-04 Thread Dan Carpenter
copy_to/from_user() returns the number of bytes remaining to be copied but the code here was testing for negative returns. I modified it to return -EFAULT. These functions are called from si4713_s_ext_ctrls() and that only tests for negative error codes. Signed-off-by: Dan Carpenter

[patch] V4L/DVB: dvb_ca_en50221: return -EFAULT on copy_to_user errors

2010-06-04 Thread Dan Carpenter
copy_to_user() returns the number of bytes remaining to be copied which isn't the right thing to return here. The comments say that these functions in dvb_ca_en50221.c should return the number of bytes copied or an error return. I've changed it to return -EFAULT. Signed-off-by: Dan Carpenter

Re: [patch] V4L/DVB: dvb_ca_en50221: return -EFAULT on copy_to_user errors

2010-06-04 Thread walter harms
Dan Carpenter schrieb: copy_to_user() returns the number of bytes remaining to be copied which isn't the right thing to return here. The comments say that these functions in dvb_ca_en50221.c should return the number of bytes copied or an error return. I've changed it to return -EFAULT.

Terratec Cinergy C DVB-C card problems

2010-06-04 Thread Rune Evjen
Hi, I've got a terratec cinergy c dvb-c card, fresh install of ubuntu 10.04 lucid i386. Card is here: http://www.linuxtv.org/wiki/index.php/TerraTec_Cinergy_C_DVB-C I followed the install instructions under Driver, installing the one from http://mercurial.intuxication.org/hg/s2-liplianin

[PATCH] IR/mceusb: clean up gen1 device init

2010-06-04 Thread Jarod Wilson
The first-gen mceusb device init code, while mostly functional, had a few issues in it. This patch does the following: 1) removes use of magic numbers 2) eliminates mapping of memory from stack 3) makes debug spew translator functional 4) properly initializes default tx blaster mask

Re: [PATCH RESEND] FusionHDTV: Use quick reads for I2C IR device probing

2010-06-04 Thread Jean Delvare
Mauro, On Wed, 26 May 2010 15:05:11 +0200, Jean Delvare wrote: IR support on FusionHDTV cards is broken since kernel 2.6.31. One side effect of the switch to the standard binding model for IR I2C devices was to let i2c-core do the probing instead of the ir-kbd-i2c driver. There is a slight

Re: [patch] V4L/DVB: dvb_ca_en50221: return -EFAULT on copy_to_user errors

2010-06-04 Thread Dan Carpenter
On Fri, Jun 04, 2010 at 02:26:05PM +0200, walter harms wrote: Doint to many things at once is bad. IMHO it is more readable to do so: +status = copy_to_user(buf, hdr, 2); +if ( status != 0) { Maybe the maintainer has different ideas but especialy lines like will gain. -if ((status =

[patch v2] V4L/DVB: dvb_ca_en50221: return -EFAULT on copy_to_user errors

2010-06-04 Thread Dan Carpenter
copy_to_user() returns the number of bytes remaining to be copied which isn't the right thing to return here. The comments say that these functions in dvb_ca_en50221.c should return the number of bytes copied or an error return. I've changed it to return -EFAULT. Signed-off-by: Dan Carpenter

[GIT PULL for 2.6.35] V4L/DVB fixes

2010-06-04 Thread Mauro Carvalho Chehab
The following changes since commit 67a3e12b05e055c0415c556a315a3d3eb637e29e: Linux 2.6.35-rc1 (2010-05-30 13:21:02 -0700) are available in the git repository at: ssh://master.kernel.org/pub/scm/linux/kernel/git/mchehab/linux-2.6.git v4l_for_2.6.35 Abylay Ospan (1): V4L/DVB: cx23885:

Re: [PATCH 1/3] IR: add core lirc device interface

2010-06-04 Thread Mauro Carvalho Chehab
Em 04-06-2010 12:51, Christoph Bartelmus escreveu: Hi Mauro, on 04 Jun 10 at 01:10, Mauro Carvalho Chehab wrote: Em 03-06-2010 19:06, Jarod Wilson escreveu: [...] As for the compat bits... I actually pulled them out of the Fedora kernel and userspace for a while, and there were only a few

Re: [PATCH RESEND] FusionHDTV: Use quick reads for I2C IR device probing

2010-06-04 Thread Mauro Carvalho Chehab
Em 04-06-2010 12:14, Jean Delvare escreveu: Mauro, On Wed, 26 May 2010 15:05:11 +0200, Jean Delvare wrote: IR support on FusionHDTV cards is broken since kernel 2.6.31. One side effect of the switch to the standard binding model for IR I2C devices was to let i2c-core do the probing instead

Re: [PATCH 1/3] IR: add core lirc device interface

2010-06-04 Thread Jon Smirl
On Fri, Jun 4, 2010 at 2:38 PM, Mauro Carvalho Chehab mche...@redhat.com wrote: Em 04-06-2010 12:51, Christoph Bartelmus escreveu: Hi Mauro, on 04 Jun 10 at 01:10, Mauro Carvalho Chehab wrote: Em 03-06-2010 19:06, Jarod Wilson escreveu: [...] As for the compat bits... I actually pulled them

[cron job] v4l-dvb daily build 2.6.22 and up: ERRORS, 2.6.16-2.6.21: ERRORS

2010-06-04 Thread Hans Verkuil
This message is generated daily by a cron job that builds v4l-dvb for the kernels and architectures in the list below. Results of the daily build of v4l-dvb: date:Fri Jun 4 19:00:22 CEST 2010 path:http://www.linuxtv.org/hg/v4l-dvb changeset: 14875:304cfde05b3f git master:

tm6000 audio buffer

2010-06-04 Thread Luis Henrique Fagundes
Hi, I'm sending a patch that hypothetically would allocate a memory buffer for the audio and copy the data from urb to buffer. It doesn't work, so I'm not putting a [PATCH] in subject and send it just for feedback. Am I going on the right way of implementing this? The patch was made against the

tm6000 autio isoc blocks

2010-06-04 Thread Stefan Ringel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Hi Mauro, I have check the windows usb log and if I have audio block it's say 0 byte, but the data is complete 180 bytes until next block header. So I think it's good if that audio block (cmd=2) resize from 0 to 180 (actual read 0 without resize

tm6000 and ir

2010-06-04 Thread Stefan Ringel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Hi Mauro, I write actually the ir implementation (tm6000-input.c). Can you give me any stuff what can help me? Stefan Ringel -BEGIN PGP SIGNATURE- Version: GnuPG v2.0.12 (MingW32) Comment: Using GnuPG with Mozilla -

Re: [PATCH 1/3] IR: add core lirc device interface

2010-06-04 Thread Jarod Wilson
On Fri, Jun 4, 2010 at 4:17 PM, Jarod Wilson ja...@redhat.com wrote: On Fri, Jun 04, 2010 at 02:57:04PM -0400, Jon Smirl wrote: ... From what I'm seeing, those are the current used ioctls: +#define LIRC_GET_FEATURES              _IOR('i', 0x, unsigned long) +#define

Re: [PATCH 1/3] IR: add core lirc device interface

2010-06-04 Thread Jon Smirl
On Fri, Jun 4, 2010 at 5:17 PM, Jarod Wilson ja...@wilsonet.com wrote: On Fri, Jun 4, 2010 at 4:17 PM, Jarod Wilson ja...@redhat.com wrote: On Fri, Jun 04, 2010 at 02:57:04PM -0400, Jon Smirl wrote: ... From what I'm seeing, those are the current used ioctls: +#define LIRC_GET_FEATURES    

Re: [PATCH] tm6000: bugfix unkown symbol tm6000_debug

2010-06-04 Thread Mauro Carvalho Chehab
Em 03-06-2010 12:49, stefan.rin...@arcor.de escreveu: From: Stefan Ringel stefan.rin...@arcor.de May 30 07:54:09 linux-v5dy kernel: [ 2555.727426] tm6000: Unknown symbol tm6000_debug This won't work, since the same module will have diferent tm6000_debug vars. I'll write a proper fix and

[PATCH 3/6] tm6000-alsa: rework audio buffer allocation/deallocation

2010-06-04 Thread Mauro Carvalho Chehab
Signed-off-by: Mauro Carvalho Chehab mche...@redhat.com diff --git a/drivers/staging/tm6000/tm6000-alsa.c b/drivers/staging/tm6000/tm6000-alsa.c index 8520434..ca9aec5 100644 --- a/drivers/staging/tm6000/tm6000-alsa.c +++ b/drivers/staging/tm6000/tm6000-alsa.c @@ -15,6 +15,7 @@ #include

[PATCH 1/6] tm6000: Fix compilation breakages

2010-06-04 Thread Mauro Carvalho Chehab
A previous patch seemed to break compilation of the driver. Signed-off-by: Mauro Carvalho Chehab mche...@redhat.com mode change 100644 = 100755 Documentation/video4linux/extract_xc3028.pl diff --git a/Documentation/video4linux/extract_xc3028.pl b/Documentation/video4linux/extract_xc3028.pl

[PATCH 2/6] tm6000: Avoid OOPS when loading tm6000-alsa module

2010-06-04 Thread Mauro Carvalho Chehab
Signed-off-by: Mauro Carvalho Chehab mche...@redhat.com diff --git a/drivers/staging/tm6000/tm6000-alsa.c b/drivers/staging/tm6000/tm6000-alsa.c index 55a0925..8520434 100644 --- a/drivers/staging/tm6000/tm6000-alsa.c +++ b/drivers/staging/tm6000/tm6000-alsa.c @@ -39,7 +39,7 @@

[PATCH 0/6] tm6000: some fixes plus alsa improvements

2010-06-04 Thread Mauro Carvalho Chehab
This patch series fixes a few compilation troubles with tm6000, caused by recent patches, and adds an alsa callback to allow it to fill the audio buffers. The current code there is just a printk code, but finishing it should be trivial (assuming that the audio buffers are properly filled). Mauro

[PATCH 6/6] tm6000: avoid unknown symbol tm6000_debug

2010-06-04 Thread Mauro Carvalho Chehab
Reported by Stefan Ringel. Thanks-to: Stefan Ringel stefan.rin...@arcor.de Signed-off-by: Mauro Carvalho Chehab mche...@redhat.com diff --git a/drivers/staging/tm6000/tm6000-video.c b/drivers/staging/tm6000/tm6000-video.c index c0d6f6a..34e8ef5 100644 --- a/drivers/staging/tm6000/tm6000-video.c

[PATCH 5/6] tm6000: Add a callback code for buffer fill

2010-06-04 Thread Mauro Carvalho Chehab
Implements a callback to be used by tm6000-alsa, in order to allow filling audio data packets. Signed-off-by: Mauro Carvalho Chehab mche...@redhat.com diff --git a/drivers/staging/tm6000/tm6000-alsa.c b/drivers/staging/tm6000/tm6000-alsa.c index db1eef9..e71579e 100644 ---

[PATCH 4/6] tm6000: Use an emum for extension type

2010-06-04 Thread Mauro Carvalho Chehab
In order to better document and be sure that the values are used at the proper places, convert extension type into an enum and name it as type, instead of id. Signed-off-by: Mauro Carvalho Chehab mche...@redhat.com diff --git a/drivers/staging/tm6000/tm6000-alsa.c

Re: tm6000 audio buffer

2010-06-04 Thread Mauro Carvalho Chehab
Hi Luis, Em 04-06-2010 16:39, Luis Henrique Fagundes escreveu: Hi, I'm sending a patch that hypothetically would allocate a memory buffer for the audio and copy the data from urb to buffer. It doesn't work, so I'm not putting a [PATCH] in subject and send it just for feedback. Am I going

Re: question about v4l2_subdev

2010-06-04 Thread Andy Walls
On Tue, 2010-06-01 at 10:14 +0200, Sedji Gaouaou wrote: Hi, 1. Something first should call v4l2_device_register() on a v4l2_device object. (Typically there is only one v4l2_device object per bridge chip between the PCI, PCIe, or USB bus and the subdevices, even if that bridge chip

dvb-usb/af9015 disconnection crashes

2010-06-04 Thread Xavier Gnata
Hi, I get crashes when I disconnect a dvb-usb-af9015: [54017.407738] usb 2-1.1: USB disconnect, address 9 [54018.685543] usb 2-1.5: USB disconnect, address 8 [54018.685895] af9015: bulk message failed:-22 (8/0) [54018.685901] af9013: I2C read failed reg:d417 [54018.685907] af9015: bulk message

Re: [PATCH 1/3] IR: add core lirc device interface

2010-06-04 Thread Jarod Wilson
On Fri, Jun 4, 2010 at 7:16 PM, Jon Smirl jonsm...@gmail.com wrote: On Fri, Jun 4, 2010 at 5:17 PM, Jarod Wilson ja...@wilsonet.com wrote: On Fri, Jun 4, 2010 at 4:17 PM, Jarod Wilson ja...@redhat.com wrote: On Fri, Jun 04, 2010 at 02:57:04PM -0400, Jon Smirl wrote: ... From what I'm seeing,