linux-firmware: add firmware v3.25.0.0 for ITEtech IT9135 DVB-T USB driver

2014-08-19 Thread Bimow Chen
Add two firmware files for ITEtech IT9135 Ax and Bx chip versions. From c05fac0989dff376729609cd6baac2367929d990 Mon Sep 17 00:00:00 2001 From: Bimow Chen bimow.c...@ite.com.tw Date: Tue, 19 Aug 2014 15:19:56 +0800 Subject: [PATCH] Add firmware v3.25.0.0 for ITEtech IT9135 DVB-T USB driver

[PATCH 1/6] V4L2: Add Renesas R-Car JPEG codec driver.

2014-08-19 Thread Mikhail Ulyanov
Signed-off-by: Mikhail Ulyanov mikhail.ulya...@cogentembedded.com --- drivers/media/platform/Kconfig | 11 + drivers/media/platform/Makefile |2 + drivers/media/platform/jpu.c| 1630 +++ 3 files changed, 1646 insertions(+) create mode 100644

[PATCH 0/6] R-Car JPEG Processing Unit

2014-08-19 Thread Mikhail Ulyanov
This series of patches contains a driver for the JPEG codec integrated peripheral found in the Renesas R-Car SoCs, JPU clocking and associated DT documentation. The driver is implemented within the V4L2 framework as a mem-to-mem device. It presents two video nodes to userspace, one for the

[PATCH 5/6] ARM: shmobile: r8a7791: Add JPU device node.

2014-08-19 Thread Mikhail Ulyanov
Signed-off-by: Mikhail Ulyanov mikhail.ulya...@cogentembedded.com --- arch/arm/boot/dts/r8a7791.dtsi | 7 +++ 1 file changed, 7 insertions(+) diff --git a/arch/arm/boot/dts/r8a7791.dtsi b/arch/arm/boot/dts/r8a7791.dtsi index c2d0c6e..464962a 100644 --- a/arch/arm/boot/dts/r8a7791.dtsi +++

[PATCH 6/6] devicetree: bindings: Document Renesas JPEG Processing Unit.

2014-08-19 Thread Mikhail Ulyanov
Signed-off-by: Mikhail Ulyanov mikhail.ulya...@cogentembedded.com --- .../devicetree/bindings/media/renesas,jpu.txt | 23 ++ 1 file changed, 23 insertions(+) create mode 100644 Documentation/devicetree/bindings/media/renesas,jpu.txt diff --git

[PATCH 2/6] ARM: shmobile: r8a7790: Add JPU clock dt and CPG define.

2014-08-19 Thread Mikhail Ulyanov
Signed-off-by: Mikhail Ulyanov mikhail.ulya...@cogentembedded.com --- arch/arm/boot/dts/r8a7790.dtsi| 6 +++--- include/dt-bindings/clock/r8a7790-clock.h | 1 + 2 files changed, 4 insertions(+), 3 deletions(-) diff --git a/arch/arm/boot/dts/r8a7790.dtsi

[PATCH 3/6] ARM: shmobile: r8a7790: Add JPU device node.

2014-08-19 Thread Mikhail Ulyanov
Signed-off-by: Mikhail Ulyanov mikhail.ulya...@cogentembedded.com --- arch/arm/boot/dts/r8a7790.dtsi | 7 +++ 1 file changed, 7 insertions(+) diff --git a/arch/arm/boot/dts/r8a7790.dtsi b/arch/arm/boot/dts/r8a7790.dtsi index 61fd193..c8bc048 100644 --- a/arch/arm/boot/dts/r8a7790.dtsi +++

[PATCH 4/6] ARM: shmobile: r8a7791: Add JPU clock dt and CPG define.

2014-08-19 Thread Mikhail Ulyanov
Signed-off-by: Mikhail Ulyanov mikhail.ulya...@cogentembedded.com --- arch/arm/boot/dts/r8a7791.dtsi| 6 +++--- include/dt-bindings/clock/r8a7791-clock.h | 1 + 2 files changed, 4 insertions(+), 3 deletions(-) diff --git a/arch/arm/boot/dts/r8a7791.dtsi

[PATCH 0/5] Add of-graph helpers to loop over endpoints and find ports by id

2014-08-19 Thread Philipp Zabel
Hi, this series converts all existing users of of_graph_get_next_endpoint that pass a non-NULL prev argument to the function and decrement its refcount themselves to stop doing that. The of_node_put is moved into of_graph_get_next_endpoint instead. This allows to add a for_each_endpoint_of_node

[PATCH 1/8] [media] soc_camera: Do not decrement endpoint node refcount in the loop

2014-08-19 Thread Philipp Zabel
In preparation for a following patch, stop decrementing the endpoint node refcount in the loop. This temporarily leaks a reference to the endpoint node, which will be fixed by having of_graph_get_next_endpoint decrement the refcount of its prev argument instead. Signed-off-by: Philipp Zabel

[PATCH 7/8] imx-drm: use for_each_endpoint_of_node macro in imx_drm_encoder_get_mux_id

2014-08-19 Thread Philipp Zabel
Using the for_each_... macro should make the code bit shorter and easier to read. This patch also properly decrements the endpoint node reference count before returning out of the loop. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- drivers/staging/imx-drm/imx-drm-core.c | 9 +++--

[PATCH 6/8] drm: use for_each_endpoint_of_node macro in drm_of_find_possible_crtcs

2014-08-19 Thread Philipp Zabel
Using the for_each_... macro should make the code a bit shorter and easier to read. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- drivers/gpu/drm/drm_of.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git a/drivers/gpu/drm/drm_of.c b/drivers/gpu/drm/drm_of.c

[PATCH 2/8] imx-drm: Do not decrement endpoint node refcount in the loop

2014-08-19 Thread Philipp Zabel
In preparation for the following patch, stop decrementing the endpoint node refcount in the loop. This temporarily leaks a reference to the endpoint node, which will be fixed by having of_graph_get_next_endpoint decrement the refcount of its prev argument instead. Signed-off-by: Philipp Zabel

[PATCH 5/8] of: Add of_graph_get_port_by_id function

2014-08-19 Thread Philipp Zabel
This patch adds a function to get a port device tree node by port id, or reg property value. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- drivers/of/base.c| 30 ++ include/linux/of_graph.h | 7 +++ 2 files changed, 37 insertions(+) diff --git

[PATCH 4/8] of: Add for_each_endpoint_of_node helper macro

2014-08-19 Thread Philipp Zabel
Note that while of_graph_get_next_endpoint decrements the reference count of the child node passed to it, of_node_put(child) still has to be called manually when breaking out of the loop. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- include/linux/of_graph.h | 4 1 file changed, 4

[PATCH 3/8] of: Decrement refcount of previous endpoint in of_graph_get_next_endpoint

2014-08-19 Thread Philipp Zabel
Decrementing the reference count of the previous endpoint node allows to use the of_graph_get_next_endpoint function in a for_each_... style macro. Prior to this patch, all current users of this function that actually pass a non-NULL prev parameter should be changed to not decrement the passed

[PATCH 8/8] imx-drm: use for_each_endpoint_of_node macro in imx_drm_encoder_parse_of

2014-08-19 Thread Philipp Zabel
Using the for_each_... macro should make the code bit shorter and easier to read. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- drivers/staging/imx-drm/imx-drm-core.c | 17 +++-- 1 file changed, 7 insertions(+), 10 deletions(-) diff --git

Re: [PATCH 1/6] V4L2: Add Renesas R-Car JPEG codec driver.

2014-08-19 Thread Hans Verkuil
Hi Mikhail, I did a quick scan over the source code and I noticed a few things that aren't right. The easiest for you is probably to run the v4l2-compliance tool over your driver and it should tell you what needs to be fixed. The things I noticed are: querycap doesn't fill in bus_info (should be

Re: [alsa-devel] [PATCH] usbtv: add audio support

2014-08-19 Thread Clemens Ladisch
Federico Simoncelli wrote: +++ b/drivers/media/usb/usbtv/usbtv-audio.c ... +#include sound/ac97_codec.h What do you need this header for? +static struct snd_pcm_hardware snd_usbtv_digital_hw = { + ... + .period_bytes_min = 11059, + .period_bytes_max = 13516, +

Re: [media-workshop] [ANNOUNCE] Linux Kernel Media mini-summit on Oct, 16-17 in Düsseldorf, Germany

2014-08-19 Thread Ricardo Ribalda Delgado
Hello I will also be in Düsseldorf the whole week for ELCE and LPC. I would love to attend the media mini-summit. I am interested in multiselection, deadpixels API and multiple timestamps per buffer. Thank you very much! On Thu, Aug 14, 2014 at 1:43 PM, Laurent Pinchart

Re: [media-workshop] [ANNOUNCE] Linux Kernel Media mini-summit on Oct, 16-17 in Düsseldorf, Germany

2014-08-19 Thread Laurent Pinchart
Hi Ricardo, On Tuesday 19 August 2014 16:48:19 Ricardo Ribalda Delgado wrote: Hello I will also be in Düsseldorf the whole week for ELCE and LPC. I would love to attend the media mini-summit. I am interested in multiselection, deadpixels API and multiple timestamps per buffer. Could

Re: [media-workshop] [ANNOUNCE] Linux Kernel Media mini-summit on Oct, 16-17 in Düsseldorf, Germany

2014-08-19 Thread Ricardo Ribalda Delgado
Hello Laurent Could you elaborate a bit on that last point ? What kind of timestamps would you need, and what are the use cases ? Right now we only have one timestamp field on the buffer structure, it might be a good idea to leave space for some more. My user case is a camera that is

Re: [PATCH v2 2/3] usb: gadget/uvc: also handle v4l2 ioctl ENUM_FMT

2014-08-19 Thread Laurent Pinchart
Hi Michael, Thank you for the patch. (CC'ing Hans Verkuil and the linux-media mailing list) On Friday 08 August 2014 17:38:58 Michael Grzeschik wrote: This patch adds ENUM_FMT as possible ioctl to the uvc v4l2 device. That makes userspace applications with a generic IOCTL calling convention

Re: [media-workshop] [ANNOUNCE] Linux Kernel Media mini-summit on Oct, 16-17 in Düsseldorf, Germany

2014-08-19 Thread Laurent Pinchart
On Tuesday 19 August 2014 18:29:08 Ricardo Ribalda Delgado wrote: Hello Laurent Could you elaborate a bit on that last point ? What kind of timestamps would you need, and what are the use cases ? Right now we only have one timestamp field on the buffer structure, it might be a good idea

Re: [PATCH v2 2/3] usb: gadget/uvc: also handle v4l2 ioctl ENUM_FMT

2014-08-19 Thread Hans Verkuil
On 08/19/2014 05:01 PM, Laurent Pinchart wrote: Hi Michael, Thank you for the patch. (CC'ing Hans Verkuil and the linux-media mailing list) On Friday 08 August 2014 17:38:58 Michael Grzeschik wrote: This patch adds ENUM_FMT as possible ioctl to the uvc v4l2 device. That makes userspace

Re: [media-workshop] [ANNOUNCE] Linux Kernel Media mini-summit on Oct, 16-17 in Düsseldorf, Germany

2014-08-19 Thread Hans Verkuil
On 08/19/2014 09:00 PM, Laurent Pinchart wrote: On Tuesday 19 August 2014 18:29:08 Ricardo Ribalda Delgado wrote: Hello Laurent Could you elaborate a bit on that last point ? What kind of timestamps would you need, and what are the use cases ? Right now we only have one timestamp field on

cron job: media_tree daily build: WARNINGS

2014-08-19 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Wed Aug 20 04:00:16 CEST 2014 git branch: test git hash: 0f3bf3dc1ca394a8385079a5653088672b65c5c4 gcc

[PATCH] videobuf2-core: make checking condition more strict

2014-08-19 Thread Zhaowei Yuan
It's also invalid that plane_no equals to vb-num_planes Signed-off-by: Zhaowei Yuan zhaowei.y...@samsung.com --- drivers/media/v4l2-core/videobuf2-core.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/v4l2-core/videobuf2-core.c