__tda18271_write_regs ERROR

2017-08-23 Thread Anders Eriksson
Hi, On a freshly booted rpi2, I got this in the logs (3rd line from bottom): [ 12.999134] em28xx 1-1.2.4.1:1.0: New device PCTV Systems PCTV 290e @ 480 Mbps (2013:024f, interface 0, class 0) [ 13.072265] em28xx 1-1.2.4.1:1.0: DVB interface 0 found: isoc [ 13.082114] em28xx 1-1.2.4.1:1.0:

Re: em28xx i2c writing error

2017-04-18 Thread Anders Eriksson
On Mon, Apr 17, 2017 at 3:55 AM, Mauro Carvalho Chehab <mche...@s-opensource.com> wrote: > Em Sat, 15 Apr 2017 20:28:20 +0200 > Anders Eriksson <aerikss...@gmail.com> escreveu: > >> Hi Mauro, >> >> I've two devices using this driver, and whenever I have th

Re: em28xx i2c writing error

2017-04-17 Thread Anders Eriksson
Hi Frank, On Sun, Apr 16, 2017 at 7:59 PM, Frank Schäfer <fschaefer@googlemail.com> wrote: > > Am 15.04.2017 um 20:28 schrieb Anders Eriksson: >> Hi Mauro, >> >> I've two devices using this driver, and whenever I have them both in >> use I eventually (b

em28xx i2c writing error

2017-04-15 Thread Anders Eriksson
Hi Mauro, I've two devices using this driver, and whenever I have them both in use I eventually (between 10K and 100K secs uptime) i2c write errors such as in the log below. If only have one of the devices in use, the machine is stable. The machine never recovers from the error. All help

Re: [PATCH 4/4] IR/imon: set up mce-only devices w/mce keytable

2010-09-16 Thread Anders Eriksson
ja...@redhat.com said: + /* iMON LCD, MCE IR */ + case 0x9e: + dev_info(ictx-dev, 0xffdc iMON VFD, MCE IR); + detected_display_type = IMON_DISPLAY_TYPE_VFD; + allowed_protos = IR_TYPE_RC6; + break; + /* iMON LCD, MCE IR */ +

Re: Fixed (Was:Re: saa7134/2.6.26 regression, noisy output)

2009-05-17 Thread Anders Eriksson
tomloh...@gmail.com said: Hello list, you are talking about tuner_config = 1 for the hvr 1110, right ? No. We're talking about the switch_addr variable. This variable is not changeable with module parameters. Changing this option doesn't affect the qualitie of the signal on tv see

Re: Fixed (Was:Re: saa7134/2.6.26 regression, noisy output)

2009-05-16 Thread Anders Eriksson
hermann-pit...@arcor.de said: thanks a lot for all your time and energy you did spend on this My pleasure. Especially since I start to see some progress! I suggest we start collecting photographs of different LNA circuits on the wiki. Do you want me to open up the case and take some photos

Fixed (Was:Re: saa7134/2.6.26 regression, noisy output)

2009-05-15 Thread Anders Eriksson
Success! I've tracked down the offending change. switch_addr takes on the wrong value and setting the LNA fails. Here's a i2c dump: saa7133[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff saa7133[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff saa7133[0]:

Re: saa7134/2.6.26 regression, noisy output

2009-05-10 Thread Anders Eriksson
An update: hermann-pit...@arcor.de said: hmm, the idea eventually was, to download these two snapshots, or make the last few changes manually on the first and try on 2.6.25. Then we might know, if the problem is already visible within Hartmut's latest fix attempts or even more and other

Re: saa7134/2.6.26 regression, noisy output

2009-05-07 Thread Anders Eriksson
hermann-pit...@arcor.de said: hmm, the idea eventually was, to download these two snapshots, or make the last few changes manually on the first and try on 2.6.25. Then we might know, if the problem is already visible within Hartmut's latest fix attempts or even more and other stuff is

saa7134/2.6.26 regression, noisy output

2009-05-03 Thread Anders Eriksson
Hi all, I've got a saa7133[0]: subsystem: 11bd:002f, board: Pinnacle PCTV 310i [card=101,autodetected] In all kernels later than 2.6.25 there is a significant layer of noise added to the video output. I've tried to bisect the problem, and it was introduced somewhere between