Re: [PATCH/RFC v10 06/19] mfd: max77693: modifications around max77693_led_platform_data

2015-01-20 Thread Lee Jones
On Fri, 09 Jan 2015, Jacek Anaszewski wrote:

 1. Rename max77693_led_platform_data to max77693_led_config_data to
avoid making impression that the led driver expects a board file -
it relies on Device Tree data.
 2. Remove fleds array, as the DT binding design has changed
 3. Add label array for Device Tree strings with the name of a LED device
 4. Make flash_timeout a two element array, for caching the sub-led
related flash timeout.
 5. Remove trigger array as the related data will not be provided
in the DT binding

Code looks fine, and I'm sure you've tested this thoroughly.

I'm slightly concerned about current users though.  Are there any?  Is
this patch-set fully bisectable?

 Signed-off-by: Jacek Anaszewski j.anaszew...@samsung.com
 Acked-by: Kyungmin Park kyungmin.p...@samsung.com
 Cc: Chanwoo Choi cw00.c...@samsung.com
 Cc: Lee Jones lee.jo...@linaro.org
 ---
  include/linux/mfd/max77693.h |9 -
  1 file changed, 4 insertions(+), 5 deletions(-)
 
 diff --git a/include/linux/mfd/max77693.h b/include/linux/mfd/max77693.h
 index f0b6585..c1ccb13 100644
 --- a/include/linux/mfd/max77693.h
 +++ b/include/linux/mfd/max77693.h
 @@ -87,17 +87,16 @@ enum max77693_led_boost_mode {
   MAX77693_LED_BOOST_FIXED,
  };
  
 -struct max77693_led_platform_data {
 - u32 fleds[2];
 +struct max77693_led_config_data {
 + const char *label[2];
   u32 iout_torch[2];
   u32 iout_flash[2];
 - u32 trigger[2];
 - u32 trigger_type[2];
 + u32 flash_timeout[2];
   u32 num_leds;
   u32 boost_mode;
 - u32 flash_timeout;
   u32 boost_vout;
   u32 low_vsys;
 + u32 trigger_type;
  };
  
  /* MAX77693 */

-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
--
To unsubscribe from this list: send the line unsubscribe linux-media in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH/RFC v10 06/19] mfd: max77693: modifications around max77693_led_platform_data

2015-01-09 Thread Pavel Machek
On Fri 2015-01-09 16:22:56, Jacek Anaszewski wrote:
 1. Rename max77693_led_platform_data to max77693_led_config_data to
avoid making impression that the led driver expects a board file -
it relies on Device Tree data.
 2. Remove fleds array, as the DT binding design has changed
 3. Add label array for Device Tree strings with the name of a LED device
 4. Make flash_timeout a two element array, for caching the sub-led
related flash timeout.
 5. Remove trigger array as the related data will not be provided
in the DT binding
 
 Signed-off-by: Jacek Anaszewski j.anaszew...@samsung.com
 Acked-by: Kyungmin Park kyungmin.p...@samsung.com
 Cc: Chanwoo Choi cw00.c...@samsung.com
 Cc: Lee Jones lee.jo...@linaro.org

Seems that max77693_led_platform_data is unused at the moment, so it
should not break bisect.

Acked-by: Pavel Machek pa...@ucw.cz

 index f0b6585..c1ccb13 100644
 --- a/include/linux/mfd/max77693.h
 +++ b/include/linux/mfd/max77693.h
 @@ -87,17 +87,16 @@ enum max77693_led_boost_mode {
   MAX77693_LED_BOOST_FIXED,
  };
  
 -struct max77693_led_platform_data {
 - u32 fleds[2];
 +struct max77693_led_config_data {
 + const char *label[2];
   u32 iout_torch[2];
   u32 iout_flash[2];

-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) 
http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
--
To unsubscribe from this list: send the line unsubscribe linux-media in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH/RFC v10 06/19] mfd: max77693: modifications around max77693_led_platform_data

2015-01-09 Thread Jacek Anaszewski
1. Rename max77693_led_platform_data to max77693_led_config_data to
   avoid making impression that the led driver expects a board file -
   it relies on Device Tree data.
2. Remove fleds array, as the DT binding design has changed
3. Add label array for Device Tree strings with the name of a LED device
4. Make flash_timeout a two element array, for caching the sub-led
   related flash timeout.
5. Remove trigger array as the related data will not be provided
   in the DT binding

Signed-off-by: Jacek Anaszewski j.anaszew...@samsung.com
Acked-by: Kyungmin Park kyungmin.p...@samsung.com
Cc: Chanwoo Choi cw00.c...@samsung.com
Cc: Lee Jones lee.jo...@linaro.org
---
 include/linux/mfd/max77693.h |9 -
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/include/linux/mfd/max77693.h b/include/linux/mfd/max77693.h
index f0b6585..c1ccb13 100644
--- a/include/linux/mfd/max77693.h
+++ b/include/linux/mfd/max77693.h
@@ -87,17 +87,16 @@ enum max77693_led_boost_mode {
MAX77693_LED_BOOST_FIXED,
 };
 
-struct max77693_led_platform_data {
-   u32 fleds[2];
+struct max77693_led_config_data {
+   const char *label[2];
u32 iout_torch[2];
u32 iout_flash[2];
-   u32 trigger[2];
-   u32 trigger_type[2];
+   u32 flash_timeout[2];
u32 num_leds;
u32 boost_mode;
-   u32 flash_timeout;
u32 boost_vout;
u32 low_vsys;
+   u32 trigger_type;
 };
 
 /* MAX77693 */
-- 
1.7.9.5

--
To unsubscribe from this list: send the line unsubscribe linux-media in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html