This patch fixes the remaining coding style warnings in the lirc module.
Instead of hard coding the function name the __func__ variable
should be used.


It fixes the following checkpatch.pl warning:

WARNING: Prefer using '"%s...", __func__' to using 'read', this
function's name, in a string

Signed-off-by: Martin Homuth <martin.hom...@martinhomuth.de>
---
 drivers/staging/media/cxd2099/cxd2099.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/media/cxd2099/cxd2099.c
b/drivers/staging/media/cxd2099/cxd2099.c
index 3e30f48..6641dd2 100644
--- a/drivers/staging/media/cxd2099/cxd2099.c
+++ b/drivers/staging/media/cxd2099/cxd2099.c
@@ -101,7 +101,7 @@ static int i2c_read_reg(struct i2c_adapter *adapter,
u8 adr,
                                   .buf = val, .len = 1} };

        if (i2c_transfer(adapter, msgs, 2) != 2) {
-               dev_err(&adapter->dev, "error in i2c_read_reg\n");
+               dev_err(&adapter->dev, "error in %s\n", __func__);
                return -1;
        }
        return 0;
@@ -116,7 +116,7 @@ static int i2c_read(struct i2c_adapter *adapter, u8 adr,
                                   .buf = data, .len = n} };

        if (i2c_transfer(adapter, msgs, 2) != 2) {
-               dev_err(&adapter->dev, "error in i2c_read\n");
+               dev_err(&adapter->dev, "error in %s\n", __func__);
                return -1;
        }
        return 0;
-- 
2.10.0

Reply via email to