Re: [PATCH v2 1/2] uvcvideo: rename UVC_QUIRK_INFO to UVC_INFO_QUIRK

2018-08-20 Thread Laurent Pinchart
Hi Guennadi, Thank you for the patch. On Monday, 20 August 2018 09:45:16 EEST Guennadi Liakhovetski wrote: > Hi Laurent, > > As far as I understand we've missed the 4.19 cycle. Can we move on with > this please? I've taken this patch in my tree and will try to handle the rest this week. --

Re: [PATCH v2 1/2] uvcvideo: rename UVC_QUIRK_INFO to UVC_INFO_QUIRK

2018-08-20 Thread Laurent Pinchart
Hi Guennadi, On Monday, 20 August 2018 15:02:53 EEST Laurent Pinchart wrote: > On Friday, 3 August 2018 14:36:56 EEST Guennadi Liakhovetski wrote: > > This macro defines "information about quirks," not "quirks for > > information." To address Nicolas' objection, would you mind saying "device

Re: [PATCH v2 1/2] uvcvideo: rename UVC_QUIRK_INFO to UVC_INFO_QUIRK

2018-08-20 Thread Laurent Pinchart
Hi Guennadi, Thank you for the patch. On Friday, 3 August 2018 14:36:56 EEST Guennadi Liakhovetski wrote: > This macro defines "information about quirks," not "quirks for > information." > > Signed-off-by: Guennadi Liakhovetski Reviewed-by: Laurent Pinchart and taken in my tree. > --- >

Re: [PATCH v2 1/2] uvcvideo: rename UVC_QUIRK_INFO to UVC_INFO_QUIRK

2018-08-20 Thread Laurent Pinchart
Hi Nicolas, On Saturday, 4 August 2018 18:58:18 EEST Nicolas Dufresne wrote: > Le vendredi 03 août 2018 à 13:36 +0200, Guennadi Liakhovetski a écrit : > > This macro defines "information about quirks," not "quirks for > > information." > > Does not sound better to me. It's "Quirk's information",

Re: [PATCH v2 1/2] uvcvideo: rename UVC_QUIRK_INFO to UVC_INFO_QUIRK

2018-08-20 Thread Guennadi Liakhovetski
Hi Laurent, As far as I understand we've missed the 4.19 cycle. Can we move on with this please? Thanks Guennadi On Fri, 3 Aug 2018, Guennadi Liakhovetski wrote: > This macro defines "information about quirks," not "quirks for > information." > > Signed-off-by: Guennadi Liakhovetski > --- >

Re: [PATCH v2 1/2] uvcvideo: rename UVC_QUIRK_INFO to UVC_INFO_QUIRK

2018-08-04 Thread Nicolas Dufresne
Le vendredi 03 août 2018 à 13:36 +0200, Guennadi Liakhovetski a écrit : > This macro defines "information about quirks," not "quirks for > information." Does not sound better to me. It's "Quirk's information", vs "information about quirks". I prefer the first one. In term of C namespace the

[PATCH v2 1/2] uvcvideo: rename UVC_QUIRK_INFO to UVC_INFO_QUIRK

2018-08-03 Thread Guennadi Liakhovetski
This macro defines "information about quirks," not "quirks for information." Signed-off-by: Guennadi Liakhovetski --- drivers/media/usb/uvc/uvc_driver.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/drivers/media/usb/uvc/uvc_driver.c