Using the for_each_... macro should make the code a bit shorter and
easier to read.

Signed-off-by: Philipp Zabel <p.za...@pengutronix.de>
Acked-by: Laurent Pinchart <laurent.pinch...@ideasonboard.com>
---
 drivers/gpu/drm/drm_of.c | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

diff --git a/drivers/gpu/drm/drm_of.c b/drivers/gpu/drm/drm_of.c
index 16150a0..024fa77 100644
--- a/drivers/gpu/drm/drm_of.c
+++ b/drivers/gpu/drm/drm_of.c
@@ -46,11 +46,7 @@ uint32_t drm_of_find_possible_crtcs(struct drm_device *dev,
        struct device_node *remote_port, *ep = NULL;
        uint32_t possible_crtcs = 0;
 
-       do {
-               ep = of_graph_get_next_endpoint(port, ep);
-               if (!ep)
-                       break;
-
+       for_each_endpoint_of_node(port, ep) {
                remote_port = of_graph_get_remote_port(ep);
                if (!remote_port) {
                        of_node_put(ep);
@@ -60,7 +56,7 @@ uint32_t drm_of_find_possible_crtcs(struct drm_device *dev,
                possible_crtcs |= drm_crtc_port_mask(dev, remote_port);
 
                of_node_put(remote_port);
-       } while (1);
+       }
 
        return possible_crtcs;
 }
-- 
2.1.0

--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to