Re: CI-Module not working on Technisat Cablestar HD2

2010-06-25 Thread Pascal Hahn
Thanks for the feedback already. Do you know which kernel version this
driver is functional in out of the top of your head?

I tried multiple kernels and had no luck getting it to work so far.

On Thu, Jun 24, 2010 at 2:32 PM, Bjørn Mork bj...@mork.no wrote:
 Pascal Hahn derpa...@gmail.com writes:

 I can't see any of the expected mantis_ca_init but couldn't figure out
 in the code where that gets called.

 I don't think it is.  It was at some point, but it seems to be removed.
 Most likely because it wasn't considered ready at the time this driver
 was merged(?)

 BTW, there is a potentional null dereference in mantis_irq_handler(),
 which will do

        ca = mantis-mantis_ca;
 ..
        if (stat  MANTIS_INT_IRQ0) {
                dprintk(MANTIS_DEBUG, 0, %s, label[1]);
                mantis-gpif_status = rst_stat;
                wake_up(ca-hif_write_wq);
                schedule_work(ca-hif_evm_work);
        }

 This will blow up if (stat  MANTIS_INT_IRQ0) is true, since
 mantis-mantis_ca never is allocated.  But then I guess that the
 hardware should normally prevent (stat  MANTIS_INT_IRQ0) from being
 true as long as the ca system isn't initiated, so this does not pose a
 problem in practice.

 Still doesn't look good.



 Bjørn

 --
 To unsubscribe from this list: send the line unsubscribe linux-media in
 the body of a message to majord...@vger.kernel.org
 More majordomo info at  http://vger.kernel.org/majordomo-info.html

--
To unsubscribe from this list: send the line unsubscribe linux-media in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: CI-Module not working on Technisat Cablestar HD2

2010-06-25 Thread Bjørn Mork
Pascal Hahn derpa...@gmail.com writes:

 Thanks for the feedback already. Do you know which kernel version this
 driver is functional in out of the top of your head?

 I tried multiple kernels and had no luck getting it to work so far.

If you are talking about the mantis driver in Linus' mainline kernels,
then it isn't updated at all since it was merged.  No need to try
different kernels. They are all the same with respect to this driver.

But the mantis driver went through a lot of changes during the very
active development before it was merged, and the CA code used to be
enabled at some point.  But I do not know if it worked.  And there were
most likely very good reasons to disable it...

Google will know.


Bjørn
--
To unsubscribe from this list: send the line unsubscribe linux-media in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: CI-Module not working on Technisat Cablestar HD2

2010-06-24 Thread Bjørn Mork
Pascal Hahn derpa...@gmail.com writes:

 I can't see any of the expected mantis_ca_init but couldn't figure out
 in the code where that gets called.

I don't think it is.  It was at some point, but it seems to be removed.
Most likely because it wasn't considered ready at the time this driver
was merged(?)

BTW, there is a potentional null dereference in mantis_irq_handler(),
which will do

ca = mantis-mantis_ca;
..
if (stat  MANTIS_INT_IRQ0) {
dprintk(MANTIS_DEBUG, 0, %s, label[1]);
mantis-gpif_status = rst_stat;
wake_up(ca-hif_write_wq);
schedule_work(ca-hif_evm_work);
}

This will blow up if (stat  MANTIS_INT_IRQ0) is true, since
mantis-mantis_ca never is allocated.  But then I guess that the
hardware should normally prevent (stat  MANTIS_INT_IRQ0) from being
true as long as the ca system isn't initiated, so this does not pose a
problem in practice.

Still doesn't look good.



Bjørn

--
To unsubscribe from this list: send the line unsubscribe linux-media in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


CI-Module not working on Technisat Cablestar HD2

2010-06-23 Thread Pascal Hahn
Hi,

I am trying to get the CI module of a Technisat Cablestar HD2 to work
since about a week now. I tried multiple x64 kernelbuilds
(s2-liplianin, straight 2.6.35-rc3 kernel, 2.6.32-22 ubuntu kernel,
2.6.34, .) and could not get the cam module on the mantis-based
card to work.

After looking into it in detail, it seems that my card is not using
the tda10021 frontend (as outlined in
http://www.linuxtv.org/wiki/index.php/Technisat_CableStar_HD2) but the
tda10023 frontend.

I had a brief look through the code and also tried to use the tda10021
frontend manually but the detection will fail.

My dmesg looks like this:

[   19.821945] IR NEC protocol handler initialized
[   19.832912] IR RC5(x) protocol handler initialized
[   19.835154] IR RC6 protocol handler initialized
[   19.838766] IR JVC protocol handler initialized
[   19.843647] found a VP-2040 PCI DVB-C device on (04:01.0),
[   19.843657] Mantis :04:01.0: PCI INT A - GSI 16 (level, low) - IRQ 16
[   19.843698] Mantis Rev 1 [1ae4:0002], irq: 16, latency: 64
[   19.843700] memory: 0x0, mmio: 0xc900057ca000
[   19.843917] IR Sony protocol handler initialized
[   19.844666] MAC Address=[00:08:c9:d0:37:37]
[   19.844677] mantis_alloc_buffers (0): DMA=0x379e
cpu=0x8800379e size=65536
[   19.844681] mantis_alloc_buffers (0): RISC=0x3799e000
cpu=0x88003799e000 size=1000
[   19.844683] DVB: registering new adapter (Mantis DVB adapter)
[   19.873668] r8169 :02:00.0: eth0: link up
[   19.873704] r8169 :02:00.0: eth0: link up
[   20.213418]   alloc irq_desc for 22 on node -1
[   20.213421]   alloc kstat_irqs on node -1
[   20.213427] HDA Intel :00:1b.0: PCI INT A - GSI 22 (level,
low) - IRQ 22
[   20.213519]   alloc irq_desc for 45 on node -1
[   20.213521]   alloc kstat_irqs on node -1
[   20.213529] HDA Intel :00:1b.0: irq 45 for MSI/MSI-X
[   20.213553] HDA Intel :00:1b.0: setting latency timer to 64
[   20.393010] hda_codec: ALC887: BIOS auto-probing.
[   20.394885] input: HDA Digital PCBeep as
/devices/pci:00/:00:1b.0/input/input3
[   20.768259] vp2040_frontend_init (0): Probing for CU1216 (DVB-C)
[   20.770271] vp2040_frontend_init (0): found Philips CU1216 DVB-C
frontend (TDA10023) @ 0x0c
[   20.770273] vp2040_frontend_init (0): Mantis DVB-C Philips CU1216
frontend attach success
[   20.770276] DVB: registering adapter 0 frontend 0 (Philips TDA10023 DVB-C)...


I can't see any of the expected mantis_ca_init but couldn't figure out
in the code where that gets called.


Here's some pci information for the card:
04:01.0 Multimedia controller: Twinhan Technology Co. Ltd Mantis DTV
PCI Bridge Controller [Ver 1.0] (rev 01)

lspci -vv -s 04:01.0
04:01.0 Multimedia controller: Twinhan Technology Co. Ltd Mantis DTV
PCI Bridge Controller [Ver 1.0] (rev 01)
Subsystem: Device 1ae4:0002
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium
TAbort- TAbort+ MAbort- SERR- PERR- INTx-
Latency: 64 (2000ns min, 63750ns max)
Interrupt: pin A routed to IRQ 16
Region 0: Memory at f6fff000 (32-bit, prefetchable) [size=4K]
Kernel driver in use: Mantis

lspci -n -s 04:01.0
04:01.0 0480: 1822:4e35 (rev 01)


I tried the card out in a windows machine and it worked fine
(including the ci / cam module).

Is this a known issue already or is this so far not known?


Let me know if you need more information for this or if I can help
with anything,


Pascal
--
To unsubscribe from this list: send the line unsubscribe linux-media in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html