Re: [PATCH] [media] ov2640: make GPIOLIB an optional dependency

2017-04-19 Thread Mauro Carvalho Chehab
Em Wed, 19 Apr 2017 15:23:39 +0200 Pavel Machek escreveu: > Hi! > > > As warned by kbuild test robot: > > warning: (VIDEO_EM28XX_V4L2) selects VIDEO_OV2640 which has unmet > > direct dependencies (MEDIA_SUPPORT && VIDEO_V4L2 && I2C && GPIOLIB && > > MEDIA_CAMERA_SUPPORT) > >

Re: [PATCH v3 1/2] v4l: Add camera voice coil lens control class, current control

2017-04-19 Thread Mauro Carvalho Chehab
Em Sun, 16 Apr 2017 12:12:10 +0300 Sakari Ailus escreveu: > Hi Mauro, > > On Fri, Apr 14, 2017 at 11:23:32PM -0300, Mauro Carvalho Chehab wrote: > > Hi Sakari, > > > > Em Tue, 14 Feb 2017 14:20:22 +0200 > > Sakari Ailus escreveu: > > > > >

[PATCH] [media] rainshadow-cec: use strlcat instead of strncat

2017-04-19 Thread Arnd Bergmann
gcc warns about an obviously incorrect use of strncat(): drivers/media/usb/rainshadow-cec/rainshadow-cec.c: In function 'rain_cec_adap_transmit': drivers/media/usb/rainshadow-cec/rainshadow-cec.c:299:4: error: specified bound 48 equals the size of the destination [-Werror=stringop-overflow=]

[PATCH] [media] exynos_hdmi: improve MEDIA_CEC_NOTIFIER dependency

2017-04-19 Thread Arnd Bergmann
When the media subsystem is built as a loadable module, a built-in DRM driver cannot use the cec notifiers: drivers/gpu/drm/exynos/exynos_hdmi.o: In function `hdmi_get_modes': exynos_hdmi.c:(.text.hdmi_get_modes+0x80): undefined reference to `cec_notifier_set_phys_addr_from_edid'

[PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro

2017-04-19 Thread Logan Gunthorpe
Seeing the kunmap_atomic dma_buf_ops share the same name with a macro in highmem.h, the former can be aliased if any dma-buf user includes that header. I'm personally trying to include highmem.h inside scatterlist.h and this breaks the dma-buf code proper. Christoph Hellwig suggested [1]

RFC: Power states and VIDIOC_STREAMON

2017-04-19 Thread Devin Heitmueller
Hello all, I'm in the process of putting together a bunch of long-standing fixes for HVR-950q driver, and I ran into a regression related to the way the video decoder is being managed. Before we dig into the details here's the general question: Should a user be able to interrogate video decoder

[PATCH] cx88: Fix regression in initial video standard setting

2017-04-19 Thread Devin Heitmueller
Setting initial standard at the top of cx8800_initdev would cause the first call to cx88_set_tvnorm() to return without programming any registers (leaving the driver saying it's set to NTSC but the hardware isn't programmed). Even worse, any subsequent attempt to explicitly set it to NTSC-M will

Re: [PATCH] [media] sti: hdmi: improve MEDIA_CEC_NOTIFIER dependency

2017-04-19 Thread Hans Verkuil
Hi Arnd, On 19/04/17 18:59, Arnd Bergmann wrote: > When the media subsystem is built as a loadable module, a built-in > DRM driver cannot use the cec notifiers: > > drivers/gpu/drm/sti/sti_hdmi.o: In function `sti_hdmi_remove': > sti_hdmi.c:(.text.sti_hdmi_remove+0x28): undefined reference to >

Re: [PATCH v4] [media] uvcvideo: Add iFunction or iInterface to device names.

2017-04-19 Thread Laurent Pinchart
Hi Peter, Thank you for the patch. On Wednesday 19 Apr 2017 16:45:27 Peter Boström wrote: > Permits distinguishing between two /dev/videoX entries from the same > physical UVC device (that naturally share the same iProduct name). > > This change matches current Windows behavior by prioritizing

Re: [PATCH] [media] rainshadow-cec: use strlcat instead of strncat

2017-04-19 Thread Arnd Bergmann
On Wed, Apr 19, 2017 at 11:14 PM, Hans Verkuil wrote: > On 19/04/17 19:15, Arnd Bergmann wrote: >> gcc warns about an obviously incorrect use of strncat(): >> >> drivers/media/usb/rainshadow-cec/rainshadow-cec.c: In function >> 'rain_cec_adap_transmit': >>

Re: [PATCH 1/3] dt-bindings: mt8173: Fix mdp device tree

2017-04-19 Thread Rob Herring
On Thu, Apr 13, 2017 at 03:33:05PM +0800, Minghsiu Tsai wrote: > If the mdp_* nodes are under an mdp sub-node, their corresponding > platform device does not automatically get its iommu assigned properly. > > Fix this by moving the mdp component nodes up a level such that they are > siblings of

[PATCH] [media] sti: hdmi: improve MEDIA_CEC_NOTIFIER dependency

2017-04-19 Thread Arnd Bergmann
When the media subsystem is built as a loadable module, a built-in DRM driver cannot use the cec notifiers: drivers/gpu/drm/sti/sti_hdmi.o: In function `sti_hdmi_remove': sti_hdmi.c:(.text.sti_hdmi_remove+0x28): undefined reference to `cec_notifier_set_phys_addr'

[PATCH v4] [media] uvcvideo: Add iFunction or iInterface to device names.

2017-04-19 Thread Peter Boström
Permits distinguishing between two /dev/videoX entries from the same physical UVC device (that naturally share the same iProduct name). This change matches current Windows behavior by prioritizing iFunction over iInterface, but unlike Windows it displays both iProduct and iFunction/iInterface

Re: [PATCH] [media] rainshadow-cec: use strlcat instead of strncat

2017-04-19 Thread Hans Verkuil
On 19/04/17 19:15, Arnd Bergmann wrote: > gcc warns about an obviously incorrect use of strncat(): > > drivers/media/usb/rainshadow-cec/rainshadow-cec.c: In function > 'rain_cec_adap_transmit': > drivers/media/usb/rainshadow-cec/rainshadow-cec.c:299:4: error: specified > bound 48 equals the

Re: [PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro

2017-04-19 Thread Laura Abbott
On 04/19/2017 12:36 PM, Logan Gunthorpe wrote: Seeing the kunmap_atomic dma_buf_ops share the same name with a macro in highmem.h, the former can be aliased if any dma-buf user includes that header. I'm personally trying to include highmem.h inside scatterlist.h and this breaks the dma-buf code

Re: [PATCH] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro

2017-04-19 Thread Sinclair Yeh
Minor nits, otherwise the vmwgfx part, Reviewed-by: Sinclair Yeh On Tue, Apr 18, 2017 at 06:17:00PM -0600, Logan Gunthorpe wrote: > Seeing the kunmap_atomic dma_buf_op shares the same name with a macro s^ > in higmem.h, the former can be

cron job: media_tree daily build: ERRORS

2017-04-19 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Thu Apr 20 05:00:17 CEST 2017 media-tree git hash:9eb9db3a0f92b75ec710066202e0b2accb45afa9 media_build

[PATCH 00/12] minor cleanups for HVR-950q

2017-04-19 Thread Devin Heitmueller
This is a series of mostly minor cleanups/fixes for the HVR-950q driver. We'll get this stuff merged since it's non-controversial, and then we can argue about the more invasive patches to follow. Devin Heitmueller (12): au8522: don't attempt to configure unsupported VBI slicer au8522: don't

[PATCH 01/12] au8522: don't attempt to configure unsupported VBI slicer

2017-04-19 Thread Devin Heitmueller
Since we don't suppoort sliced VBI with the au0828/au8522, there is no need to configure the au8522 VBI slicer, which because of the coefficients requires a large amount of i2c traffic. Remove the relevant code. Note that this has no effect on raw VBI support, which is currently the only

[PATCH 04/12] au8522: remove note about VBI not being implemented

2017-04-19 Thread Devin Heitmueller
I got this working a couple of years ago. Remove it from the list of known issues. Signed-off-by: Devin Heitmueller --- drivers/media/dvb-frontends/au8522_decoder.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/media/dvb-frontends/au8522_decoder.c

[PATCH 05/12] au8522: remove leading bit for register writes

2017-04-19 Thread Devin Heitmueller
The leading bit in register values is actually an indicator as to whether to perform a read or write, so remove the bit from the register values, since the au8522_writereg() is now responsible for adding this bit automatically. Signed-off-by: Devin Heitmueller ---

[PATCH 02/12] au8522: don't touch i2c master registers on au8522

2017-04-19 Thread Devin Heitmueller
Some stray lines got inserted into the driver when I reverse engineered the I2C traffic (at the time I didn't know what the registers did). It turns up these registers muck with the onboard I2C master, which we don't use since we instead use the I2C gate. Remove the lines which can actually

[PATCH 08/12] Add USB quirk for HVR-950q to avoid intermittent device resets

2017-04-19 Thread Devin Heitmueller
The USB core and sysfs will attempt to enumerate certain parameters which are unsupported by the au0828 - causing inconsistent behavior and sometimes causing the chip to reset. Avoid making these calls. This problem manifested as intermittent cases where the au8522 would be reset on analog video

[PATCH 03/12] au8522: rework setup of audio routing

2017-04-19 Thread Devin Heitmueller
The original code was based on my reverse engineering of an I2C trace of the Windows driver. Now that I know what the registers actually do, restructure the code a bit, removing some unneeded register programming and fixing the sequencing of operations. This reduces the time it takes to change

[PATCH 09/12] xc5000: Don't spin waiting for analog lock

2017-04-19 Thread Devin Heitmueller
The xc5000 driver should not be spinning waiting for an analog lock. The ioctl() should be returning immediately and the application is responsible for polling for lock status. This behavior isn't very visible in cases where you tune to a valid channel, since lock is usually achieved much faster

[PATCH 07/12] au8522: fix lock detection to be more reliable.

2017-04-19 Thread Devin Heitmueller
Only looking at the lock register causes the status to float between locked and not locked when there is no signal. So improve the logic to also examine the state of the FSC PLL, which results in the lock status being consistently reported. Signed-off-by: Devin Heitmueller

[PATCH 12/12] au0828: Add timer to restart TS stream if no data arrives on bulk endpoint

2017-04-19 Thread Devin Heitmueller
For reasons unclear, we intermittently see a case where the tune is successful but the bulk stream fails to deliver any packets. Add a timer to automatically stop/start the data pump if we encounter such a case. Signed-off-by: Devin Heitmueller ---

[PATCH 11/12] Fix breakage in "make menuconfig" for media_build

2017-04-19 Thread Devin Heitmueller
The Kconfig format is strict enough where if the indentation isn't correct then the "make menuconfig" will break. Fix the indentation to match all the other entries. Signed-off-by: Devin Heitmueller --- drivers/media/rc/Kconfig | 8 1 file changed, 4

[PATCH 10/12] au8522: Set the initial modulation

2017-04-19 Thread Devin Heitmueller
We need to set the initial modulation on driver setup, or else any calls to GET_FRONTEND prior to the first SET_FRONTEND call will get back garbage. Signed-off-by: Devin Heitmueller --- drivers/media/dvb-frontends/au8522_common.c | 1 + 1 file changed, 1

[PATCH 06/12] au8522 Remove 0x4 bit for register reads

2017-04-19 Thread Devin Heitmueller
The second highest bit in the register value is an indicator to do a register read, so remove it since now au8522_regread() inserts the bit automatically. Also remove a stray instance where we were actually trying to write to the I2C status register, which was actually a read. Signed-off-by:

Re: [PATCH] arm: dma: fix sharing of coherent DMA memory without struct page

2017-04-19 Thread Shuah Khan
Hi Russell, and Marek, On 04/14/2017 03:46 AM, Russell King - ARM Linux wrote: > On Fri, Apr 14, 2017 at 09:56:07AM +0200, Marek Szyprowski wrote: This would be however quite large task, especially taking into account all current users of DMA-buf framework... >>> Yeah it will be a large

Re: [Linaro-mm-sig] [PATCHv4 12/12] staging/android: Update Ion TODO list

2017-04-19 Thread Laurent Pinchart
Hi Daniel, On Wednesday 19 Apr 2017 10:36:55 Daniel Vetter wrote: > On Tue, Apr 18, 2017 at 11:27:14AM -0700, Laura Abbott wrote: > > Most of the items have been taken care of by a clean up series. Remove > > the completed items and add a few new ones. > > > > Signed-off-by: Laura Abbott

Re: [PATCH 1/6] drm: Add writeback connector type

2017-04-19 Thread Brian Starkey
On Wed, Apr 19, 2017 at 01:34:34PM +0200, Boris Brezillon wrote: On Wed, 19 Apr 2017 10:51:23 +0100 Brian Starkey wrote: [snip] Could you expand a bit on how you think planes fit better? Just had the impression that the writeback feature was conceptually closer to a

[PATCH] staging: media: atomisp: fix misspelled word in comment

2017-04-19 Thread Luis Oliveira
This fix "overrided", the correct past tense form of "override" is "overridden". Signed-off-by: Luis Oliveira --- drivers/staging/media/atomisp/i2c/ov2680.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/media/atomisp/i2c/ov2680.c

Re: [PATCH] [media] ov2640: make GPIOLIB an optional dependency

2017-04-19 Thread Pavel Machek
Hi! > As warned by kbuild test robot: > warning: (VIDEO_EM28XX_V4L2) selects VIDEO_OV2640 which has unmet > direct dependencies (MEDIA_SUPPORT && VIDEO_V4L2 && I2C && GPIOLIB && > MEDIA_CAMERA_SUPPORT) > > The em28xx driver can use ov2640, but it doesn't depend > (or use) the GPIOLIB in

Re: [PATCH] [media] Order the Makefile alphabetically

2017-04-19 Thread Mauro Carvalho Chehab
Em Thu, 6 Apr 2017 16:40:51 +0200 Maxime Ripard escreveu: > The Makefiles were a free for all without a clear order defined. Sort all the > options based on the Kconfig symbol. > > Signed-off-by: Maxime Ripard > > --- > >

Re: [PATCH 1/6] drm: Add writeback connector type

2017-04-19 Thread Boris Brezillon
On Wed, 19 Apr 2017 10:51:23 +0100 Brian Starkey wrote: > On Tue, Apr 18, 2017 at 09:57:17PM +0200, Boris Brezillon wrote: > >Hi Brian, > > > >On Tue, 18 Apr 2017 18:34:43 +0100 > >Brian Starkey wrote: > > > >> >> @@ -214,6 +214,19 @@ struct

[PATCH] [media] ov2640: make GPIOLIB an optional dependency

2017-04-19 Thread Mauro Carvalho Chehab
As warned by kbuild test robot: warning: (VIDEO_EM28XX_V4L2) selects VIDEO_OV2640 which has unmet direct dependencies (MEDIA_SUPPORT && VIDEO_V4L2 && I2C && GPIOLIB && MEDIA_CAMERA_SUPPORT) The em28xx driver can use ov2640, but it doesn't depend (or use) the GPIOLIB in order to power

Re: [PATCH 0/9] Unify i2c_mux_add_adapter error reporting

2017-04-19 Thread Mauro Carvalho Chehab
Em Mon, 3 Apr 2017 13:27:48 +0200 Peter Rosin escreveu: > On 2017-04-03 12:27, Wolfram Sang wrote: > > On Mon, Apr 03, 2017 at 10:38:29AM +0200, Peter Rosin wrote: > >> Hi! > >> > >> Many users of the i2c_mux_add_adapter interface log a message > >> on failure, but the

[PATCH] [media] pixfmt-meta-vsp1-hgo.rst: remove spurious '-'

2017-04-19 Thread Mauro Carvalho Chehab
Remove spurious '-' in the VSP1 hgo table. This resulted in a weird dot character that also caused the row to be double-height. We used to have it on other tables, but we got rid of them on changeset 8ed29e302dd1 ("[media] subdev-formats.rst: remove spurious '-'"). Fixes: 14d665387165 ("[media]

Re: [PATCH 28/38] Annotate hardware config module parameters in drivers/staging/media/

2017-04-19 Thread Mauro Carvalho Chehab
Em Wed, 05 Apr 2017 18:01:01 +0100 David Howells escreveu: > When the kernel is running in secure boot mode, we lock down the kernel to > prevent userspace from modifying the running kernel image. Whilst this > includes prohibiting access to things like /dev/mem, it must

Re: [PATCH 13/38] Annotate hardware config module parameters in drivers/media/

2017-04-19 Thread Mauro Carvalho Chehab
Em Wed, 05 Apr 2017 17:58:41 +0100 David Howells escreveu: > When the kernel is running in secure boot mode, we lock down the kernel to > prevent userspace from modifying the running kernel image. Whilst this > includes prohibiting access to things like /dev/mem, it must

Re: [PATCH 3/3] [media] cobalt: Use v4l2_calc_timeperframe helper

2017-04-19 Thread Jose Abreu
Hi Hans, On 31-03-2017 09:59, Jose Abreu wrote: > Hi Hans, > > > On 30-03-2017 14:42, Hans Verkuil wrote: >> Hi Jose, >> >> On 21/03/17 12:49, Jose Abreu wrote: >>> Currently, cobalt driver always returns 60fps in g_parm. >>> This patch uses the new v4l2_calc_timeperframe helper to >>> calculate

[PATCH] [media] mtk-vcodec: avoid warnings because of empty macros

2017-04-19 Thread Mauro Carvalho Chehab
Remove those gcc warnings: drivers/media/platform/mtk-vcodec/mtk_vcodec_dec_pm.c: In function 'mtk_vcodec_dec_pw_on': drivers/media/platform/mtk-vcodec/mtk_vcodec_dec_pm.c:114:51: warning: suggest braces around empty body in an 'if' statement [-Wempty-body]

Re: [PATCH] media: mtk-vcodec: remove informative log

2017-04-19 Thread Mauro Carvalho Chehab
Em Wed, 5 Apr 2017 19:09:59 +0800 Tiffany Lin escreveu: > On Wed, 2017-04-05 at 18:54 +0800, Minghsiu Tsai wrote: > > Driver is stable. Remove DEBUG definition from driver. > > > > There are debug message in /var/log/messages if DEBUG is defined, > > such as: > >

Re: [PATCH] [media] pixfmt-meta-vsp1-hgo.rst: remove spurious '-'

2017-04-19 Thread Sakari Ailus
On 04/19/17 14:04, Mauro Carvalho Chehab wrote: > Remove spurious '-' in the VSP1 hgo table. > > This resulted in a weird dot character that also caused > the row to be double-height. > > We used to have it on other tables, but we got rid of them > on changeset 8ed29e302dd1 ("[media]

[GIT PULL FOR v4.12] cec: clean up Kconfig, headers

2017-04-19 Thread Hans Verkuil
Hi Mauro, This should be merged for 4.12 before more CEC drivers are merged. >From the cover letter of the patch series: - This patch series cleans up the various CEC config options. In particular it adds a CEC_CORE config option which is what CEC drivers should

Re: [Linaro-mm-sig] [PATCHv4 05/12] staging: android: ion: Break the ABI in the name of forward progress

2017-04-19 Thread Daniel Vetter
On Tue, Apr 18, 2017 at 11:27:07AM -0700, Laura Abbott wrote: > Several of the Ion ioctls were designed in such a way that they > necessitate compat ioctls. We're breaking a bunch of other ABIs and > cleaning stuff up anyway so let's follow the ioctl guidelines and clean > things up while everyone

Re: [Linaro-mm-sig] [PATCHv4 10/12] staging: android: ion: Remove ion_handle and ion_client

2017-04-19 Thread Daniel Vetter
On Tue, Apr 18, 2017 at 11:27:12AM -0700, Laura Abbott wrote: > ion_handle was introduced as an abstraction to represent a reference to > a buffer via an ion_client. As frameworks outside of Ion evolved, the dmabuf > emerged as the preferred standard for use in the kernel. This has made > the

Re: [PATCH 1/6] drm: Add writeback connector type

2017-04-19 Thread Brian Starkey
On Tue, Apr 18, 2017 at 09:57:17PM +0200, Boris Brezillon wrote: Hi Brian, On Tue, 18 Apr 2017 18:34:43 +0100 Brian Starkey wrote: >> @@ -214,6 +214,19 @@ struct drm_connector_state { >>struct drm_encoder *best_encoder; >> >>struct drm_atomic_state

Re: [Linaro-mm-sig] [PATCHv4 12/12] staging/android: Update Ion TODO list

2017-04-19 Thread Daniel Vetter
On Tue, Apr 18, 2017 at 11:27:14AM -0700, Laura Abbott wrote: > Most of the items have been taken care of by a clean up series. Remove > the completed items and add a few new ones. > > Signed-off-by: Laura Abbott > --- > drivers/staging/android/TODO | 21