Re: Reception issue: DViCO Fusion HDTV DVB-T Dual Express

2010-07-14 Thread Vincent McIntyre
I have this card (lspci reports pciid 14f1:8852, subsystem 18ac:db78) and the Dual Digital 4 (lsusb 0fe9:db78). I had a few problems similar to this (on Nine in Sydney, particularly) until Mauro applied some patches to fix some weirdness in the calculations of the tuning offsets, a few months ago

[patch] new_build.git - remove bashist equality testing

2010-10-30 Thread Vincent McIntyre
Hi, while trying to build this on ubuntu 10.04 (2.6.32-24-generic) I noticed some of the equality tests in linux/Makefile are bash-style, not POSIX-style. The problem I encountered was error messages like: ... make -C ../linux apply_patches make[2]: Entering directory

new_build on ubuntu (dvbdev.c)

2010-11-13 Thread Vincent McIntyre
Hi, I'm trying to build on 2.6.32 (ubuntu lucid i386). I followed the instructions for building from git[1] but I get an error I don't understand. make -C /lib/modules/2.6.32-25-3dbc39-generic/build SUBDIRS=/home/me/git/clones/linuxtv.org/new_build/v4l modules make[3]: Entering directory

Re: new_build on ubuntu (dvbdev.c)

2010-11-14 Thread Vincent McIntyre
Apologies, I replied off-list. On 11/14/10, Andy Walls awa...@md.metrocast.net wrote: On Sun, 2010-11-14 at 09:08 +1100, Vincent McIntyre wrote: Hi, I'm trying to build on 2.6.32 (ubuntu lucid i386). I followed the instructions for building from git[1] Shouldn't you be building from

Re: new_build on ubuntu (dvbdev.c)

2010-11-15 Thread Vincent McIntyre
On 11/15/10, Mauro Carvalho Chehab mauroche...@gmail.com wrote: ... I've added several patches for the new-build today, in order to make it compile against older kernels. I tested compilation here with both RHEL6 (2.6.32) and Fedora 14 (2.6.35) and compilation is working fine. Didn't test the

[patch] new_build.git - avoid failing on 'rm' of nonexistent file

2011-01-07 Thread Vincent McIntyre
While attempting to build recently I have found the 'make distclean' target fails if 'rm' tries to remove a file that is not there. The attached patch fixes the issue for me (by using rm -f). I converted all the other 'rm' calls to 'rm -f' along the way. Please consider applying this. Cheers

[patch] new_build.git - drop videodev.h

2011-01-07 Thread Vincent McIntyre
'make tar' fails for me (building against ubuntu 2.6.32) unless I remove videodev.h from TARFILES. Is this the correct thing to do here? diff --git a/linux/Makefile b/linux/Makefile index 695dcf2..8bbeee8 100644 --- a/linux/Makefile +++ b/linux/Makefile @@ -20,7 +20,6 @@ TARDIR += include/media/

Re: Debug code in HG repositories

2011-01-07 Thread Vincent McIntyre
On 1/8/11, Hans Verkuil hverk...@xs4all.nl wrote: Have you tried Mauro's media_build tree? I had to use it today to test a driver from git on a 2.6.35 kernel. Works quite nicely. Perhaps we should promote this more. I could add backwards compatibility builds to my daily build script that uses

Re: difference mchehab/new_build.git to media_build.git ?

2011-01-08 Thread Vincent McIntyre
There's no difference. It started out at mchehab/new_build.git, then got moved to media_build.git, but there's a symlink in place to keep from breaking things for people who originally checked it out at the old location. The move essentially promoted it from something Mauro's tinkering with

Re: Debug code in HG repositories

2011-01-11 Thread Vincent McIntyre
On 1/10/11, Mauro Carvalho Chehab mche...@redhat.com wrote: Thanks for your script, but it seems specific to your environment. Could you please make it more generic and perhaps patch the existing build.sh script? I was mainly intending to show how I happen to do this. It's way too complicated

Re: Debug code in HG repositories

2011-01-11 Thread Vincent McIntyre
On 1/10/11, Mauro Carvalho Chehab mche...@redhat.com wrote: Em 07-01-2011 23:02, Vincent McIntyre escreveu: On 1/8/11, Hans Verkuil hverk...@xs4all.nl wrote: Have you tried Mauro's media_build tree? I had to use it today to test a driver from git on a 2.6.35 kernel. Works quite nicely

[patch] addition to v2.6.35_i2c_new_probed_device.patch (was: Re: Debug code in HG repositories)

2011-01-12 Thread Vincent McIntyre
On 1/12/11, Mauro Carvalho Chehab mche...@redhat.com wrote: which on the face of it suggests btty-input.c already handled, my mistake. cx88-input.c the search string was in a comment hdpvr-i2c.c see below I have no time currently to touch on it, since I still have lots of patches

Re: [patch] addition to v2.6.35_i2c_new_probed_device.patch (was: Re: Debug code in HG repositories)

2011-01-14 Thread Vincent McIntyre
On 1/13/11, Mauro Carvalho Chehab mche...@redhat.com wrote: This seems to be a relatively simple patch, inline below. This is against the linux-media tree, I could not figure out how to turn it into a clean patch of media_build/backports/v2.6.35_i2c_new_probed_device.patch I did look for

media_build: build against 2.6.32 fails on rc-technisat-usb2.c

2011-01-14 Thread Vincent McIntyre
compilation breakage due to BKL dependency ... $ cd ~/git/clones/new_build $ git log -1 commit 6da048c31318ddeb9b19d899403a91f4c10e34dc Author: Vincent McIntyre vincent.mcint...@gmail.com Date: Thu Jan 13 10:41:14 2011 -0200 Update it to cover hdpvr-i2c.c Signed-off-by: Mauro Carvalho Chehab

media_build: build fails against (ubuntu) 2.6.32 on pvrusb2-debugifc.c

2011-01-19 Thread Vincent McIntyre
Hi, I am building against linux-2.6.32-26-generic from ubuntu, with just the linux-headers package. I know there is a big fat warning about doing this but I thought I should report the issue because mostly building like this does work. The build was against a clean checkout of the media_build

[patch] Re: media_build: build fails against (ubuntu) 2.6.32 on pvrusb2-debugifc.c

2011-01-21 Thread Vincent McIntyre
The problem was the new check function was not being called. Signed-off-by: vincent.mcint...@gmail.com diff --git a/v4l/scripts/make_config_compat.pl b/v4l/scripts/make_config_compat. index 438561a..f1dd577 100755 --- a/v4l/scripts/make_config_compat.pl +++ b/v4l/scripts/make_config_compat.pl @@

Re: [linux-dvb] DVICO HDTV Dual Express2

2011-04-04 Thread Vincent McIntyre
Hi Nick, Could you post the output of lspci -vvv -nn for the device in question - you'll also need to give the -s argument, eg -s 02:00.0 or whatever. This is so it is clear what chips your example of the card is using - a given card may be implemented with different chipsets over time

Re: [linux-dvb] DVICO HDTV Dual Express2

2011-04-04 Thread Vincent McIntyre
On 4/4/11, Daniel O'Connor dar...@dons.net.au wrote: I take it you use both tuners? I find I can only use one otherwise one of them hangs whatever app is using it. I do. I haven't tested very carefully that I can use both tuners at once successfully but I am pretty sure there have been times

imon: spews to dmesg

2011-04-18 Thread Vincent McIntyre
Hi list, I just (2011-04-19) upgraded to the current media_build with build.sh commit bcfdefe9f4538abf12fca1cdb631c80e3d598026 Author: Mauro Carvalho Chehab mchehab@nehalem.(none) Date: Sun Apr 17 08:21:25 2011 -0300 and hit a problem. I have an Antec case with an LCD screen. It needs the

Re: imon: spews to dmesg

2011-04-30 Thread Vincent McIntyre
On 4/20/11, Jarod Wilson ja...@wilsonet.com wrote: Those are almost all dev_dbg spew. Indeed, it seems to come from retval = send_packet(ictx); if (retval) { pr_err(send packet failed!\n); goto exit; } else {

Re: Build Failure

2011-05-01 Thread Vincent McIntyre
On 5/1/11, Colin Minihan colin.mini...@gmail.com wrote: On Ubuntu 10.04 attempting to run git clone git://linuxtv.org/media_build.git cd media_build ./check_needs.pl make -C linux/ download make -C linux/ untar make stagingconfig make results in the following failure ... I see this

Re: imon: spews to dmesg

2011-05-17 Thread Vincent McIntyre
I think I have found the source of this. linux/drivers/media/video/omap3isp/Makefile contains this: ifdef CONFIG_VIDEO_OMAP3_DEBUG EXTRA_CFLAGS += -DDEBUG endif but this module is not turned on,nor is the _DEBUG setting for it. % grep OMAP3 media_build/v4l/.config #

[bug]? cx23885 - tries to create duplicate (firmware) filename in sysfs

2011-06-06 Thread Vincent McIntyre
Hi, I just noticed this starting to happen - I can't see any sign of it in syslog before I rebuilt the modules (git commit tags are listed below). I don't know if this is a backporting issue or a bug in mainline. The system in question has two dual-tuner cards, one a USB (mounted on a PCI card)

Re: bisected regression in tuner-xc2028 on DVICO dual digital 4

2009-11-05 Thread Vincent McIntyre
I have one of these too. lsusb: Bus 003 Device 003: ID 0fe9:db78 DVICO FusionHDTV DVB-T Dual Digital 4 (ZL10353+xc2028/xc3028) (initialized) Bus 003 Device 002: ID 0fe9:db78 DVICO FusionHDTV DVB-T Dual Digital 4 (ZL10353+xc2028/xc3028) (initialized) In addition I have a DViCO Dual Digital

Re: bisected regression in tuner-xc2028 on DVICO dual digital 4

2009-11-07 Thread Vincent McIntyre
applies to his EXACT product . please provide the pci/usb I'd in question. thanks, devin On 11/6/09, Vincent McIntyre vincent.mcint...@gmail.com wrote: I tried this patch, on 2.6.24-23-rt and 2.6.31-14-generic . On the first, it appears to work fine. Thanks again Rob! On the second, while

Re: bisected regression in tuner-xc2028 on DVICO dual digital 4

2009-11-08 Thread Vincent McIntyre
On 11/8/09, Devin Heitmueller dheitmuel...@kernellabs.com wrote: I think the next step at this point is for you to definitively find a use case that does not work with the latest v4l-dvb tip and Robert's patch, and include exactly what kernel you tested with and which board is having the

Re: bisected regression in tuner-xc2028 on DVICO dual digital 4

2009-11-08 Thread Vincent McIntyre
Hi Barry, did you try cold-booting either system? how are you tuning? mythtv? Cheers Vince On 11/9/09, Barry Williams bazzaw...@gmail.com wrote: On Mon, Nov 9, 2009 at 12:22 PM, Devin Heitmueller dheitmuel...@kernellabs.com wrote: On Sun, Nov 8, 2009 at 8:43 PM, Barry Williams

Re: DViCO FusionHDTV DVB-T Dual Digital 4 (rev 1) tuning regression

2009-11-26 Thread Vincent McIntyre
Hi Rob would you mind very much posting a patch that implements these two reversions, so I can try it easily? My hg-fu is somewhat lacking... I have the same hardware and noticed what I think is the same issue, just with Channel 9. Another manifestation is huge BER and nonzero REC in the output

Re: DViCO FusionHDTV DVB-T Dual Digital 4 (rev 1) tuning regression

2009-11-26 Thread Vincent McIntyre
On 11/26/09, Vincent McIntyre vincent.mcint...@gmail.com wrote: Another manifestation is huge BER and nonzero REC in the output from 'tzap'. doh! I meant huge BER and nonzero UNC. Apologies also for the top-post. -- To unsubscribe from this list: send the line unsubscribe linux-media

Re: [RESEND] Re: DViCO FusionHDTV DVB-T Dual Digital 4 (rev 1) tuning regression

2009-12-08 Thread Vincent McIntyre
Mauro, Resend of my proposed patch attached that reverts tuning regressions with my DViCO card, whilst still fixing the original 6Mhz tuning issue. Please merge or let me know how else I should proceed to get this merged. Thanks -Rob perhaps the attached notes will help Rob's case here.

Re: [OT] preferred video apps?

2010-05-01 Thread vincent . mcintyre
On 1/05/10 10:48 AM, Mauro Carvalho Chehab wrote: Please, _do_not_ reply privately ;) I've found VLC useful for testing reception quality by eye, though it's not obvious how to force usage of a particular tuner. I am pretty sure it can record. Also '{c,s,t}zap' ow w-zap are helpful for

regression: firmware loading for dvico dual digital 4

2014-05-14 Thread Vincent McIntyre
Hi, Antti asked me to report this. I built the latest media_build git on Ubuntu 12.04, with 3.8.0 kernel, using './build --main-git'. The attached tarball has the relvant info. Without the media_build modules, firmware loads fine (file dmesg.1) Once I build and install the media_build modules,

regression: (repost) firmware loading for dvico dual digital 4

2014-06-30 Thread Vincent McIntyre
Hi, I am reposting this since it got ignored/missed last time around... On 5/14/14, Vincent McIntyre vincent.mcint...@gmail.com wrote: Hi, Antti asked me to report this. I built the latest media_build git on Ubuntu 12.04, with 3.8.0 kernel, using './build --main-git'. The attached tarball

Re: regression: (repost) firmware loading for dvico dual digital 4

2014-07-24 Thread Vincent McIntyre
Hi Mauro, thanks for taking the time to look at this. On Mon, Jun 30, 2014 at 11:56:33AM -0300, Mauro Carvalho Chehab wrote: Em Mon, 30 Jun 2014 23:19:46 +1000 Vincent McIntyre vincent.mcint...@gmail.com escreveu: Hi, I am reposting this since it got ignored/missed last time around

[patch] ensure correct install of modules from drivers/{misc,staging}

2014-09-14 Thread Vincent McIntyre
Hi, On an ubuntu system the code builds ok but not all modules run properly; the issue I noticed was the cx23885 module gave these errors when loaded: [ 20.395552] cx23885: disagrees about version of symbol altera_init [ 20.395560] cx23885: Unknown symbol altera_init (err -22) The cause was

Re: build failure on ubuntu 14.04.1 LTS

2015-01-20 Thread Vincent McIntyre
On Mon, Jan 19, 2015 at 01:45:44PM +0100, Hans Verkuil wrote: On 01/19/2015 01:32 PM, Vincent McIntyre wrote: Hi I am seeing build failures since 11 January. A build I did on 22 December worked fine. My build procedure and the error are shown below. I've just updated media_build

build failure on ubuntu 14.04.1 LTS

2015-01-19 Thread Vincent McIntyre
Hi I am seeing build failures since 11 January. A build I did on 22 December worked fine. My build procedure and the error are shown below. $ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=14.04 DISTRIB_CODENAME=trusty DISTRIB_DESCRIPTION=Ubuntu 14.04.1 LTS $ uname -a Linux ubuntu

Re: [PATCH] [media] rtl28xxu: add [0413:6f12] WinFast DTV2000 DS Plus

2015-03-13 Thread Vincent McIntyre
On Mon, Mar 09, 2015 at 03:19:01PM +1000, Christian Dale wrote: Add Leadtek WinFast DTV2000DS Plus device based on Realtek RTL2832U. I have not tested the remote, but it is the Y04G0051 model. Thanks for doing this Christian. I have one of these cards also, 0x6f12. I wrote the same patch

Re: Mygica T230 DVB-T/T2/C Ubuntu 14.04 (kernel 3.13.0-45) using media_build

2015-02-23 Thread Vincent McIntyre
On 2/23/15, Vincent McIntyre vincent.mcint...@gmail.com wrote: I saw this too, while working with Antti on adding support for another rtl* device. I should add how I triggered this - build --main-git, make install, halt - cold-boot, check modules loaded ok, check /dev/dvb/adapter* exist

Re: Mygica T230 DVB-T/T2/C Ubuntu 14.04 (kernel 3.13.0-45) using media_build

2015-02-23 Thread Vincent McIntyre
I saw this too, while working with Antti on adding support for another rtl2832-based DVB card. The kernel version [0.00] Linux version 3.13.0-45-generic (buildd@kissel) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #74-Ubuntu SMP Tue Jan 13 19:37:48 UTC 2015 (Ubuntu

issue with videobuf2-dma-sg.ko

2015-05-03 Thread Vincent McIntyre
Hi I am trying to load the cx23885 module. It fails to load and I get this in dmesg; [ 433.506983] videobuf2_dma_sg: Unknown symbol dma_buf_export (err 0) I wrote a small script to load each of the dependencies one at a time, which shows pretty clearly the problem is videobuf2-dma-sg.ko. I

Re: issue with videobuf2-dma-sg.ko

2015-05-03 Thread Vincent McIntyre
On Sun, May 03, 2015 at 10:45:37AM +0200, Hans Verkuil wrote: Hi Vince, On 05/03/2015 09:14 AM, Vincent McIntyre wrote: Hi I am trying to load the cx23885 module. It fails to load and I get this in dmesg; [ 433.506983] videobuf2_dma_sg: Unknown symbol dma_buf_export (err 0

[patch]: v4l-utils/util/dvb add -C to manpages

2015-05-08 Thread Vincent McIntyre
Hi I noticed the -C option was in the help from the -? option but not in the manpages. Cheers Vince diff --git a/utils/dvb/dvbv5-scan.1.in b/utils/dvb/dvbv5-scan.1.in index 08e3163..8016185 100644 --- a/utils/dvb/dvbv5-scan.1.in +++ b/utils/dvb/dvbv5-scan.1.in @@ -35,6 +35,9 @@ Force dvbv5\-scan

Re: rtl28xx Leadtek

2015-05-17 Thread Vincent McIntyre
On Sat, May 16, 2015 at 04:37:47PM +1000, Eyal Lebedinsky wrote: On 16/05/15 13:23, Vincent McIntyre wrote: Hi, I have been trying to get support going for a Leadtek WinFast DTV2000DS Plus (usbid 0413:6f12) In case it matters here, I have these cards and am using the driver built from

[patch] fix failure when applying backports/debug.patch

2015-07-17 Thread Vincent McIntyre
Hi, backports/debug.patch has gotten out of sync with the main tree. The last patch hunk fails: ... Applying patches for kernel 3.13.0-57-generic patch -s -f -N -p1 -i ../backports/api_version.patch patch -s -f -N -p1 -i ../backports/pr_fmt.patch patch -s -f -N -p1 -i ../backports/debug.patch 1

Re: Failure of ./build

2017-02-04 Thread Vincent McIntyre
Hi Bill with this patch I can get past the errors you are seeing. Those errors are happening because recent changes in the mainline kernel have not been reflected in the backport patches directory. [Patch] remove unneeded pr_fmt patches Recently (bbdba43f) the pr_fmt macro was removed from

Re: ir-keytable: infinite loops, segfaults

2017-02-07 Thread Vincent McIntyre
I tried your patch, after disabling the custom keymap file I had put in. Unfortunately the remote isn't working at all. When the relevant modules get loaded I see this in dmesg [7.838223] media: Linux media interface: v0.10 [7.840484] WARNING: You are using an experimental version of the

Re: ir-keytable: infinite loops, segfaults

2017-02-02 Thread Vincent McIntyre
Hey there On 11/30/16, Vincent McIntyre <vincent.mcint...@gmail.com> wrote: > On Sun, Nov 27, 2016 at 07:35:10PM +, Sean Young wrote: >> >> > I wanted to mention that the IR protocol is still showing as unknown. >> > Is there anything that can be done to sort

[regression] dvb_usb_cxusb (was Re: ir-keytable: infinite loops, segfaults)

2017-02-08 Thread Vincent McIntyre
Hi I have been working with Sean on figuring out the protocol used by a dvico remote. I thought the patch he sent was at fault but I backed it out and tried again. I've attached a full dmesg but the core of it is when dvb_usb_cxusb tries to load: [7.858907] WARNING: You are using an

Re: Mysterious regression in dvb driver

2017-01-23 Thread Vincent McIntyre
On Mon, Jan 23, 2017 at 12:21:35PM +, Dreamcat4 wrote: > Hi again, > > Installed Antergos (arch) linux today, and its still same issues. That > is with an even newer 4.8 kernel. No HD channels, I2C error in dmesg, > CRC error during w_scan tuning. (when its tuning the HD channels). > > So

Re: ir-keytable: infinite loops, segfaults

2017-02-21 Thread Vincent McIntyre
On 2/21/17, Sean Young wrote: > Hi Vincent, > ... > > On the cxusb the protocol is now nec, and that is the only protocol it > supports, you can't change it. > doh! ok well that's all good then. >> $ sudo cat /sys/class/rc/rc1/protocols >> nec >> $ sudo sh >> # echo "+rc-5 +nec

Re: ir-keytable: infinite loops, segfaults

2017-02-24 Thread Vincent McIntyre
On 2/22/17, Sean Young wrote: > So it's still using the old keymap. I've attached a new one. That works, thanks. >> # vol down >> 1487676637.746348: event type EV_MSC(0x04): scancode = 0x0105 >> 1487676637.746348: event type EV_SYN(0x00). >> # vol up >>

Re: [regression] dvb_usb_cxusb (was Re: ir-keytable: infinite loops, segfaults)

2017-02-13 Thread Vincent McIntyre
hans.verk...@cisco.com> > On Wed, Feb 08, 2017 at 10:30:30PM +1100, Vincent McIntyre wrote: >> Hi >> >> I have been working with Sean on figuring out the protocol used by a >> dvico remote. >> I thought the patch he sent was at fault but I backed it out and tri

Re: ir-keytable: infinite loops, segfaults

2017-02-16 Thread Vincent McIntyre
The dmesg... dmesg.txt.gz Description: GNU Zip compressed data

Re: ir-keytable: infinite loops, segfaults

2017-02-16 Thread Vincent McIntyre
Hi again after you kindly fixed media_build for me I applied the nec protocol patch and tried again. $ sudo ir-keytable Found /sys/class/rc/rc0/ (/dev/input/event5) with: Driver imon, table rc-imon-mce Supported protocols: rc-6 Enabled protocols: rc-6 Name: iMON

Fwd: [regression] dvb_usb_cxusb (was Re: ir-keytable: infinite loops, segfaults)

2017-02-16 Thread Vincent McIntyre
Hi list I missed you in the cc: field... -- Forwarded message -- From: Vincent McIntyre <vincent.mcint...@gmail.com> Date: Thu, 16 Feb 2017 23:51:05 +1100 Subject: Re: [regression] dvb_usb_cxusb (was Re: ir-keytable: infinite loops, segfaults) To: Sean Young <s...@mess.o

Re: ir-keytable: infinite loops, segfaults

2017-03-02 Thread Vincent McIntyre
On 3/1/17, Sean Young wrote: > > Sorry Vincent, but are you sure you're running the patch with the > & 0xff mask? That should have solved it. > er, no. Some kind of build issue. Once I applied your media_build patch and then the latest kernel patch you sent, this is what the test

Re: ir-keytable: infinite loops, segfaults

2016-11-23 Thread Vincent McIntyre
On Tue, Nov 22, 2016 at 09:20:44AM +, Sean Young wrote: > > Thanks for this. I have got it to build within the media_build setup > > but will need to find some windows in the schedule for testing. More > > in a couple of days. Are there specific things you would like me to > > test? > > You

[patch] fix 'make install'

2016-11-23 Thread Vincent McIntyre
Recent work on handling the case of no frame_vector.c in the kernel seems to have ended up breaking the 'make install' target. The patch below makes it work again for me, on ubuntu 16.04 LTS, amd64, kernel 4.4. Without it, I get this behavior: moake -C /home/me/media_build/v4l install make[1]:

Re: ir-keytable: infinite loops, segfaults

2016-11-24 Thread Vincent McIntyre
On Wed, Nov 23, 2016 at 10:34:19PM +, Sean Young wrote: > > Not sure why Driver is (null), dvb_usb_cxusb is loaded. > > That's a mistake, I've fixed that now. Ah. I see the added module_name struct members. > > I tried -t and it generated events constantly, before I could press > > any

Re: ir-keytable: infinite loops, segfaults

2016-11-25 Thread Vincent McIntyre
On 11/25/16, Sean Young wrote: > > So if I understand you correctly, if you change the keymap, like you > changed 0xfe47 to KEY_PAUSE, then "ir-keytable -s rc1 -t" show you the > correct (new) key? So as far as ir-keytable is concerned, everything > works? > > However when you try

Re: Problem with media_build install

2016-11-25 Thread Vincent McIntyre
Hi list, I sent a patch for this issue, could someone take a look? http://www.mail-archive.com/linux-media@vger.kernel.org/msg105340.html -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: ir-keytable: infinite loops, segfaults

2016-11-28 Thread Vincent McIntyre
On Sun, Nov 27, 2016 at 07:35:10PM +, Sean Young wrote: > > The application I am trying to use it with is the mythtv frontend. I > > am doing the keycode munging from an SSH session while myth is still > > running on the main screen. I didn't think this would matter (since it > > worked for

Re: ir-keytable: infinite loops, segfaults

2016-11-21 Thread Vincent McIntyre
On 11/21/16, Sean Young wrote: >> >> Ah. Here we have a problem. The device (/dev/input/event15) >> doesn't have a corresponding rcX node, see ir-keytable output below. >> I had it explained to me like this: > > As I said you would need to use a raw IR receiver which has rc-core

ir-keytable: infinite loops, segfaults

2016-11-16 Thread Vincent McIntyre
Hi, I have a fairly old dvico dual digital 4 tuner and remote. There seem to be some issues with support for it, can I help fix them? I am using ir-keytable 1.10.0-1 on Ubuntu 16.04 LTS, with kernel 4.4.0-47-generic (package version 4.4.0-47-generic) The remote's keymapping is the one in

Re: ir-keytable: infinite loops, segfaults

2016-11-18 Thread Vincent McIntyre
On Fri, Nov 18, 2016 at 05:40:34PM +, Sean Young wrote: > > > > # ir-keytable > > Found /sys/class/rc/rce0/ (/dev/input/event5) with: > > Driver imon, table rc-imon-mce > > Supported protocols: rc-6 > > Enabled protocols: rc-6 > > Name: iMON Remote (15c2:ffdc) > > bus:

Re: ir-keytable: infinite loops, segfaults

2016-11-18 Thread Vincent McIntyre
On Fri, Nov 18, 2016 at 05:40:34PM +, Sean Young wrote: > > > > So are you saying that the hex codes in the rc_map_dvico_mce_table > > struct are invalid (at least in some cases)? > > Most likely the remote produces IR in a standard protocol (e.g. rc5, rc6). > If we first get the keymap

Re: ir-keytable: infinite loops, segfaults

2016-11-18 Thread Vincent McIntyre
On Fri, Nov 18, 2016 at 05:40:34PM +, Sean Young wrote: > > At the moment it's not easy to determine what protocol an remote uses; > I would like to change that but for now, the following is probably > the easiest way. > > cd /sys/class/rc/rc1 # replace rc1 with your receiver > for i in

Re: ir-keytable: infinite loops, segfaults

2016-11-18 Thread Vincent McIntyre
On Thu, Nov 17, 2016 at 01:45:26PM +, Sean Young wrote: > On Wed, Nov 16, 2016 at 09:52:58PM +1100, Vincent McIntyre wrote: > > I have a fairly old dvico dual digital 4 tuner and remote. > > There seem to be some issues with support for it, can I help fix them? > > >

Re: ir-keytable: infinite loops, segfaults

2016-11-26 Thread Vincent McIntyre
>> >> However when you try to use the new mapping in some application then >> it does not work? > > That's correct. ir-keytable seems to be doing the right thing, mapping > the scancode to the input-event-codes.h key code I asked it to. > > The application I am trying to use it with is the mythtv

Re: ir-keytable: infinite loops, segfaults

2016-11-30 Thread Vincent McIntyre
On Sun, Nov 27, 2016 at 07:35:10PM +, Sean Young wrote: > > > I wanted to mention that the IR protocol is still showing as unknown. > > Is there anything that can be done to sort that out? > > It would be nice if that could be sorted out, although that would be > a separate patch. > > So

Re: [media_build] regression at 3a17e11 "update v4.10_sched_signal.patch"

2017-06-25 Thread Vincent McIntyre
On Thu, Jun 08, 2017 at 04:42:30PM +0200, Hans Verkuil wrote: > On 08/06/17 15:28, Vincent McIntyre wrote: > > I managed to find the failing patch, not sure what the fix is. > > > > $ cd linux/ > > $ patch -f -N -p1 -i ../backports/v4.10_sched_signal.patch > > pat

[regression] Build failure on ubuntu 16.04 LTS

2017-05-26 Thread Vincent McIntyre
$ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=16.04 DISTRIB_CODENAME=xenial DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS" $ uname -a Linux testbox 4.8.0-53-generic #56~16.04.1-Ubuntu SMP Tue May 16 01:18:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux $ git remote -v origin

Re: Build fails Ubuntu 17.04 / "error: implicit declaration of function"

2017-05-27 Thread Vincent McIntyre
I saw this too, ([regression] Build failure on ubuntu 16.04 LTS) 857313e51006ff51524579bcd8808b70f9a80812 media: utilize new cdev_device_add helper function introduced these in March this year. More backport patches are needed.

[PATCH 0/3] Fix failure of media_build build script

2017-05-30 Thread Vincent McIntyre
Hi I was trying to run build --main-git without the --depth option and it went splat. The attached series fixes my problem, possibly not entirely correctly for all cases, in the first patch. The other two patches are small cleanups that should make things more legible. Vincent McIntyre (3

Re: [PATCH 0/3] Fix failure of media_build build script

2017-05-30 Thread Vincent McIntyre
Before sending I ran one-more-test... which failed. Will respin and try again later. Vince

Re: media_build: fails to install

2017-06-02 Thread Vincent McIntyre
On Wed, May 31, 2017 at 03:57:04AM +0300, Olli Salonen wrote: > It seems that I'm able to build the media_build correctly on Ubuntu > 16.04.2 with kernel 4.8, but make install fails: > > ~/src/media_build$ sudo make install > make -C /home/olli/src/media_build/v4l install > make[1]: Entering

Re: Build fails Ubuntu 17.04 / "error: implicit declaration of function"

2017-06-04 Thread Vincent McIntyre
On Tue, May 30, 2017 at 09:35:03PM +0200, Karl Wallin wrote: > Hi! > > Sorry for not replying earlier, work. > I came so far as to download the patches (via n00bishly pasting the > actual content of the .patch-files into .patch-files since my git > cherry-pick command didn't work) but then after

[PATCH] small cleanup of build script

2017-06-01 Thread Vincent McIntyre
Introduce a function for better tracing of system() calls While debugging a recent issue I wanted more complete information about the sequencence of events in a series of system("foo") or die("BAR") calls. Adding this helper did that and cleaned things up a little. Si

[PATCH] Small fix to build script

2017-06-01 Thread Vincent McIntyre
, but the second falls over like so: fatal: No such remote or remote group: media_tree/master Can't update from the upstream tree at ./build line 430. The fix is to check whether that remote has been defined before trying to update from it. Signed-off-by: Vincent McIntyre <vincent.mcint...@gmail.

[PATCH] build: make check_git() give more information in verbose mode

2017-06-01 Thread Vincent McIntyre
While debugging another issue I found this change helpful. Signed-off-by: Vincent McIntyre <vincent.mcint...@gmail.com> --- build | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/build b/build index d7f51c2..4457a73 100755 --- a/build +++ b/build @@ -303,12 +303,13

Re: [media_build] regression at 3a17e11 "update v4.10_sched_signal.patch"

2017-06-08 Thread Vincent McIntyre
I managed to find the failing patch, not sure what the fix is. $ cd linux/ $ patch -f -N -p1 -i ../backports/v4.10_sched_signal.patch patching file drivers/media/dvb-core/dvb_ca_en50221.c Hunk #1 succeeded at 35 (offset 1 line). patching file drivers/media/dvb-core/dvb_demux.c Hunk #1 succeeded

Re: [media_build] regression at 3a17e11 "update v4.10_sched_signal.patch"

2017-06-08 Thread Vincent McIntyre
> > $ cat drivers/media/rc/lirc_dev.c.rej > --- drivers/media/rc/lirc_dev.c > +++ drivers/media/rc/lirc_dev.c > @@ -18,7 +18,7 @@ > #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt > > #include > -#include > +#include > #include > #include > #include > A bit of staring brings this to

Re: Unknown symbol put_vaddr_frames when using media_build

2017-06-08 Thread Vincent McIntyre
On Wed, Jun 07, 2017 at 08:12:01PM -0300, Mauro Carvalho Chehab wrote: > Em Wed, 7 Jun 2017 22:17:50 +0200 > Matthias Schwarzott escreveu: > > > Am 07.06.2017 um 20:23 schrieb Mauro Carvalho Chehab: > > > Em Tue, 9 May 2017 06:56:25 +0200 > > > Matthias Schwarzott

[media_build] regression at 3a17e11 "update v4.10_sched_signal.patch"

2017-06-08 Thread Vincent McIntyre
Hi I think the build was broken by this commit. 3a17e11 "update v4.10_sched_signal.patch" It's been fun learning about git bisect. $ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=16.04 DISTRIB_CODENAME=xenial DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS" The build script falls over on

[patch] [media_build] Small fix to build script (resend)

2017-06-09 Thread Vincent McIntyre
before trying to update from it. Signed-off-by: Vincent McIntyre <vincent.mcint...@gmail.com> --- build | 9 +++-- 1 file changed, 7 insertions(+), 2 deletions(-) diff --git a/build b/build index a4cd38e..d7f51c2 100755 --- a/build +++ b/build @@ -427,8 +427,13 @@ if (@gi

[patch] [media_build] make check_git() give more information in verbose mode (resend)

2017-06-09 Thread Vincent McIntyre
While debugging another issue I found this change helpful. Original send Date: Thu, 1 Jun 2017 20:44:27 +1000 Make check_git() give more information in verbose mode. Signed-off-by: Vincent McIntyre <vincent.mcint...@gmail.com> --- build | 3 ++- 1 file changed, 2 insertions(+), 1 de

[patch] [media_build] small cleanup of build script (resend)

2017-06-09 Thread Vincent McIntyre
ding this helper did that and cleaned things up a little. Signed-off-by: Vincent McIntyre <vincent.mcint...@gmail.com> --- build | 81 +++ 1 file changed, 47 insertions(+), 34 deletions(-) diff --git a/build b/build index 4457a73..38ffd4

Re: f26: dvb_usb_rtl28xxu not tuning "Leadtek Winfast DTV2000 DS PLUS TV"

2017-09-25 Thread Vincent McIntyre
On Mon, Sep 25, 2017 at 10:16:23AM +1000, Eyal Lebedinsky wrote: > >Turn on debug printing for the modules of interest > ># echo 'module rtl2832 +p' > /sys/kernel/debug/dynamic_debug/control > ># echo 'module dvb_usb_rtl28xxu +p' > /sys/kernel/debug/dynamic_debug/control > > Have done this.

Re: f26: dvb_usb_rtl28xxu not tuning "Leadtek Winfast DTV2000 DS PLUS TV"

2017-09-24 Thread Vincent McIntyre
On Sat, Sep 23, 2017 at 10:48:34PM +1000, Eyal Lebedinsky wrote: > On 18/09/17 14:26, Eyal Lebedinsky wrote: > >I have just upgraded to f24. I am now using the standard dvb_usb_rtl28xxu fe > > I have upgraded to f26 and this driver still fails to tune the "Leadtek > Winfast DTV2000 DS PLUS TV".

Re: [progress]: dvb_usb_rtl28xxu not tuning "Leadtek Winfast DTV2000 DS PLUS TV"

2017-09-26 Thread Vincent McIntyre
On Tue, Sep 26, 2017 at 02:32:26PM +1000, Eyal Lebedinsky wrote: > > While the problem persists, I managed to find a way around it for now. > > I changed the antenna input. > > Originally I used a powered splitter to feed all the tuners, and it worked > well with the out-of-kernel driver. This

Re: more build failures

2017-12-15 Thread Vincent McIntyre
On Fri, Dec 15, 2017 at 11:41:13PM +1100, Vincent McIntyre wrote: > > ... > > $ make allyesconfig > make -C /home/me/git/clones/media_build/v4l allyesconfig > make[1]: Entering directory '/home/me/git/clones/media_build/v4l' > No version yet, using 4.4.0-103-generic > mak

more build failures

2017-12-15 Thread Vincent McIntyre
Hi, Don't get me wrong, I appreciate the vast amount of work going on here. Just letting you know what I'm seeing. + date Friday 15 December 23:28:52 AEDT 2017 + uname -a Linux ubuntu 4.4.0-103-generic #126-Ubuntu SMP Mon Dec 4 16:23:28 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux + cat

Re: more build failures

2017-12-17 Thread Vincent McIntyre
On Sat, Dec 16, 2017 at 09:30:46AM -0200, Mauro Carvalho Chehab wrote: > > Just pushed two patches to media build, in order to address those > issues. Here, it is now compiling fine with Kernel 4.4.59. > Yep, working again. Thank you for taking the time to sort this out. Regards Vince

Re: broken build against 4.4.0

2017-11-06 Thread Vincent McIntyre
On Sun, Nov 05, 2017 at 01:55:22PM +0100, Jasmin J. wrote: > Hello Vincent! > > > can someone take a look please? > Well, Matthias may have fixed that (I didn't try). > > See: > https://www.mail-archive.com/linux-media@vger.kernel.org/msg121610.html > > Maybe you need that also: >

broken build against 4.4.0

2017-11-04 Thread Vincent McIntyre
Hi, can someone take a look please? + uname -a Linux ubuntu 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux + cat /proc/version_signature Ubuntu 4.4.0-97.120-generic 4.4.87 This was with a fresh clone, + git --no-pager log -1 commit

Re: [PATCH] build: Added missing timer_setup_on_stack

2017-12-08 Thread Vincent McIntyre
On Fri, Dec 08, 2017 at 10:12:05PM +0100, Hans Verkuil wrote: ... > > I've applied all your patches. Thank you very much for working on this. > > Let's see what the result of the nightly build will be. > > In general reverting kernel patches to make a driver compile is something of a > last

build failure on ubuntu 16.04 LTS

2017-12-06 Thread Vincent McIntyre
Hi, the build has been broken for over a week for me. Possibly my checkout is out of date?? I am using the normal build --main-git method. Setup details: + date Wednesday 6 December 21:25:28 AEDT 2017 + uname -a Linux ubuntu 4.4.0-101-generic #124-Ubuntu SMP Fri Nov 10 18:29:59 UTC 2017

Re: [PATCH] build: Added missing timer_setup_on_stack

2017-12-09 Thread Vincent McIntyre
On Sat, Dec 09, 2017 at 09:00:18AM +0100, Hans Verkuil wrote: > I misapplied a pr_fmt patch. It's now fixed. > Indeed, the build goes fine now. Thank you both again. Cheers Vince

Re: cx23885 - regression between 4.17.x and 4.18.x

2018-09-14 Thread Vincent McIntyre
On Thu, Sep 13, 2018 at 06:39:57PM +0100, David R wrote: > Hi > > Just a heads up. I'm having to revert cx23885-core.c to the 4.17 version > to obtain stability with my old AMD Phenom/ASUS M4A785TD and Hauppauge > WinTV-HVR-5525. The latest code drops out and refuses to return video > streams in

  1   2   >