Re: [PATCH 5/5] dax,iomap: Add helper dax_iomap_zero() to zero a range

2020-02-03 Thread kbuild test robot
Hi Vivek, I love your patch! Yet something to improve: [auto build test ERROR on dm/for-next] [also build test ERROR on s390/features xfs-linux/for-next linus/master linux-nvdimm/libnvdimm-for-next v5.5 next-20200203] [if your patch is applied to the wrong git tree, please drop us a note

Re: [PATCH RFC 00/10] device-dax: Support devices without PFN metadata

2020-02-03 Thread Dan Williams
On Fri, Jan 10, 2020 at 11:06 AM Joao Martins wrote: > > Hey, Hi Joao, > > Presented herewith a small series which allows device-dax to work without > struct page to be used to back KVM guests memory. It's an RFC, and there's > still some items we're looking at (see TODO below); So it turns

Re: [PATCH RFC 02/10] mm: Handle pmd entries in follow_pfn()

2020-02-03 Thread Matthew Wilcox
On Fri, Jan 10, 2020 at 07:03:05PM +, Joao Martins wrote: > @@ -4366,6 +4366,7 @@ EXPORT_SYMBOL(follow_pte_pmd); > int follow_pfn(struct vm_area_struct *vma, unsigned long address, > unsigned long *pfn) > { > + pmd_t *pmdpp = NULL; Please rename to 'pmdp'.

Re: [PATCH RFC 01/10] mm: Add pmd support for _PAGE_SPECIAL

2020-02-03 Thread Matthew Wilcox
On Fri, Jan 10, 2020 at 07:03:04PM +, Joao Martins wrote: > +++ b/arch/x86/include/asm/pgtable.h > @@ -293,6 +293,15 @@ static inline int pgd_devmap(pgd_t pgd) > { > return 0; > } > +#endif > + > +#ifdef CONFIG_ARCH_HAS_PTE_SPECIAL > +static inline int pmd_special(pmd_t pmd) > +{ > +

[PATCH 3/5] dm,dax: Add dax zero_page_range operation

2020-02-03 Thread Vivek Goyal
This patch adds support for dax zero_page_range operation to dm targets. Signed-off-by: Vivek Goyal --- drivers/md/dm-linear.c| 18 ++ drivers/md/dm-log-writes.c| 17 + drivers/md/dm-stripe.c| 23 +++ drivers/md/dm.c

[PATCH 1/5] dax, pmem: Add a dax operation zero_page_range

2020-02-03 Thread Vivek Goyal
Add a dax operation zero_page_range, to zero a range of memory. This will also clear any poison in the range being zeroed. As of now, zeroing of up to one page is allowed in a single call. There are no callers which are trying to zero more than a page in a single call. Once we grow the callers

[PATCH 2/5] s390,dax: Add dax zero_page_range operation to dcssblk driver

2020-02-03 Thread Vivek Goyal
Add dax operation zero_page_range. This just calls generic helper generic_dax_zero_page_range(). Suggested-by: Christoph Hellwig Signed-off-by: Vivek Goyal --- drivers/s390/block/dcssblk.c | 7 +++ 1 file changed, 7 insertions(+) diff --git a/drivers/s390/block/dcssblk.c

[RFC PATCH 0/5][V2] dax,pmem: Provide a dax operation to zero range of memory

2020-02-03 Thread Vivek Goyal
Hi, This is V2 of patches. I posted V1 here. https://lore.kernel.org/linux-fsdevel/20200123165249.ga7...@redhat.com/ Changes since V1. - Took care of feedback from Christoph. - Made ->zero_page_range() mandatory operation. - Provided a generic helper to zero range for non-pmem drivers. - Merged

[PATCH 5/5] dax,iomap: Add helper dax_iomap_zero() to zero a range

2020-02-03 Thread Vivek Goyal
Add a helper dax_ioamp_zero() to zero a range. This patch basically merges __dax_zero_page_range() and iomap_dax_zero(). Suggested-by: Christoph Hellwig Signed-off-by: Vivek Goyal --- fs/dax.c | 12 ++-- fs/iomap/buffered-io.c | 9 + include/linux/dax.h| 11

[PATCH 4/5] dax,iomap: Start using dax native zero_page_range()

2020-02-03 Thread Vivek Goyal
Get rid of calling block device interface for zeroing in iomap dax zeroing path and use dax native zeroing interface instead. Suggested-by: Christoph Hellwig Signed-off-by: Vivek Goyal --- fs/dax.c | 45 + 1 file changed, 9 insertions(+), 36

Re: [PATCH 5/5] libnvdimm/region: Introduce an 'align' attribute

2020-02-03 Thread Aneesh Kumar K.V
Dan Williams writes: > The align attribute applies an alignment constraint for namespace > creation in a region. Whereas the 'align' attribute of a namespace > applied alignment padding via an info block, the 'align' attribute > applies alignment constraints to the free space allocation. > > The

Re: [PATCH 4/5] libnvdimm/region: Introduce NDD_LABELING

2020-02-03 Thread Aneesh Kumar K.V
Dan Williams writes: > The NDD_ALIASING flag is used to indicate where pmem capacity might > alias with blk capacity and require labeling. It is also used to > indicate whether the DIMM supports labeling. Separate this latter > capability into its own flag so that the NDD_ALIASING flag is scoped

Re: [PATCH 3/5] libnvdimm/namespace: Enforce memremap_compat_align()

2020-02-03 Thread Aneesh Kumar K.V
Dan Williams writes: > The pmem driver on PowerPC crashes with the following signature when > instantiating misaligned namespaces that map their capacity via > memremap_pages(). > > BUG: Unable to handle kernel data access at 0xc00100040600 > Faulting instruction address:

Re: [PATCH 2/5] mm/memremap_pages: Introduce memremap_compat_align()

2020-02-03 Thread Aneesh Kumar K.V
Dan Williams writes: > The "sub-section memory hotplug" facility allows memremap_pages() users > like libnvdimm to compensate for hardware platforms like x86 that have a > section size larger than their hardware memory mapping granularity. The > compensation that sub-section support affords is

Re: [PATCH 1/5] mm/memremap_pages: Kill unused __devm_memremap_pages()

2020-02-03 Thread Aneesh Kumar K.V
Dan Williams writes: > Kill this definition that was introduced in commit 41e94a851304 ("add > devm_memremap_pages") add never used. > Reviewed-by: Aneesh Kumar K.V > Cc: Christoph Hellwig > Signed-off-by: Dan Williams > --- > include/linux/io.h |2 -- > 1 file changed, 2 deletions(-)

Re: [PATCH v2 22/27] nvdimm/ocxl: Implement the heartbeat command

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:50 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > The heartbeat admin command is a simple admin command that exercises > the communication mechanisms within the controller. > > This patch issues a heartbeat command to the card during init to ensure > we

Re: [PATCH v2 24/27] nvdimm/ocxl: Implement Overwrite

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:52 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > The near storage command 'Secure Erase' overwrites all data on the > media. > > This patch hooks it up to the security function 'overwrite'. > > Signed-off-by: Alastair D'Silva A few things to tidy up in

Re: [PATCH v2 14/27] nvdimm/ocxl: Add support for near storage commands

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:42 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > Similar to the previous patch, this adds support for near storage commands. > > Signed-off-by: Alastair D'Silva > --- > drivers/nvdimm/ocxl/scm.c | 6 + > drivers/nvdimm/ocxl/scm_internal.c

Re: [PATCH v2 13/27] nvdimm/ocxl: Add support for Admin commands

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:41 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > This patch requests the metadata required to issue admin commands, as well > as some helper functions to construct and check the completion of the > commands. > > Signed-off-by: Alastair D'Silva A few

Re: [PATCH v2 12/27] nvdimm/ocxl: Read the capability registers & wait for device ready

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:40 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > This patch reads timeouts & firmware version from the controller, and > uses those timeouts to wait for the controller to report that it is ready > before handing the memory over to libnvdimm. > >

Re: [PATCH v2 10/27] nvdimm: Add driver for OpenCAPI Storage Class Memory

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:38 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > This driver exposes LPC memory on OpenCAPI SCM cards > as an NVDIMM, allowing the existing nvram infrastructure > to be used. > > Namespace metadata is stored on the media itself, so >

Re: [PATCH v2 08/27] ocxl: Save the device serial number in ocxl_fn

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:36 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > This patch retrieves the serial number of the card and makes it available > to consumers of the ocxl driver via the ocxl_fn struct. > > Signed-off-by: Alastair D'Silva > Acked-by: Frederic Barrat >

Re: [PATCH v2 07/27] ocxl: Add functions to map/unmap LPC memory

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:35 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > Add functions to map/unmap LPC memory > > Signed-off-by: Alastair D'Silva > --- > drivers/misc/ocxl/config.c| 4 +++ > drivers/misc/ocxl/core.c | 50 +++ >

Re: [PATCH v2 06/27] ocxl: Tally up the LPC memory on a link & allow it to be mapped

2020-02-03 Thread Jonathan Cameron
On Tue, 3 Dec 2019 14:46:34 +1100 Alastair D'Silva wrote: > From: Alastair D'Silva > > Tally up the LPC memory on an OpenCAPI link & allow it to be mapped > > Signed-off-by: Alastair D'Silva Hi Alastair, A few trivial comments inline. Jonathan > --- > drivers/misc/ocxl/core.c |

2020 Google Ad Grants

2020-02-03 Thread Google Corporation
Google Inc 1600 Amphitheatre Parkway Mountain View, CA 94043 Good day Sir/Madam, Your Google Ad Grant has been approved. Sincerely, Sundar Pichai CEO, Google Inc. ___ Linux-nvdimm mailing list -- linux-nvdimm@lists.01.org To unsubscribe send an

Fwd: Payment TT Slip

2020-02-03 Thread Treeza Rodrigues
___ Linux-nvdimm mailing list -- linux-nvdimm@lists.01.org To unsubscribe send an email to linux-nvdimm-le...@lists.01.org

Re: [RFC] dax,pmem: Provide a dax operation to zero range of memory

2020-02-03 Thread Christoph Hellwig
On Fri, Jan 31, 2020 at 03:31:58PM -0800, Dan Williams wrote: > > Should we (XFS) make fallocate(ZERO_RANGE) detect when it's operating on > > a written extent in a DAX file and call this instead of what it does now > > (punch range and reallocate unwritten)? > > If it eliminates more block