Re: [PATCH 00/20] virtiofs: Add DAX support

2020-03-10 Thread Amir Goldstein
On Wed, Mar 4, 2020 at 7:01 PM Vivek Goyal wrote: > > Hi, > > This patch series adds DAX support to virtiofs filesystem. This allows > bypassing guest page cache and allows mapping host page cache directly > in guest address space. > > When a page of file is needed, guest sends a request to map

Re: [PATCH 20/20] fuse,virtiofs: Add logic to free up a memory range

2020-03-10 Thread Liu Bo
On Wed, Mar 04, 2020 at 11:58:45AM -0500, Vivek Goyal wrote: > Add logic to free up a busy memory range. Freed memory range will be > returned to free pool. Add a worker which can be started to select > and free some busy memory ranges. > > Process can also steal one of its busy dax ranges if

[PATCH -next 000/491] treewide: use fallthrough;

2020-03-10 Thread Joe Perches
by all F: patterns in in each section. Done via the perl script below and the previously posted cvt_fallthrough.pl script. Link: https://lore.kernel.org/lkml/b56602fcf79f849e733e7b521bb0e17895d390fa.1582230379.git.joe.com/ These patches are based on next-20200310 and are available in git://repo.o

邮件群发软件---500元/月,赠送200万邮箱数据

2020-03-10 Thread 邮件群发软件---500元/月,赠送200万邮箱数据
每台电脑日发5-20万邮箱数据无需发件箱的邮件群发软件外贸、物流、展会业务好帮手 E-mail : sales0769@hotmail.comQQ咨询:3351665625 ___ Linux-nvdimm mailing list -- linux-nvdimm@lists.01.org To unsubscribe send an email to linux-nvdimm-le...@lists.01.org

Re: [PATCH v3 21/27] powerpc/powernv/pmem: Add an IOCTL to request controller health & perf data

2020-03-10 Thread Alastair D'Silva
On Wed, 2020-03-04 at 12:06 +0100, Frederic Barrat wrote: > > Le 28/02/2020 à 07:12, Andrew Donnellan a écrit : > > On 21/2/20 2:27 pm, Alastair D'Silva wrote: > > > From: Alastair D'Silva > > > > > > When health & performance data is requested from the controller, > > > it responds with an

Re: [PATCH v3 20/27] powerpc/powernv/pmem: Forward events to userspace

2020-03-10 Thread Alastair D'Silva
On Wed, 2020-03-04 at 12:00 +0100, Frederic Barrat wrote: > > Le 21/02/2020 à 04:27, Alastair D'Silva a écrit : > > From: Alastair D'Silva > > > > Some of the interrupts that the card generates are better handled > > by the userspace daemon, in particular: > > Controller Hardware/Firmware Fatal

Re: [PATCH v3] block: refactor duplicated macros

2020-03-10 Thread Martin K. Petersen
Matteo, > The macros PAGE_SECTORS, PAGE_SECTORS_SHIFT and SECTOR_MASK are > defined several times in different flavours across the whole tree. > Define them just once in a common header. > > While at it, replace replace "PAGE_SHIFT - 9" with > "PAGE_SECTORS_SHIFT" too and rename SECTOR_MASK to

[PATCH v3] block: refactor duplicated macros

2020-03-10 Thread Matteo Croce
The macros PAGE_SECTORS, PAGE_SECTORS_SHIFT and SECTOR_MASK are defined several times in different flavours across the whole tree. Define them just once in a common header. While at it, replace replace "PAGE_SHIFT - 9" with "PAGE_SECTORS_SHIFT" too and rename SECTOR_MASK to PAGE_SECTORS_MASK.

Re: [PATCH v2] block: refactor duplicated macros

2020-03-10 Thread Matteo Croce
On Wed, Mar 11, 2020 at 12:10 AM Guoqing Jiang wrote: > > > > On 3/10/20 11:35 PM, Matteo Croce wrote: > > +++ b/drivers/md/raid1.c > > @@ -2129,7 +2129,7 @@ static void process_checks(struct r1bio *r1_bio) > > int vcnt; > > > > /* Fix variable parts of all bios */ > > - vcnt =

Re: [PATCH v2] block: refactor duplicated macros

2020-03-10 Thread Guoqing Jiang
On 3/10/20 11:35 PM, Matteo Croce wrote: +++ b/drivers/md/raid1.c @@ -2129,7 +2129,7 @@ static void process_checks(struct r1bio *r1_bio) int vcnt; /* Fix variable parts of all bios */ - vcnt = (r1_bio->sectors + PAGE_SIZE / 512 - 1) >> (PAGE_SHIFT - 9); + vcnt =

[PATCH v2] block: refactor duplicated macros

2020-03-10 Thread Matteo Croce
The macros PAGE_SECTORS, PAGE_SECTORS_SHIFT and SECTOR_MASK are defined several times in different flavours across the whole tree. Define them just once in a common header. Signed-off-by: Matteo Croce --- v2: As Dan Williams suggested: #define PAGE_SECTORS_MASK(~(PAGE_SECTORS - 1))

Re: [PATCH] block: refactor duplicated macros

2020-03-10 Thread Song Liu
On Sun, Feb 23, 2020 at 8:58 AM Matteo Croce wrote: > > The macros PAGE_SECTORS, PAGE_SECTORS_SHIFT and SECTOR_MASK are defined > several times in different flavours across the whole tree. > Define them just once in a common header. > > Signed-off-by: Matteo Croce > --- > block/blk-lib.c

Re: [PATCH 12/20] fuse: Introduce setupmapping/removemapping commands

2020-03-10 Thread Vivek Goyal
On Tue, Mar 10, 2020 at 08:49:49PM +0100, Miklos Szeredi wrote: > On Wed, Mar 4, 2020 at 5:59 PM Vivek Goyal wrote: > > > > Introduce two new fuse commands to setup/remove memory mappings. This > > will be used to setup/tear down file mapping in dax window. > > > > Signed-off-by: Vivek Goyal > >

Re: [PATCH 02/20] dax: Create a range version of dax_layout_busy_page()

2020-03-10 Thread Vivek Goyal
On Tue, Mar 10, 2020 at 08:19:07AM -0700, Ira Weiny wrote: > On Wed, Mar 04, 2020 at 11:58:27AM -0500, Vivek Goyal wrote: > > > > + /* If end == 0, all pages from start to till end of file */ > > + if (!end) { > > + end_idx = ULONG_MAX; > > + len = 0; > > I find this a

Re: [PATCH 12/20] fuse: Introduce setupmapping/removemapping commands

2020-03-10 Thread Miklos Szeredi
On Wed, Mar 4, 2020 at 5:59 PM Vivek Goyal wrote: > > Introduce two new fuse commands to setup/remove memory mappings. This > will be used to setup/tear down file mapping in dax window. > > Signed-off-by: Vivek Goyal > Signed-off-by: Peng Tao > --- > include/uapi/linux/fuse.h | 37

Re: [PATCH 11/20] fuse: implement FUSE_INIT map_alignment field

2020-03-10 Thread Miklos Szeredi
On Wed, Mar 4, 2020 at 5:59 PM Vivek Goyal wrote: > > The device communicates FUSE_SETUPMAPPING/FUSE_REMOVMAPPING alignment > constraints via the FUST_INIT map_alignment field. Parse this field and > ensure our DAX mappings meet the alignment constraints. > > We don't actually align anything

Re: [PATCH 10/20] fuse,virtiofs: Keep a list of free dax memory ranges

2020-03-10 Thread Miklos Szeredi
On Wed, Mar 4, 2020 at 5:59 PM Vivek Goyal wrote: > > Divide the dax memory range into fixed size ranges (2MB for now) and put > them in a list. This will track free ranges. Once an inode requires a > free range, we will take one from here and put it in interval-tree > of ranges assigned to

Re: [PATCH 04/20] virtio: Implement get_shm_region for PCI transport

2020-03-10 Thread Vivek Goyal
On Tue, Mar 10, 2020 at 07:12:25AM -0400, Michael S. Tsirkin wrote: [..] > > +static bool vp_get_shm_region(struct virtio_device *vdev, > > + struct virtio_shm_region *region, u8 id) > > +{ > > + struct virtio_pci_device *vp_dev = to_vp_device(vdev); > > + struct

Re: [PATCH 04/20] virtio: Implement get_shm_region for PCI transport

2020-03-10 Thread Vivek Goyal
On Tue, Mar 10, 2020 at 11:04:37AM +, Stefan Hajnoczi wrote: > On Wed, Mar 04, 2020 at 11:58:29AM -0500, Vivek Goyal wrote: > > diff --git a/drivers/virtio/virtio_pci_modern.c > > b/drivers/virtio/virtio_pci_modern.c > > index 7abcc50838b8..52f179411015 100644 > > ---

Re: [PATCH 02/20] dax: Create a range version of dax_layout_busy_page()

2020-03-10 Thread Ira Weiny
On Wed, Mar 04, 2020 at 11:58:27AM -0500, Vivek Goyal wrote: > > + /* If end == 0, all pages from start to till end of file */ > + if (!end) { > + end_idx = ULONG_MAX; > + len = 0; I find this a bit odd to specify end == 0 for ULONG_MAX... > } >

Re: [PATCH 08/20] fuse,virtiofs: Add a mount option to enable dax

2020-03-10 Thread Miklos Szeredi
On Wed, Mar 4, 2020 at 5:59 PM Vivek Goyal wrote: > > Add a mount option to allow using dax with virtio_fs. > > Signed-off-by: Vivek Goyal Reviewed-by: Miklos Szeredi ___ Linux-nvdimm mailing list -- linux-nvdimm@lists.01.org To unsubscribe send an

Re: [PATCH 07/20] fuse: Get rid of no_mount_options

2020-03-10 Thread Miklos Szeredi
On Wed, Mar 4, 2020 at 5:59 PM Vivek Goyal wrote: > > This option was introduced so that for virtio_fs we don't show any mounts > options fuse_show_options(). Because we don't offer any of these options > to be controlled by mounter. > > Very soon we are planning to introduce option "dax" which

Re: [PATCH 06/20] virtiofs: Provide a helper function for virtqueue initialization

2020-03-10 Thread Miklos Szeredi
On Wed, Mar 4, 2020 at 5:59 PM Vivek Goyal wrote: > > This reduces code duplication and make it little easier to read code. > > Signed-off-by: Vivek Goyal Reviewed-by: Miklos Szeredi ___ Linux-nvdimm mailing list -- linux-nvdimm@lists.01.org To

Re: [PATCH v6 0/6] dax/pmem: Provide a dax operation to zero page range

2020-03-10 Thread Vivek Goyal
On Fri, Feb 28, 2020 at 11:34:50AM -0500, Vivek Goyal wrote: > Hi, > > This is V6 of patches. These patches are also available at. Hi Dan, Ping. Does this patch series look fine to you? Vivek > > Changes since V5: > > - Dan Williams preferred ->zero_page_range() to only accept PAGE_SIZE >

Re: [PATCH 04/20] virtio: Implement get_shm_region for PCI transport

2020-03-10 Thread Michael S. Tsirkin
On Wed, Mar 04, 2020 at 11:58:29AM -0500, Vivek Goyal wrote: > From: Sebastien Boeuf > > On PCI the shm regions are found using capability entries; > find a region by searching for the capability. > > Signed-off-by: Sebastien Boeuf > Signed-off-by: Dr. David Alan Gilbert > Signed-off-by:

Re: [PATCH 05/20] virtio: Implement get_shm_region for MMIO transport

2020-03-10 Thread Stefan Hajnoczi
On Wed, Mar 04, 2020 at 11:58:30AM -0500, Vivek Goyal wrote: > From: Sebastien Boeuf > > On MMIO a new set of registers is defined for finding SHM > regions. Add their definitions and use them to find the region. > > Signed-off-by: Sebastien Boeuf > --- > drivers/virtio/virtio_mmio.c |

Re: [PATCH 04/20] virtio: Implement get_shm_region for PCI transport

2020-03-10 Thread Stefan Hajnoczi
On Wed, Mar 04, 2020 at 11:58:29AM -0500, Vivek Goyal wrote: > diff --git a/drivers/virtio/virtio_pci_modern.c > b/drivers/virtio/virtio_pci_modern.c > index 7abcc50838b8..52f179411015 100644 > --- a/drivers/virtio/virtio_pci_modern.c > +++ b/drivers/virtio/virtio_pci_modern.c > @@ -443,6

Re: [PATCH 03/20] virtio: Add get_shm_region method

2020-03-10 Thread Stefan Hajnoczi
On Wed, Mar 04, 2020 at 11:58:28AM -0500, Vivek Goyal wrote: > From: Sebastien Boeuf > > Virtio defines 'shared memory regions' that provide a continuously > shared region between the host and guest. > > Provide a method to find a particular region on a device. > > Signed-off-by: Sebastien

Please Qoute

2020-03-10 Thread contato
___ Linux-nvdimm mailing list -- linux-nvdimm@lists.01.org To unsubscribe send an email to linux-nvdimm-le...@lists.01.org