Re: [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove

2018-11-30 Thread Luis Chamberlain
On Wed, Nov 28, 2018 at 04:32:16PM -0800, Alexander Duyck wrote: > Add an additional bit flag to the device struct named async_probe. This > additional flag allows us to guarantee ordering between probe and remove > operations. > > This allows us to guarantee that if we execute a remove operation

Re: [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove

2018-11-29 Thread Dan Williams
On Thu, Nov 29, 2018 at 1:54 PM Alexander Duyck wrote: > > On Thu, 2018-11-29 at 10:55 -0800, Dan Williams wrote: > > On Thu, Nov 29, 2018 at 10:07 AM Alexander Duyck > > wrote: > > > > > > On Wed, 2018-11-28 at 17:57 -0800, Dan Williams wrote: > > > > [..] > > > > I think the flag should be

Re: [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove

2018-11-29 Thread Alexander Duyck
On Thu, 2018-11-29 at 10:55 -0800, Dan Williams wrote: > On Thu, Nov 29, 2018 at 10:07 AM Alexander Duyck > wrote: > > > > On Wed, 2018-11-28 at 17:57 -0800, Dan Williams wrote: > > [..] > > > I think the flag should be named "cancel" and set it in the > > > device_del() path. Otherwise this is

Re: [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove

2018-11-29 Thread Dan Williams
On Thu, Nov 29, 2018 at 10:07 AM Alexander Duyck wrote: > > On Wed, 2018-11-28 at 17:57 -0800, Dan Williams wrote: [..] > > I think the flag should be named "cancel" and set it in the > > device_del() path. Otherwise this is encoding code flow state in the > > struct rather than device-state that

Re: [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove

2018-11-29 Thread Alexander Duyck
On Wed, 2018-11-28 at 17:57 -0800, Dan Williams wrote: > On Wed, Nov 28, 2018 at 4:32 PM Alexander Duyck > wrote: > > > > Add an additional bit flag to the device struct named async_probe. This > > additional flag allows us to guarantee ordering between probe and remove > > operations. > > > >

Re: [driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove

2018-11-28 Thread Dan Williams
On Wed, Nov 28, 2018 at 4:32 PM Alexander Duyck wrote: > > Add an additional bit flag to the device struct named async_probe. This > additional flag allows us to guarantee ordering between probe and remove > operations. > > This allows us to guarantee that if we execute a remove operation on a

[driver-core PATCH v7 2/9] driver core: Establish clear order of operations for deferred probe and remove

2018-11-28 Thread Alexander Duyck
Add an additional bit flag to the device struct named async_probe. This additional flag allows us to guarantee ordering between probe and remove operations. This allows us to guarantee that if we execute a remove operation on a given interface it will not attempt to update the driver member