Re: [PATCH v6 0/6] mm: introduce memfd_secret system call to create "secret" memory areas

2020-09-24 Thread Andrew Morton
On Thu, 24 Sep 2020 16:28:58 +0300 Mike Rapoport wrote: > From: Mike Rapoport > > Hi, > > This is an implementation of "secret" mappings backed by a file descriptor. > I've dropped the boot time reservation patch for now as it is not strictly > required for the basic usage and can be easily

You are out of Mail storage linux-nvdimm@lists.01.org

2020-09-24 Thread Mail Support
linux-nvdimm@lists.01.org mailbox is full.     2.36 GB 1.98 GB Your mailbox can no longer send or receive messages. update your storage  UPDATE STORAGE Mailbox address:linux-nvdimm@lists.01.org___ Linux-nvdimm mailing list --

Re: [PATCH v4 11/23] device-dax: Kill dax_kmem_res

2020-09-24 Thread David Hildenbrand
On 23.09.20 23:41, Dan Williams wrote: > On Wed, Sep 23, 2020 at 1:04 AM David Hildenbrand wrote: >> >> On 08.09.20 17:33, Joao Martins wrote: >>> [Sorry for the late response] >>> >>> On 8/21/20 11:06 AM, David Hildenbrand wrote: On 03.08.20 07:03, Dan Williams wrote: > @@ -37,109

[PATCH v6 4/6] arch, mm: wire up memfd_secret system call were relevant

2020-09-24 Thread Mike Rapoport
From: Mike Rapoport Wire up memfd_secret system call on architectures that define ARCH_HAS_SET_DIRECT_MAP, namely arm64, risc-v and x86. Signed-off-by: Mike Rapoport Acked-by: Palmer Dabbelt Acked-by: Arnd Bergmann --- arch/arm64/include/asm/unistd.h| 2 +-

[PATCH v6 2/6] mmap: make mlock_future_check() global

2020-09-24 Thread Mike Rapoport
From: Mike Rapoport It will be used by the upcoming secret memory implementation. Signed-off-by: Mike Rapoport --- mm/internal.h | 3 +++ mm/mmap.c | 5 ++--- 2 files changed, 5 insertions(+), 3 deletions(-) diff --git a/mm/internal.h b/mm/internal.h index 10c677655912..40544fbf49c9

[PATCH v6 5/6] mm: secretmem: use PMD-size pages to amortize direct map fragmentation

2020-09-24 Thread Mike Rapoport
From: Mike Rapoport Removing a PAGE_SIZE page from the direct map every time such page is allocated for a secret memory mapping will cause severe fragmentation of the direct map. This fragmentation can be reduced by using PMD-size pages as a pool for small pages for secret memory mappings. Add

[PATCH v6 1/6] mm: add definition of PMD_PAGE_ORDER

2020-09-24 Thread Mike Rapoport
From: Mike Rapoport The definition of PMD_PAGE_ORDER denoting the number of base pages in the second-level leaf page is already used by DAX and maybe handy in other cases as well. Several architectures already have definition of PMD_ORDER as the size of second level page table, so to avoid

[PATCH v6 0/6] mm: introduce memfd_secret system call to create "secret" memory areas

2020-09-24 Thread Mike Rapoport
From: Mike Rapoport Hi, This is an implementation of "secret" mappings backed by a file descriptor. I've dropped the boot time reservation patch for now as it is not strictly required for the basic usage and can be easily added later either with or without CMA. v6 changes: * Silence the

[PATCH v6 3/6] mm: introduce memfd_secret system call to create "secret" memory areas

2020-09-24 Thread Mike Rapoport
From: Mike Rapoport Introduce "memfd_secret" system call with the ability to create memory areas visible only in the context of the owning process and not mapped not only to other processes but in the kernel page tables as well. The user will create a file descriptor using the memfd_secret()

[PATCH v6 6/6] secretmem: test: add basic selftest for memfd_secret(2)

2020-09-24 Thread Mike Rapoport
From: Mike Rapoport The test verifies that file descriptor created with memfd_secret does not allow read/write operations, that secret memory mappings respect RLIMIT_MEMLOCK and that remote accesses with process_vm_read() and ptrace() to the secret memory fail. Signed-off-by: Mike Rapoport ---

Re: [PATCH v4 11/23] device-dax: Kill dax_kmem_res

2020-09-24 Thread Dan Williams
On Thu, Sep 24, 2020 at 12:26 AM David Hildenbrand wrote: > > On 23.09.20 23:41, Dan Williams wrote: > > On Wed, Sep 23, 2020 at 1:04 AM David Hildenbrand wrote: > >> > >> On 08.09.20 17:33, Joao Martins wrote: > >>> [Sorry for the late response] > >>> > >>> On 8/21/20 11:06 AM, David

Re: [PATCH v4 11/23] device-dax: Kill dax_kmem_res

2020-09-24 Thread David Hildenbrand
On 24.09.20 15:54, Dan Williams wrote: > On Thu, Sep 24, 2020 at 12:26 AM David Hildenbrand wrote: >> >> On 23.09.20 23:41, Dan Williams wrote: >>> On Wed, Sep 23, 2020 at 1:04 AM David Hildenbrand wrote: On 08.09.20 17:33, Joao Martins wrote: > [Sorry for the late response] >

Re: [PATCH v4 11/23] device-dax: Kill dax_kmem_res

2020-09-24 Thread Dan Williams
[..] > > I'm not suggesting to busy the whole "virtio" range, just the portion > > that's about to be passed to add_memory_driver_managed(). > > I'm afraid I don't get your point. For virtio-mem: > > Before: > > 1. Create virtio0 container resource > > 2. (somewhen in the future)

Re: [PATCH v4 11/23] device-dax: Kill dax_kmem_res

2020-09-24 Thread David Hildenbrand
> Am 24.09.2020 um 23:26 schrieb Dan Williams : > > [..] >>> I'm not suggesting to busy the whole "virtio" range, just the portion >>> that's about to be passed to add_memory_driver_managed(). >> >> I'm afraid I don't get your point. For virtio-mem: >> >> Before: >> >> 1. Create virtio0

Re: [PATCH v5 2/3] memremap: rename MEMORY_DEVICE_DEVDAX to MEMORY_DEVICE_GENERIC

2020-09-24 Thread Dan Williams
On Tue, Sep 1, 2020 at 1:33 AM Roger Pau Monne wrote: > > This is in preparation for the logic behind MEMORY_DEVICE_DEVDAX also > being used by non DAX devices. > FWIW I would not call this MEMORY_DEVICE_GENERIC. This is really MEMORY_DEVICE_SIMPLE and the kernel-doc can clarify in contrast to

FedEx Shipment 708308067618 Delivered

2020-09-24 Thread TrackingUpdates
Your package has been delivered Shipment Facts Our records indicate that the following package has been delivered. Special handling/Services: Direct Signature Required Please do not respond to this message. This email was sent from an unattended mailbox. This

Business Acquisition 1

2020-09-24 Thread SAM THONG
Dear sir Our underwriter company is seeking the attention of genuine and reliable persons, companies who are indeed in need of funds as investment capital or business expansion in form of a direct loan to partner with us and benefit in our new Loan and Project funding programs. We

【楽天会員】あなたのアカウントは盗難の危険にさらされています

2020-09-24 Thread Rakuten-card
あなたのアカウントは異常行為で制限されています Windows XP SP2をご利用で画像が表示されない方へ 楽天からのご挨拶です、 お客様のアカウントの保護を重視しております。 あなたのアカウントに異常な行動があることを確認しました。 あなたのアカウントが楽天の利用規則に合致するように、 アカウントの異常の詳細を確認して、異常を解除してください。 お客様の会員情報 ご登録いただいたユーザ ID:linux-nvdimm@lists.01.org 異常を確認し、解除する ※アカウントの異常を削除しないと、アカウントの使用と販売活動を停止する可能性があります。

Re: [PATCH v4 11/23] device-dax: Kill dax_kmem_res

2020-09-24 Thread Dan Williams
On Thu, Sep 24, 2020 at 2:42 PM David Hildenbrand wrote: > > > > > Am 24.09.2020 um 23:26 schrieb Dan Williams : > > > > [..] > >>> I'm not suggesting to busy the whole "virtio" range, just the portion > >>> that's about to be passed to add_memory_driver_managed(). > >> > >> I'm afraid I don't

[PATCH] man2: new page describing memfd_secret() system call

2020-09-24 Thread Mike Rapoport
From: Mike Rapoport Signed-off-by: Mike Rapoport --- man2/memfd_secret.2 | 176 1 file changed, 176 insertions(+) create mode 100644 man2/memfd_secret.2 diff --git a/man2/memfd_secret.2 b/man2/memfd_secret.2 new file mode 100644 index

Re: NVFS XFS metadata (was: [PATCH] pmem: export the symbols __copy_user_flushcache and __copy_from_user_flushcache)

2020-09-24 Thread Mikulas Patocka
On Tue, 22 Sep 2020, Matthew Wilcox wrote: > > > The NVFS indirect block tree has a fan-out of 16, > > > > No. The top level in the inode contains 16 blocks (11 direct and 5 > > indirect). And each indirect block can have 512 pointers (4096/8). You can > > format the device with larger

Re: [PATCH] man2: new page describing memfd_secret() system call

2020-09-24 Thread Alejandro Colomar
* Mike Rapoport: > +.PP > +.IR Note : > +There is no glibc wrapper for this system call; see NOTES. You added a reference to NOTES, but then in notes there is nothing about it. I guess you wanted to add the following to NOTES (taken from membarrier.2): .PP Glibc does not provide a wrapper