Re: [Ksummit-discuss] [PATCH v2 3/3] libnvdimm, MAINTAINERS: Maintainer Entry Profile

2019-09-11 Thread Joe Perches
On Wed, 2019-09-11 at 08:48 -0700, Dan Williams wrote: > Document the basic policies of the libnvdimm subsystem and provide a first > example of a Maintainer Entry Profile for others to duplicate and edit. [] > +Coding Style Addendum > +- > +libnvdimm expects multi-line

Re: [PATCH v2 3/3] libnvdimm, MAINTAINERS: Maintainer Entry Profile

2019-09-11 Thread Dave Jiang
On 9/11/19 8:48 AM, Dan Williams wrote: > Document the basic policies of the libnvdimm subsystem and provide a first > example of a Maintainer Entry Profile for others to duplicate and edit. > > Cc: Vishal Verma > Cc: Dave Jiang > Signed-off-by: Dan Williams Acked-by: Dave Jiang > --- >

~~ EHS风险识别、评估控制及应急管理

2019-09-11 Thread 您好:
07133714161 转发邮件信息 发 件 人:krkt...@uibr.com 发 送 日 期:2019-9-125:04:15 收 件 人:linux-nvdimm@lists.01.org ___ Linux-nvdimm mailing list Linux-nvdimm@lists.01.org https://lists.01.org/mailman/listinfo/linux-nvdimm

Re: [Ksummit-discuss] [PATCH v2 2/3] Maintainer Handbook: Maintainer Entry Profile

2019-09-11 Thread Verma, Vishal L
On Wed, 2019-09-11 at 08:48 -0700, Dan Williams wrote: > diff --git a/MAINTAINERS b/MAINTAINERS > index 3f171339df53..e5d111a86e61 100644 > --- a/MAINTAINERS > +++ b/MAINTAINERS > @@ -98,6 +98,10 @@ Descriptions of section entries: > Obsolete:Old code. Something tagged obsolete

Re: [Ksummit-discuss] [PATCH v2 3/3] libnvdimm, MAINTAINERS: Maintainer Entry Profile

2019-09-11 Thread Vishal Verma
> Document the basic policies of the libnvdimm subsystem and provide a first > example of a Maintainer Entry Profile for others to duplicate and edit. > > Cc: Vishal Verma > Cc: Dave Jiang > Signed-off-by: Dan Williams > --- > Documentation/nvdimm/maintainer-entry-profile.rst | 64 >

Re: [Ksummit-discuss] [PATCH v2 3/3] libnvdimm, MAINTAINERS: Maintainer Entry Profile

2019-09-11 Thread Jens Axboe
On 9/11/19 12:43 PM, Dan Carpenter wrote: > On Wed, Sep 11, 2019 at 08:48:59AM -0700, Dan Williams wrote: >> +Coding Style Addendum >> +- >> +libnvdimm expects multi-line statements to be double indented. I.e. >> + >> +if (x... >> +&& ...y) { >

Re: [Ksummit-discuss] [PATCH v2 3/3] libnvdimm, MAINTAINERS: Maintainer Entry Profile

2019-09-11 Thread Dan Carpenter
On Wed, Sep 11, 2019 at 08:48:59AM -0700, Dan Williams wrote: > +Coding Style Addendum > +- > +libnvdimm expects multi-line statements to be double indented. I.e. > + > +if (x... > +&& ...y) { That looks horrible and it causes a checkpatch

[PATCH 04/13] nvdimm: Use a more common kernel spacing style

2019-09-11 Thread Joe Perches
Use the more common kernel spacing styles per line. git diff -w shows no difference. Signed-off-by: Joe Perches --- drivers/nvdimm/badrange.c | 4 ++-- drivers/nvdimm/blk.c| 2 +- drivers/nvdimm/btt.c| 4 ++-- drivers/nvdimm/btt_devs.c | 2 +-

[PATCH 02/13] nvdimm: Move logical continuations to previous line

2019-09-11 Thread Joe Perches
Make the logical continuation style more like the rest of the kernel. No change in object files. Signed-off-by: Joe Perches --- drivers/nvdimm/btt.c| 9 + drivers/nvdimm/bus.c| 4 ++-- drivers/nvdimm/claim.c | 4 ++-- drivers/nvdimm/dimm_devs.c

[PATCH 00/13] nvdimm: Use more common kernel coding style

2019-09-11 Thread Joe Perches
Rather than have a local coding style, use the typical kernel style. Joe Perches (13): nvdimm: Use more typical whitespace nvdimm: Move logical continuations to previous line nvdimm: Use octal permissions nvdimm: Use a more common kernel spacing style nvdimm: Use "unsigned int" in

Re: [PATCH 11/13] nvdimm: Use more common logic testing styles and bare ; positions

2019-09-11 Thread Verma, Vishal L
On Wed, 2019-09-11 at 19:54 -0700, Joe Perches wrote: > Avoid using uncommon logic testing styles to make the code a > bit more like other kernel code. > > e.g.: > if (foo) { > ; > } else { > > } > > is typically written > > if (!foo) { >

[PATCH 13/13] nvdimm: Miscellaneous neatening

2019-09-11 Thread Joe Perches
Random neatening, mostly trivially wrapping to 80 columns, to make the code a bit more kernel style compatible. Use casts to (u64) and not (unsigned long long) Signed-off-by: Joe Perches --- drivers/nvdimm/badrange.c | 3 +- drivers/nvdimm/blk.c| 18 ---

[PATCH 06/13] nvdimm: Add and remove blank lines

2019-09-11 Thread Joe Perches
Use a more common kernel style. Remove unnecessary multiple blank lines. Remove blank lines before and after braces. Add blank lines after functions definitions and enums. Add blank lines around #define pr_fmt. Signed-off-by: Joe Perches --- drivers/nvdimm/btt.c| 2 --

[PATCH 07/13] nvdimm: Use typical kernel brace styles

2019-09-11 Thread Joe Perches
Make the nvdimm code more like the rest of the kernel code to improve readability. Add balanced braces to multiple test blocks. Remove else statements from blocks where the block above uses return. e.g.: if (foo) { [code...]; return FOO; } else if

[PATCH 05/13] nvdimm: Use "unsigned int" in preference to "unsigned"

2019-09-11 Thread Joe Perches
Use the more common kernel type. Signed-off-by: Joe Perches --- drivers/nvdimm/label.c | 2 +- drivers/nvdimm/nd.h| 6 +++--- 2 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/nvdimm/label.c b/drivers/nvdimm/label.c index 2c780c5352dc..5700d9b35b8f 100644 ---

[PATCH 08/13] nvdimm: Use typical kernel style indentation

2019-09-11 Thread Joe Perches
Make the nvdimm code more like the rest of the kernel. Avoid indentation of labels and spaces where tabs should be used. Signed-off-by: Joe Perches --- drivers/nvdimm/btt.c | 2 +- drivers/nvdimm/region_devs.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH 09/13] nvdimm: btt.h: Neaten #defines to improve readability

2019-09-11 Thread Joe Perches
Use tab alignment to make the content and macro a bit more intelligible. Use the BIT and BIT_ULL macros. Convert MAP_LBA_MASK to use the already defined shift masks. Signed-off-by: Joe Perches --- drivers/nvdimm/btt.h | 54 ++-- 1 file changed,

[PATCH 12/13] nvdimm: namespace_devs: Change progess typo to progress

2019-09-11 Thread Joe Perches
Typing is hard. Signed-off-by: Joe Perches --- drivers/nvdimm/namespace_devs.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/nvdimm/namespace_devs.c b/drivers/nvdimm/namespace_devs.c index 7a16340f9853..253f07d97b73 100644 --- a/drivers/nvdimm/namespace_devs.c +++

[PATCH 11/13] nvdimm: Use more common logic testing styles and bare ; positions

2019-09-11 Thread Joe Perches
Avoid using uncommon logic testing styles to make the code a bit more like other kernel code. e.g.: if (foo) { ; } else { } is typically written if (!foo) { } Also put bare semicolons before the comment

[PATCH 10/13] nvdimm: namespace_devs: Move assignment operators

2019-09-11 Thread Joe Perches
Kernel code uses assignment operators where the statement is split on multiple lines on the first line. Move 2 unusual uses. Signed-off-by: Joe Perches --- drivers/nvdimm/namespace_devs.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

Re: [PATCH 1/2] libnvdimm/altmap: Track namespace boundaries in altmap

2019-09-11 Thread Johannes Thumshirn
Looks good, Reviewed-by: Johannes Thumshirn -- Johannes ThumshirnSUSE Labs Filesystems jthumsh...@suse.de+49 911 74053 689 SUSE Software Solutions Germany GmbH Maxfeldstr. 5 90409 Nürnberg Germany (HRB 247165, AG München) Key

Re: [PATCH v2 0/3] Maintainer Entry Profiles

2019-09-11 Thread Martin K. Petersen
Hi Dan! > At last years Plumbers Conference I proposed the Maintainer Entry > Profile as a document that a maintainer can provide to set contributor > expectations and provide fodder for a discussion between maintainers > about the merits of different maintainer policies. This looks pretty

[PATCH v2 0/3] Maintainer Entry Profiles

2019-09-11 Thread Dan Williams
Changes since v1 [1]: - Simplify the profile to a hopefully non-controversial set of attributes that address the most common sources of contributor confusion, or maintainer frustration. - Rename "Subsystem Profile" to "Maintainer Entry Profile". Not every entry in MAINTAINERS represents a

[PATCH v2 1/3] MAINTAINERS: Reclaim the P: tag for Maintainer Entry Profile

2019-09-11 Thread Dan Williams
Fixup some P: entries to be M: and delete the others that do not include an email address. The P: tag will be used to indicate the location of a Profile for a given MAINTAINERS entry. Cc: Joe Perches Signed-off-by: Dan Williams --- MAINTAINERS | 12 +++- 1 file changed, 3

[PATCH v2 2/3] Maintainer Handbook: Maintainer Entry Profile

2019-09-11 Thread Dan Williams
As presented at the 2018 Linux Plumbers conference [1], the Maintainer Entry Profile (formerly Subsystem Profile) is proposed as a way to reduce friction between committers and maintainers and encourage conversations amongst maintainers about common best practices. While coding-style,

[PATCH v2 3/3] libnvdimm, MAINTAINERS: Maintainer Entry Profile

2019-09-11 Thread Dan Williams
Document the basic policies of the libnvdimm subsystem and provide a first example of a Maintainer Entry Profile for others to duplicate and edit. Cc: Vishal Verma Cc: Dave Jiang Signed-off-by: Dan Williams --- Documentation/nvdimm/maintainer-entry-profile.rst | 64 +