Re: [PATCH 09/16] tty: serial: 8250_dma: Add a TX trigger workaround for AM33xx

2014-09-24 Thread Sebastian Andrzej Siewior
* Peter Hurley | 2014-09-23 13:03:51 [-0400]: readline() does this; it 'saves' the caller's termios, sets termios for non-canonical reads, reads one char, and 'restores' the caller's termios. interresting, thanks. I guess I would need to opimize this a little so the baudrate isn't going to 0 and

Re: [PATCH 09/16] tty: serial: 8250_dma: Add a TX trigger workaround for AM33xx

2014-09-24 Thread Sebastian Andrzej Siewior
* Frans Klaver | 2014-09-22 11:28:54 [+0200]: Wow, thanks for your work here. This does indeed sound hard to trap. I guess then we'd still have to answer the question why the yocto build calls set_termios() so often, but that's not on you then. Did you notice it even changing settings? We might

[PATCH 2/2] tty: omap-serial: pull out calculation from baud_is_mode16

2014-09-24 Thread Frans Klaver
To determine the correct divisor, we need to know the difference between the desired baud rate and the actual baud rate. The calculation for this difference is implemented twice within omap_serial_baud_is_mode16(). Pull out the calculation for easier maintenance. While at it, remove the

[PATCH v2 0/2]

2014-09-24 Thread Frans Klaver
On Tue, Sep 23, 2014 at 11:58 PM, Greg Kroah-Hartman wrote: So both would be needed to be backported to stable kernels? Why not just do the fix first, then the cleanup afterward, to make backporting easier? Sure thing. I read something about cleaning up first, then actually changing stuff,

[PATCH 1/2] tty: omap-serial: fix division by zero

2014-09-24 Thread Frans Klaver
If the chosen baud rate is large enough (e.g. 3.5 megabaud), the calculated n values in serial_omap_is_baud_mode16() may become 0. This causes a division by zero when calculating the difference between calculated and desired baud rates. To prevent this, cap the n13 and n16 values on 1. Division

Re: [PATCH v5 1/2] usb: rename phy to usb_phy in HCD

2014-09-24 Thread Greg KH
On Fri, Sep 05, 2014 at 01:42:09AM +0400, Sergei Shtylyov wrote: From: Antoine Tenart antoine.ten...@free-electrons.com The USB PHY member of the HCD structure is renamed to 'usb_phy' and modifications are done in all drivers accessing it. This is in preparation to adding the generic PHY

Re: [PATCH] MAINTAINERS: omap_hsmmc: remove myself from MAINTAINERS

2014-09-24 Thread Ulf Hansson
On 17 September 2014 19:20, Balaji T K balaji...@gmail.com wrote: As I won't be able to maintain omap_hsmmc driver Signed-off-by: Balaji T K balaji...@gmail.com Sorry to see you go Balaji. Thanks for all your support! Patch applied for next. Kind regards Uffe --- MAINTAINERS | 3 +-- 1

Re: [PATCH 1/2] tty: omap-serial: fix division by zero

2014-09-24 Thread Greg Kroah-Hartman
On Wed, Sep 24, 2014 at 09:55:21AM +0200, Frans Klaver wrote: If the chosen baud rate is large enough (e.g. 3.5 megabaud), the calculated n values in serial_omap_is_baud_mode16() may become 0. This causes a division by zero when calculating the difference between calculated and desired baud

Re: [PATCH 1/2] tty: omap-serial: fix division by zero

2014-09-24 Thread Frans Klaver
On Wed, Sep 24, 2014 at 01:08:52AM -0700, Greg Kroah-Hartman wrote: On Wed, Sep 24, 2014 at 09:55:21AM +0200, Frans Klaver wrote: If the chosen baud rate is large enough (e.g. 3.5 megabaud), the calculated n values in serial_omap_is_baud_mode16() may become 0. This causes a division by zero

Re: [PATCH 0/6] unshare and simplify omap_hsmmc platform struct

2014-09-24 Thread Ulf Hansson
On 22 September 2014 13:55, Andreas Fenkart afenk...@gmail.com wrote: mmci and omap_hsmmc share very little fields in the platform mmci? Should be omap right? I noticed the similar typo for one of the patches as well. Kind regards Uffe struct. unsharing significantly simplifies the

Re: [PATCH 00/26] ARM: OMAP2+: PRCM cleanups for 3.18 merge window

2014-09-24 Thread Tero Kristo
On 09/19/2014 08:27 PM, Paul Walmsley wrote: On Fri, 19 Sep 2014, Paul Walmsley wrote: However, I saw the following crash at boot on 37xxevm during one of the boot test. Ran thirty more boot tests afterwards on that board and it did not recur. It seems unlikely that the problem is related to

Re: [PATCH 1/2] tty: omap-serial: fix division by zero

2014-09-24 Thread Frans Klaver
On Wed, Sep 24, 2014 at 10:41:11AM +0200, Frans Klaver wrote: On Wed, Sep 24, 2014 at 01:08:52AM -0700, Greg Kroah-Hartman wrote: On Wed, Sep 24, 2014 at 09:55:21AM +0200, Frans Klaver wrote: If the chosen baud rate is large enough (e.g. 3.5 megabaud), the calculated n values in

[PATCH 3/5] clk: Remove .owner field for driver

2014-09-24 Thread Kiran Padwal
There is no need to init .owner field. Based on the patch from Peter Griffin peter.grif...@linaro.org mmc: remove .owner field for drivers using module_platform_driver This patch removes the superflous .owner field for drivers which use the module_platform_driver API, as this is overriden in

[PATCH v5 0/7] Enable L2 cache support on Exynos4210/4x12 SoCs

2014-09-24 Thread Marek Szyprowski
This is an updated patchset, which intends to add support for L2 cache on Exynos4 SoCs on boards running under secure firmware, which requires certain initialization steps to be done with help of firmware, as selected registers are writable only from secure mode. First four patches extend

[PATCH v5 5/7] ARM: EXYNOS: Add .write_sec outer cache callback for L2C-310

2014-09-24 Thread Marek Szyprowski
From: Tomasz Figa t.f...@samsung.com Exynos4 SoCs equipped with an L2C-310 cache controller and running under secure firmware require certain registers of aforementioned IP to be accessed only from secure mode. This means that SMC calls are required for certain register writes. To handle this, an

[PATCH v5 7/7] ARM: dts: exynos4: Add nodes for L2 cache controller

2014-09-24 Thread Marek Szyprowski
From: Tomasz Figa t.f...@samsung.com This patch adds device tree nodes for L2 cache controller present on Exynos4 SoCs. Signed-off-by: Tomasz Figa t.f...@samsung.com Signed-off-by: Marek Szyprowski m.szyprow...@samsung.com --- arch/arm/boot/dts/exynos4210.dtsi | 9 +

[PATCH v5 6/7] ARM: EXYNOS: Add support for non-secure L2X0 resume

2014-09-24 Thread Marek Szyprowski
From: Tomasz Figa t.f...@samsung.com On Exynos SoCs it is necessary to resume operation of L2C early in assembly code, because otherwise certain systems will crash. This patch adds necessary code to non-secure resume handler. Signed-off-by: Tomasz Figa t.f...@samsung.com [rewrote the code

[PATCH v5 4/7] ARM: l2c: Add support for overriding prefetch settings

2014-09-24 Thread Marek Szyprowski
From: Tomasz Figa t.f...@samsung.com Firmware on certain boards (e.g. ODROID-U3) can leave incorrect L2C prefetch settings configured in registers leading to crashes if L2C is enabled without overriding them. This patch introduces bindings to enable prefetch settings to be specified from DT and

[PATCH v5 1/7] ARM: l2c: Refactor the driver to use commit-like interface

2014-09-24 Thread Marek Szyprowski
From: Tomasz Figa t.f...@samsung.com Certain implementations of secure hypervisors (namely the one found on Samsung Exynos-based boards) do not provide access to individual L2C registers. This makes the .write_sec()-based interface insufficient and provoking ugly hacks. This patch is first step

[PATCH v5 3/7] ARM: l2c: Get outer cache .write_sec callback from mach_desc only if not NULL

2014-09-24 Thread Marek Szyprowski
From: Tomasz Figa t.f...@samsung.com Certain platforms (i.e. Exynos) might need to set .write_sec callback from firmware initialization which is happenning in .init_early callback of machine descriptor. However current code will overwrite the pointer with whatever is present in machine

[PATCH v5 2/7] ARM: l2c: Add interface to ask hypervisor to configure L2C

2014-09-24 Thread Marek Szyprowski
From: Tomasz Figa t.f...@samsung.com Because certain secure hypervisor do not allow writes to individual L2C registers, but rather expect set of parameters to be passed as argument to secure monitor calls, there is a need to provide an interface for the L2C driver to ask the firmware to configure

Re: [PATCH v5 4/7] ARM: l2c: Add support for overriding prefetch settings

2014-09-24 Thread Mark Rutland
On Wed, Sep 24, 2014 at 12:05:38PM +0100, Marek Szyprowski wrote: From: Tomasz Figa t.f...@samsung.com Firmware on certain boards (e.g. ODROID-U3) can leave incorrect L2C prefetch settings configured in registers leading to crashes if L2C is enabled without overriding them. This patch

Re: [PATCH v5 4/7] ARM: l2c: Add support for overriding prefetch settings

2014-09-24 Thread Tomasz Figa
On 24.09.2014 13:14, Mark Rutland wrote: On Wed, Sep 24, 2014 at 12:05:38PM +0100, Marek Szyprowski wrote: From: Tomasz Figa t.f...@samsung.com Firmware on certain boards (e.g. ODROID-U3) can leave incorrect L2C prefetch settings configured in registers leading to crashes if L2C is enabled

[PATCH] USB: Remove .owner field for driver

2014-09-24 Thread Kiran Padwal
There is no need to init .owner field. Based on the patch from Peter Griffin peter.grif...@linaro.org mmc: remove .owner field for drivers using module_platform_driver This patch removes the superflous .owner field for drivers which use the module_platform_driver API, as this is overriden in

Re: [PATCH] mfd: ti_am335x_tscadc: Update logic in CTRL register for 5-wire TS

2014-09-24 Thread Lee Jones
On Thu, 04 Sep 2014, Sebastian Andrzej Siewior wrote: From: Jeff Lance j-lan...@ti.com The logic in AFE_Pen_Ctrl bitmask in the CTRL register is different for five wire versus four or eight wire touschscreens. This patch should fix this for five-wire touch screens. There should be no change

Re: [PATCH v5 4/7] ARM: l2c: Add support for overriding prefetch settings

2014-09-24 Thread Mark Rutland
On Wed, Sep 24, 2014 at 12:19:45PM +0100, Tomasz Figa wrote: On 24.09.2014 13:14, Mark Rutland wrote: On Wed, Sep 24, 2014 at 12:05:38PM +0100, Marek Szyprowski wrote: From: Tomasz Figa t.f...@samsung.com Firmware on certain boards (e.g. ODROID-U3) can leave incorrect L2C prefetch

Re: [GIT PULL 2/5] omap soc changes for v3.18 merge window

2014-09-24 Thread Nishanth Menon
On 22:07-20140923, Olof Johansson wrote: On Thu, Sep 11, 2014 at 04:28:55PM -0700, Tony Lindgren wrote: The following changes since commit d7eb67f7fef9c046f27a975118da2324de65a90c: Merge branch 'pull/v3.18/powerdomain-fixes' of https://github.com/nmenon/linux-2.6-playground into

Re: [GIT PULL 2/5] omap soc changes for v3.18 merge window

2014-09-24 Thread Tony Lindgren
* Nishanth Menon n...@ti.com [140924 08:24]: On 22:07-20140923, Olof Johansson wrote: On Thu, Sep 11, 2014 at 04:28:55PM -0700, Tony Lindgren wrote: The following changes since commit d7eb67f7fef9c046f27a975118da2324de65a90c: Merge branch 'pull/v3.18/powerdomain-fixes' of

[PATCH 00/27] add pm_runtime_last_busy_and_autosuspend() helper

2014-09-24 Thread Vinod Koul
This patch series adds a simple macro pm_runtime_last_busy_and_autosuspend() which invokes pm_runtime_mark_last_busy() and pm_runtime_put_autosuspend() sequentially. Then we do a tree wide update of current patterns which are present. As evident from log below this pattern is frequent in the

[PATCH 09/27] i2c: omap: use pm_runtime_last_busy_and_autosuspend helper

2014-09-24 Thread Vinod Koul
Use the new pm_runtime_last_busy_and_autosuspend helper instead of open coding the same code Signed-off-by: Vinod Koul vinod.k...@intel.com --- drivers/i2c/busses/i2c-omap.c |6 ++ 1 files changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/i2c/busses/i2c-omap.c

[PATCH 26/27] usb: musb: omap2430: use pm_runtime_last_busy_and_autosuspend helper

2014-09-24 Thread Vinod Koul
Use the new pm_runtime_last_busy_and_autosuspend helper instead of open coding the same code Signed-off-by: Vinod Koul vinod.k...@intel.com --- drivers/usb/musb/omap2430.c |6 ++ 1 files changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/usb/musb/omap2430.c

[PATCH 16/27] mmc: omap_hsmmc: use pm_runtime_last_busy_and_autosuspend helper

2014-09-24 Thread Vinod Koul
Use the new pm_runtime_last_busy_and_autosuspend helper instead of open coding the same code This patch also changes return value from macro rather than 0 always! Signed-off-by: Vinod Koul vinod.k...@intel.com --- drivers/mmc/host/omap_hsmmc.c | 19 --- 1 files changed, 4

Re: [PATCH v5 1/2] usb: rename phy to usb_phy in HCD

2014-09-24 Thread Sergei Shtylyov
hello. On 09/24/2014 09:11 AM, Greg KH wrote: From: Antoine Tenart antoine.ten...@free-electrons.com The USB PHY member of the HCD structure is renamed to 'usb_phy' and modifications are done in all drivers accessing it. This is in preparation to adding the generic PHY support.

[PATCH v6 0/2] Add generic PHY support to USB HCD

2014-09-24 Thread Sergei Shtylyov
Hello. This patchset is against the usb-next' branch of Greg KH's 'usb.git' repo. Here I add support for the generic PHY to the 'struct usb_hcd' (having to rename the existing 'phy' field to 'usb_phy' beforehand). This was mainly intended to be used with the PCI OHCI/EHCI drivers and also xHCI

[PATCH v6 1/2] usb: rename phy to usb_phy in HCD

2014-09-24 Thread Sergei Shtylyov
From: Antoine Tenart antoine.ten...@free-electrons.com The USB PHY member of the HCD structure is renamed to 'usb_phy' and modifications are done in all drivers accessing it. This is in preparation to adding the generic PHY support. Signed-off-by: Antoine Tenart antoine.ten...@free-electrons.com

Re: [PATCH v6 1/2] usb: rename phy to usb_phy in HCD

2014-09-24 Thread Felipe Balbi
On Wed, Sep 24, 2014 at 11:05:50PM +0400, Sergei Shtylyov wrote: From: Antoine Tenart antoine.ten...@free-electrons.com The USB PHY member of the HCD structure is renamed to 'usb_phy' and modifications are done in all drivers accessing it. This is in preparation to adding the generic PHY

Re: [PATCH v6 1/2] usb: rename phy to usb_phy in HCD

2014-09-24 Thread Sergei Shtylyov
Hello. On 09/24/2014 11:28 PM, Felipe Balbi wrote: From: Antoine Tenart antoine.ten...@free-electrons.com The USB PHY member of the HCD structure is renamed to 'usb_phy' and modifications are done in all drivers accessing it. This is in preparation to adding the generic PHY support.

Re: [PATCH v6 1/2] usb: rename phy to usb_phy in HCD

2014-09-24 Thread Felipe Balbi
On Wed, Sep 24, 2014 at 11:31:11PM +0400, Sergei Shtylyov wrote: Hello. On 09/24/2014 11:28 PM, Felipe Balbi wrote: From: Antoine Tenart antoine.ten...@free-electrons.com The USB PHY member of the HCD structure is renamed to 'usb_phy' and modifications are done in all drivers accessing

Re: [PATCH 00/27] add pm_runtime_last_busy_and_autosuspend() helper

2014-09-24 Thread Rafael J. Wysocki
On Wednesday, September 24, 2014 09:44:50 PM Vinod Koul wrote: This patch series adds a simple macro pm_runtime_last_busy_and_autosuspend() which invokes pm_runtime_mark_last_busy() and pm_runtime_put_autosuspend() sequentially. Then we do a tree wide update of current patterns which are

Re: [PATCH v5 4/7] ARM: l2c: Add support for overriding prefetch settings

2014-09-24 Thread Russell King - ARM Linux
On Wed, Sep 24, 2014 at 01:10:51PM +0100, Mark Rutland wrote: On Wed, Sep 24, 2014 at 12:19:45PM +0100, Tomasz Figa wrote: On 24.09.2014 13:14, Mark Rutland wrote: I'm not too keen on tristate properties. Is this level of flexibility really required? I would say that we need a way to