Re: [RESEND] [PATCH v2 1/2] arm: devtree: Set system_rev from DT revision

2015-06-25 Thread Tony Lindgren
* Pali Rohár pali.ro...@gmail.com [150625 00:29]: On Thursday 25 June 2015 00:22:05 Tony Lindgren wrote: * Pali Rohár pali.ro...@gmail.com [150625 00:21]: Ok, but what do you mean to forget any string conversion? No need for tohexstr() in the uncommpress code if the system_rev

Re: [RESEND] [PATCH v2 1/2] arm: devtree: Set system_rev from DT revision

2015-06-25 Thread Pali Rohár
On Thursday 25 June 2015 00:22:05 Tony Lindgren wrote: * Pali Rohár pali.ro...@gmail.com [150625 00:21]: Ok, but what do you mean to forget any string conversion? No need for tohexstr() in the uncommpress code if the system_rev value is a number coming from the dts. Regards, Tony

[PATCH 1/3] i2c: omap: switch to dev_get_drvdata()

2015-06-25 Thread Felipe Balbi
there's no need to fetch the platform_device in order to dereference it back to the dev pointer to access drvdata, we can use dev_get_drvdata() instead. Signed-off-by: Felipe Balbi ba...@ti.com --- drivers/i2c/busses/i2c-omap.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff

[PATCH 1/2] ARM-OMAP2+: Delete an unnecessary check before the function call omap_device_delete

2015-06-25 Thread SF Markus Elfring
From: Markus Elfring elfr...@users.sourceforge.net Date: Thu, 25 Jun 2015 13:00:11 +0200 The omap_device_delete() function tests whether its argument is NULL and then returns immediately. Thus the test around the call is not needed. This issue was detected by using the Coccinelle software.

[PATCH 0/2] ARM-OMAP2+: Deletion of unnecessary checks before two function calls

2015-06-25 Thread SF Markus Elfring
From: Markus Elfring elfr...@users.sourceforge.net Date: Thu, 25 Jun 2015 13:24:35 +0200 Some functions which release a system resource tolerate the passing of a null pointer. I do not see a need because of this fact that a function caller repeats a corresponding check. Markus Elfring (2):

[PATCH 2/2] ARM-OMAP2+: Delete an unnecessary check before the function call of_node_put

2015-06-25 Thread SF Markus Elfring
From: Markus Elfring elfr...@users.sourceforge.net Date: Thu, 25 Jun 2015 13:05:28 +0200 The of_node_put() function tests whether its argument is NULL and then returns immediately. Thus the test around the call is not needed. This issue was detected by using the Coccinelle software.

Re: [PATCH 0/2] CLK: TI: add dpll_clksel_mac_clk node

2015-06-25 Thread Keerthy
On Thursday 18 June 2015 02:36 PM, Mugunthan V N wrote: On Thursday 18 June 2015 01:31 PM, Keerthy wrote: The series adds the missing clock node needed for cpsw. Keerthy (2): CLK: TI: add dpll_clksel_mac_clk node ARM: dts: am4372: Set the default clock rate for dpll_clksel_mac_clk

[PATCH] thermal: Switch mode to enabled once the cooling device is bound

2015-06-25 Thread Keerthy
Currently mode is still disabled even after the cooling device is bound to the appropriate device. Hence changing the mode to enabled as soon as the cooling device is registered successfully. Signed-off-by: Keerthy j-keer...@ti.com --- drivers/thermal/of-thermal.c | 3 +++ 1 file changed, 3

Re: [PATCH 02/13] dmaengine: Introduce dma_request_slave_channel_compat_reason()

2015-06-25 Thread Arnd Bergmann
On Wednesday 24 June 2015 21:54:01 Vinod Koul wrote: It would be nice to find another name for the dma_request_slave_channel_compat() so with the new name we could have chance to rearrange the parameters: (dev, name, mask, fn, fn_param) We would end up with the following APIs, all

Re: Please revert 3eea8b5d68c801fec788b411582b803463834752 as it breaks touchscreen on n900.

2015-06-25 Thread Pavel Machek
Hi! By the way, the previous version was busted, this one should compile. Input: improve parsing OF parameters for touchscreens From: Dmitry Torokhov dmitry.torok...@gmail.com When applying touchscreen parameters specified in device tree let's make sure we keep whatever setup was done

Re: [PATCH 0/2] ARM: /proc/atags: Export also for DT

2015-06-25 Thread Russell King - ARM Linux
On Fri, May 15, 2015 at 09:50:05PM +0200, Pali Rohár wrote: This patch adds support for DT /atags and stores ATAG structure to DT. It depends on ARM: /proc/cpuinfo: DT: Add support for Revision patches. Pali Rohár (2): arm: devtree: Save atags if are in DT atags field arm: boot: store

Re: [RESEND] [PATCH v2 1/2] arm: devtree: Set system_rev from DT revision

2015-06-25 Thread Russell King - ARM Linux
On Wed, May 06, 2015 at 01:44:17PM +0200, Pali Rohár wrote: On Wednesday 06 May 2015 13:04:01 Arnd Bergmann wrote: What I mean is which code accesses this variable that early? ATAG code is doing it at same early stage, so I added it to same early stage... ATAG code does it early because

[PATCH] tty: serial: 8250: omap: fix kernel crash in suspend-to-ram

2015-06-25 Thread Sekhar Nori
omap_device infrastructure has a suspend_noirq hook which runtime suspends all devices late in the suspend cycle (see _od_suspend_noirq() in arch/arm/mach-omap2/omap_device.c) This leads to a NULL pointer exception in 8250_omap driver since by the time omap8250_runtime_suspend() is called,

[PATCH 2/3] i2c: omap: abolish variable name confusion

2015-06-25 Thread Felipe Balbi
struct device pointers are usually called dev. Calling our struct omap_i2c_dev pointers also dev has caused enough confusion. This is the result of a few simple sed rules to convert all struct omap_i2c_dev pointers to be called omap instead. Signed-off-by: Felipe Balbi ba...@ti.com ---

[PATCH 3/3] i2c: omap: on -remove() call pm_runtime_put_sync()

2015-06-25 Thread Felipe Balbi
we're about to remove the module, so we can't really schedule a PM transition in the future, we must wait for it to finish. Signed-off-by: Felipe Balbi ba...@ti.com --- drivers/i2c/busses/i2c-omap.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/i2c/busses/i2c-omap.c

[PATCH] gpio: omap: prevent module from being unloaded while in use

2015-06-25 Thread Grygorii Strashko
OMAP GPIO driver allowed to be built as loadable module, but it doesn't set owner field in GPIO chip structure. As result, module_get/put() API is not working and it's possible to unload OMAP driver while in use: omap_gpio 48051000.gpio: REMOVING GPIOCHIP WITH GPIOS STILL REQUESTED Hence, add

Re: [PATCH] thermal: Switch mode to enabled once the cooling device is bound

2015-06-25 Thread Nishanth Menon
On 06/25/2015 07:50 AM, Keerthy wrote: Currently mode is still disabled even after the cooling device is bound to the appropriate device. Hence changing the mode to enabled as soon as the cooling device is registered successfully. Signed-off-by: Keerthy j-keer...@ti.com ---

Re: [PATCH V2 4/5] drivers/rtc/rtc-ds1307.c: Support optional wakeup interrupt source

2015-06-25 Thread Grygorii Strashko
On 06/24/2015 07:26 PM, Nishanth Menon wrote: On 11:07-20150624, Nishanth Menon wrote: On 06/24/2015 10:36 AM, Grygorii Strashko wrote: On 06/23/2015 07:15 PM, Nishanth Menon wrote: [...] + ds1307-wakeirq = of_irq_get(node, 1); + if (ds1307-wakeirq = 0) { +

Re: [RESEND] [PATCH v2 1/2] arm: devtree: Set system_rev from DT revision

2015-06-25 Thread Pali Rohár
On Wednesday 24 June 2015 22:01:38 Tony Lindgren wrote: * Pali Rohár pali.ro...@gmail.com [150506 04:45]: On Wednesday 06 May 2015 13:04:01 Arnd Bergmann wrote: It needs to be done in this code, so system_rev variable is set properly... What I mean is which code accesses

Re: [RESEND] [PATCH v2 1/2] arm: devtree: Set system_rev from DT revision

2015-06-25 Thread Tony Lindgren
* Pali Rohár pali.ro...@gmail.com [150625 00:21]: Ok, but what do you mean to forget any string conversion? No need for tohexstr() in the uncommpress code if the system_rev value is a number coming from the dts. Regards, Tony -- To unsubscribe from this list: send the line unsubscribe