Re: [PATCH v2 2/2] staging: IB/ipath: remove sched.h header

2015-10-25 Thread Greg Kroah-Hartman
On Sun, Oct 18, 2015 at 09:57:09PM +0800, Geliang Tang wrote: > sched.h header in ipath_*.c is now unnecessary, since I have added > sched.h in ipath_kernel.h. So remove it. Overall, it's best to split this type of thing out, don't "hide" .h includes in another .h file, so I'm not going to take

Re: [PATCH v2 2/2] staging: IB/ipath: remove sched.h header

2015-10-25 Thread Greg Kroah-Hartman
On Sat, Oct 24, 2015 at 07:05:32PM -0700, Greg Kroah-Hartman wrote: > On Sun, Oct 18, 2015 at 09:57:09PM +0800, Geliang Tang wrote: > > sched.h header in ipath_*.c is now unnecessary, since I have added > > sched.h in ipath_kernel.h. So remove it. > > Overall, it's best to split this type of

Re: [PATCH 1/3] staging: rdma: hfi1: Use setup_timer

2015-10-25 Thread Greg Kroah-Hartman
On Sat, Oct 24, 2015 at 07:58:05AM +0530, Muhammad Falak R Wani wrote: > Use the timer API function setup_timer instead of init_timer, removing > the structure field assignments. > > > > @timer@ > expression e1,e2,e3,fn_ptr; > @@ > -init_timer(); > +setup_timer(, fn_ptr, e2); > ... when !=

Re: [PATCH v2 07/22] staging/rdma/hfi1: Fix sparse error in sdma.h file

2015-10-25 Thread gre...@linuxfoundation.org
On Thu, Oct 22, 2015 at 01:01:25PM +0300, Dan Carpenter wrote: > On Wed, Oct 21, 2015 at 04:29:35PM +, Weiny, Ira wrote: > > > > > > On Mon, Oct 19, 2015 at 10:11:22PM -0400, ira.we...@intel.com wrote: > > > > From: Niranjana Vishwanathapura > > > > > > >

Re: [PATCH 1/4] staging: rdma: ipath: Use setup_timer

2015-10-25 Thread Greg Kroah-Hartman
On Sat, Oct 24, 2015 at 07:49:28AM +0530, Muhammad Falak R Wani wrote: > Use the timer API function setup_timer instead of init_timer, removing > the structure field assignments. > > > > @timer@ > expression e1,e2,e3,fn_ptr; > @@ > -init_timer(); > +setup_timer(, fn_ptr, e2); > ... when !=

[PATCH 1/3] staging: rdma: hfi1: chip: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. @timer@ expression e1,e2,e3,fn_ptr; @@ -init_timer(); +setup_timer(, fn_ptr, e2); ... when != fn_ptr = e3 -e1.function = fn_ptr; -e1.data = e2; Signed-off-by: Muhammad Falak R Wani

[PATCH 2/3] staging: hfi1: driver: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. @timer@ expression e1,e2,e3,fn_ptr; @@ -init_timer(); +setup_timer(, fn_ptr, e2); ... when != fn_ptr = e3 -e1.function = fn_ptr; -e1.data = e2; Signed-off-by: Muhammad Falak R Wani

[PATCH 3/3] staging: hfi1: sdma: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. Signed-off-by: Muhammad Falak R Wani --- v2 changes ->make subject line more specific drivers/staging/rdma/hfi1/sdma.c | 6 ++ 1 file changed, 2

[PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Weston Silbaugh
Multiple assignments should be avoided. For example: cm_event.ird = cm_event.ord = 128; Should be: cm_event.ird = 128; cm_event.ord = 128; Signed-off-by: Weston Silbaugh --- drivers/staging/rdma/amso1100/c2_ae.c | 6 -- 1 file changed, 4 insertions(+), 2

Re: Create a common verbs transport library

2015-10-25 Thread Moni Shoua
Thanks, we'll look into it today On Fri, Oct 23, 2015 at 11:49 PM, Dennis Dalessandro wrote: > On Thu, Oct 15, 2015 at 05:15:38PM +0300, Moni Shoua wrote: >>> >>> I'm thinking perhaps we'll post some stuff to GitHub and you folks can >>> take >>> a look. We can do

Re: [PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Leon Romanovsky
On Sun, Oct 25, 2015 at 12:50 PM, Weston Silbaugh wrote: > Multiple assignments should be avoided. > > For example: > > cm_event.ird = cm_event.ord = 128; > > Should be: > > cm_event.ird = 128; > cm_event.ord = 128; > > Signed-off-by: Weston Silbaugh

Re: [PATCH 1/4 v2] staging: ipath: ipath_driver: Use setup_timer

2015-10-25 Thread Leon Romanovsky
On Sun, Oct 25, 2015 at 12:17 PM, Muhammad Falak R Wani wrote: Please follow standard naming convention for the patches. It should be [PATCH v2 1/4] and not [PATCH 1/4 v2]. -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to

[PATCH 2/4 v2] staging: ipath: ipath_init_chip: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use of the timer API function setup_timer instead of init_timer, removing the structure field assignments, and make the codeflow more readable. The simplified sematic patch used is :- @timer@ expression e1,e2,e3,fn_ptr; @@ -init_timer(); +setup_timer(, fn_ptr, e2); ... when != fn_ptr = e3

[PATCH 1/4 v2] staging: ipath: ipath_driver: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. The simplified semantic patch used is :- @timer@ expression e1,e2,e3,fn_ptr; @@ -init_timer(); +setup_timer(, fn_ptr, e2); ... when != fn_ptr = e3 -e1.function = fn_ptr; -e1.data = e2;

[PATCH 3/4 v2] staging: ipath: ipath_sdma: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. Signed-off-by: Muhammad Falak R Wani --- v2 changes: -> Change the subject line to a be more specific mfrw drivers/staging/rdma/ipath/ipath_sdma.c | 6 +++---

[PATCH 4/4 v2] staging: ipath: ipath_verbs: Use setup_timer

2015-10-25 Thread Muhammad Falak R Wani
Use the timer API function setup_timer instead of init_timer, removing the structure field assignments. Signed-off-by: Muhammad Falak R Wani --- v2 changes: -> Change the subject line to a be more specific mfrw drivers/staging/rdma/ipath/ipath_verbs.c | 5 ++---

[PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Weston Silbaugh
Multiple assignments should be avoided. For example: cm_event.ird = cm_event.ord = 128; Should be: cm_event.ird = 128; cm_event.ord = 128; Signed-off-by: Weston Silbaugh --- drivers/staging/rdma/amso1100/c2_ae.c | 6 -- 1 file changed, 4 insertions(+), 2

Re: [PATCH v2 01/22] staging/rdma/hfi1: Fix regression in send performance

2015-10-25 Thread ira.weiny
On Wed, Oct 21, 2015 at 04:18:06PM +0300, Dan Carpenter wrote: > On Mon, Oct 19, 2015 at 10:11:16PM -0400, ira.we...@intel.com wrote: > > From: Mike Marciniszyn > > > > This additional call is a regression from qib. For small messages the > > progress > > routine

Re: [PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Greg KH
On Sun, Oct 25, 2015 at 04:50:06AM -0600, Weston Silbaugh wrote: > Multiple assignments should be avoided. > > For example: > > cm_event.ird = cm_event.ord = 128; > > Should be: > > cm_event.ird = 128; > cm_event.ord = 128; > > Signed-off-by: Weston Silbaugh Where