RE: [PATCH v5] usb: gadget: udc: renesas_usb3: Add register of usb role switch

2018-05-28 Thread Yoshihiro Shimoda
Hi Heikki, > From: Heikki Krogerus, Sent: Monday, May 28, 2018 10:05 PM > > On Fri, May 25, 2018 at 04:12:56PM +0900, Yoshihiro Shimoda wrote: > > @@ -2573,6 +2635,12 @@ static void renesas_usb3_init_ram(struct > > renesas_usb3 *usb3, struct device *dev, > > EXTCON_NONE, > > }; > > > >

RE: [PATCH v5] usb: gadget: udc: renesas_usb3: Add register of usb role switch

2018-05-28 Thread Yoshihiro Shimoda
Hi Andy, Thank you for your review! > From: Andy Shevchenko, Sent: Monday, May 28, 2018 9:47 PM > > On Fri, May 25, 2018 at 10:12 AM, Yoshihiro Shimoda > wrote: > > > -static void usb3_set_mode(struct renesas_usb3 *usb3, bool host) > > Wouldn't be better to choose another name for a new

Re: [PATCH v5] usb: gadget: udc: renesas_usb3: Add register of usb role switch

2018-05-28 Thread Heikki Krogerus
On Fri, May 25, 2018 at 04:12:56PM +0900, Yoshihiro Shimoda wrote: > @@ -2573,6 +2635,12 @@ static void renesas_usb3_init_ram(struct renesas_usb3 > *usb3, struct device *dev, > EXTCON_NONE, > }; > > +static struct usb_role_switch_desc renesas_usb3_role_switch_desc = { You can constify

Re: [PATCH v5] usb: gadget: udc: renesas_usb3: Add register of usb role switch

2018-05-28 Thread Andy Shevchenko
On Fri, May 25, 2018 at 10:12 AM, Yoshihiro Shimoda wrote: > -static void usb3_set_mode(struct renesas_usb3 *usb3, bool host) Wouldn't be better to choose another name for a new function? > + struct renesas_usb3 *usb3 = container_of(work, struct

[PATCH v5] usb: gadget: udc: renesas_usb3: Add register of usb role switch

2018-05-25 Thread Yoshihiro Shimoda
This patch adds role switch support for R-Car SoCs into the USB 3.0 peripheral driver. Some R-Car SoCs (e.g. R-Car H3) have USB 3.0 dual-role device controller which has the USB 3.0 xHCI host and Renesas USB 3.0 peripheral. Unfortunately, the mode change register (DRD_CON) contains the USB 3.0