Re: [PATCH 1/3] spi: bitbang: Replace spinlock by mutex when calling chipselect

2015-08-05 Thread Nicolas Boichat
On Tue, Aug 4, 2015 at 6:59 PM, Mark Brown broo...@kernel.org wrote: On Tue, Aug 04, 2015 at 02:09:56PM +0800, Nicolas Boichat wrote: [snip] Actually, I'm not sure if I understand the existing code: why are we not waiting for busy to go down to 0, then call chipselect, instead of not calling

Re: [PATCH 1/2] mfd: s2mps11: Add manual shutdown method for Odroid XU3

2015-08-05 Thread Javier Martinez Canillas
Hello Krzysztof, On 08/03/2015 02:37 PM, Krzysztof Kozlowski wrote: On Odroid XU3 board (with S2MPS11 PMIC) the PWRHOLD bit in CTRL1 register must be manually set to 0 before initiating power off sequence. One of usual power down methods for Exynos based devices looks like: 1. PWRHOLD pin

Re: [PATCH 2/2] ARM: dts: Fix power off method on exynos5422-odroidxu3

2015-08-05 Thread Javier Martinez Canillas
Hello Krzysztof, On 08/03/2015 02:37 PM, Krzysztof Kozlowski wrote: The Odroid XU3 family boards have ACOKB pin of PMIC grounded, instead of pulled up as usual. This means that PMIC must manually set PWRHOLD field in its CTRL1 register to low before initiating power down. This fixes Odroid

Re: Feedback on hardware support for Odroid U3

2015-08-05 Thread Thomas Pietrowski
Sorry for the long delay. Got now linux-stable 4.2.0-rc5 running here, but I still miss the fan support. Searched the web again for the patch and found this on LKML: https://lkml.org/lkml/2014/12/18/138 Then looked at the arm-soc repository but found this patch nowhere. Are you planing to add

Re: [PATCH 11/11] drm/exynos: remove struct exynos_drm_encoder layer

2015-08-05 Thread Gustavo Padovan
2015-08-05 Inki Dae inki@samsung.com: Hi Inki, On 2015년 08월 04일 23:47, Gustavo Padovan wrote: Hi Inki, 2015-08-04 Inki Dae inki@samsung.com: On 2015년 08월 04일 04:09, Gustavo Padovan wrote: From: Gustavo Padovan gustavo.pado...@collabora.co.uk struct exynos_drm_encoder

[PATCH v2 00/11] drm/exynos: remove exynos_drm_display and exynos_drm_encoder

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk Hi, This patchset is another important step in the exynos clean up, it removes two exynos internal structs in favor of wider use of struct drm_encoder. Structs exynos_drm_display and exynos_drm_encoder were doing exactly what struct

[PATCH v2 09/11] drm/exynos: remove exynos_drm_create_enc_conn()

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk This functions was just hiding the encoder and connector creation in a way that was less clean than if we get rid of it. For example, exynos_encoder ops had .create_connector() defined only because we were handing off the encoder and connector

[PATCH v2 03/11] drm/exynos: remove unused .remove() and .check_mode() ops from display

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk These two display_ops are not used anywhere, remove them. Signed-off-by: Gustavo Padovan gustavo.pado...@collabora.co.uk --- drivers/gpu/drm/exynos/exynos_drm_drv.h | 5 - 1 file changed, 5 deletions(-) diff --git

[PATCH v2 04/11] drm/exynos: simplify calculation of possible CRTCs

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk All CRTCs can only be LCD, HDMI or VIDI, so basically all CRTCs will be a possible CRTCs. This patch removes an extra function with switch that was only checking if the CRTC type was one of those three above. Signed-off-by: Gustavo Padovan

[PATCH v2 07/11] drm/exynos: remove extra call to exynos_dp_commit()

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk exynos_dp_commit() was getting called twice by exynos encoder core, once inside the .enable() call and another time by .commit() itself. The remove of the second call caused the wake of a bug, the operations orders inside exynos_dp_commit was

[PATCH v2 08/11] drm/exynos: remove exynos_encoder's .commit() op

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk .commit() is not used anymore, Exynos encoders now follow the .enable()/.disable() semantics from drm atomic core, so remove this callback. Signed-off-by: Gustavo Padovan gustavo.pado...@collabora.co.uk ---

[PATCH v2 06/11] drm/exynos: remove extra call to hdmi_commit()

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk hdmi_commit() was getting called twice by exynos encoder core, once inside the .enable() call and another time by .commit() itself. Signed-off-by: Gustavo Padovan gustavo.pado...@collabora.co.uk --- drivers/gpu/drm/exynos/exynos_hdmi.c | 13

[PATCH v2 02/11] drm/exynos: remove wrappers for phy_power_{on,off}

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk phy_power_on() and phy_power_off() already checks for NULL pointer. This patch removes the wrappers exynos_dp_phy_init() and exynos_dp_phy_exit() since the only think they were doing was a check for NULL phy. Signed-off-by: Gustavo Padovan

[PATCH v2 05/11] drm/exynos: remove struct exynos_drm_display

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk This struct was just representing encoder information, it was a member of struct exynos_drm_encoder, so any code trying to access encoder data would have to go through the encoder struct, get the display struct and then get the data it want.

[PATCH v2 01/11] drm/exynos: split display's .dpms() into .enable() and .disable()

2015-08-05 Thread Gustavo Padovan
From: Gustavo Padovan gustavo.pado...@collabora.co.uk The DRM Core doesn't have a dpms() operation anymore, everything now is enable() or disable(). Signed-off-by: Gustavo Padovan gustavo.pado...@collabora.co.uk --- v2: set dp-dpms_mode after enable/disable ---

Re: Feedback on hardware support for Odroid U3

2015-08-05 Thread Krzysztof Kozłowski
2015-08-05 22:07 GMT+09:00 Thomas Pietrowski thopie...@gmail.com: Sorry for the long delay. Got now linux-stable 4.2.0-rc5 running here, but I still miss the fan support. Searched the web again for the patch and found this on LKML: https://lkml.org/lkml/2014/12/18/138 Then looked at the

Re: [PATCH] cpufreq: exynos: Fix for memory leak in case SoC name does not match

2015-08-05 Thread Rafael J. Wysocki
On Tuesday, August 04, 2015 04:45:16 PM Kukjin Kim wrote: From: Shailendra Verma shailendra.capric...@gmail.com During probe free the memory allocated to exynos_info in case of unknown SoC type. Signed-off-by: Shailendra Verma shailendra.capric...@gmail.com Acked-by: Viresh Kumar