Re: [PATCH] mmc: dwmci: Add new register bit at IP version of 240A.

2012-03-19 Thread Jaehoon Chung
BIT(29) #define SDMMC_CMD_CCS_EXPBIT(23) #define SDMMC_CMD_CEATA_RD BIT(22) #define SDMMC_CMD_UPD_CLKBIT(21) Best Regards, Jaehoon Chung -- To unsubscribe from this list: send the line unsubscribe linux-samsung-soc in the body of a message to majord

Re: [PATCH] drivers: mmc: sdhci-s3c: fix broken compilation for non-Exynos SoCs

2012-03-11 Thread Jaehoon Chung
Looks fine to me. Acked-by: Jaehoon Chung jh80.ch...@samsung.com On 03/09/2012 10:44 PM, Marek Szyprowski wrote: exynos4_sdhci_drv_data structure is not available on non-Exynos builds, that's why EXYNOS4_SDHCI_DRV_DATA macro has been introduced. This patch fixes commit 67819656 'mmc: sdhci

Re: [PATCH v3 0/4] mmc: sdhci-s3c: use the sdhci-pltfm.c and move the header file

2012-03-08 Thread Jaehoon Chung
On 03/08/2012 08:01 PM, Mark Brown wrote: On Thu, Mar 08, 2012 at 02:35:53PM +0900, Jaehoon Chung wrote: So i think no problem that removed #include plat/regs-sdhci.h. is it wrong? Just touching the setup-gpio- files is problem? It should be fine, like I say I didn't really read

Re: [PATCH v3 0/4] mmc: sdhci-s3c: use the sdhci-pltfm.c and move the header file

2012-03-07 Thread Jaehoon Chung
Hi Mark. On 03/08/2012 03:48 AM, Mark Brown wrote: On Wed, Mar 07, 2012 at 12:03:31PM +0900, Jaehoon Chung wrote: On 03/07/2012 01:30 AM, Mark Brown wrote: The same IP is present and used with the same driver on other Samsung SoCs. I know that used with the same driver on other

Re: [PATCH v3 0/4] mmc: sdhci-s3c: use the sdhci-pltfm.c and move the header file

2012-03-06 Thread Jaehoon Chung
/regs-sdhci.h) also is only used in sdhci-s3c.c. And the least portion is moved into /linux/mmc/. Then included linux/mmc/sdhci-s3c.h in plat/sdhci.h. What's difference? If you can explain the more detail, i can understand. But sorry, now i didn't accept your opinion. Best Regards, Jaehoon Chung

Re: [PATCH 1/2] mmc: sdhci-s3c: Use CONFIG_PM_SLEEP to ifdef system suspend

2012-03-05 Thread Jaehoon Chung
Acked-by: Jaehoon Chung jh80.ch...@samsung.com On 03/03/2012 09:46 AM, Mark Brown wrote: This matches current best practice as one can have runtime PM enabled without system sleep and CONFIG_PM is defined for both. Signed-off-by: Mark Brown broo...@opensource.wolfsonmicro.com --- drivers

Re: [PATCH 2/2] mmc: sdhci-s3c: Enable runtime power management

2012-03-05 Thread Jaehoon Chung
Hi Mark, On 03/03/2012 09:46 AM, Mark Brown wrote: Since most of the work is already done by the core we just need to add runtime suspend methods and tell the PM core that runtime PM is enabled for this device. Signed-off-by: Mark Brown broo...@opensource.wolfsonmicro.com ---

Re: [PATCH v2 0/4] mmc: sdhci-s3c: use the sdhci-pltfm.c and move the header file

2012-03-05 Thread Jaehoon Chung
in mmc-driver) If will move into mmc-driver, we can maintain the efficient more than before. I want to know your opinion. Best Regards, Jaehoon Chung On 02/27/2012 04:58 PM, Jaehoon Chung wrote: This patchset is the purpose for using sdhci-pltfm.c and removing the arch dependency. The sdhci-s3c

[PATCH v3 1/4] mmc: sdhci-s3c: use the sdhci-pltfm for Samsung-SoC

2012-03-05 Thread Jaehoon Chung
This patch is change to use the sdhci-pltfm.c Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- drivers/mmc/host/Kconfig | 20 ++-- drivers/mmc/host/Makefile|2 +- drivers/mmc/host/sdhci-s3c.c | 252

[PATCH v3 2/4] ARM: SAMSUNG: move the header file to driver directory

2012-03-05 Thread Jaehoon Chung
The header-file is moved to drivers/mmc/host from plat. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- arch/arm/mach-exynos/setup-sdhci-gpio.c |1 - arch/arm/mach-s5pc100/setup-sdhci-gpio.c|1 - arch/arm/mach

[PATCH v3 3/4] mmc: sdhci-s3c: use the sdhci-s3c.h instead of regs-sdhci.h

2012-03-05 Thread Jaehoon Chung
Using the sdhci-s3c.h Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- drivers/mmc/host/sdhci-s3c.c | 12 +--- 1 files changed, 5 insertions(+), 7 deletions(-) diff --git a/drivers/mmc/host/sdhci-s3c.c b/drivers/mmc/host

[PATCH v3 4/4] ARM: SAMSUNG: move the mmc platdata header file to linux/mmc/

2012-03-05 Thread Jaehoon Chung
Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- arch/arm/plat-samsung/include/plat/sdhci.h | 53 +- include/linux/mmc/sdhci-s3c.h | 84 2 files changed, 85 insertions

Re: [PATCH 2/2] mmc: sdhci-s3c: Enable runtime power management

2012-03-05 Thread Jaehoon Chung
Acked-by: Jaehoon Chung jh80.ch...@samsung.com On 03/05/2012 08:52 PM, Mark Brown wrote: On Mon, Mar 05, 2012 at 07:48:42PM +0900, Jaehoon Chung wrote: On 03/03/2012 09:46 AM, Mark Brown wrote: + pm_runtime_set_autosuspend_delay(pdev-dev, 50); Could you explain why use 50ms? It's

Re: [PATCH v2 1/4] mmc: sdhci-s3c: use the sdhci-pltfm for Samsung-SoC

2012-03-01 Thread Jaehoon Chung
On 02/29/2012 03:33 PM, Seungwon Jeon wrote: Hi Jaehoon, Thank you for the patch. Could you check comments below? Jaehoon Chung jh80.ch...@samsung.com wrote: This patch is change to use the sdhci-pltfm.c Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park

Re: [PATCH v2 1/4] mmc: sdhci-s3c: use the sdhci-pltfm for Samsung-SoC

2012-03-01 Thread Jaehoon Chung
On 03/02/2012 11:15 AM, Seungwon Jeon wrote: Jaehoon Chung jh80.ch...@samsung.com wrote: On 02/29/2012 03:33 PM, Seungwon Jeon wrote: Hi Jaehoon, Thank you for the patch. Could you check comments below? Jaehoon Chung jh80.ch...@samsung.com wrote: This patch is change to use the sdhci

Re: [PATCH v2 1/4] mmc: sdhci-s3c: use the sdhci-pltfm for Samsung-SoC

2012-03-01 Thread Jaehoon Chung
be removed. Then it needs not to use SDHCI_QUIRK_NONSTANDARD_CLOCK. Best Regards, Jaehoon Chung Thanks, Seungwon Jeon. Best Regards, Jaehoon Chung And about quirks..., I think compatibility should be considered. Thanks, Seungwon Jeon. And any comment? Best Regards, Jaehoon Chung

[PATCH v2 0/4] mmc: sdhci-s3c: use the sdhci-pltfm.c and move the header file

2012-02-26 Thread Jaehoon Chung
part. In future, i will work more removing the arch dependency. This patchset based on mmc-next tree. Changlog V2: - modified driver/mmc/host/Kconfig - Add the comments for s3c64xx - based-on latest mmc-tree. Jaehoon Chung (4): mmc: sdhci-s3c: use the sdhci-pltfm

[PATCH v2 2/4] ARM: SAMSUNG: move the header file to driver directory

2012-02-26 Thread Jaehoon Chung
The header-file is moved to drivers/mmc/host from plat. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- arch/arm/mach-exynos/setup-sdhci-gpio.c |1 - arch/arm/mach-s5pc100/setup-sdhci-gpio.c|1 - arch/arm/mach

[PATCH v2 4/4] ARM: SAMSUNG: move the mmc platdata header file to linux/mmc/

2012-02-26 Thread Jaehoon Chung
Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- arch/arm/plat-samsung/include/plat/sdhci.h | 53 +- include/linux/mmc/sdhci-s3c.h | 84 2 files changed, 85 insertions

[PATCH v2 3/4] mmc: sdhci-s3c: use the sdhci-s3c.h instead of regs-sdhci.h

2012-02-26 Thread Jaehoon Chung
Using the sdhci-s3c.h Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- drivers/mmc/host/sdhci-s3c.c | 12 +--- 1 files changed, 5 insertions(+), 7 deletions(-) diff --git a/drivers/mmc/host/sdhci-s3c.c b/drivers/mmc/host

[PATCH v2 1/4] mmc: sdhci-s3c: use the sdhci-pltfm for Samsung-SoC

2012-02-26 Thread Jaehoon Chung
This patch is change to use the sdhci-pltfm.c Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- drivers/mmc/host/Kconfig | 20 ++-- drivers/mmc/host/sdhci-s3c.c | 254 ++ 2 files changed

Re: [PATCH 1/4] mmc: sdhci-s3c: use the sdhci-pltfm for Samsung-SoC

2012-02-24 Thread Jaehoon Chung
. And in mmc-next tree, latest your patch is merged. (using device-tree). So i rework this patch. Right. this is the todo list. And need more discussion. Main goal is to use the sdhci-pltfm. There are few comments below. On 14 February 2012 10:33, Jaehoon Chung jh80.ch...@samsung.com wrote: This patch

Re: [PATCH 2/4] ARM: SAMSUNG: move the header file to driver directory

2012-02-24 Thread Jaehoon Chung
On 02/24/2012 06:48 PM, Thomas Abraham wrote: Dear Mr. Chung, On 14 February 2012 10:33, Jaehoon Chung jh80.ch...@samsung.com wrote: The header-file is moved to drivers/mmc/host from plat. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p

Re: [PATCH 2/4] ARM: SAMSUNG: move the header file to driver directory

2012-02-24 Thread Jaehoon Chung
On 02/24/2012 07:36 PM, Thomas Abraham wrote: On 24 February 2012 16:00, Jaehoon Chung jh80.ch...@samsung.com wrote: On 02/24/2012 06:10 PM, Thomas Abraham wrote: Dear Mr. Chung, On 14 February 2012 10:33, Jaehoon Chung jh80.ch...@samsung.com wrote: The header-file is moved to drivers/mmc

[PATCH] ARM: SAMSUNG: change the name from s3c-sdhci to exynos4-sdhci

2012-02-22 Thread Jaehoon Chung
for-next branch) Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: kyungmin Park kyungmin.p...@samsung.com --- arch/arm/mach-exynos/mach-nuri.c |4 ++-- arch/arm/mach-exynos/mach-universal_c210.c |2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git

[PATCH 0/4] mmc: sdhci-s3c: use the sdhci-pltfm.c and move the header file

2012-02-13 Thread Jaehoon Chung
part. In future, i will work more removing the arch dependency. This patchset based on mmc-next tree. Jaehoon Chung (4): mmc: sdhci-s3c: use the sdhci-pltfm for Samsung-SoC ARM: SAMSUNG: move the header file to driver directory mmc: sdhci-s3c: use the sdhci-s3c.h instead of regs-sdhci.h

[PATCH 1/4] mmc: sdhci-s3c: use the sdhci-pltfm for Samsung-SoC

2012-02-13 Thread Jaehoon Chung
This patch is change to use the sdhci-pltfm.c Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- drivers/mmc/host/sdhci-s3c.c | 218 ++ 1 files changed, 71 insertions(+), 147 deletions(-) diff

[PATCH 3/4] mmc: sdhci-s3c: use the sdhci-s3c.h instead of regs-sdhci.h

2012-02-13 Thread Jaehoon Chung
Use the sdhci-s3c.h Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- drivers/mmc/host/sdhci-s3c.c | 12 +--- 1 files changed, 5 insertions(+), 7 deletions(-) diff --git a/drivers/mmc/host/sdhci-s3c.c b/drivers/mmc/host

[PATCH 4/4] ARM: SAMSUNG: move the mmc platdata header file to linux/mmc/

2012-02-13 Thread Jaehoon Chung
Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin-park kyungmin.p...@samsung.com --- arch/arm/plat-samsung/include/plat/sdhci.h | 59 +--- include/linux/mmc/sdhci-s3c.h | 84 2 files changed, 85 insertions

[PATCH 2/4] ARM: SAMSUNG: move the header file to driver directory

2012-02-13 Thread Jaehoon Chung
The header-file is moved to drivers/mmc/host from plat. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- arch/arm/mach-exynos/setup-sdhci-gpio.c |1 - arch/arm/mach-s5pc100/setup-sdhci-gpio.c|1 - arch/arm/mach

Re: [PATCH v3 2/2] mmc: sdhci-s3c: add platform data for the second capability

2012-02-06 Thread Jaehoon Chung
Hi Kukjin.. I want to merge these patchset with Chris's ACK at Samsung-SoC tree Samsung-SoC need to set MMC_CAP2_BROKEN_VOLTAGE..So this patch is need. Best Regards, Jaehoon Chung On 02/06/2012 08:19 PM, Chris Ball wrote: Hi, On Mon, Feb 06 2012, Jaehoon Chung wrote: This patch is added

[PATCH v3 2/2] mmc: sdhci-s3c: add platform data for the second capability

2012-02-05 Thread Jaehoon Chung
This patch is added host_caps2 in sdhci-s3c.c It's necessary that use the second capabilities. And removed the duplicated host_caps. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- Changelog v3: - based-on latest mmc-next tree

[PATCH v3 1/2] arm: samsung: support the second capability for samsung-soc

2012-02-05 Thread Jaehoon Chung
In mmc, there are capabilities and use the host_caps. That capability is expressed with bit[0:31]. But now..already filled the bit[0:31]... so we need to denote with the other capability field. (if we want to use the cache, powerclass, etc for eMMC..this field is necessary) Signed-off-by: Jaehoon

Re: [PATCHv2 1/2] arm: samsung: support the second capability for samsung-soc

2011-11-15 Thread Jaehoon Chung
Hi Kukjin On 11/15/2011 06:53 PM, Kukjin Kim wrote: Jaehoon Chung wrote: In mmc, there are capabilities and use the host_caps. That capability is expressed with bit[0:31]. But now..already filled the bit[0:31]... so we need to denote with the other capability field. (if we want to use

[PATCHv2 1/2] arm: samsung: support the second capability for samsung-soc

2011-11-02 Thread Jaehoon Chung
In mmc, there are capabilities and use the host_caps. That capability is expressed with bit[0:31]. But now..already filled the bit[0:31]... so we need to denote with the other capability field. (if we want to use the cache, powerclass, etc for eMMC..this field is necessary) Signed-off-by: Jaehoon

[PATCHv2 2/2] mmc: sdhci-s3c: add platform data for the second capability

2011-11-02 Thread Jaehoon Chung
This patch is added host_caps2 in sdhci-s3c.c It's necessary that use the second capabilities. And removed the duplicated host_caps. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- Changelog v2: - remove the duplicated host_caps

[PATCH 0/2] mmc: samsung-soc: support the second capability

2011-10-30 Thread Jaehoon Chung
This patch-set is added the platdata for the second capability. At latest, added the cap2 for capability in mmc-core. Samsung-SoC should use this field. Jaehoon Chung (2): sdhci: support the second capability for hsmmc. sdhci-s3c: add platform data for the second capability arch/arm/plat

[PATCH 1/2] arm: samsung: support the second capability for hsmmc

2011-10-30 Thread Jaehoon Chung
Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- arch/arm/plat-samsung/dev-hsmmc.c |2 ++ arch/arm/plat-samsung/dev-hsmmc1.c |2 ++ arch/arm/plat-samsung/dev-hsmmc2.c |2 ++ arch/arm/plat-samsung

[PATCH 2/2] mmc: sdhci-s3c: add platform data for the second capability

2011-10-30 Thread Jaehoon Chung
Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- drivers/mmc/host/sdhci-s3c.c |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/drivers/mmc/host/sdhci-s3c.c b/drivers/mmc/host/sdhci-s3c.c index 3d00e72..95e3a2a

[PATCH 0/2] mmc: sdhci-s3c: support wakeup during suspend

2011-10-18 Thread Jaehoon Chung
Add codes for enable wakeup on detecting card change(insert or remove). It is required to enable in case like MMC_UNSAFE_RESUME. Wonil Choi (2): arm: samsung: add wakeup platdata mmc: sdhci-s3c: add to enable wakeup for sd-card arch/arm/plat-samsung/dev-hsmmc.c |1 +

[PATCH 1/2] arm: samsung: add wakeup platdata

2011-10-18 Thread Jaehoon Chung
Signed-off-by: Wonil Choi wonil22.c...@samsung.com Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- arch/arm/plat-samsung/dev-hsmmc.c |1 + arch/arm/plat-samsung/dev-hsmmc1.c |1 + arch/arm/plat-samsung/dev-hsmmc2.c |1 + arch/arm/plat-samsung/dev

[PATCH 2/2]mmc: sdhci-s3c: add to enable wakeup for sd-card

2011-10-18 Thread Jaehoon Chung
Signed-off-by: Wonil Choi wonil22.c...@samsung.com Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- drivers/mmc/host/sdhci-s3c.c | 15 ++- 1 files changed, 14 insertions(+), 1 deletions(-) diff --git a/drivers/mmc/host/sdhci-s3c.c b/drivers/mmc/host/sdhci-s3c.c index 3d00e72

Re: [PATCH V9] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-18 Thread Jaehoon Chung
Hi Chris. Thank you for merged about eMMC4.5 feature. Best regards, Jaehoon Chung On 10/18/2011 09:53 PM, Chris Ball wrote: Hi, On Tue, Oct 18 2011, Girish K S wrote: missing one thing.unsigned intpower_notify_type; in include/linux/mmc/host.h is not alligned to the above

Re: [PATCH V9] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-17 Thread Jaehoon Chung
request. there are duplicated code in Notify patch, so i didn't add to cache patch. Regards, Jaehoon Chung On 10/18/2011 02:05 PM, Girish K S wrote: This patch adds the support for power off notify feature, available in eMMC 4.5 devices. If the the host has support for this feature, then the mmc

Re: [PATCH V9] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-17 Thread Jaehoon Chung
://git.infradead.org/users/kmpark/linux-2.6-samsung emmc4.5 What do you want how i do? :) Best regards, Jaehoon Chung On 10/18/2011 02:25 PM, Girish K S wrote: On 18 October 2011 10:49, Girish K S girish.shivananja...@linaro.org wrote: On 18 October 2011 10:46, Jaehoon Chung jh80.ch

Re: [PATCH v5] mmc: core: Add default timeout value for CMD6.

2011-10-16 Thread Jaehoon Chung
Hi Mr.Jeon I known this patch is committed for mmc-next. Maybe you need to send only the patch for power-class. Thanks, Jaehoon Chung On 10/17/2011 08:45 AM, Seungwon Jeon wrote: This mail is a duplicate from our security machine. V5 of related patch has already submitted. Please ignore

Re: [PATCH] mmc: dw_mmc: Support predefined multiple block transfers.

2011-10-05 Thread Jaehoon Chung
On 10/05/2011 05:02 PM, Seungwon Jeon wrote: Jaehoon Chung wrote: Hi Mr.Jeon One question...if we used predefined transfer, didn't send stop-command? then i think that didn't need to enter this condition..how about this? In __dw_mci_start_reqeust() function(at your patch) if (mrq-stop

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish.. i think this patch didn't base on latest for mmc-next.. i commented the below. Regards, Jaehoon Chung On 09/29/2011 07:46 PM, Girish K S wrote: This patch adds the support for power off notify feature available in eMMC 4.5 devices. If the the host has support

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish.. My means if you use host-caps2, i think right that should be define MMC_CAP2_XXX. Am i wrong? Best regards, Jaehoon Chung On 10/04/2011 08:03 PM, Girish K S wrote: Hello Mr Chung, Kindly apply my HS200 feature patch before this patch. then it will work fine. can you check

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish. I just modified the MMC_CAP2_POWEROFF_NOTIFY instead of MMC_CAP_POWEROFF_NOTIFY. Regards, Jaehoon Chung On 10/04/2011 09:12 PM, Girish K S wrote: Dear Mr Chung, i saw your pull request with poweroff notify feature. did you modify anything in the Power Notify feature. I am

Re: [PATCH] mmc: dw_mmc: Support predefined multiple block transfers.

2011-10-04 Thread Jaehoon Chung
misunderstood something, plz let me know...Thanks. Tested-by: Jaehoon Chung jh80.ch...@samsung.com On 09/28/2011 05:23 PM, Seungwon Jeon wrote: Andrei Warkentin wrote: 2011/9/26 Seungwon Jeon tgih@samsung.com: Andrei Warkentin wrote: Hi Seungwon, - Original Message - From

Re: [PATCH V2] mmc: core: eMMC4.5 Add the timeout for switch

2011-09-01 Thread Jaehoon Chung
Hi Girish. I agreed for Mr.Jeon's opinion. I think that need not to check for any exception case. (Mr.Jeon mentioned the below comment, just using default cmd6_timeout) Thanks, Jaehoon Chung Girish K S wrote: Hello Mr Jeon, In case if the timeout is specified

<    1   2   3