Re: [PATCH 04/15] ARM: OMAP: USB: Add phy binding information

2013-07-18 Thread Tony Lindgren
* Kishon Vijay Abraham I [130717 23:53]: > In order for controllers to get PHY in case of non dt boot, the phy > binding information (phy device name) should be added in the platform > data of the controller. > > Signed-off-by: Kishon Vijay Abraham I > Reviewed-by: Sylwester Nawrocki > Acked-by

Re: [PATCH 05/15] ARM: dts: omap: update usb_otg_hs data

2013-07-18 Thread Tony Lindgren
* Kishon Vijay Abraham I [130717 23:53]: > Updated the usb_otg_hs dt data to include the *phy* and *phy-names* > binding in order for the driver to use the new generic PHY framework. > Also updated the Documentation to include the binding information. > The PHY binding information can be found at

Re: [PATCH 01/15] drivers: phy: add generic PHY framework

2013-07-18 Thread Greg KH
On Thu, Jul 18, 2013 at 12:16:10PM +0530, Kishon Vijay Abraham I wrote: > +struct phy_provider *__of_phy_provider_register(struct device *dev, > + struct module *owner, struct phy * (*of_xlate)(struct device *dev, > + struct of_phandle_args *args)); > +struct phy_provider *__devm_of_phy_pro

Re: [PATCH 02/15] usb: phy: omap-usb2: use the new generic PHY framework

2013-07-18 Thread Greg KH
On Thu, Jul 18, 2013 at 12:16:11PM +0530, Kishon Vijay Abraham I wrote: > Used the generic PHY framework API to create the PHY. Now the power off and > power on are done in omap_usb_power_off and omap_usb_power_on respectively. > > However using the old USB PHY library cannot be completely removed

Re: [PATCH 01/15] drivers: phy: add generic PHY framework

2013-07-18 Thread Kishon Vijay Abraham I
Hi, On Thursday 18 July 2013 12:50 PM, Greg KH wrote: > On Thu, Jul 18, 2013 at 12:16:10PM +0530, Kishon Vijay Abraham I wrote: >> +struct phy_provider *__of_phy_provider_register(struct device *dev, >> +struct module *owner, struct phy * (*of_xlate)(struct device *dev, >> +struct of_phand

Re: [PATCH 02/15] usb: phy: omap-usb2: use the new generic PHY framework

2013-07-18 Thread Kishon Vijay Abraham I
On Thursday 18 July 2013 12:51 PM, Greg KH wrote: > On Thu, Jul 18, 2013 at 12:16:11PM +0530, Kishon Vijay Abraham I wrote: >> Used the generic PHY framework API to create the PHY. Now the power off and >> power on are done in omap_usb_power_off and omap_usb_power_on respectively. >> >> However usi

[PATCH v2 0/6] clk: exynos: Some fixes and cleanup

2013-07-18 Thread Sachin Kamat
Resending some of patches (1, 3 and 5) as per discussion in thread [1]. Other patches in the series are new. [1] http://comments.gmane.org/gmane.linux.kernel.samsung-soc/19933 Changes since v1: * Removed an unnecessary change in Patch 1 as pointed out by Kukjin Kim. * Added Kukjin's ack to patche

[PATCH 5/6] clk: exynos5440: Staticize local symbols

2013-07-18 Thread Sachin Kamat
Symbols referenced only in this file are made static. Signed-off-by: Sachin Kamat Acked-by: Kukjin Kim --- drivers/clk/samsung/clk-exynos5440.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/clk/samsung/clk-exynos5440.c b/drivers/clk/samsung/clk-ex

[PATCH 2/6] clk: exynos4: Remove unused function

2013-07-18 Thread Sachin Kamat
Subsequent to the cleanup in commit 3c70348c7c ("ARM: EXYNOS: Remove legacy timer initialization code"), this function has no more users. Hence remove it. Signed-off-by: Sachin Kamat --- drivers/clk/samsung/clk-exynos4.c | 14 -- 1 file changed, 14 deletions(-) diff --git a/driver

[PATCH 6/6] clk: exynos-audss: Staticize exynos_audss_clk_init

2013-07-18 Thread Sachin Kamat
exynos_audss_clk_init() is used only in this file. Make it static. Signed-off-by: Sachin Kamat Acked-by: Kukjin Kim --- drivers/clk/samsung/clk-exynos-audss.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/clk/samsung/clk-exynos-audss.c b/drivers/clk/samsung/clk

[PATCH 1/6] clk: exynos4: Staticize local symbols

2013-07-18 Thread Sachin Kamat
Symbols referenced only in this file are made static. Signed-off-by: Sachin Kamat --- drivers/clk/samsung/clk-exynos4.c | 28 +++- 1 file changed, 15 insertions(+), 13 deletions(-) diff --git a/drivers/clk/samsung/clk-exynos4.c b/drivers/clk/samsung/clk-exynos4.c inde

[PATCH 3/6] clk: exynos5250: Staticize local symbols

2013-07-18 Thread Sachin Kamat
Symbols referenced only in this file are made static. Signed-off-by: Sachin Kamat Acked-by: Kukjin Kim --- drivers/clk/samsung/clk-exynos5250.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/clk/samsung/clk-exynos5250.c b/drivers/clk/samsung/clk-ex

[PATCH 4/6] clk: exynos5420: Staticize local symbols

2013-07-18 Thread Sachin Kamat
Symbols referenced only in this file are made static. Signed-off-by: Sachin Kamat Acked-by: Kukjin Kim --- drivers/clk/samsung/clk-exynos5420.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/clk/samsung/clk-exynos5420.c b/drivers/clk/samsung/clk-ex

Re: [PATCH 01/15] drivers: phy: add generic PHY framework

2013-07-18 Thread Greg KH
On Thu, Jul 18, 2013 at 02:29:52PM +0530, Kishon Vijay Abraham I wrote: > Hi, > > On Thursday 18 July 2013 12:50 PM, Greg KH wrote: > > On Thu, Jul 18, 2013 at 12:16:10PM +0530, Kishon Vijay Abraham I wrote: > >> +struct phy_provider *__of_phy_provider_register(struct device *dev, > >> + struct m

Re: [PATCH v7 00/12] iommu/exynos: Fixes and Enhancements of System MMU driver with DT

2013-07-18 Thread Antonios Motakis
Hello Cho, I have been trying out the Exynos System MMU driver including your fixes, however I notice that if you try to get the iommu_group of a device (i.e. iommu_group_get(&pdev->dev)) this will not work. Since each device is behind its own System MMU I would expect a distinct iommu_group for t

Re: [PATCH 01/15] drivers: phy: add generic PHY framework

2013-07-18 Thread Kishon Vijay Abraham I
Hi, On Thursday 18 July 2013 09:19 PM, Greg KH wrote: > On Thu, Jul 18, 2013 at 02:29:52PM +0530, Kishon Vijay Abraham I wrote: >> Hi, >> >> On Thursday 18 July 2013 12:50 PM, Greg KH wrote: >>> On Thu, Jul 18, 2013 at 12:16:10PM +0530, Kishon Vijay Abraham I wrote: +struct phy_provider *__of

Re: [PATCH 01/15] drivers: phy: add generic PHY framework

2013-07-18 Thread Greg KH
On Fri, Jul 19, 2013 at 11:07:10AM +0530, Kishon Vijay Abraham I wrote: > +ret = dev_set_name(&phy->dev, "%s.%d", dev_name(dev), id); > >>> > >>> Your naming is odd, no "phy" anywhere in it? You rely on the sender to > >>> never send a duplicate name.id pair? Why not create your own

Re: [PATCH 01/15] drivers: phy: add generic PHY framework

2013-07-18 Thread Kishon Vijay Abraham I
Hi, On Friday 19 July 2013 11:13 AM, Greg KH wrote: > On Fri, Jul 19, 2013 at 11:07:10AM +0530, Kishon Vijay Abraham I wrote: >> +ret = dev_set_name(&phy->dev, "%s.%d", dev_name(dev), id); > > Your naming is odd, no "phy" anywhere in it? You rely on the sender to > never s

Re: [PATCH 01/15] drivers: phy: add generic PHY framework

2013-07-18 Thread Greg KH
On Fri, Jul 19, 2013 at 11:25:44AM +0530, Kishon Vijay Abraham I wrote: > Hi, > > On Friday 19 July 2013 11:13 AM, Greg KH wrote: > > On Fri, Jul 19, 2013 at 11:07:10AM +0530, Kishon Vijay Abraham I wrote: > >> + ret = dev_set_name(&phy->dev, "%s.%d", dev_name(dev), id); > > > > Y

Re: [PATCH 1/1] ARM: EXYNOS: Update CONFIG_ARCH_NR_GPIO for Exynos

2013-07-18 Thread Sachin Kamat
Ping Kukjin. On 15 July 2013 17:22, Sachin Kamat wrote: > On 24 June 2013 11:43, Sachin Kamat wrote: >> With the recent cleanup in Exynos platform code notably commits >> 17859bec ("ARM: EXYNOS: Do not select legacy Kconfig symbols any >> more") and b910 ("ARM: EXYNOS: Remove mach/gpio.h"),

Re: [PATCH 01/15] drivers: phy: add generic PHY framework

2013-07-18 Thread Kishon Vijay Abraham I
Hi, On Friday 19 July 2013 11:59 AM, Greg KH wrote: > On Fri, Jul 19, 2013 at 11:25:44AM +0530, Kishon Vijay Abraham I wrote: >> Hi, >> >> On Friday 19 July 2013 11:13 AM, Greg KH wrote: >>> On Fri, Jul 19, 2013 at 11:07:10AM +0530, Kishon Vijay Abraham I wrote: + ret = dev_set_name(