[PATCH 0/3] mmc: sdhci-s3c: Remove 'clk_type' member from platform data

2011-10-04 Thread Thomas Abraham
This patchset removes all uses of 'clk_type' member from the platform data of sdhci-s3c driver. The clk_type is a SoC specific information and not a board/ machine specific information. Hence, this information can be more aptly represented using SoC specific driver data in the sdhci-s3c driver.

[PATCH 2/3] arm: exynos4: use 'exynos4-sdhci' as device name for sdhci controllers

2011-10-04 Thread Thomas Abraham
With the addition of platform specific driver data in the sdhci driver for exynos4, the device name of sdhci controllers on exynos4 is changed accordingly. Cc: Kukjin Kim kgene@samsung.com Signed-off-by: Thomas Abraham thomas.abra...@linaro.org --- arch/arm/mach-exynos4/clock.c

[PATCH 1/3] mmc: sdhci-s3c: Remove usage of clk_type member in platform data

2011-10-04 Thread Thomas Abraham
SDHCI controllers on Exynos4 do not include the sdclk divider as per the sdhci controller specification. This case can be represented using the sdhci quirk SDHCI_QUIRK_NONSTANDARD_CLOCK instead of using an additional enum type definition 'clk_types'. Hence, usage of clk_type member in platform

[PATCH 3/3] arm: samsung: remove all uses of clk_type member in sdhci platform data

2011-10-04 Thread Thomas Abraham
The sdhci driver is modified to be independent of clk_type member in the sdhci platform data. Hence, all usage of clk_type in platform code is removed. Cc: Kyungmin Park kyungmin.p...@samsung.com Cc: JeongHyeon Kim jh...@insignal.co.kr Cc: Kukjin Kim kgene@samsung.com Cc: Changhwan Youn

Re: [PATCH 1/3] mmc: sdhci-s3c: Remove usage of clk_type member in platform data

2011-10-04 Thread Kyungmin Park
Hi, On Tue, Oct 4, 2011 at 4:28 PM, Thomas Abraham thomas.abra...@linaro.org wrote: SDHCI controllers on Exynos4 do not include the sdclk divider as per the sdhci controller specification. This case can be represented using the sdhci quirk SDHCI_QUIRK_NONSTANDARD_CLOCK instead of using an

Re: [PATCH 1/3] mmc: sdhci-s3c: Remove usage of clk_type member in platform data

2011-10-04 Thread Thomas Abraham
Hi Mr. Park, On 4 October 2011 13:23, Kyungmin Park kmp...@infradead.org wrote: Hi, On Tue, Oct 4, 2011 at 4:28 PM, Thomas Abraham thomas.abra...@linaro.org wrote: SDHCI controllers on Exynos4 do not include the sdclk divider as per the sdhci controller specification. This case can be

[PATCH] arm: mm: Fix infinite looping issue

2011-10-04 Thread Girish K S
This patch fixes the problem of infinite looping while booting. The bne instruction expects the z flag to be set to break the loop. The (mov r1, r1, lsr #1) doesn't behave in the expected way. If replaced with the movs instruction then the execution will exit the loop. Signed-off-by: Girish K S

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish.. i think this patch didn't base on latest for mmc-next.. i commented the below. Regards, Jaehoon Chung On 09/29/2011 07:46 PM, Girish K S wrote: This patch adds the support for power off notify feature available in eMMC 4.5 devices. If the the host has support for this

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Hello Mr Chung, Kindly apply my HS200 feature patch before this patch. then it will work fine. can you check and let me know if it applies after HS200 patch. If it can be applied i will modify and resend regards Girish K S On 4 October 2011 16:22, Jaehoon Chung jh80.ch...@samsung.com wrote: Hi

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish.. My means if you use host-caps2, i think right that should be define MMC_CAP2_XXX. Am i wrong? Best regards, Jaehoon Chung On 10/04/2011 08:03 PM, Girish K S wrote: Hello Mr Chung, Kindly apply my HS200 feature patch before this patch. then it will work fine. can you check and

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Hello Mr Chung, I got your point. My reply was for your comment on cannot apply this patch on mmc-next branch. regards Girish K S On 4 October 2011 16:46, Jaehoon Chung jh80.ch...@samsung.com wrote: Hi Girish.. My means if you use host-caps2, i think right that should be define MMC_CAP2_XXX.

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Hello Mr Chung, Since my both patches are dependent on each other. i will generate a patch series of HS200 and Power notify. So that they can be applied sequentially. Will update with your mentioned comment. kindly review it after my release. regards Girish K S On 4 October 2011 16:50, Girish

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Dear Mr Chung, i saw your pull request with poweroff notify feature. did you modify anything in the Power Notify feature. I am preparing the patch with your review comment. regards Girish K S On 4 October 2011 17:11, Girish K S girish.shivananja...@linaro.org wrote: Hello Mr Chung, Since my

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish. I just modified the MMC_CAP2_POWEROFF_NOTIFY instead of MMC_CAP_POWEROFF_NOTIFY. Regards, Jaehoon Chung On 10/04/2011 09:12 PM, Girish K S wrote: Dear Mr Chung, i saw your pull request with poweroff notify feature. did you modify anything in the Power Notify feature. I am

RE: [PATCH 2/7] s3c-adc: describe features via quirk constants

2011-10-04 Thread Kukjin Kim
Heiko Stübner wrote: Hi Kgene, Am Sonntag 02 Oktober 2011, 09:38:18 schrieb Kukjin Kim: How about following? I think following is also not bad... ok, I don't claim to have the right solution, so if keeping the TYPE_xxx enum is better, I will do a rework of the series according to your

[GIT PULL] Samsung cleanup-2 for v3.2

2011-10-04 Thread Kukjin Kim
Hi Arnd, This is second cleanup for Samsung stuff for v3.2 and includes cleanup header files in plat-s3c24xx and plat-s5p to merge into one plat-samsung directory. Please pull from: git://github.com/kgene/linux-samsung.git next-samsung-cleanup-2 And this is based on previous Samsung cleanup

Re: [PATCH 4/4] ARM: EXYNOS4: Add power domain to use generic Power domain Framework

2011-10-04 Thread Chanwoo Choi
Kukjin Kim wrote: Chanwoo Choi wrote: This patch initializes the power domain of EXYNOS4210. The devices which suppot runtime-PM have to be added in specific power domain. Signed-off-by: Chanwoo Choi cw00.c...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com ---

Re: [PATCH 2/4] ARM: EXYNOS4: Support for generic Clock manipulation PM callbacks

2011-10-04 Thread Chanwoo Choi
Kukjin Kim wrote: Chanwoo Choi wrote: Signed-off-by: Chanwoo Choi cw00.c...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- arch/arm/mach-exynos4/Makefile |2 +- arch/arm/mach-exynos4/pm-runtime.c | 56 2 files

Re: [PATCH] mmc: dw_mmc: Support predefined multiple block transfers.

2011-10-04 Thread Jaehoon Chung
Hi Mr.Jeon One question...if we used predefined transfer, didn't send stop-command? then i think that didn't need to enter this condition..how about this? In __dw_mci_start_reqeust() function(at your patch) if (mrq-stop) host-stop_cmdr = dw_mci_prepare_command(slot-mmc, mrq-stop); If i

[PATCH 0/3] ARM: SAMSUNG: Add support for sdhci clock lookup using generic names

2011-10-04 Thread Rajeshwari Shinde
This patchset adds support for sdhci controller clock lookup using generic names. With this patchset, there will be no need to pass clock names in sdhci platform data. This patchset depends on two other patchsets: mmc: sdhci-s3c: Remove 'clk_type' member from platform data Add a common macro for

[PATCH 1/3] SDHCI: S3C: Use generic clock names for sdhci bus clock options

2011-10-04 Thread Rajeshwari Shinde
This patch modifies the driver to stop depending on the clock names being passed from the platform and switch over to bus clock lookup using generic clock names. Signed-off-by: Rajeshwari Shinde rajeshwar...@samsung.com --- drivers/mmc/host/sdhci-s3c.c |6 ++ 1 files changed, 2

[PATCH 2/3] ARM: SAMSUNG: Remove SDHCI bus clocks from platform data

2011-10-04 Thread Rajeshwari Shinde
The bus clocks previously sent through platform data to SDHCI controller are removed. Signed-off-by: Rajeshwari Shinde rajeshwar...@samsung.com --- arch/arm/mach-exynos4/Makefile |1 - arch/arm/mach-exynos4/setup-sdhci.c| 22 ---

[PATCH 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-04 Thread Rajeshwari Shinde
Add support for lookup of sdhci-s3c controller clocks using generic names for s3c2416, s3c64xx, s5pc100, s5pv210 and exynos4 SoC's. Signed-off-by: Rajeshwari Shinde rajeshwar...@samsung.com --- arch/arm/mach-exynos4/clock.c | 99 ++- arch/arm/mach-s3c2416/clock.c | 68