Re: [PATCH V8] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-13 Thread Chris Ball
Hi Girish, just trivial changes below. Does anyone have a Tested-by: to add to the patch? On Thu, Oct 13 2011, Girish K S wrote: > This patch adds the support for power off notify feature, available in > eMMC 4.5 devices. If the the host has support for this feature, then the > mmc core will not

Re: [PATCH] rtc: rtc-s3c: Add device tree support

2011-10-13 Thread Grant Likely
On Tue, Oct 11, 2011 at 07:48:07PM +0900, Kukjin Kim wrote: > Thomas Abraham wrote: > > > > On 3 September 2011 21:19, Thomas Abraham > > wrote: > > > Add device tree based discovery support for Samsung's rtc controller. > > > > > > Cc: Ben Dooks > > > Signed-off-by: Thomas Abraham > > > --- >

Re: [PATCH 2/3] ARM: Exynos4: Add ioremap interceptor for statically remapped regions

2011-10-13 Thread Nicolas Pitre
On Thu, 13 Oct 2011, Thomas Abraham wrote: > On 12 October 2011 22:00, Thomas Abraham wrote: > > On 12 October 2011 21:43, Rob Herring wrote: > >> On 10/10/2011 03:11 AM, Thomas Abraham wrote: > >>> ioremap() request for statically remapped regions are intercepted and the > >>> statically assign

Re: [PATCH 5/7] ARM: EXYNOS4: Add support external GIC

2011-10-13 Thread Will Deacon
On Thu, Oct 13, 2011 at 12:09:28PM +0100, Russell King - ARM Linux wrote: > On Mon, Oct 10, 2011 at 02:02:09PM +0100, Marc Zyngier wrote: > > On 07/10/11 16:16, Will Deacon wrote: > > > On Fri, Oct 07, 2011 at 10:44:59AM +0100, Marc Zyngier wrote: > > >> +static void __cpuinit exynos4_secondary_ini

Re: [PATCH 2/2] ARM: dts: Add intial dts file for Exynos4210 SoC, SMDKV310 and Origen board

2011-10-13 Thread Grant Likely
On Tue, Oct 11, 2011 at 07:43:16PM +0530, Thomas Abraham wrote: > Add initial dts file for Exynos4210 SoC. This dts file describes the SoC > specific devices and properties. Along with this, add dts file for Samsung's > SMDKV310 board and Insignal's Origen board which uses the Exynos4210 dts file >

Re: [PATCH 1/2] ARM: Samsung: Add Exynos4 device tree enabled board file

2011-10-13 Thread Grant Likely
On Tue, Oct 11, 2011 at 07:43:15PM +0530, Thomas Abraham wrote: > Add a new Exynos4 compatible device tree enabled board file. Boards based on > the Exynos4 family of SoC's can use this as the machine/board file. When using > this machine fike, a corresponding device tree blob which describes the

Re: [PATCH 5/7] ARM: EXYNOS4: Add support external GIC

2011-10-13 Thread Russell King - ARM Linux
On Mon, Oct 10, 2011 at 02:02:09PM +0100, Marc Zyngier wrote: > On 07/10/11 16:16, Will Deacon wrote: > > On Fri, Oct 07, 2011 at 10:44:59AM +0100, Marc Zyngier wrote: > >> +static void __cpuinit exynos4_secondary_init(unsigned int cpu) > >> { > >>void __iomem *dist_base = S5P_VA_GIC_DIST + >

Re: [RESEND][PATCH V2 1/2] ARM: CLKDEV: Add Common Macro for clk_lookup

2011-10-13 Thread Russell King - ARM Linux
On Tue, Oct 11, 2011 at 05:15:29PM +0530, Padmavathi Venna wrote: > From: Padmavathi Venna > > Added a standardized macro CLKDEV_INIT which can used across all > the platforms to support clkdev > > Suggested by: Russell King Should be Suggested-by: (with a '-' rather than a ' '). Other than

Re: [RESEND][PATCH V2 0/2] Add a common macro for creating struct clk_lookup entries

2011-10-13 Thread Russell King - ARM Linux
On Tue, Oct 11, 2011 at 08:56:23PM +0900, Kukjin Kim wrote: > Russell, > Maybe as you know, this is required on upcoming Samsung stuff. Actually it's > just change/consolidate on other stuff but add on Samsung stuff. So if > you're ok, how about sending this to upstream via arm-soc or your tree in

Re: [PATCH V2 1/2] ARM: EXYNOS4: Add SPI support

2011-10-13 Thread Russell King - ARM Linux
On Mon, Oct 10, 2011 at 01:38:04PM +0530, Padmavathi Venna wrote: > +void __init exynos4_spi_set_info(int cntrlr, int src_clk_nr, int num_cs) > +{ > + struct s3c64xx_spi_info *pd; > + > + /* Reject invalid configuration */ > + if (!num_cs || src_clk_nr < 0 > + || src

Re: [PATCH V4 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-13 Thread Sylwester Nawrocki
On 10/13/2011 10:55 AM, Russell King - ARM Linux wrote: > On Thu, Oct 13, 2011 at 09:55:04AM +0200, Sylwester Nawrocki wrote: >> Yes, it allowed to add clkdev support with minimal changes required. >> >> But let's see what happens when the works on common struct clk for all >> architectures are mor

Re: [PATCH V4 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-13 Thread Russell King - ARM Linux
On Thu, Oct 13, 2011 at 09:55:04AM +0200, Sylwester Nawrocki wrote: > Yes, it allowed to add clkdev support with minimal changes required. > > But let's see what happens when the works on common struct clk for all > architectures are more or less completed and we convert Samsung platforms > to use

[PATCH V5 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-13 Thread Rajeshwari Shinde
Add support for lookup of sdhci-s3c controller clocks using generic names for s3c2416, s3c64xx, s5pc100, s5pv210 and exynos4 SoC's. Signed-off-by: Rajeshwari Shinde --- arch/arm/mach-exynos4/clock.c | 88 ++--- arch/arm/mach-s3c2416/clock.c | 68 +++-- arc

[PATCH V4 2/3] ARM: SAMSUNG: Remove SDHCI bus clocks from platform data

2011-10-13 Thread Rajeshwari Shinde
The bus clocks previously sent through platform data to SDHCI controller are removed. Signed-off-by: Rajeshwari Shinde --- arch/arm/mach-exynos4/Makefile |1 - arch/arm/mach-exynos4/setup-sdhci.c| 22 --- arch/arm/mach-s3c2416/Makefile |1

[PATCH V4 1/3] SDHCI: S3C: Use generic clock names for sdhci bus clock options

2011-10-13 Thread Rajeshwari Shinde
This patch modifies the driver to stop depending on the clock names being passed from the platform and switch over to bus clock lookup using generic clock names. Signed-off-by: Rajeshwari Shinde --- drivers/mmc/host/sdhci-s3c.c |6 ++ 1 files changed, 2 insertions(+), 4 deletions(-) dif

[PATCH V4 0/3] ARM: SAMSUNG: Add support for sdhci clock lookup using generic names

2011-10-13 Thread Rajeshwari Shinde
This patchset adds support for sdhci controller clock lookup using generic names. With this patchset, there will be no need to pass clock names in sdhci platform data. This patchset depends on the patchset: Add a common macro for creating struct clk_lookup entries. mmc: sdhci-s3c: add default cont

[PATCH v5 2/2] iommu/exynos: Add iommu driver for Exynos Platforms

2011-10-13 Thread KyongHo Cho
This is the exactly same patch with the previous "[PATCH v5 2/2] iommu/exynos: Add iommu driver for Exynos Platforms". The only change from the previous one is to change Sylwester's email address in the Cc list by his request. Regards, KyongHo. commit e1ad653521025dec5888b9818ed1a96aa9a5ad3a Au

Re: [PATCH V4 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-13 Thread Sylwester Nawrocki
On 10/13/2011 09:16 AM, Rajeshwari Birje wrote: > On Wed, Oct 12, 2011 at 9:49 PM, Sylwester Nawrocki > wrote: >> On 10/12/2011 02:36 PM, Rajeshwari Birje wrote: >>> On Wed, Oct 12, 2011 at 3:54 PM, Sylwester Nawrocki >>> wrote: Hi Rajeshwari, On 10/12/2011 11:43 AM, Rajeshwari Shi

Re: [PATCH V4 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-13 Thread Rajeshwari Birje
Hi Sylwester, On Wed, Oct 12, 2011 at 9:49 PM, Sylwester Nawrocki wrote: > On 10/12/2011 02:36 PM, Rajeshwari Birje wrote: >> On Wed, Oct 12, 2011 at 3:54 PM, Sylwester Nawrocki >> wrote: >>> Hi Rajeshwari, >>> >>> On 10/12/2011 11:43 AM, Rajeshwari Shinde wrote: Add support for lookup of s