[PATCH 3/7] s3c-hsudc: add a remove function

2011-12-17 Thread Heiko Stübner
As the driver is also buildable as a module it should need a cleanup function for the removal of the module. Signed-off-by: Heiko Stuebner he...@sntech.de --- drivers/usb/gadget/s3c-hsudc.c | 25 + 1 files changed, 25 insertions(+), 0 deletions(-) diff --git

[PATCH 4/7] s3c-hsudc: add missing otg_put_transceiver in probe

2011-12-17 Thread Heiko Stübner
The number of get and put calls should always be equal. Signed-off-by: Heiko Stuebner he...@sntech.de --- drivers/usb/gadget/s3c-hsudc.c |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/drivers/usb/gadget/s3c-hsudc.c b/drivers/usb/gadget/s3c-hsudc.c index

[PATCH 5/7] s3c-hsudc: move device registration to probe and remove

2011-12-17 Thread Heiko Stübner
Instead of adding and deleting the gadget device in the start and stop invocations. Use device_register in the probe method to initialize and add the gadget device and unregister it in the remove function. This also requires a release function for the gadget device. Signed-off-by: Heiko Stuebner

[PATCH 6/7] s3c-hsudc: use udc_start and udc_stop functions

2011-12-17 Thread Heiko Stübner
udc_start and udc_stop reduce code duplication in comparison to start and stop generalising calls done by all drivers (i.e. bind and unbind) and moving these calls to common code. Signed-off-by: Heiko Stuebner he...@sntech.de --- drivers/usb/gadget/s3c-hsudc.c | 44

[PATCH 7/7] s3c-hsudc: Add regulator handling

2011-12-17 Thread Heiko Stübner
The udc has three supplies: vdda (3.3V), vddi (1.2V) and vddosc (1.8-3.3V). Turn these on and off on start and stop calls. Signed-off-by: Heiko Stuebner he...@sntech.de --- drivers/usb/gadget/s3c-hsudc.c | 43 --- 1 files changed, 39 insertions(+), 4

Re: [PATCH v5 1/5] ARM: l2x0/pl310: Refactor Kconfig to be more maintainable

2011-12-17 Thread Olof Johansson
On Thu, Dec 15, 2011 at 7:53 AM, Dave Martin dave.mar...@linaro.org wrote: Making CACHE_L2X0 depend on (huge list of MACH_ and ARCH_ configs) is bothersome to maintain and likely to lead to merge conflicts. This patch moves the knowledge of which platforms have a L2x0 or PL310 cache