Re: [PATCHv6 0/2] thermal: exynos: Add support for TRIMINFO feature of Exynos3250

2014-09-03 Thread Eduardo Valentin
Hi,

On Wed, Sep 03, 2014 at 12:09:01PM +0900, Chanwoo Choi wrote:
 This patchset add the support of TRIMINFO_RELOAD feature for Exynos3250.
 But Exynos3250 has two TRIMINFO_CTRL register instead other Exynos has only 
 one
 TRIMINFO_CTRL register. So, this patchset support the some Exynos SoC which
 has more than one TRIMINF_CTRL.
 
 Also, this patchset fix wrong value of TRIMINFO_RELOAD_SHIFT and remove
 duplicate code when reading triminfo register of Exynos5440.
 
 Changes from v5:
 - Rebase this patchset on next branch of linux-soc-thermal.git
 

Pulled into my next branch. Thanks.

 Changes from v4:
 - Remove un-necessary triminfo_ctrl_{shift, mask} field
 - Includes Bartlomiej's patch[1] that Exynos5260 / Exynos5420 should not use
 TRIM_RELOAD flag
 [2] https://lkml.org/lkml/2014/8/20/481
 
 Changes from v3:
 - Add reviewed message of Amit Daniel Kachhap amit.dan...@samsung.com
 - Split RELOAD patch as two patch
 - Fix 'TRIMINFO_RELOAD_SHIFT' value
 - This series includes separate patch[1]
 [1] https://lkml.org/lkml/2014/8/20/5
 - Drop ACTIME bit setting because TRM includes not enough information of 
 ACTIME bit.
 
 Changes from v2:
 - Fix build break because of missing 'or' operation.
 
 Changes from v1:
 - Add missing 'TMU_SUPPORT_TRIM_RELOAD' features
 
 Chanwoo Choi (2):
   thermal: exynos: Add support for many TRIMINFO_CTRL registers
   thermal: exynos: Add support for TRIM_RELOAD feature at Exynos3250
 
  drivers/thermal/samsung/exynos_thermal_common.h |  1 +
  drivers/thermal/samsung/exynos_tmu.c| 15 ---
  drivers/thermal/samsung/exynos_tmu.h|  7 +--
  drivers/thermal/samsung/exynos_tmu_data.c   | 11 +--
  drivers/thermal/samsung/exynos_tmu_data.h   |  8 ++--
  5 files changed, 33 insertions(+), 9 deletions(-)
 
 -- 
 1.8.0
 
 --
 To unsubscribe from this list: send the line unsubscribe linux-pm in
 the body of a message to majord...@vger.kernel.org
 More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line unsubscribe linux-samsung-soc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCHv6 0/2] thermal: exynos: Add support for TRIMINFO feature of Exynos3250

2014-09-03 Thread Chanwoo Choi
Dear Eduardo,

On 08/30/2014 11:39 AM, Eduardo Valentin wrote:
 Hi,
 
 On Wed, Sep 03, 2014 at 12:09:01PM +0900, Chanwoo Choi wrote:
 This patchset add the support of TRIMINFO_RELOAD feature for Exynos3250.
 But Exynos3250 has two TRIMINFO_CTRL register instead other Exynos has only 
 one
 TRIMINFO_CTRL register. So, this patchset support the some Exynos SoC which
 has more than one TRIMINF_CTRL.

 Also, this patchset fix wrong value of TRIMINFO_RELOAD_SHIFT and remove
 duplicate code when reading triminfo register of Exynos5440.

 Changes from v5:
 - Rebase this patchset on next branch of linux-soc-thermal.git

 
 Pulled into my next branch. Thanks.

Thanks.

Best Regards,
Chanwoo Choi
--
To unsubscribe from this list: send the line unsubscribe linux-samsung-soc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCHv6 0/2] thermal: exynos: Add support for TRIMINFO feature of Exynos3250

2014-09-02 Thread Chanwoo Choi
This patchset add the support of TRIMINFO_RELOAD feature for Exynos3250.
But Exynos3250 has two TRIMINFO_CTRL register instead other Exynos has only one
TRIMINFO_CTRL register. So, this patchset support the some Exynos SoC which
has more than one TRIMINF_CTRL.

Also, this patchset fix wrong value of TRIMINFO_RELOAD_SHIFT and remove
duplicate code when reading triminfo register of Exynos5440.

Changes from v5:
- Rebase this patchset on next branch of linux-soc-thermal.git

Changes from v4:
- Remove un-necessary triminfo_ctrl_{shift, mask} field
- Includes Bartlomiej's patch[1] that Exynos5260 / Exynos5420 should not use
TRIM_RELOAD flag
[2] https://lkml.org/lkml/2014/8/20/481

Changes from v3:
- Add reviewed message of Amit Daniel Kachhap amit.dan...@samsung.com
- Split RELOAD patch as two patch
- Fix 'TRIMINFO_RELOAD_SHIFT' value
- This series includes separate patch[1]
[1] https://lkml.org/lkml/2014/8/20/5
- Drop ACTIME bit setting because TRM includes not enough information of ACTIME 
bit.

Changes from v2:
- Fix build break because of missing 'or' operation.

Changes from v1:
- Add missing 'TMU_SUPPORT_TRIM_RELOAD' features

Chanwoo Choi (2):
  thermal: exynos: Add support for many TRIMINFO_CTRL registers
  thermal: exynos: Add support for TRIM_RELOAD feature at Exynos3250

 drivers/thermal/samsung/exynos_thermal_common.h |  1 +
 drivers/thermal/samsung/exynos_tmu.c| 15 ---
 drivers/thermal/samsung/exynos_tmu.h|  7 +--
 drivers/thermal/samsung/exynos_tmu_data.c   | 11 +--
 drivers/thermal/samsung/exynos_tmu_data.h   |  8 ++--
 5 files changed, 33 insertions(+), 9 deletions(-)

-- 
1.8.0

--
To unsubscribe from this list: send the line unsubscribe linux-samsung-soc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html