RE: [PATCH] qla2xxx: fix RSCN handling on big-endian systems

2007-02-22 Thread Seokmann Ju
On Wednesday, February 21, 2007 6:54 PM, Malahal Naineni wrote: I have JBOD in FL-port and if I unplug the cable or disable the switch port, the qla2xxx driver doesn't fail the I/O soon. The remote port status is 'online' all the time. The I/O's usually timeout after the usual scsi timeout.

Re: [Patch 1/2] cciss: fix for 2TB support

2007-02-22 Thread Mike Miller (OS Dev)
On Wed, Feb 21, 2007 at 07:14:27PM -0800, Andrew Morton wrote: On Wed, 21 Feb 2007 15:10:39 -0600 Mike Miller (OS Dev) [EMAIL PROTECTED] wrote: Patch 1/2 This patch changes the way we determine if a logical volume is larger than 2TB. The original test looked for a total_size of 0.

Re: [PATCH] qla2xxx: fix RSCN handling on big-endian systems

2007-02-22 Thread malahal
Seokmann Ju [EMAIL PROTECTED] wrote: On Wednesday, February 21, 2007 6:54 PM, Malahal Naineni wrote: I have JBOD in FL-port and if I unplug the cable or disable the switch port, the qla2xxx driver doesn't fail the I/O soon. The remote port status is 'online' all the time. The I/O's

RE: [PATCH] qla2xxx: fix RSCN handling on big-endian systems

2007-02-22 Thread Seokmann Ju
On Thursday, February 22, 2007 11:09 AM, Malahal Naineni wrote: I removed the cable and didn't put it back at all for more than 1 hour. There is no recovery here. When I disable an F-port, after few seconds the remote port state is set to something other than 'online'. Why not same

[PATCH 1/2] sas_ata: Rename ata_queued_cmd-lldd_task to driver_data

2007-02-22 Thread Darrick J. Wong
Per Tejun's request, rename the lldd_task field and add comments about it. Signed-off-by: Darrick J. Wong [EMAIL PROTECTED] --- drivers/scsi/libsas/sas_ata.c |8 include/linux/libata.h|4 +++- 2 files changed, 7 insertions(+), 5 deletions(-) diff --git

[PATCH 2/2]: sas_ata: Don't reset the phy in post_internal_command

2007-02-22 Thread Darrick J. Wong
We don't need to reset the SAS phy in sas_ata_post_internal; all that is necessary is to clear out the task from the SAS HA. Signed-off-by: Darrick J. Wong [EMAIL PROTECTED] --- drivers/scsi/libsas/sas_ata.c |5 - 1 files changed, 0 insertions(+), 5 deletions(-) diff --git

Re: [PATCH 1/2] sas_ata: Rename ata_queued_cmd-lldd_task to driver_data

2007-02-22 Thread Jeff Garzik
Darrick J. Wong wrote: Per Tejun's request, rename the lldd_task field and add comments about it. Signed-off-by: Darrick J. Wong [EMAIL PROTECTED] --- drivers/scsi/libsas/sas_ata.c |8 include/linux/libata.h|4 +++- 2 files changed, 7 insertions(+), 5 deletions(-)

Re: program inquiry is using a deprecated scsi_ioctl , please convert it to SG_IO

2007-02-22 Thread James Bottomley
On Thu, 2007-02-22 at 11:59 +0530, MASTHAN DUDEKULA wrote: Hi JAMES, The following code is SG_IO equivalent of scsi ioctls SCSI_TEST_UNIT_READY unsigned char sense_b[32]; unsigned char turCmbBlk[] = {0x00, 0, 0, 0, 0, 0}; struct sg_io_hdr io_hdr; memset(io_hdr, 0,

Re: program inquiry is using a deprecated scsi_ioctl , please convert it to SG_IO

2007-02-22 Thread Douglas Gilbert
James Bottomley wrote: On Thu, 2007-02-22 at 11:59 +0530, MASTHAN DUDEKULA wrote: Hi JAMES, The following code is SG_IO equivalent of scsi ioctls SCSI_TEST_UNIT_READY unsigned char sense_b[32]; unsigned char turCmbBlk[] = {0x00, 0, 0, 0, 0, 0}; struct sg_io_hdr io_hdr;

aacraid not detecting drives if compiled into kernel

2007-02-22 Thread pcaldes
I'm using the Redhat kernel-2.4.21-47.EL on an IBM x3550 server which has a IBM ServeRAID 8k-l controller. I recompiled kernel to include the aacraid driver in the kernel (not as a module) for use with a bootcd. CONFIG_SCSI=y CONFIG_BLK_DEV_SD=y CONFIG_SCSI_AACRAID=y When the kernel loads, the

Fiber Channel Testing Gear

2007-02-22 Thread Sean Bruno
I'm working on a Target implementation using the target capabilities of the qla23xx series of boards and was looking around for a 'cheap' way to do F/C protocol testing. By 'cheap' I meant less that the price of a full blown F/C analyzer, but if that is what I must do then so be it. Sean -

Re: [Patch 1/2] cciss: fix for 2TB support

2007-02-22 Thread Mike Miller (OS Dev)
On Wed, Feb 21, 2007 at 07:14:27PM -0800, Andrew Morton wrote: + if (total_size == 0x) { I seem to remember having already questioned this. total_size is sector_t, which can be either 32-bit or 64-bit. Are you sure that comparison works as intended in both cases? +

Re: [Patch 1/2] cciss: fix for 2TB support

2007-02-22 Thread Andrew Morton
On Thu, 22 Feb 2007 10:51:23 -0600 Mike Miller (OS Dev) [EMAIL PROTECTED] wrote: On Wed, Feb 21, 2007 at 07:14:27PM -0800, Andrew Morton wrote: On Wed, 21 Feb 2007 15:10:39 -0600 Mike Miller (OS Dev) [EMAIL PROTECTED] wrote: Patch 1/2 + if (total_size == 0x) {

[Patch 2/2] cciss: add shutdown support (replaces reboot notifier)

2007-02-22 Thread Mike Miller (OS Dev)
Patch 2/2 This adds support for struct pci_driver shutdown and negates the previous NAK'ed reboot_notifier patch. It's much easier, wish I had know about this before. Thanks to Christoph for pointing this out. Signed-off-by: Mike Miller [EMAIL PROTECTED]

RE: [Patch 1/2] cciss: fix for 2TB support

2007-02-22 Thread Miller, Mike (OS Dev)
-Original Message- From: Mike Miller (OS Dev) [mailto:[EMAIL PROTECTED] Andrew, Using this test program and changing the type of x to int, long, long long signed and unsigned the comparison always worked on x86, x86_64, and ia64. It looks to me like the comparsion will

Re: [Patch 1/2] cciss: fix for 2TB support

2007-02-22 Thread James Bottomley
On Thu, 2007-02-22 at 13:24 -0800, Andrew Morton wrote: On Thu, 22 Feb 2007 10:51:23 -0600 Mike Miller (OS Dev) [EMAIL PROTECTED] wrote: On Wed, Feb 21, 2007 at 07:14:27PM -0800, Andrew Morton wrote: On Wed, 21 Feb 2007 15:10:39 -0600 Mike Miller (OS Dev) [EMAIL PROTECTED] wrote:

Re: [Patch 2/2] cciss: add shutdown support (replaces reboot notifier)

2007-02-22 Thread James Bottomley
On Thu, 2007-02-22 at 15:38 -0600, Mike Miller (OS Dev) wrote: .remove = __devexit_p(cciss_remove_one), .id_table = cciss_pci_device_id,/* id_table */ + .shutdown = cciss_remove_one, You need a __devexit_p() wrapper for this one too. James - To unsubscribe from

Re: [Patch 2/2] cciss: add shutdown support (replaces reboot notifier)

2007-02-22 Thread Christoph Hellwig
On Thu, Feb 22, 2007 at 03:49:38PM -0600, James Bottomley wrote: On Thu, 2007-02-22 at 15:38 -0600, Mike Miller (OS Dev) wrote: .remove = __devexit_p(cciss_remove_one), .id_table = cciss_pci_device_id,/* id_table */ + .shutdown = cciss_remove_one, You need a

Re: [Patch 2/2] cciss: add shutdown support (replaces reboot notifier)

2007-02-22 Thread Mike Miller (OS Dev)
On Thu, Feb 22, 2007 at 09:45:02PM +, Christoph Hellwig wrote: On Thu, Feb 22, 2007 at 03:38:45PM -0600, Mike Miller (OS Dev) wrote: Patch 2/2 This adds support for struct pci_driver shutdown and negates the previous NAK'ed reboot_notifier patch. It's much easier, wish I had know

Re: [Patch 1/2] cciss: fix for 2TB support

2007-02-22 Thread Mike Miller (OS Dev)
On Thu, Feb 22, 2007 at 03:41:24PM -0600, James Bottomley wrote: On Thu, 2007-02-22 at 13:24 -0800, Andrew Morton wrote: On Thu, 22 Feb 2007 10:51:23 -0600 Mike Miller (OS Dev) [EMAIL PROTECTED] wrote: On Wed, Feb 21, 2007 at 07:14:27PM -0800, Andrew Morton wrote: On Wed, 21 Feb

Re: [Patch 1/2] cciss: fix for 2TB support

2007-02-22 Thread James Bottomley
On Thu, 2007-02-22 at 16:02 -0600, Mike Miller (OS Dev) wrote: Will this patch for my patch work for now? Yes, I think that should be fine ... it's only a theoretical worry; at the moment sector_t is unsigned ... but just in case. James - To unsubscribe from this list: send the line

Re: [Patch 2/2] cciss: add shutdown support (replaces reboot notifier)

2007-02-22 Thread scott . ashcroft
Mike Miller (OS Dev) wrote: + if (return_code = IO_OK) { Shouldn't that be == + printk(KERN_WARNING Completed cache flush on controller %d\n, i); + } else { + printk(KERN_WARNING Error Flushing cache on controller %d\n, i); }

Re: [Patch 2/2] cciss: add shutdown support (replaces reboot notifier)

2007-02-22 Thread Mike Miller (OS Dev)
On Thu, Feb 22, 2007 at 09:55:01PM +, Christoph Hellwig wrote: On Thu, Feb 22, 2007 at 03:49:38PM -0600, James Bottomley wrote: On Thu, 2007-02-22 at 15:38 -0600, Mike Miller (OS Dev) wrote: .remove = __devexit_p(cciss_remove_one), .id_table = cciss_pci_device_id,

Re: [Patch 2/2] cciss: add shutdown support (replaces reboot notifier)

2007-02-22 Thread Greg KH
On Thu, Feb 22, 2007 at 03:56:11PM -0600, Mike Miller (OS Dev) wrote: On Thu, Feb 22, 2007 at 09:45:02PM +, Christoph Hellwig wrote: On Thu, Feb 22, 2007 at 03:38:45PM -0600, Mike Miller (OS Dev) wrote: Patch 2/2 This adds support for struct pci_driver shutdown and negates the