Re: [PATCHv2 0/5] Support 64-bit LUNs

2014-05-29 Thread James Bottomley
On Wed, 2014-05-28 at 03:56 -0700, Christoph Hellwig wrote: James, can you take a look at this series? I would be great to get it merged for 3.16! Remind me how we're planning to fix the conversion bug in scsilun_to_int, it doesn't seem to be in the patch series anymore... I remember there

Re: Make SCSI error handler code easier to understand

2014-05-29 Thread James Bottomley
On Wed, 2014-05-28 at 16:15 -0400, Joe Lawrence wrote: On Mon, 26 May 2014 17:12:27 +0200 Bart Van Assche bvanass...@acm.org wrote: Every now and then someone asks how it is avoided that the SCSI error handler and the SCSI completion handler are invoked concurrently for the same SCSI

[PATCH v2, repost] hpsa: remove unneeded loop

2014-05-29 Thread Tomas Henzl
Originally this was first patch in a series, but while the other patches were accepted, this one was forgotten. The code below is adapted for the latest sources. The cmd_pool_bits is protected everywhere with a spinlock, we don't need the test_and_set_bit, set_bit is enough and the loop can be

Re: [PATCH 6/6] [SCSI] sd: Implement copy offload support

2014-05-29 Thread Douglas Gilbert
On 14-05-28 11:52 PM, Martin K. Petersen wrote: Implement support for hardware copy offload. This initial implementation only supports EXTENDED COPY(LID1). If need be we can add support for LID4 or token copy at a later date. If a device has the 3PC flag set in the standard INQUIRY response

Re: [PATCH v2, repost] hpsa: remove unneeded loop

2014-05-29 Thread scameron
On Thu, May 29, 2014 at 04:02:19PM +0200, Tomas Henzl wrote: Originally this was first patch in a series, but while the other patches were accepted, this one was forgotten. The code below is adapted for the latest sources. The cmd_pool_bits is protected everywhere with a spinlock, we don't

Re: [PATCH 3/4] scsi: increase upper limit for max_sectors

2014-05-29 Thread Akinobu Mita
2014-05-29 1:18 GMT+09:00 Elliott, Robert (Server Storage) elli...@hp.com: -Original Message- From: linux-scsi-ow...@vger.kernel.org [mailto:linux-scsi- ow...@vger.kernel.org] On Behalf Of Akinobu Mita Sent: Sunday, 25 May, 2014 7:44 AM To: linux-scsi@vger.kernel.org Cc: Akinobu

Re: [PATCH v2, repost] hpsa: remove unneeded loop

2014-05-29 Thread Tomas Henzl
On 05/29/2014 04:51 PM, scame...@beardog.cce.hp.com wrote: On Thu, May 29, 2014 at 04:02:19PM +0200, Tomas Henzl wrote: Originally this was first patch in a series, but while the other patches were accepted, this one was forgotten. The code below is adapted for the latest sources. The

[PATCH 2 01/24] hpsa: add new Smart Array PCI IDs (May 2014)

2014-05-29 Thread Stephen M. Cameron
From: Joe Handzik joseph.t.hand...@hp.com Signed-off-by: Scott Teel scott.t...@hp.com Signed-off-by: Joe Handzik joseph.t.hand...@hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Stephen M. Cameron scame...@beardog.cce.hp.com Cc: sta...@vger.kernel.org ---

[PATCH 2 00/24] Resend of May 2014 patches for hpsa driver

2014-05-29 Thread Stephen M. Cameron
Not a lot of extensive changes in this set, some new PCI IDs, some small bug fixes, quieting some noisy messages, allowing more reply queues, setting irq affinity hints, and some minor locking improvments. Two patches are slightly changed since they were first sent due to reviewer comments and

[PATCH 2 02/24] hpsa: fix missing check of kzalloc return value

2014-05-29 Thread Stephen M. Cameron
From: Joe Handzik joseph.t.hand...@hp.com Signed-off-by: Scott Teel scott.t...@hp.com Signed-off-by: Joe Handzik joseph.t.hand...@hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Stephen M. Cameron scame...@beardog.cce.hp.com Cc: sta...@vger.kernel.org ---

[PATCH 2 09/24] hpsa: allocate reply queues individually

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com Now that we can allocate more than 4 reply queues (up to 64) we shouldn't try to make them share the same allocation but should allocate them separately. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Mike Miller

[PATCH 2 08/24] hpsa: choose number of reply queues more intelligently.

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com No sense having 8 or 16 reply queues if you only have 4 cpus, and likewise no sense limiting to 8 reply queues if you have many more cpus. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Mike Miller

[PATCH 2 13/24] hpsa: Rearrange start_io to avoid one unlock/lock sequence in main io path

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Joe Handzik joseph.t.hand...@hp.com --- drivers/scsi/hpsa.c | 24 1 files changed, 16 insertions(+), 8 deletions(-) diff --git

[PATCH 2 06/24] hpsa: use gcc aligned attribute instead of manually padding structs

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Webb Scales webb.sca...@hp.com --- drivers/scsi/hpsa.c |3 --- drivers/scsi/hpsa_cmd.h | 33 ++--- 2 files changed, 6

[PATCH 2 15/24] hpsa: kill annoying messages about SSD Smart Path retries

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com There's nothing the user can or should do about these messages, the commands are retried down the normal RAID path, and the messages just flood the logs and sap performance. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com

[PATCH 2 03/24] hpsa: remove unused fields from struct ctlr_info

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com The fields major, max_outstanding, and usage_count of struct ctlr_info were not used for anything. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Mike Miller michael.mil...@canonical.com Reviewed-by: Webb Scales

[PATCH 2 05/24] hpsa: change doorbell reset delay to ten seconds

2014-05-29 Thread Stephen M. Cameron
From: Justin Lindley justin.lind...@hp.com After 3.22 firmware, PMC firmware guys tell us the previous 5 second delay after a reset now needs to be 10 secs to avoid a PCIe error due to the driver looking at the controller too soon after the reset. Signed-off-by: Justin Lindley

[PATCH 2 10/24] hpsa: set irq affinity hints to route MSI-X vectors across CPUs

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Mike Miller michael.mil...@canonical.com Reviewed-by: Scott Teel scott.t...@hp.com --- drivers/scsi/hpsa.c | 17 - 1 files changed, 16 insertions(+),

[PATCH 2 04/24] hpsa: allow passthru ioctls to work with bidirectional commands

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com Treat the the data direction bits as a bit mask allowing both READ and WRITE at the same time instead of testing for equality to see if it's a exclusively a READ or a WRITE. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com

[PATCH 2 21/24] hpsa: remove messages about volume status VPD inquiry page not supported

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com They are annoying and do not help anyone. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Justin Lindley justin.lind...@hp.com Reviewed-by: Mike Miller michael.mil...@hp.com --- drivers/scsi/hpsa.c | 12

[PATCH 2 19/24] hpsa: fix memory leak in hpsa_hba_mode_enabled

2014-05-29 Thread Stephen M. Cameron
From: Joe Handzik joseph.t.hand...@hp.com And while we're at it fix a magic number Signed-off-by: Joe Handzik joseph.t.hand...@hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Stephen M. Cameron scame...@beardog.cce.hp.com --- drivers/scsi/hpsa.c |7 ++-

[PATCH 2 20/24] hpsa: do not ignore failure of sense controller parameters command

2014-05-29 Thread Stephen M. Cameron
From: Joe Handzik joseph.t.hand...@hp.com Signed-off-by: Joe Handzik joseph.t.hand...@hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Stephen M. Cameron scame...@beardog.cce.hp.com --- drivers/scsi/hpsa.c |8 +--- 1 files changed, 5 insertions(+), 3

[PATCH 2 14/24] hpsa: define extended_report_lun_entry data structure

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Joe Handzik joseph.t.hand...@hp.com --- drivers/scsi/hpsa.c | 21 - drivers/scsi/hpsa_cmd.h | 12 +++- 2 files changed, 19

[PATCH 2 24/24] hpsa: fix handling of hpsa_volume_offline return value

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com Make return value an int instead of an unsigned char so that we do not lose negative error return values. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Webb Scales webb.sca...@hp.com Reported-by: Dan Carpenter

[PATCH 2 18/24] hpsa: report check condition even if no sense data present for ioaccel2 mode

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com It shouldn't happen that we get a check condition with no sense data, but if it does, we shouldn't just drop the check condition on the floor. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Justin Lindley

[PATCH 2 23/24] hpsa: return -ENOMEM not -1 on kzalloc failure in hpsa_get_device_id

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reported-by: Dan Carpenter dan.carpen...@oracle.com Reviewed-by: Mike Miller michael.mil...@canonical.com --- drivers/scsi/hpsa.c |2 +- 1 files changed, 1 insertions(+), 1

[PATCH 2 16/24] hpsa: fix event filtering to prevent excessive rescans with old firmware

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com CTLR_STATE_CHANGE_EVENT and CTLR_STATE_CHANGE_EVENT_REDUNDANT_CNTRL do not require rescans to be initiated. Current firmware filters out these events already, but some out of date firmware doesn't, so the driver needs to filter them out too.

[PATCH 2 22/24] hpsa: fix bad comparison of signed with unsigned in hpsa_update_scsi_devices

2014-05-29 Thread Stephen M. Cameron
From: Joe Handzik joseph.t.hand...@hp.com rescan_hba_mode was defined as a u8 so could never be less than zero: rescan_hba_mode = hpsa_hba_mode_enabled(h); if (rescan_hba_mode 0) goto out; Signed-off-by: Joe Handzik joseph.t.hand...@hp.com Signed-off-by: Stephen

[PATCH 2 12/24] hpsa: avoid unnecessary readl on every command submission

2014-05-29 Thread Stephen M. Cameron
From: Stephen M. Cameron scame...@beardog.cce.hp.com for controllers which support either of the ioaccel transport methods. Signed-off-by: Stephen M. Cameron scame...@beardog.cce.hp.com Reviewed-by: Mike Miller michael.mil...@canonical.com Reviewed-by: Joe Handzik joseph.t.hand...@hp.com ---

block: remove dead code in scsi_ioctl:blk_verify_command

2014-05-29 Thread Dave Jones
filter gets assigned the address of blk_default_cmd_filter on entry to this function, so the !filter condition can never be true. Signed-off-by: Dave Jones da...@redhat.com diff --git a/block/scsi_ioctl.c b/block/scsi_ioctl.c index 26487972ac54..9c28a5b38042 100644 --- a/block/scsi_ioctl.c +++

Re: block: remove dead code in scsi_ioctl:blk_verify_command

2014-05-29 Thread Jens Axboe
On 05/29/2014 01:11 PM, Dave Jones wrote: filter gets assigned the address of blk_default_cmd_filter on entry to this function, so the !filter condition can never be true. Signed-off-by: Dave Jones da...@redhat.com diff --git a/block/scsi_ioctl.c b/block/scsi_ioctl.c index

Re: [PATCH] qla2xxx: Convert to percpu_ida session tag pre-allocation

2014-05-29 Thread Quinn Tran
Nicholas, Answer is below. Regards, Quinn Tran On 5/23/14 7:33 PM, Nicholas A. Bellinger n...@linux-iscsi.org wrote: Hi Qlogic folks, A question for you below.. On Sat, 2014-05-24 at 00:43 +, Nicholas A. Bellinger wrote: From: Nicholas Bellinger n...@linux-iscsi.org This patch

Re: [PATCH] scsi: pm8001: pm8001_hwi.c: Fix for possible null pointer dereference

2014-05-29 Thread Rickard Strandqvist
Hi Quite rightly, this is what cppcheck reacts. Ok, I'll send a patch for that instead then. Best regards Rickard Strandqvist 2014-05-28 13:38 GMT+02:00 Tomas Henzl the...@redhat.com: On 05/28/2014 01:28 PM, Christoph Hellwig wrote: On Sun, May 18, 2014 at 06:14:00PM +0200, Rickard

[PATCH] scsi: pm8001: pm8001_hwi.c: Fix to remove null pointer checks that could never happen

2014-05-29 Thread Rickard Strandqvist
Removal of null pointer checks that could never happen Signed-off-by: Rickard Strandqvist rickard_strandqv...@spectrumdigital.se --- drivers/scsi/pm8001/pm8001_hwi.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/scsi/pm8001/pm8001_hwi.c

Re: [PATCH 6/6] [SCSI] sd: Implement copy offload support

2014-05-29 Thread Martin K. Petersen
Doug == Douglas Gilbert dgilb...@interlog.com writes: Doug, Doug SPC-4 has downgraded the RECEIVE COPY OPERATION PARAMETERS command Doug in favour of the new Third Party Copy (TPC) VPD page [0x8f]. If Doug the latter is present, it should be used. Most real world Doug implementations of

Get back to me

2014-05-29 Thread Kong Hui
I am a bank director from Hong Kong, I want you to be my partner in a business project of mutual benefit. Get back to me if interested. Thank you, Kong Hui. -- To unsubscribe from this list: send the line unsubscribe linux-scsi in the body of a message to majord...@vger.kernel.org More majordomo