[PATCH 1/1] mvsas: add SGPIO support to Marvell 94xx

2015-11-13 Thread Wilfried Weissmann
add SGPIO support to Marvell 94xx Signed-off-by: Wilfried Weissmann --- drivers/scsi/mvsas/mv_94xx.c | 134 + drivers/scsi/mvsas/mv_94xx.h | 71 + drivers/scsi/mvsas/mv_init.c |2 drivers/scsi/mvsas/mv_sas.c |

[GIT PULL] target updates for v4.4-rc1

2015-11-13 Thread Nicholas A. Bellinger
Hello Linus, Apologies for the late PULL request. Please pull from: git://git.kernel.org/pub/scm/linux/kernel/git/nab/target-pending.git for-next This series contains HCH's changes to absorb configfs attribute ->show() + ->store() function pointer usage from it's original tree-wide

[GIT PULL] target updates for v4.4-rc1

2015-11-13 Thread Nicholas A. Bellinger
Hello Linus, Apologies for the late PULL request. Please pull from: git://git.kernel.org/pub/scm/linux/kernel/git/nab/target-pending.git for-next This series contains HCH's changes to absorb configfs attribute ->show() + ->store() function pointer usage from it's original tree-wide

Re: [PATCH] mpt3sas: Fix use sas_is_tlr_enabled API before enabling MPI2_SCSIIO_CONTROL_TLR_ON flag

2015-11-13 Thread Tomas Henzl
On 12.11.2015 19:10, Sreekanth Reddy wrote: > Before enabling MPI2_SCSIIO_CONTROL_TLR_ON flag in MPI SCSI IO > request message, check whether TLR is enabled on the drive using > 'sas_is_tlr_enabled' API. > > Actually in the driver code, driver is using below API's > > 1. sas_enable_tlr() - to

Re: [PATCH 3/9] IB: add a helper to safely drain a QP

2015-11-13 Thread Steve Wise
On 11/13/2015 7:46 AM, Christoph Hellwig wrote: Signed-off-by: Christoph Hellwig --- drivers/infiniband/core/cq.c | 46 include/rdma/ib_verbs.h | 2 ++ 2 files changed, 48 insertions(+) diff --git

Re: [PATCH 1/1] iscsi: fix regression caused by session lock patch

2015-11-13 Thread Mike Christie
On 11/13/2015 09:06 AM, Or Gerlitz wrote: >> The patch has caused multiple regressions, did not even compile when >> > sent to me, and was poorly reviewed and I have not heard from you guys >> > in a week. Given the issues the patch has had and the current time, I do >> > not feel comfortable with

Re: 4.4 SCSI queue status

2015-11-13 Thread Christoph Hellwig
On Wed, Nov 11, 2015 at 10:55:52PM -0500, Martin K. Petersen wrote: > > As some of you may have noticed, I have been volunteered to help with > the SCSI tree going forward. Much like Christoph did for while. My > current tree is here: It would be good to update MAINTAINERS with your address and

Re: [GIT PULL] target updates for v4.4-rc1

2015-11-13 Thread Bart Van Assche
On 11/13/2015 02:00 AM, Nicholas A. Bellinger wrote: Hello Linus, Apologies for the late PULL request. Please pull from: git://git.kernel.org/pub/scm/linux/kernel/git/nab/target-pending.git for-next This series contains HCH's changes to absorb configfs attribute ->show() + ->store()

Re: [PATCH 1/9] move blk_iopoll to limit and make it generally available

2015-11-13 Thread Or Gerlitz
On Fri, Nov 13, 2015 at 3:46 PM, Christoph Hellwig wrote: > The new name is irq_poll as iopoll is already taken. Better suggestions > welcome. Sagi (or Christoph if you can address that), @ some pointer over the last 18 months there was a port done at mellanox for iser to use

Re: [PATCH 1/1] iscsi: fix regression caused by session lock patch

2015-11-13 Thread Or Gerlitz
On Thu, Nov 12, 2015 at 10:58 PM, Mike Christie wrote: > On 11/12/2015 06:03 AM, Sagi Grimberg wrote: >>> The bug is caused by this patch: >>> >>> 659743b02c411075b26601725947b21df0bb29c8 >>> >>> which allowed the task lists to be manipulated under different locks >>> in the

Re: [patch] mvsas: don't allow negative timeouts

2015-11-13 Thread Jinpu Wang
On Fri, Nov 13, 2015 at 3:23 PM, Dan Carpenter wrote: > There is a static checker warning here because "val" is controlled by > the user and we have a upper bound on it but allow negative numbers. > "val" appears to be a timeout in usec so this bug probably means we >

Re: [PATCH 2/9] IB: add a proper completion queue abstraction

2015-11-13 Thread Bart Van Assche
On 11/13/2015 10:25 AM, Jason Gunthorpe wrote: On Fri, Nov 13, 2015 at 02:46:43PM +0100, Christoph Hellwig wrote: This adds an abstraction that allows ULP to simply pass a completion object and completion callback with each submitted WR and let the RDMA core handle the nitty gritty details of

Re: [GIT PULL] target updates for v4.4-rc1

2015-11-13 Thread Linus Torvalds
What the hell is wrong with linux-scsi.org? Your machine: Date: Fri, 13 Nov 2015 02:00:11 -0800 linux-iscsi.org: Received: from [192.168.1.69] ... by linux-iscsi.org (Postfix) with ESMTPSA id 80B6822DA37; Fri, 13 Nov 2015 09:55:48 + (UTC) mx.google.com: Received:

Re: [PATCH 2/9] IB: add a proper completion queue abstraction

2015-11-13 Thread Jason Gunthorpe
On Fri, Nov 13, 2015 at 02:46:43PM +0100, Christoph Hellwig wrote: > This adds an abstraction that allows ULP to simply pass a completion > object and completion callback with each submitted WR and let the RDMA > core handle the nitty gritty details of how to handle completion > interrupts and

Re: [GIT PULL] target updates for v4.4-rc1

2015-11-13 Thread Nicholas A. Bellinger
On Fri, 2015-11-13 at 09:48 -0800, Linus Torvalds wrote: > On Fri, Nov 13, 2015 at 1:59 AM, Nicholas A. Bellinger > wrote: > > > > Please pull from: > > > > git://git.kernel.org/pub/scm/linux/kernel/git/nab/target-pending.git > > for-next > > Ok, not only was this pull

Re: [GIT PULL] target updates for v4.4-rc1

2015-11-13 Thread Linus Torvalds
On Fri, Nov 13, 2015 at 1:59 AM, Nicholas A. Bellinger wrote: > > Please pull from: > > git://git.kernel.org/pub/scm/linux/kernel/git/nab/target-pending.git > for-next Ok, not only was this pull request late, it had a semantic conflict that causes the end result to not

Re: [PATCH 1/9] move blk_iopoll to limit and make it generally available

2015-11-13 Thread Bart Van Assche
On 11/13/2015 05:46 AM, Christoph Hellwig wrote: The new name is irq_poll as iopoll is already taken. Better suggestions welcome. Hello Christoph, Would it be possible to provide more background information about this ? Which other kernel subsystem is using the name iopoll ? I think the

[PATCH 2/3] block/sd: Fix device-imposed transfer length limits

2015-11-13 Thread Martin K. Petersen
Commit 4f258a46346c ("sd: Fix maximum I/O size for BLOCK_PC requests") had the unfortunate side-effect of removing an implicit clamp to BLK_DEF_MAX_SECTORS for REQ_TYPE_FS requests in the block layer code. This caused problems for some SMR drives. Debugging this issue revealed a few problems with

[PATCH 3/3] MAINTAINERS: Add myself as co-maintainer of the SCSI subsystem.

2015-11-13 Thread Martin K. Petersen
Signed-off-by: Martin K. Petersen --- MAINTAINERS | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/MAINTAINERS b/MAINTAINERS index 9de185da5f5b..978df6e36ddf 100644 --- a/MAINTAINERS +++ b/MAINTAINERS @@ -9205,8 +9205,10 @@ F:

[PATCH 1/3] sd: Make discard granularity match logical block size when LBPRZ=1

2015-11-13 Thread Martin K. Petersen
A device may report an OPTIMAL UNMAP GRANULARITY and UNMAP GRANULARITY ALIGNMENT in the Block Limits VPD. These parameters describe the device's internal provisioning allocation units. By default the block layer will round and align any discard requests based on these limits. If a device reports

Re: [GIT PULL] target updates for v4.4-rc1

2015-11-13 Thread Linus Torvalds
On Fri, Nov 13, 2015 at 11:55 AM, Nicholas A. Bellinger wrote: > >> So just to make it really clear to people: if you ignore the reports >> from linux-next, then I will damn well ignore you. Comprende? Fair is >> fair. > > Would you accept an updated PULL request with

Re: [PATCH] mpt3sas: Fix use sas_is_tlr_enabled API before enabling MPI2_SCSIIO_CONTROL_TLR_ON flag

2015-11-13 Thread Martin K. Petersen
> "Sreekanth" == Sreekanth Reddy writes: Sreekanth> Before enabling MPI2_SCSIIO_CONTROL_TLR_ON flag in MPI SCSI Sreekanth> IO request message, check whether TLR is enabled on the drive Sreekanth> using 'sas_is_tlr_enabled' API. Applied. -- Martin K. Petersen

Re: [patch] mvsas: don't allow negative timeouts

2015-11-13 Thread Martin K. Petersen
> "Dan" == Dan Carpenter writes: Dan> There is a static checker warning here because "val" is controlled Dan> by the user and we have a upper bound on it but allow negative Dan> numbers. "val" appears to be a timeout in usec so this bug Dan> probably means we have

Re: [PATCH 2/9] IB: add a proper completion queue abstraction

2015-11-13 Thread Jason Gunthorpe
On Fri, Nov 13, 2015 at 11:57:56AM -0800, Bart Van Assche wrote: > I think this is the conversation you are referring to: "About a shortcoming > of the verbs API" (http://thread.gmane.org/gmane.linux.drivers.rdma/5028). > That conversation occurred five years ago, which means that you have an >

Re: [PATCHv4 1/1] SCSI: hosts: update to use ida_simple for host_no management

2015-11-13 Thread Martin K. Petersen
> "Lee" == Lee Duncan writes: >> Well, I'm a bit worried about the loss of a monotonically increasing >> host number from the debugging perspective. Right now, if you look >> at any log, hostX always refers to one and only one incarnation >> throughout the system lifetime

[GIT PULL] target updates for v4.4-rc1 (-v2)

2015-11-13 Thread Nicholas A. Bellinger
Hi Linus, Here is the (late) target-updates for v4.4-rc1. There is one build failure as reported by linux-next in hwtracing/stm to expect after merging: https://lkml.org/lkml/2015/10/6/1016 That has been fixed-up to use the new configfs attribute API by Alexander (CC'ed) here: [PATCH] stm

Re: [PATCH 00/25] mpt3sas: Mergering mpt2sas & mpt3sas driver code

2015-11-13 Thread Martin K. Petersen
> "Yinghai" == Yinghai Lu writes: Yinghai, Yinghai> error: inlining failed in call to always_inline James already queued the following fix from sfr: 0a5149ba02bd. But thanks for the heads-up! -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from

Re: [patch] hpsa: logical vs bitwise AND typo

2015-11-13 Thread Martin K. Petersen
> "Dan" == Dan Carpenter writes: Dan> HPSA_DIAG_OPTS_DISABLE_RLD_CACHING is a mask and bitwise AND was Dan> intended here instead of logical &&. This bug is essentially Dan> harmless, it means that sometimes we don't print a warning message Dan> which we wanted to

[GIT PULL] final round of SCSI updates for the 4.3+ merge window

2015-11-13 Thread James Bottomley
Sorry for the delay in this patch which was mostly caused by getting the merger of the mpt2/mpt3sas driver, which was seen as an essential item of maintenance work to do before the drivers diverge too much. Unfortunately, this caused a compile failure (detected by linux-next), which then had to be

Re: [PATCH 1/9] move blk_iopoll to limit and make it generally available

2015-11-13 Thread Christoph Hellwig
On Fri, Nov 13, 2015 at 11:19:24AM -0800, Bart Van Assche wrote: > On 11/13/2015 05:46 AM, Christoph Hellwig wrote: >> The new name is irq_poll as iopoll is already taken. Better suggestions >> welcome. > > Hello Christoph, > > Would it be possible to provide more background information about

Re: [PATCH 1/9] move blk_iopoll to limit and make it generally available

2015-11-13 Thread Christoph Hellwig
On Fri, Nov 13, 2015 at 05:23:39PM +0200, Or Gerlitz wrote: > On Fri, Nov 13, 2015 at 3:46 PM, Christoph Hellwig wrote: > > The new name is irq_poll as iopoll is already taken. Better suggestions > > welcome. > > Sagi (or Christoph if you can address that), > > @ some pointer over

Re: [PATCH 3/9] IB: add a helper to safely drain a QP

2015-11-13 Thread Christoph Hellwig
On Fri, Nov 13, 2015 at 10:16:04AM -0600, Steve Wise wrote: > So how can we do this for iwarp? It seems like all that might be needed is > to modify the QP state to idle, retrying until it succeeds: > >If the QP is transitioning to the Error state, or has not yet >finished flushing the

Re: [PATCH 2/9] IB: add a proper completion queue abstraction

2015-11-13 Thread Christoph Hellwig
On Fri, Nov 13, 2015 at 03:06:36PM -0700, Jason Gunthorpe wrote: > Looking at that thread and then at the patch a bit more.. > > +void ib_process_cq_direct(struct ib_cq *cq) > [..] > + __ib_process_cq(cq, INT_MAX); > > INT_MAX is not enough, it needs to loop. > This is missing a

Re: dm-multipath test scripts

2015-11-13 Thread Johannes Thumshirn
On Wed, 2015-10-07 at 05:39 +, Junichi Nomura wrote: > This is a set of scripts for kernel-side dm-multipath testing. > Current > set of scripts are stress testing of extreme situation and its > coverage > is limited. But recently found dm-mpath regressions should be > detectable > with this.

[PATCH 1/9] move blk_iopoll to limit and make it generally available

2015-11-13 Thread Christoph Hellwig
The new name is irq_poll as iopoll is already taken. Better suggestions welcome. Signed-off-by: Christoph Hellwig --- Documentation/kernel-per-CPU-kthreads.txt | 2 +- block/Makefile| 2 +- block/blk-iopoll.c| 224

[PATCH 4/9] srpt: chain RDMA READ/WRITE requests

2015-11-13 Thread Christoph Hellwig
Remove struct rdma_iu and instead allocate the struct ib_rdma_wr array early and fill out directly. This allows us to chain the WRs, and thus archive both less lock contention on the HCA workqueue as well as much simpler error handling. Signed-off-by: Christoph Hellwig ---

[PATCH 7/9] IB/iser: Use a dedicated descriptor for login

2015-11-13 Thread Christoph Hellwig
From: Sagi Grimberg Makes better sense and we'll need it later with CQ abstraction. iser switch login bufs to void Signed-off-by: Sagi Grimberg Signed-off-by: Christoph Hellwig --- drivers/infiniband/ulp/iser/iscsi_iser.h | 30 +--

[patch] mvsas: don't allow negative timeouts

2015-11-13 Thread Dan Carpenter
There is a static checker warning here because "val" is controlled by the user and we have a upper bound on it but allow negative numbers. "val" appears to be a timeout in usec so this bug probably means we have a longer timeout than we should. Let's fix this by changing "val" to unsigned.

[PATCH 5/9] srpt: use the new CQ API

2015-11-13 Thread Christoph Hellwig
Signed-off-by: Christoph Hellwig --- drivers/infiniband/ulp/srpt/ib_srpt.c | 327 +- drivers/infiniband/ulp/srpt/ib_srpt.h | 28 +-- 2 files changed, 88 insertions(+), 267 deletions(-) diff --git a/drivers/infiniband/ulp/srpt/ib_srpt.c

[PATCH 6/9] srp: use the new CQ API

2015-11-13 Thread Christoph Hellwig
This also moves recv completion handling from hardirq context into softirq context. Signed-off-by: Christoph Hellwig --- drivers/infiniband/ulp/srp/ib_srp.c | 198 ++-- drivers/infiniband/ulp/srp/ib_srp.h | 7 +- 2 files changed, 76 insertions(+),

[PATCH 9/9] IB/iser: Convert to CQ abstraction

2015-11-13 Thread Christoph Hellwig
From: Sagi Grimberg Signed-off-by: Sagi Grimberg Signed-off-by: Christoph Hellwig --- drivers/infiniband/ulp/iser/iscsi_iser.h | 68 --- drivers/infiniband/ulp/iser/iser_initiator.c | 142 ++-

[PATCH 8/9] IB/iser: Use helper for container_of

2015-11-13 Thread Christoph Hellwig
From: Sagi Grimberg Nicer this way. Signed-off-by: Sagi Grimberg Signed-off-by: Christoph Hellwig --- drivers/infiniband/ulp/iser/iscsi_iser.h | 6 ++ drivers/infiniband/ulp/iser/iser_initiator.c | 3 +--

[PATCH 2/9] IB: add a proper completion queue abstraction

2015-11-13 Thread Christoph Hellwig
This adds an abstraction that allows ULP to simply pass a completion object and completion callback with each submitted WR and let the RDMA core handle the nitty gritty details of how to handle completion interrupts and poll the CQ. In detail there is a new ib_cqe structure which just contains

add a proper completion queue abstraction

2015-11-13 Thread Christoph Hellwig
This series adds a new RDMA core abstraction that insulated the ULPs from the nitty gritty details of CQ polling. See the individual patches for more details. Note that this series should be applied on top of my "IB: merge struct ib_device_attr into struct ib_device" patch. A git tree is also

[PATCH 3/9] IB: add a helper to safely drain a QP

2015-11-13 Thread Christoph Hellwig
Signed-off-by: Christoph Hellwig --- drivers/infiniband/core/cq.c | 46 include/rdma/ib_verbs.h | 2 ++ 2 files changed, 48 insertions(+) diff --git a/drivers/infiniband/core/cq.c b/drivers/infiniband/core/cq.c index