Re: [PATCH v5 00/32] HiSilicon SAS driver

2015-11-18 Thread Martin K. Petersen
> "John" == John Garry writes: John> thanks, please note that we still have the dependency on John> http://www.spinics.net/lists/arm-kernel/msg452833.html John> Without it the driver can only be built into the kernel, and not John> as a module. I have your driver in

[PATCH v2] lpfc: replaced kmalloc + memset with kzalloc

2015-11-18 Thread Saurabh Sengar
replacing kmalloc and memset by a single call of kzalloc Signed-off-by: Saurabh Sengar --- v2 : I didn't got any response for my initial patch, I am sending it again on top of latest kernel(today's) drivers/scsi/lpfc/lpfc_els.c | 3 +-- 1 file changed, 1 insertion(+),

Re: [PATCH 02/71] ncr5380: Remove redundant static variable initializers

2015-11-18 Thread Hannes Reinecke
On 11/18/2015 09:34 AM, Finn Thain wrote: Signed-off-by: Finn Thain --- drivers/scsi/NCR5380.c |2 +- drivers/scsi/dtc.c |4 ++-- drivers/scsi/g_NCR5380.c |4 ++-- drivers/scsi/pas16.c | 10 +- drivers/scsi/sun3_scsi.c |8

Re: [PATCH 03/71] ncr5380: Eliminate PDEBUG*, TDEBUG* and DTCDEBUG* macros

2015-11-18 Thread Hannes Reinecke
On 11/18/2015 09:34 AM, Finn Thain wrote: Replace {P,T,DTC}DEBUG_INIT with NDEBUG_INIT. Remove dead debugging code, including code that's conditional upon *DEBUG_TRANSFER. Signed-off-by: Finn Thain --- drivers/scsi/dtc.c | 18 ++

Re: [PATCH 01/71] atari_scsi: Fix SCSI host ID setting

2015-11-18 Thread Hannes Reinecke
On 11/18/2015 09:34 AM, Finn Thain wrote: The NVRAM location of this byte is 16, as documented in http://toshyp.atari.org/en/004009.html This was confirmed by Michael Schmitz, by setting the SCSI host ID under EmuTOS and then checking the value in /proc/driver/nvram and /dev/nvram under Linux.

Re: [PATCH 05/71] ncr5380: Remove NCR5380_local_declare and NCR5380_setup macros

2015-11-18 Thread Hannes Reinecke
On 11/18/2015 09:35 AM, Finn Thain wrote: The NCR5380_local_declare and NCR5380_setup macros exist to define and initialize a particular local variable, to provide the address of the chip registers needed for the driver's implementation of its NCR5380_read/write register access macros. In

Re: [PATCH 06/71] ncr5380: Remove NCR5380_instance_name macro

2015-11-18 Thread Hannes Reinecke
On 11/18/2015 09:35 AM, Finn Thain wrote: This macro makes the code cryptic. Remove it. Signed-off-by: Finn Thain --- drivers/scsi/NCR5380.c |2 +- drivers/scsi/g_NCR5380.c |7 --- drivers/scsi/g_NCR5380.h |2 -- 3 files changed, 5

Re: [PATCH 00/71] More fixes, cleanup and modernization for NCR5380 drivers

2015-11-18 Thread Ondrej Zary
On Thursday 19 November 2015, Finn Thain wrote: > On Wed, 18 Nov 2015, Ondrej Zary wrote: > > On Wednesday 18 November 2015, Finn Thain wrote: > > > Like my previous work on the NCR5380 drivers, this patch series has > > > bug fixes, code cleanup and modernization. These drivers suffer from > > >

Re: [PATCH for-next 05/10] iser: Have initiator and target to share protocol structures and definitions

2015-11-18 Thread Or Gerlitz
On 11/16/2015 6:37 PM, Sagi Grimberg wrote: +/** + * struct iser_hello - iSER Hello header + * + * @opcode: opcode (must be set to ISER_HELLO) + * @max_min_ver: maximum and minimum iser versions + * @iser_ird: iSER IRD + * @rsvd: reserved + */ +struct iser_hello { + u8

Re: [PATCH 04/71] ncr5380: Remove more pointless macros

2015-11-18 Thread Hannes Reinecke
On 11/18/2015 09:34 AM, Finn Thain wrote: ASM macro is never defined. rtrc in pas16.c is not used. NCR5380_map_config, do_NCR5380_intr, do_t128_intr and do_pas16_intr are unused. NCR_NOT_SET harms readability. Remove them. Signed-off-by: Finn Thain ---

Re: [PATCH 10/71] atari_NCR5380: Remove RESET_BOOT, CONFIG_ATARI_SCSI_TOSHIBA_DELAY and CONFIG_ATARI_SCSI_RESET_BOOT

2015-11-18 Thread Michael Schmitz
Hi Finn, Am 19.11.2015 um 17:05 schrieb Finn Thain: > w > On Thu, 19 Nov 2015, Michael Schmitz wrote: > >> Hi Finn, >> >> Am 18.11.2015 um 21:35 schrieb Finn Thain: >> >>> The bus reset may raise an interrupt. That would be new behaviour for >>> atari_scsi only when

<    1   2