Re: [PATCH] qla2xxx: setup data needed in ISR before setting up the ISR

2016-07-13 Thread Martin K. Petersen
> "Johannes" == Johannes Thumshirn writes: Johannes> qla2xxx first calls request_irq() and then does the setup of Johannes> the queue entry data needed in the interrupt handlers in when Johannes> using MSI-X. This could lead to a NULL pointer dereference Johannes> when an

Re: [PATCH 1/2] scsi: lpfc: avoid harmless comparison warning

2016-07-13 Thread Martin K. Petersen
> "Arnd" == Arnd Bergmann writes: Arnd> When building with -Wextra, we get a lot of warnings for the lpfc Arnd> driver concerning expressions that are always true, starting with: Arnd> drivers/scsi/lpfc/lpfc_attr.c: In function Arnd> 'lpfc_enable_npiv_init':

Re: [PATCH 1/3] ipr: Add new CCIN for new adapters support

2016-07-13 Thread Martin K. Petersen
> "wenxiong" == wenxiong writes: wenxiong> Add the appropriate definitions and table entries for new wenxiong> adapters support. Applied patch 1+2 to 4.8/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from this list: send

Re: [PATCH trivial] fcoe: use defines from ethtool for 20Gbit and 40Gbit speeds

2016-07-13 Thread Martin K. Petersen
> "Johannes" == Johannes Thumshirn writes: Johannes> Use defines from ethtool for 20Gbit and 40Gbit speeds instead Johannes> of magic numbers. Applied to 4.8/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from this list: send the line

Re: [PATCH] scsi: remove current_cmnd field from struct scsi_device

2016-07-13 Thread Martin K. Petersen
> "Christoph" == Christoph Hellwig writes: Christoph> The field is only used by the 53c700 driver, so move it into Christoph> the driver-private device data instead of having it in the Christoph> common structure. Applied to 4.8/scsi-queue. -- Martin K. Petersen Oracle

Re: [PATCH] megaraid_sas: Do not fire MR_DCMD_PD_LIST_QUERY to controllers which do not support it

2016-07-13 Thread Martin K. Petersen
> "Sumit" == Sumit Saxena writes: Sumit> There was an issue reported by Lucz Geza on Dell Perc 6i. As per Sumit> issue reported, megaraid_sas driver goes into an infinite error Sumit> reporting loop as soon as there is a change in the status of one Sumit> of the

Re: [PATCH] cxl: remove dead Kconfig options

2016-07-13 Thread Martin K. Petersen
> "Andrew" == Andrew Donnellan writes: >> This patch straddles a few subsystems. Did you intend for me to queue >> it through SCSI? Andrew> Sorry for not stating explicitly - I'd like this taken through Andrew> powerpc as the cxlflash change is incidental to

Re: [PATCH 0/6] fcoe: VN2VN target mode fixes

2016-07-13 Thread Martin K. Petersen
> "Hannes" == Hannes Reinecke writes: Hannes> Hi all, When setting up a VN2VN FCoE target there is no real Hannes> need to run fcoeadm, especially if DCB is disabled. So this Hannes> patchset implements a VIP VLAN responder which can be enabled by Hannes> writing to the sysfs

Re: [PATCH] cxl: remove dead Kconfig options

2016-07-13 Thread Andrew Donnellan
On 14/07/16 12:05, Andrew Donnellan wrote: Sorry for not stating explicitly - I'd like this taken through powerpc as the cxlflash change is incidental to the cxl changes. I'll also be submitting a v2 that applies on top of another cxl series that hasn't been merged yet. -- Andrew Donnellan

Re: [PATCH] cxl: remove dead Kconfig options

2016-07-13 Thread Andrew Donnellan
On 14/07/16 12:02, Martin K. Petersen wrote: "Andrew" == Andrew Donnellan writes: Andrew> Remove the CXL_KERNEL_API and CXL_EEH Kconfig options, as they Andrew> were only needed to coordinate the merging of the cxlflash Andrew> driver. Also remove the stub

Re: [PATCH] cxl: remove dead Kconfig options

2016-07-13 Thread Martin K. Petersen
> "Andrew" == Andrew Donnellan writes: Andrew> Remove the CXL_KERNEL_API and CXL_EEH Kconfig options, as they Andrew> were only needed to coordinate the merging of the cxlflash Andrew> driver. Also remove the stub implementation of Andrew>

Re: [PATCH v2] libfc: sanity check cpu number extracted from xid

2016-07-13 Thread Martin K. Petersen
> "Johannes" == Johannes Thumshirn writes: Johannes> @Martin, do you queue the libfc patches as well? Sure. (Sorry about the delay, been on vacation). -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from this list: send the line "unsubscribe

Re: [PATCH v2] libfc: sanity check cpu number extracted from xid

2016-07-13 Thread Martin K. Petersen
> "Chris" == Chris Leech writes: Chris> In the receive path libfc extracts a cpu number from the ox_id in Chris> the fiber channel header and uses that to do a per_cpu_ptr Chris> conversion. If, for some reason, a frame is received with an Chris> invalid ox_id,

Re: [PATCH v3 1/7] lib: string: add functions to case-convert strings

2016-07-13 Thread Markus Mayer
On 13 July 2016 at 15:53, Luis de Bethencourt wrote: > > Hi Markus, > > Thank you very much for the thorough testing and solution searching. > > Earlier today I sent a patch that removes dynamic_debug.h from > include/linux/kernel.h, since it isn't really needed. Sorry

Re: [PATCH v3 0/7] lib: string: add functions to case-convert strings

2016-07-13 Thread Markus Mayer
On Sat, Jul 09, 2016 at 09:11:05PM -0700, Markus Mayer wrote: > On 9 July 2016 at 20:13, Chris Metcalf wrote: > > On 7/8/2016 6:43 PM, Markus Mayer wrote: > >> > >> This series introduces a family of generic string case conversion > >> functions. This kind of functionality

Re: [PATCH v3 1/7] lib: string: add functions to case-convert strings

2016-07-13 Thread Luis de Bethencourt
On 13/07/16 23:26, Markus Mayer wrote: > On 13 July 2016 at 10:19, Luis de Bethencourt wrote: >> On 11/07/16 23:46, Markus Mayer wrote: >> >> Hi Markus, >> >> Amazing. I see this happening as well, but I know it shouldn't. >> >> The reason the #ifndef guards in headers are

Re: [PATCH v3 1/7] lib: string: add functions to case-convert strings

2016-07-13 Thread Markus Mayer
On 13 July 2016 at 10:19, Luis de Bethencourt wrote: > On 11/07/16 23:46, Markus Mayer wrote: > > Hi Markus, > > Amazing. I see this happening as well, but I know it shouldn't. > > The reason the #ifndef guards in headers are there is precisely to allow > circular

Re: [PATCH v3 1/7] lib: string: add functions to case-convert strings

2016-07-13 Thread Luis de Bethencourt
On 11/07/16 23:46, Markus Mayer wrote: > On 9 July 2016 at 08:30, Markus Mayer wrote: >> On 9 July 2016 at 05:04, Luis de Bethencourt wrote: >>> On 08/07/16 23:43, Markus Mayer wrote: Add a collection of generic functions to convert strings

[Bug 129611] New: baba ji ka thullu@@!!!USA AVG support help 18.o..o882o..652 avg antivIRUS TEchnICal SUPPoRT PhoNE NUMbER

2016-07-13 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=129611 Bug ID: 129611 Summary: baba ji ka thullu@@!!!USA AVG support help 18.o..o882o..652 avg antivIRUS TEchnICal SUPPoRT PhoNE NUMbER Product: SCSI Drivers Version:

Re: [RFC 1/3] ata: bump ATA_MAX_SECTORS_LBA48 to 65536

2016-07-13 Thread Tejun Heo
Hello, On Wed, Jul 13, 2016 at 12:47:06PM +0800, tom.t...@gmail.com wrote: > From: Tom Yan > > ATA_MAX_SECTORS_LBA48 is only used for setting the queue limit > "max_hw_sectors", which only serves as the cap for "max_sectors", > which is in turn the actual limit being used.

Re: [RFC 3/3] libata-scsi: add optimal transfer length to block limits VPD

2016-07-13 Thread Tejun Heo
On Wed, Jul 13, 2016 at 12:47:08PM +0800, tom.t...@gmail.com wrote: > From: Tom Yan > > As of commit 6b7e9cde4969 ("sd: Fix rw_max for devices that report > an optimal xfer size"), the scsi disk driver (correctly) derive both > of the queue limits "io_opt" and "max_sectors"

Re: unexpected sync delays in dpkg for small pre-allocated files on ext4

2016-07-13 Thread Gernot Hillier
Dear Ted, On 01.06.2016 16:12, Theodore Ts'o wrote: > On Wed, Jun 01, 2016 at 03:17:14PM +0200, Gernot Hillier wrote: >> I repeated the discussed tests and found comparable results on this machine: >> >> - 3 seconds dpkg install time on ext3 vs. 80 seconds for ext4 >> on same partition for same

Re: [PATCH] scsi: remove the disable_blk_mq host flag

2016-07-13 Thread Bart Van Assche
On 07/13/2016 11:19 AM, Christoph Hellwig wrote: We've had scsi-mq for 2.5 years now, so we can remove the unused flag to disable the code on a per-host basis that was put in for unexpected emergencies during bringup. Reviewed-by: bart.vanass...@sandisk.com -- To unsubscribe from this list: