[PATCH v5 2/2] add support for DWC UFS Host Controller

2016-02-10 Thread Joao Pinto
This patch has the goal to add support for DesignWare UFS Controller specific operations and to add specific platform and pci drivers. Signed-off-by: Joao Pinto --- Changes v4->v5 (Akinobu Mita): - All functions used only locally in ufshcd-dwc are now declared as static -

[PATCH v5 0/2] add support for DWC UFS Controller

2016-02-10 Thread Joao Pinto
The work consisted of: - Fixed typo in ufshcd-pltfrm.c - Tweak ufshcd.c for UFS 2.0 support - Implement ufshcd-dwc which contains all DWC HW specific code - Unipro attributes were added and new registers were added to the driver - Implement a ufs-dwc glue platform driver - Implement a ufs-dwc-pci

[PATCH v5 1/2] fixed typo in ufshcd-pltfrm

2016-02-10 Thread Joao Pinto
Fixed typo in ufshcd-pltfrm. Signed-off-by: Joao Pinto --- Changes v0->v5: - Nothing changed (just to keep up with patch set version). drivers/scsi/ufs/ufshcd-pltfrm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/scsi/ufs/ufshcd-pltfrm.c

Re: [PATCH] Separate target visibility from reaped state information

2016-02-10 Thread James Bottomley
On Wed, 2016-02-10 at 15:05 +0100, Johannes Thumshirn wrote: > On Wed, Feb 03, 2016 at 11:38:16PM +0100, Sebastian Herbszt wrote: > > James Bottomley wrote: > > > On Mon, 2016-02-01 at 19:43 -0800, Bart Van Assche wrote: > > > > On 01/19/16 17:03, James Bottomley wrote: > > > > > On Tue,

Re: [PATCH] Separate target visibility from reaped state information

2016-02-10 Thread Johannes Thumshirn
On Wed, Feb 03, 2016 at 11:38:16PM +0100, Sebastian Herbszt wrote: > James Bottomley wrote: > > On Mon, 2016-02-01 at 19:43 -0800, Bart Van Assche wrote: > > > On 01/19/16 17:03, James Bottomley wrote: > > > > On Tue, 2016-01-19 at 19:30 -0500, Martin K. Petersen wrote: > > > > > > > > > > "Bart"

[PATCH] scsi: fix soft lockup in scsi_remove_target() on module removal

2016-02-10 Thread James Bottomley
This softlockup is currently happening: [ 444.088002] NMI watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [kworker/1:1:29] [ 444.088002] Modules linked in: lpfc(-) qla2x00tgt(O) qla2xxx_scst(O) scst_vdisk(O) scsi_transport_fc libcrc32c scst(O) dlm configfs nfsd lockd grace nfs_acl

Re: [PATCH] be2iscsi: Fix memory leak in beiscsi_alloc_mem()

2016-02-10 Thread Martin K. Petersen
> "Maurizio" == Maurizio Lombardi writes: Jitendra, Please review. > In case of error, the memory allocated for phwi_ctrlr was not freed. > > Signed-off-by: Maurizio Lombardi > --- > drivers/scsi/be2iscsi/be_main.c | 4 +++- > 1 file changed, 3

Re: [PATCH v2] megaraid_sas: add an i/o barrier

2016-02-10 Thread Martin K. Petersen
> "Tomas" == Tomas Henzl writes: Tomas> A barrier should be added to ensure proper ordering of memory Tomas> mapped writes. Tomas> V2: - added the barrier also to megasas_fire_cmd_skinny, as Tomas> suggested by Kashyap Desai Sumit, Kashyap: Please review this patch. --

Re: [PATCH] lpfc: Remove redundant code block in lpfc_scsi_cmd_iocb_cmpl

2016-02-10 Thread Martin K. Petersen
> "Johannes" == Johannes Thumshirn writes: Johannes> This removes a redundant code block that will either be Johannes> executed if the ENABLE_FCP_RING_POLLING flag is set in Johannes> phba->cfg_poll or not. The code is just duplicated in both Johannes> cases, hence we

Re: [PATCH] Separate target visibility from reaped state information

2016-02-10 Thread Johannes Thumshirn
On Wed, Feb 10, 2016 at 07:34:51AM -0800, James Bottomley wrote: > On Wed, 2016-02-10 at 15:05 +0100, Johannes Thumshirn wrote: > > On Wed, Feb 03, 2016 at 11:38:16PM +0100, Sebastian Herbszt wrote: > > > James Bottomley wrote: > > > > On Mon, 2016-02-01 at 19:43 -0800, Bart Van Assche wrote: > >

Re: [mpt3sas driver patches 00/10] mpt3sas driver enhancements and

2016-02-10 Thread Martin K. Petersen
> "Suganath" == Suganath prabu Subaramani > writes: Applied to 4.6/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to

[PATCH v6 0/2] add support for DWC UFS Controller

2016-02-10 Thread Joao Pinto
The work consisted of: - Fixed typo in ufshcd-pltfrm.c - Tweak ufshcd.c for UFS 2.0 support - Implement ufshcd-dwc which contains all DWC HW specific code - Unipro attributes were added and new registers were added to the driver - Implement a ufs-dwc glue platform driver - Implement a ufs-dwc-pci

Re: [PATCH RESEND] bfa: deinline __bfa_trc() and __bfa_trc32()

2016-02-10 Thread Martin K. Petersen
> "Denys" == Denys Vlasenko writes: Denys> __bfa_trc32() is very similar, so it is uninlined too. However, Denys> it appears to be unused, therefore this patch ifdefs it out. Why don't we just drop it? -- Martin K. Petersen Oracle Linux Engineering -- To

[PATCH v6 2/2] add support for DWC UFS Host Controller

2016-02-10 Thread Joao Pinto
This patch has the goal to add support for DesignWare UFS Controller specific operations and to add specific platform and pci drivers. Signed-off-by: Joao Pinto --- Changes v5->v6: - Patch bad format fixed Changes v4->v5 (Akinobu Mita): - All functions used only locally in

[PATCH v6 1/2] fixed typo in ufshcd-pltfrm

2016-02-10 Thread Joao Pinto
Fixed typo in ufshcd-pltfrm. Signed-off-by: Joao Pinto --- Changes v0->v6: - Nothing changed (just to keep up with patch set version). drivers/scsi/ufs/ufshcd-pltfrm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/scsi/ufs/ufshcd-pltfrm.c

Re: [RFC PATCH v2] blk-mq: Introduce per sw queue time-slice

2016-02-10 Thread Markus Trippelsdorf
On 2016.02.10 at 20:34 +0100, Andreas Herrmann wrote: > On Tue, Feb 09, 2016 at 06:41:56PM +0100, Markus Trippelsdorf wrote: > > > Recently Johannes sent a patch to enable scsi-mq per driver, see > > > http://marc.info/?l=linux-scsi=145347009631192=2 > > > > > > Probably that is a good solution

Re: [RFC PATCH v2] blk-mq: Introduce per sw queue time-slice

2016-02-10 Thread Andreas Herrmann
On Tue, Feb 09, 2016 at 06:41:56PM +0100, Markus Trippelsdorf wrote: > On 2016.02.09 at 18:12 +0100, Andreas Herrmann wrote: > > [CC-ing linux-block and linux-scsi and adding some comments] > > > > On Mon, Feb 01, 2016 at 11:43:40PM +0100, Andreas Herrmann wrote: > > > This introduces a new

RE: [PATCH v2] megaraid_sas: add an i/o barrier

2016-02-10 Thread Kashyap Desai
> -Original Message- > From: Martin K. Petersen [mailto:martin.peter...@oracle.com] > Sent: Wednesday, February 10, 2016 10:55 PM > To: Tomas Henzl > Cc: 'linux-scsi@vger.kernel.org'; sumit.sax...@avagotech.com; Desai, > Kashyap; Uday Lingala; sta...@vger.kernel.org > Subject: Re: [PATCH

Re: [PATCH v6 2/2] add support for DWC UFS Host Controller

2016-02-10 Thread Arnd Bergmann
On Wednesday 10 February 2016 16:06:13 Joao Pinto wrote: > This patch has the goal to add support for DesignWare UFS Controller > specific operations and to add specific platform and pci drivers. > > Signed-off-by: Joao Pinto >

Re: [RFC PATCH v2] blk-mq: Introduce per sw queue time-slice

2016-02-10 Thread Andreas Herrmann
On Wed, Feb 10, 2016 at 08:47:15PM +0100, Markus Trippelsdorf wrote: > On 2016.02.10 at 20:34 +0100, Andreas Herrmann wrote: > > On Tue, Feb 09, 2016 at 06:41:56PM +0100, Markus Trippelsdorf wrote: > > > > Recently Johannes sent a patch to enable scsi-mq per driver, see > > > >

[PATCH 2/2] qla2xxx: use TARGET_SCF_USE_CPUID flag to indiate CPU Affinity

2016-02-10 Thread Himanshu Madhani
From: Quinn Tran Signed-off-by: Quinn Tran Reviewed-by: Christoph Hellwig Reviewed-by: Bart Van Assche Fixes: fb3269b ("qla2xxx: Add selective command queuing") Signed-off-by: Himanshu Madhani

[PATCH 0/2] qla2xxx: Fixes for target-pending

2016-02-10 Thread Himanshu Madhani
Hi Nic, Here are the patches that addresses review comments from Bart and Christoph. See email threads http://www.spinics.net/lists/target-devel/msg11418.html http://www.spinics.net/lists/target-devel/msg11419.html Please apply these patches to target-pending. Thanks, Himanshu Quinn Tran

[PATCH 1/2] target/transport: add flag to indicate CPU Affinity is observed

2016-02-10 Thread Himanshu Madhani
From: Quinn Tran Signed-off-by: Quinn Tran Reviewed-by: Christoph Hellwig Reviewed-by: Bart Van Assche Fixes: fb3269b ("qla2xxx: Add selective command queuing") Signed-off-by: Himanshu Madhani

Re: [PATCH 0/2] qla2xxx: Fixes for target-pending

2016-02-10 Thread Nicholas A. Bellinger
On Wed, 2016-02-10 at 18:59 -0500, Himanshu Madhani wrote: > Hi Nic, > > Here are the patches that addresses review comments from Bart > and Christoph. See email threads > > http://www.spinics.net/lists/target-devel/msg11418.html > http://www.spinics.net/lists/target-devel/msg11419.html > >

Business Partnership

2016-02-10 Thread EYADEMA
Hello, I am Mr. LAURENT EYADEMA from Republic of Togo.please read the attached proposal. Thanks in anticipation of your urgent response, LAURENT EYADEMA proposal.docx Description: Binary data

[PATCH RESEND] scsi: sim710: fix build warning

2016-02-10 Thread Sudip Mukherjee
We are getting build warning about: "Section mismatch in reference from the variable sim710_eisa_driver to the function .init.text:sim710_eisa_probe() The variable sim710_eisa_driver references the function __init sim710_eisa_probe()" sim710_eisa_probe() was having __init but that was being

[PATCH] target: Fix incorrect unmap_zeroes_data_store return

2016-02-10 Thread Nicholas A. Bellinger
From: Nicholas Bellinger This patch fixes an incorrect return of zero from the new unmap_zeroes_data_store() configfs store attribute handler introduced in v4.5-rc1, to use the correct 'count' bytes return value. Signed-off-by: Nicholas Bellinger ---

Re: [PATCH-v4 0/5] Fix LUN_RESET active I/O + TMR handling

2016-02-10 Thread Nicholas A. Bellinger
Hi Himanshu & Co, On Tue, 2016-02-09 at 18:03 +, Himanshu Madhani wrote: > Hi Nic, > > > On 2/8/16, 9:25 PM, "Nicholas A. Bellinger" wrote: > > >Hi Himanshu, > > > >On Mon, 2016-02-08 at 23:27 +, Himanshu Madhani wrote: > >> > >> I am testing this series with

[PATCH RESEND] scsi: ppa: use new parport device model

2016-02-10 Thread Sudip Mukherjee
Modify ppa driver to use the new parallel port device model. Signed-off-by: Sudip Mukherjee --- Resending as there was no review or ACK for this change. This has exactly same changes as done in scsi/imm.c which has already been accepted. drivers/scsi/ppa.c | 46

Business Partnership

2016-02-10 Thread EYADEMA
Hello, I am Mr. LAURENT EYADEMA from Republic of Togo.please read the attached proposal. Thanks in anticipation of your urgent response, LAURENT EYADEMA proposal.docx Description: Binary data

Re: [PATCH] lpfc: Remove redundant code block in lpfc_scsi_cmd_iocb_cmpl

2016-02-10 Thread Martin K. Petersen
> "Johannes" == Johannes Thumshirn writes: Johannes> This removes a redundant code block that will either be Johannes> executed if the ENABLE_FCP_RING_POLLING flag is set in Johannes> phba->cfg_poll or not. The code is just duplicated in both Johannes> cases, hence we

Re: [PATCH v2] megaraid_sas: add an i/o barrier

2016-02-10 Thread Martin K. Petersen
> "Tomas" == Tomas Henzl writes: Tomas> A barrier should be added to ensure proper ordering of memory Tomas> mapped writes. Applied to 4.6/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from this list: send the line "unsubscribe

Re: [PATCH 0/7] SCSI bug fixes for 4.6

2016-02-10 Thread Martin K. Petersen
> "Arnd" == Arnd Bergmann writes: Arnd> Here are a bunch of fixes for harmless bugs I found during ARM Arnd> randconfig testing. It would be nice to get them mered in 4.6, but Arnd> there is no need to have them in 4.5 as no incorrect behavior Arnd> results from the current

[PATCH v2 0/7] ibmvscsi code cleanup

2016-02-10 Thread Tyrel Datwyler
Fixed up a couple spots that were out of line with the PAPR in regards to its defined VSCSI protocol. Did away with some magic numbers directly in the code. Fixed a minor endian issue. -- v2 changes: -Renamed CRQ header enums and added enums for INIT formats -Check that crq->valid !=

[PATCH v2 4/7] ibmvscsi: Use of_root to access OF device tree root node

2016-02-10 Thread Tyrel Datwyler
The root node of the OF device tree is exported as of_root. No need to look up the root by path name. Instead just get a reference directly via of_root. Signed-off-by: Tyrel Datwyler Reviewed-by: Johannes Thumshirn ---

[PATCH v2 6/7] ibmvscsi: Add endian conversions to sysfs attribute show functions

2016-02-10 Thread Tyrel Datwyler
The values returned by the show functions for the host os_type, mad_version, and partition_number attributes get their values directly from the madapter_info struct whose associated fields are __be32 typed. Added endian conversion to ensure these values are sane on LE platforms. Signed-off-by:

[PATCH v2 7/7] ibmvscsi: use H_CLOSED instead of magic number

2016-02-10 Thread Tyrel Datwyler
In a couple places the magic value of 2 is used to check the return code of hypercalls. This translates to H_CLOSED. Signed-off-by: Tyrel Datwyler --- drivers/scsi/ibmvscsi/ibmvscsi.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

Re: [PATCH v7 00/14] Big fixes, retries, handle a race condition

2016-02-10 Thread Martin K. Petersen
> "Yaniv" == Yaniv Gardi writes: Yaniv> V7: updated patch 0001 according to a comment also, removed patch Yaniv> 07/15 from V6, so now there are only 14 patches Applied to 4.6/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering -- To unsubscribe from

Re: [Resend PATCH 1/3] scsi:stex.c Support to Pegasus series.

2016-02-10 Thread Martin K. Petersen
> "Charles" == Charles Chiou writes: Charles, Charles> Pegasus is a high performace hardware RAID solution designed to Charles> unleash the raw power of Thunderbolt technology. Please address Oliver's concerns about power management. Also, I was going to merge the

[PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines

2016-02-10 Thread Tyrel Datwyler
Add defines for mad version and mad os_type, and replace the magic numbers in set_adapter_info() accordingly. Signed-off-by: Tyrel Datwyler --- drivers/scsi/ibmvscsi/ibmvscsi.c | 8 drivers/scsi/ibmvscsi/viosrp.h | 3 +++ 2 files changed, 7 insertions(+), 4

[PATCH v2 5/7] ibmvscsi: Remove unsupported host config MAD

2016-02-10 Thread Tyrel Datwyler
A VIOSRP_HOST_CONFIG_TYPE management datagram (MAD) has existed in the code for some time. From what information I've gathered from Brian King this was likely implemented on the host side in a SLES 9 based VIOS, which is no longer supported anywhere. Further, it is not defined in PAPR or supported

[PATCH v2 2/7] ibmvscsi: Add and use enums for valid CRQ header values

2016-02-10 Thread Tyrel Datwyler
The PAPR defines four valid header values for the first byte of a CRQ message. Namely, an unused/empty message (0x00), a valid command/response entry (0x80), a valid initialization entry (0xC0), and a valid transport event (0xFF). Further, initialization responses have two formats namely

[PATCH v2 1/7] ibmvscsi: Correct values for several viosrp_crq_format enums

2016-02-10 Thread Tyrel Datwyler
The enum values for VIOSRP_LINUX_FORMAT and VIOSRP_INLINE_FORMAT are off by one. They are currently defined as 0x06 and 0x07 respetively. These values are defined in PAPR correctly as 0x05 and 0x06. This inconsistency has gone unnoticed as neither enum is currently used. The possible future

Re: [PATCH 00/23] ALUA device handler update, part II

2016-02-10 Thread Martin K. Petersen
> "Bart" == Bart Van Assche writes: Bart, Bart> I will try to free up some time to help with reviewing and testing Bart> this patch series. But before I can do that the v4.5-rc multipath Bart> code needs to be stabilized first. See also Bart>

Business Partnership

2016-02-10 Thread EYADEMA
Hello, I am Mr. LAURENT EYADEMA from Republic of Togo.please read the attached proposal. Thanks in anticipation of your urgent response, LAURENT EYADEMA proposal.docx Description: Binary data