Re: [PATCH 1/1] sd: fix lbprz discard granularity as expected

2016-03-11 Thread Martin K. Petersen
> "Tom" == Tom Yan writes: Tom, Tom> Would min_not_zero() be more proper than max()? That would effectively set discard_granularity to physical_block_size regardless of whether unmap_granularity was provided or not. -- Martin K. Petersen Oracle Linux Engineering

re: [SCSI] bfa: Brocade BFA FC SCSI driver

2016-03-11 Thread Dan Carpenter
Hello Jing Huang, The patch 7725ccfda597: "[SCSI] bfa: Brocade BFA FC SCSI driver" from Sep 23, 2009, leads to the following static checker warning: drivers/scsi/bfa/bfa_fcs_fcpim.c:596 bfa_fcs_itnim_create() error: potentially using uninitialized 'itnim'.

Re: [patch] scsi_dh_alua: uninitialized variable in alua_check_vpd()

2016-03-11 Thread Hannes Reinecke
On 03/11/2016 11:17 AM, Dan Carpenter wrote: > The pg_updated variable is support to be set to zero at the start but > it is uninitialized. > > Fixes: cb0a168cb6b8 ('scsi_dh_alua: update 'access_state' field') > Signed-off-by: Dan Carpenter > > diff --git

[patch] scsi_dh_alua: uninitialized variable in alua_check_vpd()

2016-03-11 Thread Dan Carpenter
The pg_updated variable is support to be set to zero at the start but it is uninitialized. Fixes: cb0a168cb6b8 ('scsi_dh_alua: update 'access_state' field') Signed-off-by: Dan Carpenter diff --git a/drivers/scsi/device_handler/scsi_dh_alua.c

Re: [PATCH v7] scsi: ufs: add ioctl interface for query request

2016-03-11 Thread Hannes Reinecke
On 03/11/2016 02:43 AM, Martin K. Petersen wrote: >> "Arnd" == Arnd Bergmann writes: > > Arnd> Looking through what other drivers do, I've found a couple of > Arnd> patterns now. n particular, most use the SG_IO ioctl to pass down > Arnd> commands from user space into a device

Re: [PATCH 1/1] sd: fix lbprz discard granularity as expected

2016-03-11 Thread Tom Yan
Suppose a device has logical block size of 512 bytes and physical block size of 4096 bytes ("AF 512e"). If it has unmap granularity reported to be 1, then its discard granularity should be 1 * 512 = 512 bytes. However, with max() it is set to 4096 bytes instead. With min_not_zero(), it is

FUND TRANSFER (KEEP AS CONFIDENTIAL)

2016-03-11 Thread johnsoncole564
FUND TRANSFER (KEEP AS CONFIDENTIAL) BANK LETTER..doc Description: MS-Word document

Re: [PATCH 1/1] sd: fix lbprz discard granularity as expected

2016-03-11 Thread Tom Yan
But yeah if it has unmap granularity reported to be, for example, 16, then it will not be correctly set with min_not_zero(). Wait, shouldn't it be: max(sdkp->logical_block_size, sdkp->unmap_granularity * logical_block_size); then? On 12 March 2016 at 13:37, Tom Yan

Re: [patch] scsi_dh_alua: uninitialized variable in alua_check_vpd()

2016-03-11 Thread Dan Carpenter
On Fri, Mar 11, 2016 at 11:50:30AM +0100, Hannes Reinecke wrote: > On 03/11/2016 11:17 AM, Dan Carpenter wrote: > > The pg_updated variable is support to be set to zero at the start but > > it is uninitialized. > > > > Fixes: cb0a168cb6b8 ('scsi_dh_alua: update 'access_state' field') > >

Re: [PATCH 1/1] sd: fix lbprz discard granularity as expected

2016-03-11 Thread Martin K. Petersen
> "Tom" == Tom Yan writes: Tom, Tom> In that case, if the granularity only act as some sort of Tom> "reference" but has no real "binding" to the actual behaviour, why Tom> would the kernel even "make up" the granularity itself according to Tom> the physical block size of

Re: [patch v2] scsi_dh_alua: uninitialized variable in alua_check_vpd()

2016-03-11 Thread Hannes Reinecke
On 03/11/2016 12:19 PM, Dan Carpenter wrote: > The pg_updated variable is support to be set to false at the start but > it is uninitialized. > > Fixes: cb0a168cb6b8 ('scsi_dh_alua: update 'access_state' field') > Signed-off-by: Dan Carpenter > > diff --git

[Bug 114401] New: crash dump aic94xx

2016-03-11 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=114401 Bug ID: 114401 Summary: crash dump aic94xx Product: SCSI Drivers Version: 2.5 Kernel Version: 4.4.3-gentoo #1 SMP Mon Feb 29 16:03:39 MSK 2016 x86_64 Hardware: x86-64

[patch v2] scsi_dh_alua: uninitialized variable in alua_check_vpd()

2016-03-11 Thread Dan Carpenter
The pg_updated variable is support to be set to false at the start but it is uninitialized. Fixes: cb0a168cb6b8 ('scsi_dh_alua: update 'access_state' field') Signed-off-by: Dan Carpenter diff --git a/drivers/scsi/device_handler/scsi_dh_alua.c

[PATCH] scsi: vpd pages are mandatory for SPC-2

2016-03-11 Thread Hannes Reinecke
VPD pages 0x0 and 0x83 are mandatory even for SPC-2, so we should be lowering the restriction to avoid having to whitelist every SPC-2 compliant device. Signed-off-by: Hannes Reinecke --- include/scsi/scsi_device.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff

Re: [RFC 14/34] iscsi-target: export symbols

2016-03-11 Thread Nicholas A. Bellinger
Hi Varun & Co, On Mon, 2016-03-07 at 15:22 -0800, Nicholas A. Bellinger wrote: > So obviously this is going to take longer to sort out, and likely not > end up being v4.6-rc1 material. That is OK, as the end result will be > better code. :) > > That said, it would make sense do the initial

[Bug 111341] Firmware loader

2016-03-11 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=111341 --- Comment #6 from walter59 --- hi, fine bug is resolved in version 4.5_rc7. thanks ticket closed regards -- You are receiving this mail because: You are watching the assignee of the bug. -- To unsubscribe

[PATCH] vmw_pscsi: reuse PAGE_ALIGNED to simplify the code

2016-03-11 Thread Shawn Lin
Aligned check with page size can be replaced with PAGE_ALIGNED to simplify the code. Signed-off-by: Shawn Lin --- drivers/scsi/vmw_pvscsi.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/scsi/vmw_pvscsi.c

Re: [patch v2] scsi_dh_alua: uninitialized variable in alua_check_vpd()

2016-03-11 Thread Manoj Kumar
On 3/11/2016 5:19 AM, Dan Carpenter wrote: The pg_updated variable is support to be set to false at the start but it is uninitialized. Fixes: cb0a168cb6b8 ('scsi_dh_alua: update 'access_state' field') Signed-off-by: Dan Carpenter diff --git

Re: [PATCH 1/1] sd: fix lbprz discard granularity as expected

2016-03-11 Thread Tom Yan
Would min_not_zero() be more proper than max()? On 11 March 2016 at 20:37, Martin K. Petersen wrote: >> "Tom" == Tom Yan writes: > > Tom, > > Tom> In that case, if the granularity only act as some sort of > Tom> "reference" but has no real

[PATCH 05/11] scsi/fcoe: drop the p_target lock earlier if there is no thread online

2016-03-11 Thread Sebastian Andrzej Siewior
If the thread on the target CPU is not online then all skbs are freed. There is no need to hold p_target's lock during that period. Cc: Vasu Dev Cc: "James E.J. Bottomley" Cc: "Martin K. Petersen" Cc: Christoph Hellwig

[PATCH 10/11] scsi: bnx2fc: fix hotplug race in bnx2fc_process_new_cqes()

2016-03-11 Thread Sebastian Andrzej Siewior
The ->iothread is accessed without holding the lock. Take this: CPU A CPU B ------ bnx2fc_process_new_cqes() bnx2fc_percpu_thread_destroy() spin_lock_bh(fp_work_lock); fps->iothread != NULL

[PATCH 08/11] scsi/fcoe: convert to smpboot thread

2016-03-11 Thread Sebastian Andrzej Siewior
The driver creates its own per-CPU threads which are updated based on CPU hotplug events. It is also possible to delegate this task to the smpboot-thread infrastructure and get the same job done while saving a few lines of code. The code checked ->thread to decide if there is an active per-CPU

[PATCH 07/11] scsi/fcoe: drop the crc_eof page early

2016-03-11 Thread Sebastian Andrzej Siewior
On cleanup we free the crc_eof_page after all skbs are freed. There is no reason why it can't be done earlier. We hold a reference to that page and each skb does. Cc: Vasu Dev Cc: "James E.J. Bottomley" Cc: "Martin K. Petersen"

[PATCH 06/11] scsi/fcoe: use skb_queue_splice_tail() intead of manual job

2016-03-11 Thread Sebastian Andrzej Siewior
skb_queue_splice_tail() is able to do the same thing as a loop with __skb_dequeue() and __skb_queue_tail() like we have it now. Cc: Vasu Dev Cc: "James E.J. Bottomley" Cc: "Martin K. Petersen" Cc: Christoph Hellwig

[PATCH 11/11] scsi: bnx2fc: convert to smpboot thread

2016-03-11 Thread Sebastian Andrzej Siewior
The driver creates its own per-CPU threads which are updated based on CPU hotplug events. It is also possible to delegate this task to the smpboot-thread infrastructure and get the same job done while saving a few lines of code. The code checked ->iothread to decide if there is an active per-CPU

[PATCH 01/11] scsi/fcoe: lock online CPUs in fcoe_percpu_clean()

2016-03-11 Thread Sebastian Andrzej Siewior
for_each_possible_cpu() with a cpu_online() + `thread' check possibly does the job. But there is a tiny race: Say CPU5 is reported online but is going down. And after fcoe_percpu_clean() saw that CPU5 is online it decided to enqueue a packet. After dev_alloc_skb() returned a skb that CPU is

[PATCH 00/11] SCSI smpboot thread conversion

2016-03-11 Thread Sebastian Andrzej Siewior
This series converts fcoe, bnx2i and bnx2fc to smpboot thread instead of their own magic. The fcoe driver ended in more patches than I wanted but that way it is easier to find the individual code blocks which were used in the final patch. The overall diffstat: 8 files changed, 253

[PATCH 02/11] scsi/fcoe: remove CONFIG_SMP in fcoe_percpu_thread_destroy()

2016-03-11 Thread Sebastian Andrzej Siewior
There is only a marginal win in code size if the !SMP code is ifdeffed out. The compiler should be able to optimize almost everything out. Remove the ifdeffery for readability sake. Cc: Vasu Dev Cc: "James E.J. Bottomley" Cc: "Martin K. Petersen"

[PATCH 09/11] scsi: bnx2i: convert to smpboot thread

2016-03-11 Thread Sebastian Andrzej Siewior
The driver creates its own per-CPU threads which are updated based on CPU hotplug events. It is also possible to delegate this task to the smpboot-thread infrastructure and get the same job done while saving a few lines of code. The code checked ->iothread to decide if there is an active per-CPU

[PATCH 03/11] scsi/fcoe: drop locking in fcoe_percpu_thread_destroy() if cpu == targ_cpu

2016-03-11 Thread Sebastian Andrzej Siewior
The locking here is not required. At the begin of the function we hold the lock and assign NULL to p->thread. This is used in other places to ensure that nobody adds new items to the list. Also, in the cpu != targ_cpu case we don't hold the lock of p-> as well. This makes is consistent. Cc: Vasu

[PATCH 04/11] scsi/fcoe: rename p0 to p_target in fcoe_percpu_thread_destroy()

2016-03-11 Thread Sebastian Andrzej Siewior
The `p' and `p0' variables have very small names on can get mixed up easily. Thus I rename `p0' to `p_target' so it sounds more like the target pointer than `p0' does. Cc: Vasu Dev Cc: "James E.J. Bottomley" Cc: "Martin K. Petersen"

[PATCH] scsi: disable automatic target scan

2016-03-11 Thread Hannes Reinecke
On larger installations it is useful to disable automatic LUN scanning, and only add the required LUNs via udev rules. This can speed up bootup dramatically. This patch introduces a scan_type 'disabled', which work like 'none', but can be overriden by setting the 'rescan' value from

[PATCH] scsi_transport_sas: add 'scsi_target_id' sysfs attribute

2016-03-11 Thread Hannes Reinecke
There is no way to detect the scsi_target_id for any given SAS remote port, so add a new sysfs attribute 'scsi_target_id'. Signed-off-by: Hannes Reinecke --- drivers/scsi/scsi_sas_internal.h | 2 +- drivers/scsi/scsi_transport_sas.c | 2 ++ 2 files changed, 3 insertions(+), 1

Re: [PATCH v8 00/17] add fixes, device quirks, error recovery,

2016-03-11 Thread Hannes Reinecke
On 03/11/2016 03:36 AM, Martin K. Petersen wrote: >> "Yaniv" == Yaniv Gardi writes: > > Yaniv> V8: fixed cyclic dependency by removing ufs_quirk.c that was > Yaniv> previously added in V7 06/17, and moving its code into ufshcd.c > > Patch 6 is now different yet it

[PATCH] MAINTAINERS: Update the email address of James E.J. Bottomley

2016-03-11 Thread Sebastian Andrzej Siewior
after sending a few patches to the odin.com email address I noticed that it is no longer valid. Signed-off-by: Sebastian Andrzej Siewior --- MAINTAINERS | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/MAINTAINERS b/MAINTAINERS index

Re: [PATCH 01/11] scsi/fcoe: lock online CPUs in fcoe_percpu_clean()

2016-03-11 Thread Christoph Hellwig
On Fri, Mar 11, 2016 at 04:28:53PM +0100, Sebastian Andrzej Siewior wrote: > for_each_possible_cpu() with a cpu_online() + `thread' check possibly does > the job. But there is a tiny race: Say CPU5 is reported online but is > going down. And after fcoe_percpu_clean() saw that CPU5 is online it >

Re: [PATCH 01/11] scsi/fcoe: lock online CPUs in fcoe_percpu_clean()

2016-03-11 Thread Sebastian Andrzej Siewior
On 03/11/2016 05:17 PM, Christoph Hellwig wrote: > On Fri, Mar 11, 2016 at 04:28:53PM +0100, Sebastian Andrzej Siewior wrote: >> for_each_possible_cpu() with a cpu_online() + `thread' check possibly does >> the job. But there is a tiny race: Say CPU5 is reported online but is >> going down. And

Re: [PATCH] scsi_transport_sas: add 'scsi_target_id' sysfs attribute

2016-03-11 Thread Manoj Kumar
On 3/11/2016 9:33 AM, Hannes Reinecke wrote: There is no way to detect the scsi_target_id for any given SAS remote port, so add a new sysfs attribute 'scsi_target_id'. Signed-off-by: Hannes Reinecke --- drivers/scsi/scsi_sas_internal.h | 2 +-