Re: [PATCH] scsi: fix dma_unmap_sg() parameter in some drivers

2018-01-02 Thread John Garry
On 21/12/2017 08:15, chenxiang wrote: For function dma_unmap_sg(), the parameter should be number of elements in the scatterlist prior to the mapping, not after the mapping. So fix this usage in ibmvscsi_tgt/isci/mvsas/pm8001. Hi chenxiang, I think that it may be better to rewrite the

Re: [PATCH] scsi: fix dma_unmap_sg() parameter in some drivers

2018-01-02 Thread chenxiang (M)
在 2018/1/2 18:51, John Garry 写道: On 21/12/2017 08:15, chenxiang wrote: For function dma_unmap_sg(), the parameter should be number of elements in the scatterlist prior to the mapping, not after the mapping. So fix this usage in ibmvscsi_tgt/isci/mvsas/pm8001. Hi chenxiang, I think that it

Re: [PATCH v5 0/7] Enhance libsas hotplug feature

2018-01-02 Thread John Garry
On 08/12/2017 09:42, Jason Yan wrote: Now the libsas hotplug has some issues, Dan Williams report a similar bug here before https://www.mail-archive.com/linux-scsi@vger.kernel.org/msg39187.html Hi Martin, James, At this point we feel that we have a decent solution to the long-standing

Re: [PATCH v1] libsas: remove private hex2bin() implementation

2018-01-02 Thread chenxiang (M)
在 2017/12/20 1:37, Andy Shevchenko 写道: The function sas_parse_addr() could be easily substituted by hex2bin() which is in kernel library code. Cc: Christoph Hellwig Signed-off-by: Andy Shevchenko Tested-by: Xiang Chen

[PATCH 3/3] scsi: libsas: initialize sas_phy status according to response of DISCOVER

2018-01-02 Thread Jason Yan
From: chenxiang The status of SAS PHY is in sas_phy->enabled. There is an issue that the status of a remote SAS PHY may be initialized incorrectly: if disable remote SAS PHY through sysfs interface (such as echo 0 > /sys/class/sas_phy/phy-1:0:0/enable), then reboot

[PATCH 2/3] scsi: libsas: fix error when getting phy events

2018-01-02 Thread Jason Yan
The intend purpose here was to goto out if smp_execute_task() returned error. Obviously something got screwed up. We will never get these link error statistics below: ~:/sys/class/sas_phy/phy-1:0:12 # cat invalid_dword_count 0 ~:/sys/class/sas_phy/phy-1:0:12 # cat running_disparity_error_count 0

[PATCH 0/3] Three small fixes for libsas

2018-01-02 Thread Jason Yan
We've found three small bugs. Please consider including them for 4.15. Jason Yan (2): scsi: libsas: fix memory leak in sas_smp_get_phy_events() scsi: libsas: fix error when getting phy events chenxiang (1): scsi: libsas: initialize sas_phy status according to response of DISCOVER

[PATCH 1/3] scsi: libsas: fix memory leak in sas_smp_get_phy_events()

2018-01-02 Thread Jason Yan
We've got a memory leak with the following producer: while true; do cat /sys/class/sas_phy/phy-1:0:12/invalid_dword_count >/dev/null; done The buffer req is allocated and not freed after we return. Fix it. Signed-off-by: Jason Yan CC: John Garry CC:

Re: [PATCH] scsi: libiscsi: Allow sd_shutdown on bad transport

2018-01-02 Thread Lee Duncan
On 12/07/2017 01:59 PM, Rafael David Tinoco wrote: > If, for any reason, userland shuts down iscsi transport interfaces > before proper logouts - like when logging in to LUNs manually, > without logging out on server shutdown, or when automated scripts > can't umount/logout from logged LUNs -

Re: [PATCH 2/3] scsi: libsas: fix error when getting phy events

2018-01-02 Thread Jason Yan
On 2018/1/2 21:50, John Garry wrote: On 02/01/2018 12:15, Jason Yan wrote: The intend purpose here was to goto out if smp_execute_task() returned error. Obviously something got screwed up. We will never get these link error statistics below: ~:/sys/class/sas_phy/phy-1:0:12 # cat

RE: [PATCH v3 1/9] ufs: sysfs: device descriptor

2018-01-02 Thread Stanislav Nijnikov
> -Original Message- > From: Greg KH [mailto:gre...@linuxfoundation.org] > Sent: Friday, December 29, 2017 11:23 AM > To: Stanislav Nijnikov > Cc: linux-scsi@vger.kernel.org; linux-ker...@vger.kernel.org; Alex Lemberg > > Subject: Re:

Re: [RFC] sg3_utils: sgp_dd: work around on pthread_cancel for android

2018-01-02 Thread Bart Van Assche
On 12/26/17 14:21, Bean Huo (beanhuo) wrote: My changes are below: Configure.ac: +# check for pthread_cancel +AC_SEARCH_LIBS(pthread_cancel, pthread, + [AC_DEFINE(HAVE_PTHREAD_CANCEL, 1, [have pthread_cancel])], [], []) Src/Makefile.am -sgp_dd_LDADD = ../lib/libsgutils2.la @os_libs@

Re: [PATCH 2/9] scsi: qla2xxx: Use zeroing allocator rather than allocator/memset

2018-01-02 Thread Madhani, Himanshu
> On Dec 30, 2017, at 7:28 AM, Himanshu Jha wrote: > > Use dma_zalloc_coherent and vzalloc instead of dma_alloc_coherent and > vmalloc respectively, followed by memset 0. > > Generated-by: scripts/coccinelle/api/alloc/kzalloc-simple.cocci > > Suggested-by: Luis R.

Re: [Cluster-devel] [PATCH 00/12] drop unneeded newline

2018-01-02 Thread Bob Peterson
- Original Message - | Drop newline at the end of a message string when the printing function adds | a newline. Hi Julia, NACK. As much as it's a pain when searching the source code for output strings, this patch set goes against the accepted Linux coding style document. See:

Re: [Cluster-devel] [PATCH 00/12] drop unneeded newline

2018-01-02 Thread Bob Peterson
- Original Message - | - Original Message - | | Drop newline at the end of a message string when the printing function adds | | a newline. | | Hi Julia, | | NACK. | | As much as it's a pain when searching the source code for output strings, | this patch set goes against the

Re: [Cluster-devel] [PATCH 00/12] drop unneeded newline

2018-01-02 Thread Julia Lawall
On Tue, 2 Jan 2018, Bob Peterson wrote: > - Original Message - > | Drop newline at the end of a message string when the printing function adds > | a newline. > > Hi Julia, > > NACK. > > As much as it's a pain when searching the source code for output strings, > this patch set goes

Re: [PATCH v3 1/9] ufs: sysfs: device descriptor

2018-01-02 Thread Bart Van Assche
On Tue, 2018-01-02 at 13:54 +, Stanislav Nijnikov wrote: > The existing configuration doesn't allow to add a new file to be compiled > as a part of this module. The line like " obj-$(CONFIG_SCSI_UFSHCD) += > ufshcd.o ufs-sysfs.o" in the makefile will actually create 2 modules. > This was the

RE: [PATCH v3 1/9] ufs: sysfs: device descriptor

2018-01-02 Thread Stanislav Nijnikov
> -Original Message- > From: Jaegeuk Kim [mailto:jaeg...@kernel.org] > Sent: Thursday, December 28, 2017 9:37 PM > To: Stanislav Nijnikov > Cc: linux-scsi@vger.kernel.org; linux-ker...@vger.kernel.org; > gre...@linuxfoundation.org; Alex Lemberg

Re: [Cluster-devel] [PATCH 00/12] drop unneeded newline

2018-01-02 Thread Julia Lawall
On Tue, 2 Jan 2018, Bob Peterson wrote: > - Original Message - > | - Original Message - > | | Drop newline at the end of a message string when the printing function > adds > | | a newline. > | > | Hi Julia, > | > | NACK. > | > | As much as it's a pain when searching the source

Re: [Cluster-devel] [PATCH 00/12] drop unneeded newline

2018-01-02 Thread Julia Lawall
On Tue, 2 Jan 2018, Bart Van Assche wrote: > On Tue, 2018-01-02 at 15:00 +0100, Julia Lawall wrote: > > On Tue, 2 Jan 2018, Bob Peterson wrote: > > > - Original Message - > > > > - Original Message - > > > > > > > Still, the GFS2 and DLM code has a plethora of broken-up printk

Re: [PATCH v3 1/9] ufs: sysfs: device descriptor

2018-01-02 Thread Greg KH
On Tue, Jan 02, 2018 at 02:04:39PM +, Stanislav Nijnikov wrote: > > > > -Original Message- > > From: Greg KH [mailto:gre...@linuxfoundation.org] > > Sent: Friday, December 29, 2017 11:23 AM > > To: Stanislav Nijnikov > > Cc: linux-scsi@vger.kernel.org;

Re: [Cluster-devel] [PATCH 00/12] drop unneeded newline

2018-01-02 Thread Bart Van Assche
On Tue, 2018-01-02 at 15:00 +0100, Julia Lawall wrote: > On Tue, 2 Jan 2018, Bob Peterson wrote: > > - Original Message - > > > - Original Message - > > > > > Still, the GFS2 and DLM code has a plethora of broken-up printk messages, > > and I don't like the thought of re-combining

[PATCH v17 0/4] Replace PCI pool by DMA pool API

2018-01-02 Thread Romain Perier
by the dma pool API and remove the defines. Changes in v17: - Rebased series onto next-20180102 - Added Acked-by tags by David S. Miller on patches 02/04 and 03/04 Changes in v16: - Rebased series onto next-20171215 - I have fixed patch 04/04, so it can be applied - Added Acked-by for Bjorn

[PATCH v17 4/4] PCI: Remove PCI pool macro functions

2018-01-02 Thread Romain Perier
From: Romain Perier Now that all the drivers use dma pool API, we can remove the macro functions for PCI pool. Signed-off-by: Romain Perier Reviewed-by: Peter Senna Tschudin Acked-by: Bjorn Helgaas

[PATCH v17 3/4] hinic: Replace PCI pool old API

2018-01-02 Thread Romain Perier
From: Romain Perier The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: David S. Miller ---

RE: [PATCH v4 net-next 0/4] qed*: Advance to FW 8.33.1.0

2018-01-02 Thread Elior, Ariel
> From: Tomer Tayar > Date: Wed, 27 Dec 2017 19:30:04 +0200 > > > This series advances all qed* drivers to use firmware 8.33.1.0 which brings > > new capabilities and initial support of new HW. The changes are mostly in > > qed, and include changes in the FW interface

Re: [PATCH v3 1/9] ufs: sysfs: device descriptor

2018-01-02 Thread Jaegeuk Kim
On 01/02, Stanislav Nijnikov wrote: > > > > -Original Message- > > From: Jaegeuk Kim [mailto:jaeg...@kernel.org] > > Sent: Thursday, December 28, 2017 9:37 PM > > To: Stanislav Nijnikov > > Cc: linux-scsi@vger.kernel.org; linux-ker...@vger.kernel.org; > >

Re: [PATCH v4 net-next 0/4] qed*: Advance to FW 8.33.1.0

2018-01-02 Thread David Miller
From: Tomer Tayar Date: Wed, 27 Dec 2017 19:30:04 +0200 > This series advances all qed* drivers to use firmware 8.33.1.0 which brings > new capabilities and initial support of new HW. The changes are mostly in > qed, and include changes in the FW interface files, as well

Re: [PATCH 7/9] scsi: bnx2fc: Use zeroing allocator rather than allocator/memset

2018-01-02 Thread Chad Dupuis
On Sat, 30 Dec 2017, 10:28am, Himanshu Jha wrote: > Use dma_zalloc_coherent instead of dma_alloc_coherent followed by > memset 0. > > Generated-by: scripts/coccinelle/api/alloc/kzalloc-simple.cocci > > Suggested-by: Luis R. Rodriguez > Signed-off-by: Himanshu Jha

[PATCH v17 1/4] block: DAC960: Replace PCI pool old API

2018-01-02 Thread Romain Perier
From: Romain Perier The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin

[PATCH v17 2/4] net: e100: Replace PCI pool old API

2018-01-02 Thread Romain Perier
From: Romain Perier The PCI pool API is deprecated. This commit replaces the PCI pool old API by the appropriate function with the DMA pool API. Signed-off-by: Romain Perier Acked-by: Peter Senna Tschudin

[PATCH for sg3_utils 4/4] configure.ac, Makefile.am: Use CFLAGS and LIBS instead of os_cflags and os_libs

2018-01-02 Thread Bart Van Assche
Instead of introducing variables for system-specific flags and libraries, use CFLAGS and LIBS. This simplifies the Makefiles since automake appends these automatically. Signed-off-by: Bart Van Assche --- Makefile.in | 2 - configure | 36

[PATCH for sg3_utils 2/4] configure.ac: Only link with the pthread library if required

2018-01-02 Thread Bart Van Assche
Let the configure script detect whether pthread functions occur in the pthread library (all platforms except Android) or in the C library (Android). From the autoconf manual: action-if-found is a list of shell commands to run if the link with the library succeeds; action-if-not-found is a

[PATCH for sg3_utils 0/4] Simplify the sg3_utils configure script

2018-01-02 Thread Bart Van Assche
Hello Doug, The four patches in this series is what I came up with after having reviewed the sg3_utils configure script. Please consider to apply these patches on the sg3_utils trunk. Thanks, Bart. Bart Van Assche (4): configure.ac: Suppress an autoconf warning configure.ac: Only link with

[PATCH for sg3_utils 3/4] configure.ac: Avoid code duplication

2018-01-02 Thread Bart Van Assche
Ensure that the code for checking the Linux NVMe headers occurs once. Signed-off-by: Bart Van Assche --- config.h.in | 2 +- configure| 124 --- configure.ac | 45 ++ 3 files changed, 21

[PATCH for sg3_utils 1/4] configure.ac: Suppress an autoconf warning

2018-01-02 Thread Bart Van Assche
Avoid that autoconf reports the following warning: configure.ac:15: warning: LT_INIT was called before AM_PROG_AR Signed-off-by: Bart Van Assche --- configure| 352 +-- configure.ac | 6 +- 2 files changed,

Re: [PATCH] scsi: smartpqi: allow static build ("built-in")

2018-01-02 Thread Steffen Weber
If CONFIG_SCSI_SMARTPQI=y then don't build this driver as a module. Signed-off-by: Steffen Weber --- drivers/scsi/smartpqi/Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/scsi/smartpqi/Makefile b/drivers/scsi/smartpqi/Makefile index

Re: [PATCH v17 0/4] Replace PCI pool by DMA pool API

2018-01-02 Thread Bjorn Helgaas
On Tue, Jan 02, 2018 at 06:53:52PM +0100, Romain Perier wrote: > The current PCI pool API are simple macro functions direct expanded to > the appropriate dma pool functions. The prototypes are almost the same > and semantically, they are very similar. I propose to use the DMA pool > API directly