Re: [PATCH v2 78/71] ncr5380: Add support for HP 53C400A-based cards (C2502)

2015-12-08 Thread Finn Thain
On Tue, 8 Dec 2015, Ondrej Zary wrote: > HP C2502 cards (based on 53C400A chips) use different magic numbers for > software-based I/O address configuration than other cards. The > configuration is also extended to allow setting the IRQ. > > Move the configuration to a new function

[PATCH RFC 2/2] scsi_proc: Change /proc/scsi/scsi to use bus device iterator

2015-12-08 Thread Ewan D. Milne
From: "Ewan D. Milne" This prevents crashing due to accessing a removed element on the list, the iterator will now hold the correct reference. It was not sufficient to rely on the klist's reference on the containing device object. >From a patch originally developed by David

[PATCH RFC 1/2] drivers/base: add bus_device_iter_init, bus_device_iter_next, bus_device_iter_exit

2015-12-08 Thread Ewan D. Milne
From: "Ewan D. Milne" These functions are needed to expose an iterator for SCSI usage. >From a patch originally developed by David Jeffery Signed-off-by: Ewan D. Milne --- drivers/base/bus.c | 59

[PATCH RFC 0/2] avoid crashing when reading /proc/scsi/scsi and simultaneously removing devices

2015-12-08 Thread Ewan D. Milne
From: "Ewan D. Milne" The klist traversal used by the reading of /proc/scsi/scsi is not interlocked against device removal. It takes a reference on the containing object, but this does not prevent the device from being removed from the list. Thus, we get errors and

[PATCH] [SCSI] osd: fix signed char versus %02x issue

2015-12-08 Thread Rasmus Villemoes
If char is signed and one of these bytes happen to have a value outside the ascii range, the corresponding output will consist of "ff" followed by the two hex chars that were actually intended. One way to fix it would be to change the casts to (u8*) aka (unsigned char*), but it is much simpler

Re: [PATCH 00/20] ALUA device handler update, part II

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 08:37 AM, Hannes Reinecke wrote: Hi all, as promised here is now the second part of my ALUA device handler update. This contains a major rework of the ALUA device handler as execution is moved onto a workqueue. This has the advantage that we avoid having to do multiple calls to

Re: [PATCH 02/20] qla2xxx: Enable Exchange offload support.

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > Signed-off-by: Himanshu Madhani > Signed-off-by: Giridhar Malavali > --- Same here. Please add a patch description. Cheers, Hannes -- Dr. Hannes Reinecke zSeries &

Re: [PATCH 01/20] qla2xxx: Enable Extended Login support

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > Signed-off-by: Himanshu Madhani > Signed-off-by: Giridhar Malavali > --- A patch description would be nice; ATM it doesn't look as if this interface is used anywhere... Cheers, Hannes

[PATCH] ses: Fix problems with simple enclosures

2015-12-08 Thread James Bottomley
Simple enclosure implementations (mostly USB) are allowed to return only page 8 to every diagnostic query. That really confuses our implementation because we assume the return is the page we asked for and end up doing incorrect offsets based on bogus information leading to accesses outside of

Re: [PATCH 07/20] qla2xxx: Wait for all conflicts before ack'ing PLOGI

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > From: Alexei Potashnik > > Until now ack'ing of a new PLOGI has only been delayed if there > was an existing session for the same WWN. Ack was released when > the session deletion completed. > > If there was another WWN

Re: [PATCH 04/20] qla2xxx: Add FW resource count in DebugFS.

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > From: Quinn Tran > > DebugFS now will show fw_resource_count node. > > FW Resource count > > Original TGT exchg count[0] > current TGT exchg count[0] > original Initiator Exchange count[2048] > Current Initiator Exchange

Re: [PATCH 05/20] qla2xxx: Added interface to send ELS commands from driver.

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > Signed-off-by: Himanshu Madhani > Signed-off-by: Giridhar Malavali > --- > drivers/scsi/qla2xxx/qla_attr.c | 36 +++ > drivers/scsi/qla2xxx/qla_dbg.c|5 +- >

Re: [PATCH 03/20] qla2xxx: Enable Target counters in DebugFS.

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > Following counters are added in target mode to help debugging efforts. > > Target Counters > > qla_core_sbt_cmd = 0 > qla_core_ret_sta_ctio = 0 > qla_core_ret_ctio = 0 > core_qla_que_buf = 0 > core_qla_snd_status = 0 > core_qla_free_cmd = 0 > num

Re: [PATCH 06/20] qla2xxx: Delete session if initiator is gone from FW

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > From: Alexei Potashnik > > 1. Initiator A is logged in with fc_id(1)/loop_id(1) > 2. Initiator A re-logs in with fc_id(2)/loop_id(2) > 3. Part of old session deletion async logoout for 1/1 is queued > 4. Initiator B logs

Re: [PATCH 08/20] qla2xxx: Replace QLA_TGT_STATE_ABORTED with a bit.

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > From: Quinn Tran > > Replace QLA_TGT_STATE_ABORTED state with a bit because > the current state of the command is lost when an abort > is requested by upper layer. > > Signed-off-by: Quinn Tran >

Re: [Bug 108771] scsi: ses: kasan: ses_enclosure_data_process use after free on boot SAS2X28

2015-12-08 Thread James Bottomley
On Mon, 2015-12-07 at 14:01 +, bugzilla-dae...@bugzilla.kernel.org wrote: > https://bugzilla.kernel.org/show_bug.cgi?id=108771 > > --- Comment #1 from Pavel Tikhomirov --- > Aditional info about enclosue(from that node, but older 3.10 based kernel): > > [root@p9

Re: [PATCH] ses: Fix problems with simple enclosures

2015-12-08 Thread Ewan Milne
On Tue, 2015-12-08 at 09:00 -0800, James Bottomley wrote: > Simple enclosure implementations (mostly USB) are allowed to return only > page 8 to every diagnostic query. That really confuses our > implementation because we assume the return is the page we asked for and > end up doing incorrect

[PATCH v4 1/3] badblocks: Add core badblock management code

2015-12-08 Thread Vishal Verma
Take the core badblocks implementation from md, and make it generally available. This follows the same style as kernel implementations of linked lists, rb-trees etc, where you can have a structure that can be embedded anywhere, and accessor functions to manipulate the data. The only changes in

Re: [PATCH 01/20] qla2xxx: Enable Extended Login support

2015-12-08 Thread Himanshu Madhani
On 12/8/15, 7:51 AM, "Hannes Reinecke" wrote: >On 12/08/2015 01:48 AM, Himanshu Madhani wrote: >> Signed-off-by: Himanshu Madhani >> Signed-off-by: Giridhar Malavali >> --- >A patch description would be nice; ATM it

[PATCH v4 3/3] md: convert to use the generic badblocks code

2015-12-08 Thread Vishal Verma
Retain badblocks as part of rdev, but use the accessor functions from include/linux/badblocks for all manipulation. Signed-off-by: Vishal Verma --- drivers/md/md.c | 516 +++- drivers/md/md.h | 40 + 2 files

[PATCH v4 2/3] block: Add badblock management for gendisks

2015-12-08 Thread Vishal Verma
NVDIMM devices, which can behave more like DRAM rather than block devices, may develop bad cache lines, or 'poison'. A block device exposed by the pmem driver can then consume poison via a read (or write), and cause a machine check. On platforms without machine check recovery features, this would

[PATCH v4 0/3] Badblock tracking for gendisks

2015-12-08 Thread Vishal Verma
v4: - Rebase to v4.4-rc4 v3: - Add kernel-doc style comments to all exported functions in badblocks.c (James) - Make return values from badblocks functions consistent with themselves and the kernel style. Change the polarity of badblocks_set, and update all callers accordingly

Re: [PATCH v2 1/3] badblocks: Add core badblock management code

2015-12-08 Thread Verma, Vishal L
On Wed, 2015-12-09 at 08:03 +1100, NeilBrown wrote: > On Sat, Dec 05 2015, Verma, Vishal L wrote: > > > > > > > +int badblocks_clear(struct badblocks *bb, sector_t s, int > > > > sectors) > > > > +{ > > > [...] > > > > +#define DO_DEBUG 1 > > > > > > Why have this at all if it's unconditionally

Re: [PATCH v4 0/3] Badblock tracking for gendisks

2015-12-08 Thread NeilBrown
On Wed, Dec 09 2015, Vishal Verma wrote: > > Patch 3 converts md over to use the new badblocks 'library'. I have > done some pretty simple testing on this - created a raid 1 device, > made sure the sysfs entries show up, and can be used to add and view > badblocks. A

Re: [PATCH v2 1/3] badblocks: Add core badblock management code

2015-12-08 Thread NeilBrown
On Sat, Dec 05 2015, Verma, Vishal L wrote: >> >> > +int badblocks_clear(struct badblocks *bb, sector_t s, int sectors) >> > +{ >> [...] >> > +#define DO_DEBUG 1 >> >> Why have this at all if it's unconditionally defined and always set. > > Neil - any reason or anything you had in mind for this?

RE: [PATCH v2] storvsc: add logging for error/warning messages

2015-12-08 Thread KY Srinivasan
> -Original Message- > From: Long Li [mailto:lon...@microsoft.com] > Sent: Friday, December 4, 2015 12:07 AM > To: KY Srinivasan ; Haiyang Zhang > ; James E.J. Bottomley > Cc: de...@linuxdriverproject.org;

Re: [PATCH v2 1/3] badblocks: Add core badblock management code

2015-12-08 Thread Verma, Vishal L
On Tue, 2015-12-08 at 13:18 -0800, Dan Williams wrote: > On Tue, Dec 8, 2015 at 1:08 PM, Verma, Vishal L > wrote: > > On Wed, 2015-12-09 at 08:03 +1100, NeilBrown wrote: > > > On Sat, Dec 05 2015, Verma, Vishal L wrote: > > > > > > > > > > > +int badblocks_clear(struct

Re: [PATCH 10/20] qla2xxx: Fix interaction issue between qla2xxx and Target Core Module

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > From: Quinn Tran > > During lun reset, TMR thread from TCM would issue abort > to qla driver. At abort time, each command is in different > state. Depending on the state, qla will use the TMR thread > to trigger a command

Update

2015-12-08 Thread robert
Good day, hoping you read this email and respond to me in good time.I do not intend to solicit for funds but your time and energy in using my own resources to assist the less privileged becauseI am medically ill and confined at the moment hence I request your indulgence.I will give you a

Re: [PATCH 09/20] qla2xxx: Change check_stop_free to always return 1

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > From: Quinn Tran > > change tcm_qla2xxx_check_stop_free to always return 1 > to prevent transport_cmd_finish_abort from accidently > taking extra kref_put. > > Signed-off-by: Quinn Tran >

Re: [PATCH 12/20] target/tmr: LUN reset cause cmd premature free.

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > From: Quinn Tran > > During LUN/Target reset, the TMR code attempt to intercept > cmds and try to aborted them. Current code assume cmds are > always intercepted at the back end device. The cleanup code > would issue a

Re: [PATCH 11/20] qla2xxx: Add TAS detection for kernel 3.15 n newer

2015-12-08 Thread Hannes Reinecke
On 12/08/2015 01:48 AM, Himanshu Madhani wrote: > From: Quinn Tran > > For kernel 3.15 and newer with TCM API change, add detection > for TCM support of TAS. Instead of default command terminate > for LUN/TARGET reset error handling, allow SCSI status to go > out if we

Re: [PATCH] [SCSI] osd: fix signed char versus %02x issue

2015-12-08 Thread Boaz Harrosh
On 12/08/2015 04:25 PM, Rasmus Villemoes wrote: > If char is signed and one of these bytes happen to have a value > outside the ascii range, the corresponding output will consist of > "ff" followed by the two hex chars that were actually > intended. One way to fix it would be to change the

Re: [PATCH v2 1/3] badblocks: Add core badblock management code

2015-12-08 Thread Dan Williams
On Tue, Dec 8, 2015 at 1:08 PM, Verma, Vishal L wrote: > On Wed, 2015-12-09 at 08:03 +1100, NeilBrown wrote: >> On Sat, Dec 05 2015, Verma, Vishal L wrote: >> > > >> > > > +int badblocks_clear(struct badblocks *bb, sector_t s, int >> > > > sectors) >> > > > +{ >> > >

Re: [PATCH v4 0/3] Badblock tracking for gendisks

2015-12-08 Thread Finn Thain
On Wed, 9 Dec 2015, NeilBrown wrote: > On Wed, Dec 09 2015, Vishal Verma wrote: > > > > > Patch 3 converts md over to use the new badblocks 'library'. I have > > done some pretty simple testing on this - created a raid 1 device, > > made sure the sysfs entries show