Re: [PATCH] esas2r: Fix array overrun

2016-02-15 Thread Johannes Thumshirn
On Mon, Feb 15, 2016 at 07:01:29PM +, Alan wrote: > Check the array size *before* dereferencing it with a user provided offset > > Signed-off-by: Alan Cox > --- > drivers/scsi/esas2r/esas2r_ioctl.c |5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) > >

Re: [PATCH] lpfc: fix missing zero termination in debugfs

2016-02-15 Thread Johannes Thumshirn
On Mon, Feb 15, 2016 at 07:11:56PM +, Alan wrote: > If you feed 32 bytes in then the kstrtoull() doesn't receive a terminated > string so will run off the end. > > Signed-off-by: Alan Cox > --- > drivers/scsi/lpfc/lpfc_debugfs.c |4 ++-- > 1 file changed, 2

Re: [PATCH] aic7xxx: Fix queue depth handling

2016-02-15 Thread Hannes Reinecke
On 02/15/2016 07:53 PM, Alan wrote: > We were setting the queue depth correctly, then setting it back to two. If > you hit this as a bisection point then please send me an email as it would > imply we've been hiding other bugs with this one. > > Signed-off-by: Alan Cox >

[PATCH] fusion-mptbase: handle failed allocation for workqueue

2016-02-15 Thread Insu Yun
the failure of ioc->reset_work_q is checked, but not ioc->fw_event_q. Signed-off-by: Insu Yun --- drivers/message/fusion/mptbase.c | 7 +++ 1 file changed, 7 insertions(+) diff --git a/drivers/message/fusion/mptbase.c b/drivers/message/fusion/mptbase.c index

[Bug 111341] Firmware loader

2016-02-15 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=111341 --- Comment #4 from walter59 --- sorry --- bug is always on -- only on the one board with c600 intel it works, five other boards doesnt . all asus boards x79 / 2011 Intel. in next days me look for differenz

[Bug 111341] Firmware loader

2016-02-15 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=111341 --- Comment #3 from walter59 --- fine --- changes in kernel 4.5-rc4 ahci for c600 intel id 1d02 now ok ! thanks to all ! -- You are receiving this mail because: You are watching the assignee of the bug. --

[PATCH] lpfc: fix missing zero termination in debugfs

2016-02-15 Thread Alan
If you feed 32 bytes in then the kstrtoull() doesn't receive a terminated string so will run off the end. Signed-off-by: Alan Cox --- drivers/scsi/lpfc/lpfc_debugfs.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

Re: [PATCH-v4 0/5] Fix LUN_RESET active I/O + TMR handling

2016-02-15 Thread Himanshu Madhani
Hi Nic, On 2/12/16, 11:03 PM, "Nicholas A. Bellinger" wrote: >Hi Himanshu & Co, > >On Fri, 2016-02-12 at 00:48 -0800, Nicholas A. Bellinger wrote: >> On Fri, 2016-02-12 at 05:30 +, Himanshu Madhani wrote: > > > >> Thanks for the crash dump output. >> >> So it's a

Re: [PATCH] aic7xxx: Fix queue depth handling

2016-02-15 Thread James Bottomley
On Mon, 2016-02-15 at 18:53 +, Alan wrote: > We were setting the queue depth correctly, then setting it back to > two. If you hit this as a bisection point then please send me an > email as it would imply we've been hiding other bugs with this one. > > Signed-off-by: Alan Cox

[PATCH] esas2r: Fix array overrun

2016-02-15 Thread Alan
Check the array size *before* dereferencing it with a user provided offset Signed-off-by: Alan Cox --- drivers/scsi/esas2r/esas2r_ioctl.c |5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/scsi/esas2r/esas2r_ioctl.c

[PATCH] aic7xxx: Fix queue depth handling

2016-02-15 Thread Alan
We were setting the queue depth correctly, then setting it back to two. If you hit this as a bisection point then please send me an email as it would imply we've been hiding other bugs with this one. Signed-off-by: Alan Cox --- drivers/scsi/aic7xxx/aic7xxx_osm.c |1 +

Re: [PATCH] Use ida_simple for SCSI iSCSI transport session id

2016-02-15 Thread Chris Leech
On Fri, Feb 12, 2016 at 09:54:51AM -0800, James Bottomley wrote: > On Fri, 2016-02-12 at 09:38 -0800, Lee Duncan wrote: > > The scsi_transport_iscsi module already uses the ida_simple > > routines for managing the target ID, if requested to do > > so. This change replaces an ever-increasing atomic

Re: [RFC 22/34] iscsi-target: call Rx thread function

2016-02-15 Thread Sagi Grimberg
call Rx thread function if registered by transport driver, so that transport drivers can use iscsi-target Rx thread for Rx processing. update iSER target driver to use this interface. Signed-off-by: Varun Prakash Other than the handler name, looks harmless. Acked-by:

Re: [RFC 20/34] iscsi-target: update struct iscsit_transport definition

2016-02-15 Thread Sagi Grimberg
1. void (*iscsit_rx_pdu)(struct iscsi_conn *); Rx thread uses this for receiving and processing iSCSI PDU in full feature phase. Is iscsit_rx_pdu the best name for this? it sounds like a function that would handle A pdu, but it's actually the thread function dequeuing pdus correct? --

Re: [RFC 19/34] iscsi-target: clear tx_thread_active

2016-02-15 Thread Sagi Grimberg
On 14/02/2016 19:42, Varun Prakash wrote: clear tx_thread_active for ISCSI_TCP_CXGB4 transport in logout_post_handler functions. Signed-off-by: Varun Prakash --- drivers/target/iscsi/iscsi_target.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git

Re: [RFC 18/34] iscsi-target: call complete on conn_logout_comp

2016-02-15 Thread Sagi Grimberg
On 14/02/2016 19:42, Varun Prakash wrote: ISCSI_TCP_CXGB4 driver waits on conn_logout_comp as ISCSI_TCP driver so call complete if transport type is ISCSI_TCP_CXGB4. Signed-off-by: Varun Prakash --- drivers/target/iscsi/iscsi_target.c | 10 ++ 1 file changed, 6

[PATCH v8 2/3] added UFS 2.0 capabilities

2016-02-15 Thread Joao Pinto
Adding UFS 2.0 support to the UFS core driver. Signed-off-by: Joao Pinto --- Changes v7->v8: - Added "jedec, ufs-2.0" to the ufschd-platform compatibility strings Changes v0->v7: - Nothing changed (just to keep up with patch set version).

[PATCH v8 1/3] fixed typo in ufshcd-pltfrm

2016-02-15 Thread Joao Pinto
Fixed typo in ufshcd-pltfrm. Signed-off-by: Joao Pinto --- Changes v0->v8: - Nothing changed (just to keep up with patch set version). drivers/scsi/ufs/ufshcd-pltfrm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/scsi/ufs/ufshcd-pltfrm.c

[PATCH v8 3/3] add support for DWC UFS Host Controller

2016-02-15 Thread Joao Pinto
This patch has the goal to add support for DesignWare UFS Controller specific operations and to add specific platform and pci drivers. Signed-off-by: Joao Pinto --- Changes v7->v8 (Akinobu Mita): - DME sets were simplified for easier reading - CLK DIV default values

[PATCH v8 0/3] add support for DWC UFS Controller

2016-02-15 Thread Joao Pinto
The work consisted of: - Fixed typo in ufshcd-pltfrm.c - Tweak ufshcd.c for UFS 2.0 support - Implement ufshcd-dwc which contains all DWC HW specific code - Unipro attributes were added and new registers were added to the driver - Implement a ufs-dwc glue platform driver - Implement a ufs-dwc-pci

Re: [PATCH v7 3/3] add support for DWC UFS Host Controller

2016-02-15 Thread Joao Pinto
Hi Akinobu, On 2/13/2016 1:27 PM, Akinobu Mita wrote: > Hi Joao, > > 2016-02-11 21:13 GMT+09:00 Joao Pinto : >> +static int ufshcd_dwc_connection_setup(struct ufs_hba *hba) >> +{ >> + int ret = 0; >> + >> + /* Local side Configuration */ >> + ret =

[PATCHv7 06/23] scsi_dh_alua: allocate RTPG buffer separately

2016-02-15 Thread Hannes Reinecke
The RTPG buffer will only evaluated within alua_rtpg(), so we can allocate it locally there and avoid having to put it into the global structure. Reviewed-by: Ewan Milne Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke ---

[PATCHv7 00/23] ALUA device handler update, part II

2016-02-15 Thread Hannes Reinecke
as promised here is now the second part of my ALUA device handler update. This contains a major rework of the ALUA device handler as execution is moved onto a workqueue. This has the advantage that we avoid having to do multiple calls to the same LUN (as happens frequently when failing over a LUN

[PATCHv7 03/23] scsi_dh_alua: Make stpg synchronous

2016-02-15 Thread Hannes Reinecke
The 'activate_complete' function needs to be executed after stpg has finished, so we can as well execute stpg synchronously and call the function directly. Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c |

[PATCHv7 04/23] scsi_dh_alua: call alua_rtpg() if stpg fails

2016-02-15 Thread Hannes Reinecke
If the call to SET TARGET PORT GROUPS fails we have no idea what state the array is left in, so we need to issue a call to REPORT TARGET PORT GROUPS in these cases. Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke ---

[PATCHv7 17/23] scsi_dh_alua: update all port states

2016-02-15 Thread Hannes Reinecke
When we read in the target port group state we should be updating all affected port groups, otherwise we risk running out of sync. Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 35

[PATCHv7 14/23] scsi_dh_alua: Allow workqueue to run synchronously

2016-02-15 Thread Hannes Reinecke
Some arrays may only capable of handling one STPG at a time, so this patch adds a singlethreaded workqueue for STPGs to be submitted synchronously. Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 21

[PATCHv7 09/23] scsi_dh_alua: simplify alua_initialize()

2016-02-15 Thread Hannes Reinecke
Rework alua_check_vpd() to use scsi_vpd_get_tpg() and move the port group selection into the function, too. With that we can simplify alua_initialize() to just call alua_check_tpgs() and alua_check_vpd(); Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke

[PATCHv7 19/23] scsi_dh: add 'rescan' callback

2016-02-15 Thread Hannes Reinecke
If a device needs to be rescanned the device_handler might need to be rechecked, too. So add a 'rescan' callback to the device handler and call it upon scsi_rescan_device(). The rescan callback will be invoked from the Unit Attention handling of ASC/ASCQ 3F 03 (INQUIRY DATA HAS CHANGED).

[PATCHv7 12/23] scsi_dh_alua: remove 'rel_port' from alua_dh_data structure

2016-02-15 Thread Hannes Reinecke
The 'relative port' field is not used, and might get stale when the port group changes. So remove the field altogether. Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 6 +- 1 file changed, 1

[PATCHv7 16/23] scsi_dh_alua: Recheck state on unit attention

2016-02-15 Thread Hannes Reinecke
When we receive a unit attention code of 'ALUA state changed' we should recheck the state, as it might be due to an implicit ALUA state transition. This allows us to return NEEDS_RETRY instead of ADD_TO_MLQUEUE, allowing to terminate the retries after a certain time. At the same time a workqueue

[PATCHv7 23/23] scsi_dh_alua: Update version to 2.0

2016-02-15 Thread Hannes Reinecke
Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/scsi/device_handler/scsi_dh_alua.c b/drivers/scsi/device_handler/scsi_dh_alua.c

[PATCHv7 05/23] scsi_dh_alua: switch to scsi_execute_req_flags()

2016-02-15 Thread Hannes Reinecke
All commands are issued synchronously, so no need to open-code scsi_execute_req_flags() anymore. And we can get rid of the static sense code structure element. scsi_execute_req_flags() will be setting REQ_QUIET and REQ_PREEMPT, but that is perfectly fine as we're evaluating and logging any errors

[PATCHv7 07/23] scsi_dh_alua: Use separate alua_port_group structure

2016-02-15 Thread Hannes Reinecke
The port group needs to be a separate structure as several LUNs might belong to the same group. Reviewed-by: Christoph Hellwig Reviewed-by: Ewan Milne Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 181

[PATCHv7 22/23] scsi_dh_alua: update 'access_state' field

2016-02-15 Thread Hannes Reinecke
Track attached SCSI devices and update the 'access_state' field whenever an ALUA state change has been detected. Reviewed-by: Ewan Milne Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c |

[PATCHv7 21/23] scsi_dh_alua: use common definitions for ALUA state

2016-02-15 Thread Hannes Reinecke
scsi_proto.h now contains definitions for the ALUA state, so we don't have to carry them in the device handler. Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 58 +- 1 file

[PATCHv7 01/23] scsi_dh_alua: Pass buffer as function argument

2016-02-15 Thread Hannes Reinecke
Pass in the buffer as a function argument for submit_rtpg(). Reviewed-by: Martin K. Petersen Reviewed-by: Christoph Hellwig Reviewed-by: Bart Van Assche Signed-off-by: Hannes Reinecke ---

[PATCHv7 15/23] scsi_dh_alua: Add new blacklist flag 'BLIST_SYNC_ALUA'

2016-02-15 Thread Hannes Reinecke
Add a new blacklist flag BLIST_SYNC_ALUA to instruct the alua device handler to use synchronous command submission for ALUA commands. Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 2 ++

[PATCHv7 20/23] scsi: Add 'access_state' attribute

2016-02-15 Thread Hannes Reinecke
Add an 'access_state' attribute to struct scsi_device to display the asymmetric LUN access state. Reviewed-by: Ewan Milne Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/scsi_scan.c | 1 +

[PATCHv7 10/23] revert commit a8e5a2d593cb ("[SCSI] scsi_dh_alua: ALUA handler attach should succeed while TPG is transitioning")

2016-02-15 Thread Hannes Reinecke
This reverts commit a8e5a2d593cbfccf530c3382c2c328d2edaa7b66 Obsoleted by the next patch. Reviewed-by: Christoph Hellwig Reviewed-by: Ewan Milne Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 31

[PATCHv7 08/23] scsi_dh_alua: use unique device id

2016-02-15 Thread Hannes Reinecke
Use scsi_vpd_lun_id() to assign a unique device identification to the alua port group structure. Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 55 +++--- 1 file changed, 50

[PATCHv7 02/23] scsi_dh_alua: separate out alua_stpg()

2016-02-15 Thread Hannes Reinecke
Separate out SET TARGET PORT GROUP functionality into a separate function alua_stpg(). Reviewed-by: Christoph Hellwig Signed-off-by: Hannes Reinecke --- drivers/scsi/device_handler/scsi_dh_alua.c | 95 +++--- 1 file changed, 61 insertions(+),