Re: [PATCH] scsi: be2iscsi: Use kasprintf

2017-10-11 Thread Himanshu Jha
On Tue, Oct 10, 2017 at 05:54:15PM -0400, Kyle Fortin wrote: > Hi Himanshu, > > On Oct 6, 2017, at 2:57 PM, Himanshu Jha wrote: > > > > Use kasprintf instead of combination of kmalloc and sprintf. > > > > Signed-off-by: Himanshu Jha >

Re: [PATCH 12/13] kthread: Convert callback to use from_timer()

2017-10-11 Thread Petr Mladek
On Wed 2017-10-04 16:27:06, Kees Cook wrote: > In preparation for unconditionally passing the struct timer_list pointer > to all timer callbacks, switch kthread to use from_timer() and pass the > timer pointer explicitly. > > Cc: Andrew Morton > Cc: Petr Mladek

Re: [PATCH 2/2] hpsa: destroy sas transport properties before scsi_host

2017-10-11 Thread Martin Wilck
On Tue, 2017-10-10 at 23:04 +, Don Brace wrote: > Now that Hannes's patch 9441284fbc39610c0f9ec0ed118ff85d78352906 > has been applied, this patch corrects the stack trace issue. > > Would you like to re-submit this patch or would you like me to send > it up? > I'll run some quick tests if

Re: [PATCH 11/13] timer: Remove expires argument from __TIMER_INITIALIZER()

2017-10-11 Thread Petr Mladek
On Wed 2017-10-04 16:27:05, Kees Cook wrote: > The expires field is normally initialized during the first mod_timer() > call. It was unused by all callers, so remove it from the macro. > > Signed-off-by: Kees Cook > --- > include/linux/kthread.h | 2 +- >

dick.kenn...@broadcom.com , james.sm...@broadcom.com, h...@suse.com, martin.peter...@oracle.com

2017-10-11 Thread Gomonovych, Vasyl
>From 1d3f6e197b8f9027910bf4ab1e97e69e3d77faf9 Mon Sep 17 00:00:00 2001 From: Vasyl Gomonovych Date: Wed, 11 Oct 2017 10:47:03 +0200 Subject: [PATCH] scsi: lpfc: fix kzalloc-simple.cocci warnings drivers/scsi/lpfc/lpfc_debugfs.c:5460:22-29: WARNING: kzalloc should be used

Re: [PATCH] scsi: logging_level: update bits description

2017-10-11 Thread Steffen Maier
On 10/10/2017 09:32 PM, Kyle Fortin wrote: On Oct 10, 2017, at 3:05 PM, Randy Dunlap wrote: From: Randy Dunlap Update the description of 'scsi_logging_level' from 8 4-bit nibbles to the (pre-git) reality of 10 3-bit 'nibbles'. Signed-off-by:

[PATCH 5/5] qla2xxx: Update driver version to 10.00.00.02-k

2017-10-11 Thread Madhani, Himanshu
From: Himanshu Madhani Signed-off-by: Himanshu Madhani --- drivers/scsi/qla2xxx/qla_version.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/scsi/qla2xxx/qla_version.h b/drivers/scsi/qla2xxx/qla_version.h

[PATCH 4/5] qla2xxx: Changes to support N2N logins

2017-10-11 Thread Madhani, Himanshu
From: Duane Grigsby If we discovered a topology that is N2N then we will issue a login to the target. If our WWPN is bigger than the target's WWPN then we will initiate login, otherwise we will just wait for the target to initiate login. Signed-off-by: Duane Grigsby

[PATCH 1/5] qla2xxx: Add module param ql2xenablemsix

2017-10-11 Thread Madhani, Himanshu
From: Himanshu Madhani Signed-off-by: Himanshu Madhani --- drivers/scsi/qla2xxx/qla_gbl.h | 1 + drivers/scsi/qla2xxx/qla_isr.c | 9 ++--- drivers/scsi/qla2xxx/qla_os.c | 9 + 3 files changed, 16 insertions(+), 3

[PATCH 3/5] qla2xxx: Allow MBC_GET_PORT_DATABASE to query and save the port states

2017-10-11 Thread Madhani, Himanshu
From: Duane Grigsby The MBC_GET_PORT_DATABASE command normally checks the port state informationi. This patch allows it to save that info in the fcport structure and ignore the check if the query flag is set. Signed-off-by: Duane Grigsby

[PATCH 2/5] qla2xxx: Add ATIO-Q processing for INTx mode

2017-10-11 Thread Madhani, Himanshu
From: Himanshu Madhani Signed-off-by: Himanshu Madhani --- drivers/scsi/qla2xxx/qla_def.h| 1 + drivers/scsi/qla2xxx/qla_isr.c| 8 ++-- drivers/scsi/qla2xxx/qla_target.c | 12 +--- 3 files changed, 16

[PATCH 0/5] qla2xxx: Patches for scsi-misc

2017-10-11 Thread Madhani, Himanshu
From: Himanshu Madhani Hi Martin, This series adds support for INTx mode for qla2xxx driver. Also, adds support for N2N login for FC-NVMe. Please apply to 4.15/scsi-queue at your earliest convenience. Thanks, Himanshu Duane Grigsby (2): qla2xxx: Allow

[PATCH] scsi: libcxgbi: simplify task->hdr allocation for mgmt cmds

2017-10-11 Thread Varun Prakash
In case of mgmt cmds task->hdr is dereferenced after transmitting the pdu in iscsi_tcp_task_xmit() to handle this case current code increments the Tx skb reference count and frees the skb in cxgbi_cleanup_task(), in some error cases this results in skb leak. To fix this in case of mgmt cmds

[PATCH] scsi: cxgb4i: fix Tx skb leak

2017-10-11 Thread Varun Prakash
In case of connection reset Tx skb queue can have some skbs which are not transmitted so purge Tx skb queue in release_offload_resources() to avoid skb leak. Signed-off-by: Varun Prakash --- drivers/scsi/cxgbi/cxgb4i/cxgb4i.c | 1 + 1 file changed, 1 insertion(+) diff --git

Re: [PATCH 01/10] mpt3sas: Processing of Cable Exception events

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Earlier Active Cable Exception event with reason code > "Cable Degraded (0x02))" was added only for Active Cable, > Now this event is extended to Passive cable too. > So re-arranged display message accordingly. > > Also added Cable Exception Event

Re: [PATCH 03/10] mpt3sas: Reduce memory footprints in kdump kernel

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > To reduce the memory footprints of the driver in kdump kernel, > we have made below driver setting when system boots in to kdump kernel, > > 1. Used single MSI-x vector. > 2. Disable RDPQ mode. > 3. Set sg_table_size to 32 by default. > 4) Set SCSI

Re: [PATCH] scsi: use set_host_byte instead of open-coding it

2017-10-11 Thread Steffen Maier
On 10/10/2017 05:29 PM, Johannes Thumshirn wrote: Call set_host_byte() instead of open-coding it. Converted using this simple Coccinelle spatch @@ local idexpression struct scsi_cmnd *c; expression E1; @@ - c->result = E1 << 16; + set_host_byte(c, E1); Maybe I misunderstand, but doesn't

Re: [PATCH] scsi: use set_host_byte instead of open-coding it

2017-10-11 Thread Johannes Thumshirn
On Wed, Oct 11, 2017 at 03:05:40PM +0200, Steffen Maier wrote: > Maybe I misunderstand, but doesn't set_host_byte only set the host byte but > leave the other 3 parts untouched in c->result? > > static inline void set_host_byte(struct scsi_cmnd *cmd, char status) > { > cmd->result =

Re: [PATCH 02/10] mpt3sas: Fixed memory leaks in driver

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Fixed below memory leak in driver, > > * While removing Expander devices - we are removing expander > device entry from the list before freeing it's child devices, > so while freeing child device we are finding its parent device > node as NULL

Re: [PATCH v2] scsi: logging: update description of logging_level bits

2017-10-11 Thread Kyle Fortin
Looks good. Reviewed-by: Kyle Fortin

Re: [PATCH v8 03/10] md: Neither resync nor reshape while the system is frozen

2017-10-11 Thread Bart Van Assche
On Tue, 2017-10-10 at 18:48 -0700, Shaohua Li wrote: > The problem is __md_stop_writes set some bit like MD_RECOVERY_FROZEN, which > will prevent md_check_recovery restarting resync/reshape. I think we need > preserve mddev->recovery in suspend prepare and restore after resume Hello Shaohua, As

[PATCH v2] scsi: logging: update description of logging_level bits

2017-10-11 Thread Randy Dunlap
From: Randy Dunlap Update the description of 'scsi_logging_level' from 8 4-bit nibbles to the (pre-git) reality of 10 3-bit bitfields. Signed-off-by: Randy Dunlap Reviewed-by: Kyle Fortin Reviewed-by: Steffen Maier

Re: [PATCH 04/10] mpt3sas: Fix removal and addition of vSES device during host reset

2017-10-11 Thread James Bottomley
On Wed, 2017-10-11 at 18:12 +0200, Tomas Henzl wrote: > On 10/11/2017 05:56 PM, James Bottomley wrote: > > > > On Wed, 2017-10-11 at 17:35 +0200, Tomas Henzl wrote: > > > > > > On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > > > > > > > > For Dev Handles who value is less than hba's phys count

Re: [PATCH] scsi: sd: add check for changing allow_restart

2017-10-11 Thread Martin K. Petersen
weiping, > /sys/class/scsi_disk/0:2:0:0/allow_restart can be changed to 0 unexpectly by > writing invalid string, like following: > > echo asdf > /sys/class/scsi_disk/0:2:0:0/allow_restart Please switch to kstrtobool() and fix up manage_start_stop as well. Thanks! -- Martin K. Petersen

Re: [PATCH 04/10] mpt3sas: Fix removal and addition of vSES device during host reset

2017-10-11 Thread Martin K. Petersen
Tomas, > Sure, sorry for that, corrected too late in 8/10 should I resend with > "Reviewed-by" ? I'll fix it up. -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH] scsi: libiscsi: fix shifting of DID_REQUEUE host byte

2017-10-11 Thread Martin K. Petersen
Johannes, > The SCSI host byte should be shifted left by 16 in order to have > scsi_decide_disposition() do the right thing (.i.e. requeue the > command). Applied to 4.14/scsi-fixes. Thank you! -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH v2 1/4] scsi: ufs: Change HCI macro to actual bit position

2017-10-11 Thread Martin K. Petersen
Alim, > Currently UFS HCI uses UFS_BIT() macro to get various bit position for > the hardware registers status bits. Which makes code longer instead of > shorter. This macro does not improve code readability as well. Lets > re-write these macro definition with the actual bit position. Applied

Re: [PATCH 05/10] mpt3sas: Fix IO error occurs on pulling out a drive from RAID1 volume created on two SATA drive

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Whenever IO for raid volume fails with IOCStatus > "MPI2_IOCSTATUS_SCSI_IOC_TERMINATED"and SCSIStatus equal to > "(MPI2_SCSI_STATE_TERMINATED | MPI2_SCSI_STATE_NO_SCSI_STATUS)" > then return the IO to SML with "DID_RESET" > (i.e. retry the IO

Re: [PATCH 04/10] mpt3sas: Fix removal and addition of vSES device during host reset

2017-10-11 Thread Tomas Henzl
On 10/11/2017 05:56 PM, James Bottomley wrote: > On Wed, 2017-10-11 at 17:35 +0200, Tomas Henzl wrote: >> On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: >>> For Dev Handles who value is less than hba's phys count number >>>  driver will return HBA sas address value as a sas address. >>> So for

Re: [PATCH 09/10] mpt3sas: Adding support for SAS3616 HBA device

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Adding PNP ID of Mercator i.e. SAS3616 HBA device. > Its device ID is 0xD1 and vendor ID is 0x1000. > > Signed-off-by: Sreekanth Reddy Reviewed-by: Tomas Henzl Tomas

Re: [PATCH 04/10] mpt3sas: Fix removal and addition of vSES device during host reset

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > For Dev Handles who value is less than hba's phys count number > driver will return HBA sas address value as a sas address. > So for Virtual SES device also driver was returning HBA sas address instead > of Virtual SES sas address. So now updated

Re: [PATCH 08/10] mpt3sas: Fix possibility of using invalid Enclosure Handles for SAS device after host reset

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Enclosure handles are not updated after host reset. > As a result, driver device structure is holding previously > assigned enclosure handle which is different from the > enclosure handle populated in the corresponding device page. > > Modified

Re: [PATCH 08/10] mpt3sas: Fix possibility of using invalid Enclosure Handles for SAS device after host reset

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Enclosure handles are not updated after host reset. > As a result, driver device structure is holding previously > assigned enclosure handle which is different from the > enclosure handle populated in the corresponding device page. > > Modified

[PATCH v2] scsi: be2iscsi: Use kasprintf

2017-10-11 Thread Himanshu Jha
Use kasprintf instead of combination of kmalloc and sprintf. Also, remove BEISCSI_MSI_NAME macro used to specify size of string as kasprintf handles size computations. Signed-off-by: Himanshu Jha --- v2: -remove the unnecessary macro BEISCSI_MSI_NAME.

Re: [PATCH 06/10] mpt3sas: Updated MPI headers to v2.00.48

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Updated MPI headers to v2.00.48 > > Signed-off-by: Sreekanth Reddy Signed-off-by: Tomas Henzl Tomas

Re: [PATCH 04/10] mpt3sas: Fix removal and addition of vSES device during host reset

2017-10-11 Thread James Bottomley
On Wed, 2017-10-11 at 17:35 +0200, Tomas Henzl wrote: > On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > > > > For Dev Handles who value is less than hba's phys count number > >  driver will return HBA sas address value as a sas address. > > So for Virtual SES device also driver was returning HBA

Re: [PATCH 07/10] mpt3sas: Display chassis slot information of the drive

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Display chassis slot information along with other drive location parameters > such as slot number and connector name in the logs; if chassis slot > validity bit is set in 'SAS Enclosure Page 0' while adding the drive. > > Signed-off-by: Sreekanth

Re: [PATCH 10/10] mpt3sas: Bump mpt3sas driver version to v16.100.00.00

2017-10-11 Thread Tomas Henzl
On 10/10/2017 03:11 PM, Sreekanth Reddy wrote: > Bump mpt3sas driver version to v16.100.00.00 > > Signed-off-by: Sreekanth Reddy Reviewed-by: Tomas Henzl Tomas

Re: [PATCH] scsi: logging_level: update bits description

2017-10-11 Thread Randy Dunlap
On 10/11/17 06:18, Steffen Maier wrote: > > On 10/10/2017 09:32 PM, Kyle Fortin wrote: >> On Oct 10, 2017, at 3:05 PM, Randy Dunlap wrote: >>> From: Randy Dunlap >>> >>> Update the description of 'scsi_logging_level' from 8 4-bit nibbles >>> to the

Re: [PATCH 00/10] be2iscsi: driver update 11.4.0.1

2017-10-11 Thread Chris Leech
These all look good to me. Acked-by: Chris Leech On Tue, Oct 10, 2017 at 04:18:10PM +0530, Jitendra Bhivare wrote: > This patch is generated against for-next branch. > > Jitendra Bhivare (10): > be2iscsi: Fix boot flags in sysfs > be2iscsi: Fix return value in

Re: [PATCH 00/10] [SCSI] mpt3sas: Phase15 driver enhancements and fixes

2017-10-11 Thread Martin K. Petersen
Sreekanth, > Phase15 driver enhancements and fixes. Applied to 4.15/scsi-queue. Thank you! -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH 00/10] be2iscsi: driver update 11.4.0.1

2017-10-11 Thread Martin K. Petersen
Jitendra, > This patch is generated against for-next branch. Applied to 4.15/scsi-queue. Thank you! -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH] scsi: fix doc. typo for I2O

2017-10-11 Thread Martin K. Petersen
Randy, > Fix typo: I20 should be I2O. Applied to 4.15/scsi-queue. Thanks! -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH] scsi: libcxgbi: simplify task->hdr allocation for mgmt cmds

2017-10-11 Thread Martin K. Petersen
Varun, > In case of mgmt cmds task->hdr is dereferenced after transmitting the > pdu in iscsi_tcp_task_xmit() to handle this case current code > increments the Tx skb reference count and frees the skb in > cxgbi_cleanup_task(), in some error cases this results in skb leak. > > To fix this in

Re: [PATCH v2] scsi: be2iscsi: Use kasprintf

2017-10-11 Thread Kyle Fortin
On Oct 11, 2017, at 11:36 AM, Himanshu Jha wrote: > > Use kasprintf instead of combination of kmalloc and sprintf. > Also, remove BEISCSI_MSI_NAME macro used to specify size of string as > kasprintf handles size computations. > > Signed-off-by: Himanshu Jha

Re: [PATCH v2] scsi: logging: update description of logging_level bits

2017-10-11 Thread Martin K. Petersen
Randy, > Update the description of 'scsi_logging_level' from 8 4-bit nibbles > to the (pre-git) reality of 10 3-bit bitfields. Applied to 4.15/scsi-queue. Thank you! -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH] scsi: cxgb4i: fix Tx skb leak

2017-10-11 Thread Martin K. Petersen
Varun, > In case of connection reset Tx skb queue can have some skbs which are > not transmitted so purge Tx skb queue in release_offload_resources() > to avoid skb leak. Applied to 4.15/scsi-queue. -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH] scsi: libcxgbi: in case of vlan pass 0 as ifindex to find route

2017-10-11 Thread Martin K. Petersen
Varun, > In case of vlan pass 0 as ifindex to find route instead of passing > real_dev ifindex, if we pass real_dev ifindex then > ip_route_output_ports() and ip6_route_output() will check for route > through real_dev not through vlan interface. Applied to 4.15/scsi-queue. Thank you! --

Re: [PATCH] qla2xxx: Fix uninitialize work element

2017-10-11 Thread Martin K. Petersen
Himanshu, > From: Quinn Tran > > Fixes following stack trace Applied to 4.14/scsi-fixes. Thank you! -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH v3] scsi: fc: check for rport presence in fc_block_scsi_eh

2017-10-11 Thread Martin K. Petersen
Johannes, > Coverity-scan recently found a possible NULL pointer dereference in > fc_block_scsi_eh() as starget_to_rport() either returns the rport for > the startget or NULL. > > While it is rather unlikely to have fc_block_scsi_eh() called without > an rport associated it's a good idea to

Re: [PATCH v8 03/10] md: Neither resync nor reshape while the system is frozen

2017-10-11 Thread Shaohua Li
On Wed, Oct 11, 2017 at 05:17:56PM +, Bart Van Assche wrote: > On Tue, 2017-10-10 at 18:48 -0700, Shaohua Li wrote: > > The problem is __md_stop_writes set some bit like MD_RECOVERY_FROZEN, which > > will prevent md_check_recovery restarting resync/reshape. I think we need > > preserve

[PATCH] scsi: lpfc: fix kzalloc-simple.cocci warnings

2017-10-11 Thread Vasyl Gomonovych
drivers/scsi/lpfc/lpfc_debugfs.c:5460:22-29: WARNING: kzalloc should be used for phba -> nvmeio_trc, instead of kmalloc/memset drivers/scsi/lpfc/lpfc_debugfs.c:2230:20-27: WARNING: kzalloc should be used for phba -> nvmeio_trc, instead of kmalloc/memset Use kzalloc rather than kmalloc followed