Re: [PATCH 07/20] scsi_transport_fc: rename 'fc_rport_create' to 'fc_remote_port_create'

2016-10-18 Thread James Smart



On 10/18/2016 9:18 AM, Johannes Thumshirn wrote:


Hi James,

fc_rport_create() in scsi_transport_fc.c is static so there is no 
interface change here.


Johannes



ah - that this was the published routine.  ok.

-- james

--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 07/20] scsi_transport_fc: rename 'fc_rport_create' to 'fc_remote_port_create'

2016-10-18 Thread James Smart


On 10/18/2016 1:01 AM, Hannes Reinecke wrote:

Required for the next patch.

Signed-off-by: Hannes Reinecke 
---
  drivers/scsi/scsi_transport_fc.c | 8 
  1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/scsi/scsi_transport_fc.c b/drivers/scsi/scsi_transport_fc.c
index 0f3a386..4534085 100644
--- a/drivers/scsi/scsi_transport_fc.c
+++ b/drivers/scsi/scsi_transport_fc.c
@@ -2592,7 +2592,7 @@ static void fc_terminate_rport_io(struct fc_rport *rport)
  
  
  /**

- * fc_rport_create - allocates and creates a remote FC port.
+ * fc_remote_port_create - allocates and creates a remote FC port.
   * @shost:scsi host the remote port is connected to.
   * @channel:  Channel on shost port connected to.
   * @ids:  The world wide names, fc address, and FC4 port
@@ -2605,8 +2605,8 @@ static void fc_terminate_rport_io(struct fc_rport *rport)
   *This routine assumes no locks are held on entry.
   */
  static struct fc_rport *
-fc_rport_create(struct Scsi_Host *shost, int channel,
-   struct fc_rport_identifiers  *ids)
+fc_remote_port_create(struct Scsi_Host *shost, int channel,
+ struct fc_rport_identifiers  *ids)
  {
struct fc_host_attrs *fc_host = shost_to_fc_host(shost);
struct fc_internal *fci = to_fc_internal(shost->transportt);
@@ -2914,7 +2914,7 @@ struct fc_rport *
spin_unlock_irqrestore(shost->host_lock, flags);
  
  	/* No consistent binding found - create new remote port entry */

-   rport = fc_rport_create(shost, channel, ids);
+   rport = fc_remote_port_create(shost, channel, ids);
  
  	return rport;

  }


Hannes,

Why are you making an interface change that will now affect drivers that 
are not users of libfc ?   Can't this be localized within libfc ?


-- james
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 07/20] scsi_transport_fc: rename 'fc_rport_create' to 'fc_remote_port_create'

2016-10-18 Thread Johannes Thumshirn
On Tue, Oct 18, 2016 at 10:01:41AM +0200, Hannes Reinecke wrote:
> Required for the next patch.
> 
> Signed-off-by: Hannes Reinecke 
> ---

Given the comment on the next patch,
Acked-by: Johannes Thumshirn 

-- 
Johannes Thumshirn  Storage
jthumsh...@suse.de+49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html