Re: [PATCH 03/21] mm: remove CONFIG_HAVE_MEMBLOCK_NODE_MAP option

2020-04-20 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > The CONFIG_HAVE_MEMBLOCK_NODE_MAP is used to differentiate initialization > of nodes and zones structures between the systems that have region to node > mapping in memblock and those that don't. > > Currently all the NUMA

Re: [PATCH 02/21] mm: make early_pfn_to_nid() and related defintions close to each other

2020-04-20 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > The early_pfn_to_nid() and it's helper __early_pfn_to_nid() are spread > around include/linux/mm.h, include/linux/mmzone.h and mm/page_alloc.c. > > Drop unused stub for __early_pfn_to_nid() and move its actual generic >

[PATCH V17 0/2] mm/debug: Add tests validating architecture page table helpers

2020-04-20 Thread Anshuman Khandual
This adds a test validation for architecture exported page table helpers. Patch adds basic transformation tests at various levels of the page table. This test was originally suggested by Catalin during arm64 THP migration RFC discussion earlier. Going forward it can include more specific tests

[PATCH V17 2/2] mm/debug: Add tests validating architecture page table helpers

2020-04-20 Thread Anshuman Khandual
This adds tests which will validate architecture page table helpers and other accessors in their compliance with expected generic MM semantics. This will help various architectures in validating changes to existing page table helpers or addition of new ones. This test covers basic page table

Re: [PATCH 02/21] mm: make early_pfn_to_nid() and related defintions close to each other

2020-04-20 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > The early_pfn_to_nid() and it's helper __early_pfn_to_nid() are spread > around include/linux/mm.h, include/linux/mmzone.h and mm/page_alloc.c. > > Drop unused stub for __early_pfn_to_nid() and move its actual generic >

Re: [PATCH 01/21] mm: memblock: replace dereferences of memblock_region.nid with API calls

2020-04-20 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > There are several places in the code that directly dereference > memblock_region.nid despite this field being defined only when > CONFIG_HAVE_MEMBLOCK_NODE_MAP=y. > > Replace these with calls to memblock_get_region_nid() to

Re: [PATCH 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-20 Thread Anshuman Khandual
On 04/21/2020 02:33 AM, Will Deacon wrote: > On Fri, Mar 20, 2020 at 10:24:17AM +0530, Anshuman Khandual wrote: >> pmd_present() is expected to test positive after pmdp_mknotpresent() as the >> PMD entry still points to a valid huge page in memory. pmdp_mknotpresent() >> implies that given PMD

Re: [PATCH v3 2/2] dt-bindings: Document the Synopsys ARC HDMI TX bindings

2020-04-20 Thread Rob Herring
On Wed, Apr 15, 2020 at 02:29:29AM +0300, Eugeniy Paltsev wrote: > This patch adds documentation of device tree bindings for the Synopsys > HDMI 2.0 TX encoder driver for ARC SoCs. You're going to need to base this on top of Laurent's conversion of dw_hdmi.txt to schema. > > Acked-by: Sam

Re: [PATCH 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-20 Thread Will Deacon
On Fri, Mar 20, 2020 at 10:24:17AM +0530, Anshuman Khandual wrote: > pmd_present() is expected to test positive after pmdp_mknotpresent() as the > PMD entry still points to a valid huge page in memory. pmdp_mknotpresent() > implies that given PMD entry is just invalidated from MMU perspective

Re: [PATCH v5 11/14] ARC: Update syscall-names.list for ARC specific syscalls

2020-04-20 Thread Joseph Myers
On Fri, 17 Apr 2020, Vineet Gupta via Libc-alpha wrote: > On 4/17/20 4:05 PM, Joseph Myers wrote: > > This patch is OK. > > So when the rest of port is ready, this will be part of main commit ? I think it's reasonable to commit this patch before then, much like the relocations in elf.h, so

Re: [PATCH v5 06/14] ARC: hardware floating point support

2020-04-20 Thread Joseph Myers
On Fri, 17 Apr 2020, Vineet Gupta via Libc-alpha wrote: > > My suggestion would be to define the > > macro (using do { ... } while (0)) to copy the argument to a temporary > > variable, and do the bit-set operation in C code on that temporary > > variable rather than as part of the asm. > >

Re: [PATCH 15/21] mm: memmap_init: iterate over memblock regions rather that check each PFN

2020-04-20 Thread Qian Cai
> On Apr 12, 2020, at 3:48 PM, Mike Rapoport wrote: > > From: Baoquan He > > When called during boot the memmap_init_zone() function checks if each PFN > is valid and actually belongs to the node being initialized using > early_pfn_valid() and early_pfn_in_nid(). > > Each such check may