[PATCH V2 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mkinvalid()

2020-04-21 Thread Anshuman Khandual
pmd_present() is expected to test positive after pmdp_mknotpresent() as the PMD entry still points to a valid huge page in memory. pmdp_mknotpresent() implies that given PMD entry is just invalidated from MMU perspective while still holding on to pmd_page() referred valid huge page thus also

[PATCH V2 0/2] mm/thp: Rename pmd_mknotpresent() as pmd_mkinvalid()

2020-04-21 Thread Anshuman Khandual
This series renames pmd_mknotpresent() as pmd_mkinvalid(). Before that it drops an existing pmd_mknotpresent() definition from powerpc platform which was never required as it defines it's pmdp_invalidate() through subscribing __HAVE_ARCH_PMDP_INVALIDATE. This does not create any functional change.

Re: [PATCH v3 1/2] DRM: ARC: add HDMI 2.0 TX encoder support

2020-04-21 Thread Neil Armstrong
On 15/04/2020 19:33, Daniel Vetter wrote: > On Wed, Apr 15, 2020 at 02:29:28AM +0300, Eugeniy Paltsev wrote: >> The Synopsys ARC SoCs (like HSDK4xD) include on-chip DesignWare HDMI >> encoders. Support them with a platform driver to provide platform glue >> data to the dw-hdmi driver. >> >>

Re: [PATCH 03/21] mm: remove CONFIG_HAVE_MEMBLOCK_NODE_MAP option

2020-04-21 Thread Baoquan He
On 04/21/20 at 12:09pm, Mike Rapoport wrote: > > > diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c > > > index fc0aad0bc1f5..e67dc501576a 100644 > > > --- a/mm/memory_hotplug.c > > > +++ b/mm/memory_hotplug.c > > > @@ -1372,11 +1372,7 @@ check_pages_isolated_cb(unsigned long start_pfn, > >

Re: [PATCH 02/21] mm: make early_pfn_to_nid() and related defintions close to each other

2020-04-21 Thread Baoquan He
On 04/21/20 at 11:49am, Mike Rapoport wrote: > On Tue, Apr 21, 2020 at 10:24:35AM +0800, Baoquan He wrote: > > On 04/12/20 at 10:48pm, Mike Rapoport wrote: > > > From: Mike Rapoport > > > > > > The early_pfn_to_nid() and it's helper __early_pfn_to_nid() are spread > > > around

Re: [PATCH 03/21] mm: remove CONFIG_HAVE_MEMBLOCK_NODE_MAP option

2020-04-21 Thread Mike Rapoport
On Tue, Apr 21, 2020 at 12:23:16PM +0800, Baoquan He wrote: > On 04/12/20 at 10:48pm, Mike Rapoport wrote: > > From: Mike Rapoport > > > > The CONFIG_HAVE_MEMBLOCK_NODE_MAP is used to differentiate initialization > > of nodes and zones structures between the systems that have region to node > >

Re: [PATCH 02/21] mm: make early_pfn_to_nid() and related defintions close to each other

2020-04-21 Thread Mike Rapoport
On Tue, Apr 21, 2020 at 10:24:35AM +0800, Baoquan He wrote: > On 04/12/20 at 10:48pm, Mike Rapoport wrote: > > From: Mike Rapoport > > > > The early_pfn_to_nid() and it's helper __early_pfn_to_nid() are spread > > around include/linux/mm.h, include/linux/mmzone.h and mm/page_alloc.c. > > > >

Re: [PATCH 02/21] mm: make early_pfn_to_nid() and related defintions close to each other

2020-04-21 Thread Mike Rapoport
On Tue, Apr 21, 2020 at 11:31:14AM +0800, Baoquan He wrote: > On 04/12/20 at 10:48pm, Mike Rapoport wrote: > > From: Mike Rapoport > > > > The early_pfn_to_nid() and it's helper __early_pfn_to_nid() are spread > > around include/linux/mm.h, include/linux/mmzone.h and mm/page_alloc.c. > > > >

Re: [PATCH 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-21 Thread Anshuman Khandual
On 04/21/2020 12:37 PM, Will Deacon wrote: > On Tue, Apr 21, 2020 at 04:57:26AM +0530, Anshuman Khandual wrote: >> >> >> On 04/21/2020 02:33 AM, Will Deacon wrote: >>> On Fri, Mar 20, 2020 at 10:24:17AM +0530, Anshuman Khandual wrote: pmd_present() is expected to test positive after

Re: [PATCH 2/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-04-21 Thread Will Deacon
On Tue, Apr 21, 2020 at 04:57:26AM +0530, Anshuman Khandual wrote: > > > On 04/21/2020 02:33 AM, Will Deacon wrote: > > On Fri, Mar 20, 2020 at 10:24:17AM +0530, Anshuman Khandual wrote: > >> pmd_present() is expected to test positive after pmdp_mknotpresent() as the > >> PMD entry still points