[linux-sunxi] Re: [PATCH 3/6] sunxi: SPL SPI: Introduce is_new_gen_spi()

2020-01-27 Thread Jagan Teki
On Mon, Jan 27, 2020 at 6:59 AM André Przywara  wrote:
>
> On 21/01/2020 08:20, Jagan Teki wrote:
>
> Hi Jagan,
>
> first: many thanks for merging those other patches of mine, much
> appreciated!
>
> > On Mon, Jan 6, 2020 at 6:59 AM Andre Przywara  
> > wrote:
> >>
> >> So far we were using the CONFIG_SUNXI_GEN_SUN6I symbol to select between
> >> the two SPI controller generations used on Allwinner SoCs. This is a
> >> convenience symbol to roughly differentiate between "older" and "newer"
> >> generation of SoCs.
> >>
> >> The H6 SoCs is the newest SoC so far, but is sufficiently different to
> >> not define this symbol. However it is using a SPI controller compatible
> >> to the "new gen" SoCs.
> >>
> >> To prepare for H6 support, we replace the check for this single symbol
> >> with an explicit function, which can later be extended.
> >> For now we just return CONFIG_SUNXI_GEN_SUN6I in there, so this does not
> >> create a functional change.
> >>
> >> Signed-off-by: Andre Przywara 
> >> ---
> >>  arch/arm/mach-sunxi/spl_spi_sunxi.c | 22 ++
> >>  1 file changed, 14 insertions(+), 8 deletions(-)
> >>
> >> diff --git a/arch/arm/mach-sunxi/spl_spi_sunxi.c 
> >> b/arch/arm/mach-sunxi/spl_spi_sunxi.c
> >> index 5b4598a25b..b19f1bf4af 100644
> >> --- a/arch/arm/mach-sunxi/spl_spi_sunxi.c
> >> +++ b/arch/arm/mach-sunxi/spl_spi_sunxi.c
> >> @@ -100,9 +100,14 @@ static void spi0_pinmux_setup(unsigned int 
> >> pin_function)
> >> sunxi_gpio_set_cfgpin(SUNXI_GPC(3), pin_function);
> >>  }
> >>
> >> +static bool is_new_gen_spi(void)
> >> +{
> >> +   return IS_ENABLED(CONFIG_SUNXI_GEN_SUN6I);
> >> +}
> >
> > Doesn't it confusing? new gen is H6, but it returns 6I?
>
> Well, naming ...
> For the purpose of U-Boot there are two generations of SPI controller
> *register interfaces*, the "old" one used in the older SoCs like the
> A20, and the "newer" one used in everything halfway recent. The H6 uses
> the same "new" generation, just at a different address. Yes, it adds
> quad-SPI, but this is not relevant for this driver.
> I have seen this old/new terminology at different places, so just went
> with it.
> I could rename it to is_spi_sun6i_gen() or something if that makes you
> happy...

Please do, would be great if you can send the new changes as soon as
possible so-that I can send PR for the rc1.

Jagan.

-- 
You received this message because you are subscribed to the Google Groups 
"linux-sunxi" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to linux-sunxi+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/linux-sunxi/CAMty3ZAdchUNb9qX-XagucRMRM_oEGKuorJ5xL62ocrtxyu%2Bnw%40mail.gmail.com.


[linux-sunxi] Re: [PATCH 3/6] sunxi: SPL SPI: Introduce is_new_gen_spi()

2020-01-26 Thread André Przywara
On 21/01/2020 08:20, Jagan Teki wrote:

Hi Jagan,

first: many thanks for merging those other patches of mine, much
appreciated!

> On Mon, Jan 6, 2020 at 6:59 AM Andre Przywara  wrote:
>>
>> So far we were using the CONFIG_SUNXI_GEN_SUN6I symbol to select between
>> the two SPI controller generations used on Allwinner SoCs. This is a
>> convenience symbol to roughly differentiate between "older" and "newer"
>> generation of SoCs.
>>
>> The H6 SoCs is the newest SoC so far, but is sufficiently different to
>> not define this symbol. However it is using a SPI controller compatible
>> to the "new gen" SoCs.
>>
>> To prepare for H6 support, we replace the check for this single symbol
>> with an explicit function, which can later be extended.
>> For now we just return CONFIG_SUNXI_GEN_SUN6I in there, so this does not
>> create a functional change.
>>
>> Signed-off-by: Andre Przywara 
>> ---
>>  arch/arm/mach-sunxi/spl_spi_sunxi.c | 22 ++
>>  1 file changed, 14 insertions(+), 8 deletions(-)
>>
>> diff --git a/arch/arm/mach-sunxi/spl_spi_sunxi.c 
>> b/arch/arm/mach-sunxi/spl_spi_sunxi.c
>> index 5b4598a25b..b19f1bf4af 100644
>> --- a/arch/arm/mach-sunxi/spl_spi_sunxi.c
>> +++ b/arch/arm/mach-sunxi/spl_spi_sunxi.c
>> @@ -100,9 +100,14 @@ static void spi0_pinmux_setup(unsigned int pin_function)
>> sunxi_gpio_set_cfgpin(SUNXI_GPC(3), pin_function);
>>  }
>>
>> +static bool is_new_gen_spi(void)
>> +{
>> +   return IS_ENABLED(CONFIG_SUNXI_GEN_SUN6I);
>> +}
> 
> Doesn't it confusing? new gen is H6, but it returns 6I?

Well, naming ...
For the purpose of U-Boot there are two generations of SPI controller
*register interfaces*, the "old" one used in the older SoCs like the
A20, and the "newer" one used in everything halfway recent. The H6 uses
the same "new" generation, just at a different address. Yes, it adds
quad-SPI, but this is not relevant for this driver.
I have seen this old/new terminology at different places, so just went
with it.
I could rename it to is_spi_sun6i_gen() or something if that makes you
happy...

Cheers,
Andre

-- 
You received this message because you are subscribed to the Google Groups 
"linux-sunxi" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to linux-sunxi+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/linux-sunxi/915f8cff-5639-224d-5c27-6f8b617b1f9e%40arm.com.


[linux-sunxi] Re: [PATCH 3/6] sunxi: SPL SPI: Introduce is_new_gen_spi()

2020-01-21 Thread Jagan Teki
On Mon, Jan 6, 2020 at 6:59 AM Andre Przywara  wrote:
>
> So far we were using the CONFIG_SUNXI_GEN_SUN6I symbol to select between
> the two SPI controller generations used on Allwinner SoCs. This is a
> convenience symbol to roughly differentiate between "older" and "newer"
> generation of SoCs.
>
> The H6 SoCs is the newest SoC so far, but is sufficiently different to
> not define this symbol. However it is using a SPI controller compatible
> to the "new gen" SoCs.
>
> To prepare for H6 support, we replace the check for this single symbol
> with an explicit function, which can later be extended.
> For now we just return CONFIG_SUNXI_GEN_SUN6I in there, so this does not
> create a functional change.
>
> Signed-off-by: Andre Przywara 
> ---
>  arch/arm/mach-sunxi/spl_spi_sunxi.c | 22 ++
>  1 file changed, 14 insertions(+), 8 deletions(-)
>
> diff --git a/arch/arm/mach-sunxi/spl_spi_sunxi.c 
> b/arch/arm/mach-sunxi/spl_spi_sunxi.c
> index 5b4598a25b..b19f1bf4af 100644
> --- a/arch/arm/mach-sunxi/spl_spi_sunxi.c
> +++ b/arch/arm/mach-sunxi/spl_spi_sunxi.c
> @@ -100,9 +100,14 @@ static void spi0_pinmux_setup(unsigned int pin_function)
> sunxi_gpio_set_cfgpin(SUNXI_GPC(3), pin_function);
>  }
>
> +static bool is_new_gen_spi(void)
> +{
> +   return IS_ENABLED(CONFIG_SUNXI_GEN_SUN6I);
> +}

Doesn't it confusing? new gen is H6, but it returns 6I?

-- 
You received this message because you are subscribed to the Google Groups 
"linux-sunxi" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to linux-sunxi+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/linux-sunxi/CAMty3ZAfZrA9-SV16hU7_eEBG83do2SHiJVd7UdA9ROfrH2wOA%40mail.gmail.com.