Re: USB 3.0 driver code flow for OTG gadget/host decision process

2014-03-27 Thread Greg KH
On Thu, Mar 27, 2014 at 12:32:07PM -0600, David Kochendorfer wrote: > Greg, > > I apologize if you've already received a copy of this - I inadvertently > shutdown evolution in the middle of sending and it doesn't look like the > first one was sent, so ... > > Is there a document/tutorial on the U

[RFC] mtd: nand: Preparatory patch for adding on-die ECC controller support. This patch adds NAND_ECC_HW_ON_DIE and all other changes to generic code.

2014-03-27 Thread David Mosberger
Pekon, Before I go any further with this, could you confirm that what is below is what you had in mind as far as the generic portion of the patch is concerned. If so, I'll go ahead and create the second, Micron-specific part next. Thanks, --david PS: This patch adds a one-liner to of_mtd.c t

Re: problem with resume after s2ram

2014-03-27 Thread Peter Münster
On Thu, Mar 27 2014, Alan Stern wrote: > Oops -- I just realized that the instructions I sent you before were > incomplete. Please try running the same test again, but this time > issue the following commands to suspend the device: > > echo on >/sys/bus/usb/devices/4-2/power/control >

USB 3.0 driver code flow for OTG gadget/host decision process

2014-03-27 Thread David Kochendorfer
Greg, I apologize if you've already received a copy of this - I inadvertently shutdown evolution in the middle of sending and it doesn't look like the first one was sent, so ... Is there a document/tutorial on the USB 3.0 driver code flow in general, especially regarding the OTG decisions process

USB 3.0 code flow for OTG gadget/host decision process

2014-03-27 Thread David Kochendorfer
Greg, Is there a document/tutorial on the USB 3.0 driver code flow in general, especially regarding the OTG decisions process? I am interested in both: (1) my Samsung (android linux) defaults to a host at 2.0 when a 3.0 OTG gadget is plugged in, posting a pop-up to select 3.0; I'd like to have i

Re: [PATCH v2] usb: dwc3: gadget: Iterate only over valid endpoints

2014-03-27 Thread Ivan T. Ivanov
On Thu, 2014-03-27 at 12:15 -0500, Felipe Balbi wrote: > > I mean, -rc8 is out, if you fix your patches up right now, how much > testing can you do in the next couple days ? Patches need to soak in > linux-next for a while. Even if Greg would accept a pull request, I'm > not sure I'd feel comforta

Re: [PATCH v2] usb: dwc3: gadget: Iterate only over valid endpoints

2014-03-27 Thread Felipe Balbi
On Thu, Mar 27, 2014 at 06:16:15PM +0200, Ivan T. Ivanov wrote: > On Thu, 2014-03-27 at 09:58 -0500, Felipe Balbi wrote: > > On Thu, Mar 27, 2014 at 04:03:08PM +0200, Ivan T. Ivanov wrote: > > > > > > Hi, > > > > > > On Wed, 2014-03-26 at 12:15 -0500, Felipe Balbi wrote: > > > > > > ps: can you

Re: [PATCH v2] usb: dwc3: gadget: Iterate only over valid endpoints

2014-03-27 Thread Ivan T. Ivanov
On Thu, 2014-03-27 at 09:58 -0500, Felipe Balbi wrote: > On Thu, Mar 27, 2014 at 04:03:08PM +0200, Ivan T. Ivanov wrote: > > > > Hi, > > > > On Wed, 2014-03-26 at 12:15 -0500, Felipe Balbi wrote: > > > > > ps: can you guys, please, just send your dwc3 glue layer ? :-) > > > > > > > > Ivan Ivano

[PATCH v2 1/7] usb: gadget: gr_udc: Make struct platform_device variable name clearer and use platform_set/get_drvdata

2014-03-27 Thread Andreas Larsson
Rename struct platform_device pointers from ofdev to pdev for clarity. Suggested by Mark Rutland. Signed-off-by: Andreas Larsson --- Differences since v1: use platform_set/get_drvdata drivers/usb/gadget/gr_udc.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --

[PATCH v2 5/7] usb: gadget: gr_udc: Add ep.maxpacket_limit to debugfs information

2014-03-27 Thread Andreas Larsson
Add information on ep.maxpacket_limit for each endpoint in the debugfs information. Signed-off-by: Andreas Larsson --- Differences since v1: none drivers/usb/gadget/gr_udc.c |1 + 1 file changed, 1 insertion(+) diff --git a/drivers/usb/gadget/gr_udc.c b/drivers/usb/gadget/gr_udc.c index 0f

[PATCH v2 3/7] usb: gadget: gr_udc: Use platform_get_irq instead of irq_of_parse_and_map

2014-03-27 Thread Andreas Larsson
Use platform_get_irq as no mapping needs to be done. No functional difference for SPARC which is the typical environment for the driver though. Suggested by Mark Rutland. Signed-off-by: Andreas Larsson --- Differences since v1: none drivers/usb/gadget/gr_udc.c | 14 -- 1 file chan

[PATCH v2 4/7] usb: gadget: gr_udc: Use of_property_read_u32_index to access arrays

2014-03-27 Thread Andreas Larsson
Use an appropriate accessor function for property arrays to make the code nicer and make the code correct if it would ever run on little endian architectures. Suggested by Mark Rutland. Signed-off-by: Andreas Larsson --- Differences since v1: none drivers/usb/gadget/gr_udc.c | 12

[PATCH v2 2/7] usb: gadget: gr_udc: Expand devicetree documentation

2014-03-27 Thread Andreas Larsson
Provide more information on the two different interrupt cases and more information of endpoint buffer sizes. Suggested by Mark Rutland. Signed-off-by: Andreas Larsson --- Differences since v1: none Documentation/devicetree/bindings/usb/gr-udc.txt | 22 ++ 1 file changed, 1

[PATCH 7/7] usb: gadget: gr_udc: Use GFP_ATOMIC when allocating under help spinlock

2014-03-27 Thread Andreas Larsson
As gr_ep_init must be called with dev->lock held, GFP_KERNEL must not be used. Reported-by: Dan Carpenter Signed-off-by: Andreas Larsson --- New patch but needs patch 1/7 to apply drivers/usb/gadget/gr_udc.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/us

[PATCH v2 6/7] usb: gadget: gr_udc: Return error code when trying to set ep.maxpacket > ep.maxpacket_limit

2014-03-27 Thread Andreas Larsson
Make gr_ep_enable fail properly when a call requests a larger ep.maxpacket than ep.maxpacket_limit. Signed-off-by: Andreas Larsson --- Differences since v1: none drivers/usb/gadget/gr_udc.c |4 1 file changed, 4 insertions(+) diff --git a/drivers/usb/gadget/gr_udc.c b/drivers/usb/gadg

[PATCH v2 0/7] usb: gadget: gr_udc: OF and ep.maxpacket_limit improvements and fix of GFP_KERNEL in atomic context

2014-03-27 Thread Andreas Larsson
This patchset: - Adds some OF related improvements suggested by Mark Rutland. - Adds ep.maxpacket_limit to the debugfs file and adds a check if gr_ep_enable is called with a maxpacket value greater than ep.maxpacket_limit. - Fixes a bug where GFP_KERNEL was used in atomic context Andre

Re: Fwd: Failure to recognize device for 45 minutes and Device Disconnects

2014-03-27 Thread Alan Stern
On Wed, 26 Mar 2014, Mike Mitchell wrote: > On Mon, Mar 24, 2014 at 7:30 AM, Alan Stern wrote: > > > What happens if you run "lsusb -v" shortly after booting? Does that > cause the mouse to be recognized? Oops -- I meant "microphone", not "mouse". Trying to work on too many bug reports at on

Re: [PATCH v2] usb: dwc3: gadget: Iterate only over valid endpoints

2014-03-27 Thread Felipe Balbi
On Thu, Mar 27, 2014 at 04:03:08PM +0200, Ivan T. Ivanov wrote: > > Hi, > > On Wed, 2014-03-26 at 12:15 -0500, Felipe Balbi wrote: > > > > ps: can you guys, please, just send your dwc3 glue layer ? :-) > > > > > > Ivan Ivanov (cc'ed) had sent a number of patches for our "dwc3-msm" > > > layer t

Re: problem with resume after s2ram

2014-03-27 Thread Alan Stern
On Wed, 26 Mar 2014, Peter Münster wrote: > On Wed, Mar 26 2014, Alan Stern wrote: > > > Please try running the test again. When it finishes, go to the > > /sys/kernel/debug/usb/ohci/:00:12.1/ directory and post a copy of > > the "registers" file. > > > > Check the contents of that file seve

Re: usb/serial/io_ti.c broken on BE systems

2014-03-27 Thread Ludovic Drolez
Hi Johan, I just tested your patch on a x86 system and everything works fine. If I find some time I'll try to find why the module crashes on arm with debug=1. Best regards, -- Ludovic Drolez. http://www.aopensource.com - The Android Open Source Portal http://www.drolez.com

Re: usb: gadget: Add UDC driver for Aeroflex Gaisler GRUSBDC

2014-03-27 Thread Andreas Larsson
Hi! Other responsibilities has been holding back the Linux commitments. Thank you for reminding me! I'll get to it! Best regards, Andreas Larsson Software Engineer Aeroflex Gaisler AB Aeroflex Microelectronic Solutions – HiRel Kungsgatan 12 SE-411 19 Gothenburg, Sweden Phone: +46 31 7758669 an

Re: [PATCH v2] usb: dwc3: gadget: Iterate only over valid endpoints

2014-03-27 Thread Ivan T. Ivanov
Hi, On Wed, 2014-03-26 at 12:15 -0500, Felipe Balbi wrote: > > > ps: can you guys, please, just send your dwc3 glue layer ? :-) > > > > Ivan Ivanov (cc'ed) had sent a number of patches for our "dwc3-msm" > > layer to the list for review, but I think they were still held up in the > > feedback p

Re: usb: gadget: Add UDC driver for Aeroflex Gaisler GRUSBDC

2014-03-27 Thread Dan Carpenter
This bug is still there in linux-next. What's the story, Andreas? regards, dan carpenter On Thu, Jan 23, 2014 at 07:19:57PM +0300, Dan Carpenter wrote: > Hello Andreas Larsson, > > The patch 27e9dcc924e9: "usb: gadget: Add UDC driver for Aeroflex > Gaisler GRUSBDC" from Dec 23, 2013, leads to t

XHCI ERROR: Transfer error on endpoint

2014-03-27 Thread Keerthy V
Hi, I am trying to send data to a USB device connected to a USB3.0 port over a USB bulk end point using libusb APIs . It is failing failed with error ERROR_IO. The same device and the test program works fine on a USB2.0 port. After enabling the XHCI debug options, I found that I am getting the

[PATCH RESEND] gadgetfs: Initialize CHIP to NULL before UDC probe

2014-03-27 Thread Lubomir Rintel
Otherwise the value from the last probe would be retained that possibly is freed since (the UDC is removed) and therefore no longer relevant. Reproducible with the dummy UDC: modprobe dummy_hcd mount -t gadgetfs gadgetfs /dev/gadget umount /dev/gadget rmmod dummy_hcd mount -t gadgetfs ga