Re: [PATCH v2] usb: dwc2: Use generic PHY width in params setup

2019-05-31 Thread Jules Maselbas
Hi Minas, This is a reminder in case you missed this patch. Kind regards, Jules On Thu, May 09, 2019 at 11:15:28AM +0200, Jules Maselbas wrote: > Setting params.phy_utmi_width in dwc2_lowlevel_hw_init() is pointless since > it's value will be overwritten by dwc2_init_params(). >

[PATCH v2] usb: dwc2: Use generic PHY width in params setup

2019-05-09 Thread Jules Maselbas
, the phy_utmi_width params can still be overrided by devicetree specific params and will also be checked against hardware capabilities. Fixes: 707d80f0a3c5 ("usb: dwc2: gadget: Replace phyif with phy_utmi_width") Tested-by: Marek Szyprowski Signed-off-by: Jules Maselbas --- v2: Fix typo in

[PATCH] usb: dwc2: Use generic PHY width in params setup

2019-05-07 Thread Jules Maselbas
Hi, The patch 'usb: dwc2: gadget: Replace phyif with phy_utmi_width' changed a little the "behavior" of the platform lowlevel hw init. As setting the params.utmi_phy_width at that time is pointless, see the attached patch for detailed information. I think that's why the USB on Exynos4412 fails,

[PATCH] usb: dwc2: Use generic PHY width in params setup

2019-05-07 Thread Jules Maselbas
, the phy_utmi_width params can still be overridden by devicetree specific params and will also be checked against hardware capabilities. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/params.c | 9 + drivers/usb/dwc2/platform.c | 9 - 2 files changed, 9 insertions(+), 9 dele

Re: [PATCH 1/5] usb: dwc2: Move UTMI_PHY_DATA defines closer

2019-04-25 Thread Jules Maselbas
Hi Felipe, On Thu, Apr 25, 2019 at 03:52:16PM +0300, Felipe Balbi wrote: > Jules Maselbas writes: > > > Makes GHWCFG4_UTMI_PHY_DATA* defines closer to their relative shift and > > mask defines to improve readability. > > > > Signed-off-by: Jules Maselbas > >

Re: [PATCH 03/14] usb: dwc2: Fix wakeup detected and session request interrupt handlers.

2019-04-12 Thread Jules Maselbas
Hi Artur, On Fri, Apr 12, 2019 at 01:38:56PM +, Artur Petrosyan wrote: > In host mode port power must be turned on when wakeup > detected or session request interrupt is detected. > Because, otherwise core wouldn't exit form partial > power down. > > - Turned on the port power by setting HPRT

[PATCH v2 1/5] usb: dwc2: Move UTMI_PHY_DATA defines closer

2019-04-05 Thread Jules Maselbas
Makes GHWCFG4_UTMI_PHY_DATA* defines closer to their relative shift and mask defines to improve readability. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/hw.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/usb/dwc2/hw.h b/drivers/usb/dwc2/hw.h index

[PATCH v2 4/5] usb: dwc2: Move phy init into core

2019-04-05 Thread Jules Maselbas
As the phy initialization is almost the same in host and gadget mode. This only move the phy initialization functions into core.c for now, the goal is to share theses functions between the two modes. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/core.c | 190

[PATCH v2 5/5] usb: dwc2: gadget: Move gadget phy init into core phy init

2019-04-05 Thread Jules Maselbas
Most of the phy initialization is shared between host and gadget, this adds the turnaround configuration only used by gadgets to the global phy init. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/core.c | 9 + drivers/usb/dwc2/gadget.c | 25 + 2 files

[PATCH v2 0/5] usb: dwc2: Improve gadget phy init

2019-04-05 Thread Jules Maselbas
in core.h (to be used in hcd.c) - Fix patch `Replace phyif with phy_utmi_width` (wrong value set to usbcfg) - Add check for utmi phy type in patch `Replace phyif with phy_utmi_width` --- Jules Maselbas (5): usb: dwc2: Move UTMI_PHY_DATA defines closer usb: dwc2: gadget: Remove duplicate

[PATCH v2 2/5] usb: dwc2: gadget: Remove duplicated phy init

2019-04-05 Thread Jules Maselbas
The function dwc2_hsotg_init is only called once just before calling dwc2_hsotg_core_init_disconnected which does the same initialization: setting the usbcfg register with turnaround time, timeout calibration and phy width. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/gadget.c | 13

[PATCH v2 3/5] usb: dwc2: gadget: Replace phyif with phy_utmi_width

2019-04-05 Thread Jules Maselbas
Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/core.h | 2 -- drivers/usb/dwc2/gadget.c | 20 ++-- drivers/usb/dwc2/platform.c | 5 + 3 files changed, 15 insertions(+), 12 deletions(-) diff --git a/drivers/usb/dwc2/core.h b/drivers/usb/dwc2/core.h index 30bab8463c9

[PATCH 3/5] usb: dwc2: gadget: Remove duplicated phy init

2019-04-02 Thread Jules Maselbas
The function dwc2_hsotg_init is only called once just before calling dwc2_hsotg_core_init_disconnected which does the same initialization: setting the usbcfg register with turnaround time, timeout calibration and phy width. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/gadget.c | 13

[PATCH 1/5] usb: dwc2: Move UTMI_PHY_DATA defines closer

2019-04-02 Thread Jules Maselbas
Makes GHWCFG4_UTMI_PHY_DATA* defines closer to their relative shift and mask defines to improve readability. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/hw.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/usb/dwc2/hw.h b/drivers/usb/dwc2/hw.h index

[PATCH 4/5] usb: dwc2: gadget: Replace phyif with phy_utmi_width

2019-04-02 Thread Jules Maselbas
Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/core.h | 2 -- drivers/usb/dwc2/gadget.c | 4 ++-- drivers/usb/dwc2/platform.c | 5 + 3 files changed, 3 insertions(+), 8 deletions(-) diff --git a/drivers/usb/dwc2/core.h b/drivers/usb/dwc2/core.h index 1fad5dcbcd81..96cf645e53fe 100644 --

[PATCH 5/5] usb: dwc2: gadget: Move gadget phy init into core phy init

2019-04-02 Thread Jules Maselbas
Most of the phy initialization is shared between host and gadget, this adds the turnaround configuration only used by gadgets to the global phy init. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/core.c | 9 + drivers/usb/dwc2/gadget.c | 21 +++-- 2 files changed

[PATCH 0/5] usb: dwc2: Improve gadget phy init

2019-04-02 Thread Jules Maselbas
was set by default to 16 bits. Best, Jules --- Jules Maselbas (5): usb: dwc2: Move UTMI_PHY_DATA defines closer usb: dwc2: Move phy init into core usb: dwc2: gadget: Remove duplicated phy init usb: dwc2: gadget: Replace phyif with phy_utmi_width usb: dwc2: gadget: Move gadget phy init int

[PATCH 2/5] usb: dwc2: Move phy init into core

2019-04-02 Thread Jules Maselbas
As the phy initialization is almost the same in host and gadget mode. This only move the phy initialization functions into core.c for now, the goal is to share theses functions between the two modes. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/core.c | 190

Re: [PATCH v3 0/2] max3421: add devicetree support

2017-11-01 Thread Jules Maselbas
écrit : > On Tue, Oct 24, 2017 at 01:08:41AM +0200, Jules Maselbas wrote: >> Hi, >> >> This patchset adds devicetree support to the max3421 driver. >> Theses modification are based on a previous (unapplied) patch >> series by Alexander Amelkin [1]. > > I

[PATCH] usb: host: max3421-hcd: Remove pdata test in max3421_hub_control()

2017-10-31 Thread Jules Maselbas
We do not have to test if platform_data pointer is null in max3421_hub_control(), as the driver probe will fail if no platform_data is found. Fixes: 721fdc83b31b ("usb: max3421: Add devicetree support") Signed-off-by: Jules Maselbas Reported-by: Julia Lawall Reported-by: Dan

[PATCH] dt-bindings: usb: max3421: Interrupt-parent is optional

2017-10-31 Thread Jules Maselbas
Documentation modification, now interrupt-parent is an optional property. Also fix few typos. Signed-off-by: Jules Maselbas Reported-by: Sergei Shtylyov --- Documentation/devicetree/bindings/usb/maxim,max3421.txt | 8 +--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git a

Re: [PATCH] usb: max3421: unlock on error in max3421_hub_control()

2017-10-27 Thread Jules Maselbas
> On Fri, Oct 27, 2017 at 11:06:36AM +0200, Jules Maselbas wrote: >> Hi, >> >> > We can't return directly in max3421_hub_control(), we have to unlock >> > first. >> Yes you are right. >> I think testing if pdata is null is not necessary as drive

Re: [PATCH] usb: max3421: unlock on error in max3421_hub_control()

2017-10-27 Thread Jules Maselbas
Hi, > We can't return directly in max3421_hub_control(), we have to unlock > first. Yes you are right. I think testing if pdata is null is not necessary as driver_probe will fail if the device do not have a platform_data. Jules. > Fixes: 721fdc83b31b ("usb: max3421: Add devicetree support") > Si

[PATCH v3 1/2] usb: max3421: Add devicetree support

2017-10-23 Thread Jules Maselbas
Adds support for devicetree to the max3421 driver. Signed-off-by: Jules Maselbas --- drivers/usb/host/max3421-hcd.c | 75 +- 1 file changed, 74 insertions(+), 1 deletion(-) diff --git a/drivers/usb/host/max3421-hcd.c b/drivers/usb/host/max3421-hcd.c

[PATCH v3 2/2] dt-bindings: max3421: Add bindings documentation

2017-10-23 Thread Jules Maselbas
Adds bindings documentation for the max3421 driver. Signed-off-by: Jules Maselbas Acked-by: Rob Herring --- .../devicetree/bindings/usb/maxim,max3421.txt | 25 ++ 1 file changed, 25 insertions(+) create mode 100644 Documentation/devicetree/bindings/usb/maxim,max3421

[PATCH v3 0/2] max3421: add devicetree support

2017-10-23 Thread Jules Maselbas
] --- Jules Maselbas (2): usb: max3421: Add devicetree support dt-bindings: max3421: Add bindings documentation .../devicetree/bindings/usb/maxim,max3421.txt | 25 drivers/usb/host/max3421-hcd.c | 75 +- 2 files changed, 99 insertions

Re: [PATCH v2 2/2] dt-bindings: max3421: Add bindings documentation

2017-10-16 Thread Jules Maselbas
Thanks Sergei, Is it better if the documentation say: " Optional property: - interrupt-parent: the phandle of the associated interrupt controller. " or should I also add that "it may be inherited from the parent nodes."? Jules Maselbas. - Mail original - De:

[PATCH v2 0/2] max3421: add devicetree support

2017-10-15 Thread Jules Maselbas
dev_err print if devm_kzalloc fail. * Removed a test for platform_data null pointer in max3421_hub_control() as the driver probe will fail if no platform_data is found. Thank you. [1]: [https://lkml.org/lkml/2017/5/26/285] --- Jules Maselbas (2): usb: max3421: Add devicetree support dt

[PATCH v2 1/2] usb: max3421: Add devicetree support

2017-10-15 Thread Jules Maselbas
Adds support for devicetree to the max3421 driver. Signed-off-by: Jules Maselbas --- drivers/usb/host/max3421-hcd.c | 75 +- 1 file changed, 74 insertions(+), 1 deletion(-) diff --git a/drivers/usb/host/max3421-hcd.c b/drivers/usb/host/max3421-hcd.c

[PATCH v2 2/2] dt-bindings: max3421: Add bindings documentation

2017-10-15 Thread Jules Maselbas
Adds bindings documentation for the max3421 driver. Signed-off-by: Jules Maselbas --- .../devicetree/bindings/usb/maxim,max3421.txt | 24 ++ 1 file changed, 24 insertions(+) create mode 100644 Documentation/devicetree/bindings/usb/maxim,max3421.txt diff --git a

[PATCH 0/2] max3421: add devicetree support

2017-09-15 Thread Jules Maselbas
) ? 2. If it neccessary to free platform_data in max3421_remove function ? Thank you, [1]: [https://lkml.org/lkml/2017/5/26/285] --- Jules Maselbas (2): usb: max3421: Add devicetree support dt-bindings: max3421: Add bindings documentation .../devicetree/bindings/usb/maxim,max3421.txt

[PATCH 2/2] dt-bindings: max3421: Add bindings documentation

2017-09-15 Thread Jules Maselbas
Adds bindings documentation for the max3421 driver. Signed-off-by: Jules Maselbas --- .../devicetree/bindings/usb/maxim,max3421.txt | 24 ++ 1 file changed, 24 insertions(+) create mode 100644 Documentation/devicetree/bindings/usb/maxim,max3421.txt diff --git a

[PATCH 1/2] usb: max3421: Add devicetree support

2017-09-15 Thread Jules Maselbas
Adds support for devicetree to the max3421 driver. Signed-off-by: Jules Maselbas --- drivers/usb/host/max3421-hcd.c | 87 +- 1 file changed, 86 insertions(+), 1 deletion(-) diff --git a/drivers/usb/host/max3421-hcd.c b/drivers/usb/host/max3421-hcd.c